aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcus von Appen <mva@FreeBSD.org>2010-05-14 05:41:11 +0000
committerMarcus von Appen <mva@FreeBSD.org>2010-05-14 05:41:11 +0000
commitdecaca3feca96c34565d963069d88d226b660604 (patch)
tree23bedae61f9bea768f9ff4eff2479b08d5f6827a
parent578f24eff702d5733597437d8908e27c58fd3134 (diff)
downloadports-decaca3feca96c34565d963069d88d226b660604.tar.gz
ports-decaca3feca96c34565d963069d88d226b660604.zip
Notes
-rw-r--r--audio/py-fastaudio/Makefile1
-rw-r--r--audio/py-fastaudio/files/patch-fastaudio.pyx13
-rw-r--r--devel/pyrex/Makefile2
-rw-r--r--devel/pyrex/distinfo6
-rw-r--r--devel/pyrex/pkg-plist5
-rw-r--r--multimedia/miro/Makefile2
-rw-r--r--multimedia/miro/files/patch-platform__gtk-x11__xine__xine.pyx11
7 files changed, 33 insertions, 7 deletions
diff --git a/audio/py-fastaudio/Makefile b/audio/py-fastaudio/Makefile
index d51e2d36202b..a11b5737c29c 100644
--- a/audio/py-fastaudio/Makefile
+++ b/audio/py-fastaudio/Makefile
@@ -8,6 +8,7 @@
PORTNAME= fastaudio
PORTVERSION= 0.1
+PORTREVISION= 1
CATEGORIES= audio python
MASTER_SITES= http://www.freenet.org.nz/python/pyPortAudio/:site1 \
http://www.portaudio.com/archives/:site2
diff --git a/audio/py-fastaudio/files/patch-fastaudio.pyx b/audio/py-fastaudio/files/patch-fastaudio.pyx
index 8f097b13b3f0..025b6aaacfb5 100644
--- a/audio/py-fastaudio/files/patch-fastaudio.pyx
+++ b/audio/py-fastaudio/files/patch-fastaudio.pyx
@@ -1,5 +1,5 @@
---- fastaudio.pyx.orig 2004-06-15 20:37:39.000000000 +0900
-+++ fastaudio.pyx 2009-06-06 18:54:52.000000000 +0900
+--- fastaudio.pyx.orig 2004-06-15 13:37:39.000000000 +0200
++++ fastaudio.pyx 2010-05-08 09:24:38.000000000 +0200
@@ -92,7 +92,7 @@
#@+node:portaudio.h
# portaudio-specifics
@@ -9,6 +9,15 @@
ctypedef int PaError
cdef enum PA_ERRORS:
+@@ -553,7 +553,7 @@
+ cdef int isrunning
+ #@-node:attributes
+ #@+node:__new__
+- def __new__(self, samplerate=8000, channels=2, format='int16', framesPerBuf=4096, maxbufs=16, **kwds):
++ def __cinit__(self, samplerate=8000, channels=2, format='int16', framesPerBuf=4096, maxbufs=16, **kwds):
+ """
+ Constructor for fastaudio stream objects.
+
@@ -586,8 +586,8 @@
cdata.framesPerBuf = framesPerBuf
cdata.bytesPerFrame = channels * _sampleFormatSizes[format]
diff --git a/devel/pyrex/Makefile b/devel/pyrex/Makefile
index 19bb911d97bb..9e5351c7a724 100644
--- a/devel/pyrex/Makefile
+++ b/devel/pyrex/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= pyrex
-PORTVERSION= 0.9.8.6
+PORTVERSION= 0.9.9
CATEGORIES= devel lang python
MASTER_SITES= http://www.cosc.canterbury.ac.nz/greg.ewing/python/Pyrex/
PKGNAMEPREFIX= ${PYTHONPKGNAMEPREFIX}
diff --git a/devel/pyrex/distinfo b/devel/pyrex/distinfo
index 053eee0ad086..b49cc5cac868 100644
--- a/devel/pyrex/distinfo
+++ b/devel/pyrex/distinfo
@@ -1,3 +1,3 @@
-MD5 (Pyrex-0.9.8.6.tar.gz) = 7445280f3f1060ae86c93a0e03eff0ab
-SHA256 (Pyrex-0.9.8.6.tar.gz) = 914afcb6d59c6a63f5b5150f9f253dcb302f0225a43919059ccc7e56872c1fff
-SIZE (Pyrex-0.9.8.6.tar.gz) = 246713
+MD5 (Pyrex-0.9.9.tar.gz) = 515dee67d15d4393841e2d60e8341947
+SHA256 (Pyrex-0.9.9.tar.gz) = 5f87df06831d0b3412eb4bc9d3fc2ee7bfae1b913d7da8c23ab2bf5699fb6b50
+SIZE (Pyrex-0.9.9.tar.gz) = 255272
diff --git a/devel/pyrex/pkg-plist b/devel/pyrex/pkg-plist
index 9449ad0d03a2..3502a58aa21d 100644
--- a/devel/pyrex/pkg-plist
+++ b/devel/pyrex/pkg-plist
@@ -17,6 +17,9 @@ bin/pyrexc
%%PYTHON_SITELIBDIR%%/Pyrex/Compiler/ExprNodes.py
%%PYTHON_SITELIBDIR%%/Pyrex/Compiler/ExprNodes.pyc
%%PYTHON_SITELIBDIR%%/Pyrex/Compiler/ExprNodes.pyo
+%%PYTHON_SITELIBDIR%%/Pyrex/Compiler/Filenames.py
+%%PYTHON_SITELIBDIR%%/Pyrex/Compiler/Filenames.pyc
+%%PYTHON_SITELIBDIR%%/Pyrex/Compiler/Filenames.pyo
%%PYTHON_SITELIBDIR%%/Pyrex/Compiler/Lexicon.pickle
%%PYTHON_SITELIBDIR%%/Pyrex/Compiler/Lexicon.py
%%PYTHON_SITELIBDIR%%/Pyrex/Compiler/Lexicon.pyc
@@ -151,6 +154,7 @@ bin/pyrexc
%%PORTDOCS%%%%DOCSDIR%%/About.html
%%PORTDOCS%%%%DOCSDIR%%/FAQ.html
%%PORTDOCS%%%%DOCSDIR%%/LanguageOverview.html
+%%PORTDOCS%%%%DOCSDIR%%/Release_Notes_0.9.9.html
%%PORTDOCS%%%%DOCSDIR%%/Manual/Limitations.html
%%PORTDOCS%%%%DOCSDIR%%/Manual/basics.html
%%PORTDOCS%%%%DOCSDIR%%/Manual/extension_types.html
@@ -158,6 +162,7 @@ bin/pyrexc
%%PORTDOCS%%%%DOCSDIR%%/Manual/sharing.html
%%PORTDOCS%%%%DOCSDIR%%/Manual/source_files.html
%%PORTDOCS%%%%DOCSDIR%%/Manual/special_methods.html
+%%PORTDOCS%%%%DOCSDIR%%/Manual/using_with_c++.html
%%PORTDOCS%%%%DOCSDIR%%/index.html
%%PORTDOCS%%%%DOCSDIR%%/primes.c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Makefile
diff --git a/multimedia/miro/Makefile b/multimedia/miro/Makefile
index f744a05ac0bf..85197bed6a3a 100644
--- a/multimedia/miro/Makefile
+++ b/multimedia/miro/Makefile
@@ -7,7 +7,7 @@
PORTNAME= miro
PORTVERSION= 2.5.4
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= multimedia
MASTER_SITES= ftp://ftp.osuosl.org/pub/pculture.org/miro/src/ \
http://ftp.osuosl.org/pub/pculture.org/miro/src/
diff --git a/multimedia/miro/files/patch-platform__gtk-x11__xine__xine.pyx b/multimedia/miro/files/patch-platform__gtk-x11__xine__xine.pyx
new file mode 100644
index 000000000000..217130dd4b69
--- /dev/null
+++ b/multimedia/miro/files/patch-platform__gtk-x11__xine__xine.pyx
@@ -0,0 +1,11 @@
+--- platform/gtk-x11/xine/xine.pyx.orig 2010-05-08 21:58:50.000000000 +0200
++++ platform/gtk-x11/xine/xine.pyx 2010-05-08 21:59:10.000000000 +0200
+@@ -89,7 +89,7 @@
+ cdef _Xine* xine
+ cdef object eosCallback
+
+- def __new__(self):
++ def __cinit__(self):
+ self.xine = xineCreate(on_xine_event, <void*>self)
+ self.eosCallback = None
+ def __dealloc__(self):