aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2012-04-22 13:56:09 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>2012-04-22 13:56:09 +0000
commit10ebd76858432f96584ddf67a196f61440507fca (patch)
treee2758e950e4338cc6ec025198dbfb525d2eff47a
parentb039fb81285275b445dc10d4f71c67aaee265d56 (diff)
downloadports-10ebd76858432f96584ddf67a196f61440507fca.tar.gz
ports-10ebd76858432f96584ddf67a196f61440507fca.zip
Notes
-rw-r--r--devel/p5-Perl-Metrics-Simple/Makefile3
-rw-r--r--devel/p5-Perl-Metrics-Simple/files/patch-TestData.pm39
2 files changed, 42 insertions, 0 deletions
diff --git a/devel/p5-Perl-Metrics-Simple/Makefile b/devel/p5-Perl-Metrics-Simple/Makefile
index a53586b96118..389ce2ef8740 100644
--- a/devel/p5-Perl-Metrics-Simple/Makefile
+++ b/devel/p5-Perl-Metrics-Simple/Makefile
@@ -19,6 +19,9 @@ RUN_DEPENDS= \
p5-Readonly>=1.03:${PORTSDIR}/devel/p5-Readonly \
p5-Statistics-Basic>0:${PORTSDIR}/math/p5-Statistics-Basic
BUILD_DEPENDS= ${RUN_DEPENDS}
+TEST_DEPENDS= \
+ p5-Test-Pod>0:${PORTSDIR}/devel/p5-Test-Pod \
+ p5-Test-Pod-Coverage>0:${PORTSDIR}/devel/p5-Test-Pod-Coverage
PERL_CONFIGURE= yes
diff --git a/devel/p5-Perl-Metrics-Simple/files/patch-TestData.pm b/devel/p5-Perl-Metrics-Simple/files/patch-TestData.pm
new file mode 100644
index 000000000000..2de3a35d2e49
--- /dev/null
+++ b/devel/p5-Perl-Metrics-Simple/files/patch-TestData.pm
@@ -0,0 +1,39 @@
+--- t/lib/Perl/Metrics/Simple/TestData.pm.orig 2012-04-22 22:39:58.229109428 +0900
++++ t/lib/Perl/Metrics/Simple/TestData.pm 2012-04-22 22:41:19.361852783 +0900
+@@ -127,12 +127,14 @@
+ name => 'foo',
+ lines => 1,
+ mccabe_complexity => 1,
++ line_number => 10,
+ path => "$test_directory/subs_no_package.pl",
+ },
+ {
+ name => 'bar',
+ lines => 2,
+ mccabe_complexity => 1,
++ line_number => 11,
+ path => "$test_directory/subs_no_package.pl",
+ }
+ ],
+@@ -152,18 +154,21 @@
+ name => 'new',
+ lines => 5,
+ mccabe_complexity => 1,
++ line_number => 8,
+ path => "$test_directory/Perl/Code/Analyze/Test/Module.pm",
+ },
+ {
+ name => 'foo',
+ lines => 9,
+ mccabe_complexity => 8,
++ line_number => 14,
+ path => "$test_directory/Perl/Code/Analyze/Test/Module.pm",
+ },
+ {
+ name => 'say_hello',
+ lines => 9,
+ mccabe_complexity => 5,
++ line_number => 26,
+ path => "$test_directory/Perl/Code/Analyze/Test/Module.pm",
+ },
+ ],