aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2019-06-04 08:23:41 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2019-06-04 08:23:41 +0000
commit1139967e50bfb00f23d64643a95ed7cc39048877 (patch)
treeed32bd1487045a4b102ca02a5de1d489c97428d3
parentde44085926d7bdf022889068c3e05cac967ae767 (diff)
downloadports-1139967e50bfb00f23d64643a95ed7cc39048877.tar.gz
ports-1139967e50bfb00f23d64643a95ed7cc39048877.zip
Notes
-rw-r--r--graphics/giflib/Makefile2
-rw-r--r--graphics/giflib/distinfo6
-rw-r--r--graphics/giflib/files/patch-Makefile36
-rw-r--r--graphics/giflib/files/patch-tests_makefile4
-rw-r--r--graphics/giflib/pkg-plist3
5 files changed, 31 insertions, 20 deletions
diff --git a/graphics/giflib/Makefile b/graphics/giflib/Makefile
index b4c0c460257e..d89ae45c9260 100644
--- a/graphics/giflib/Makefile
+++ b/graphics/giflib/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= giflib
-PORTVERSION= 5.1.8
+PORTVERSION= 5.1.9
PORTREVISION= 0
CATEGORIES= graphics
MASTER_SITES= SF/${PORTNAME}
diff --git a/graphics/giflib/distinfo b/graphics/giflib/distinfo
index 3caeecb7fe87..6f71a95119fb 100644
--- a/graphics/giflib/distinfo
+++ b/graphics/giflib/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1553869894
-SHA256 (giflib-5.1.8.tar.gz) = d105a905df34a7822172d13657cdae3d4b0c8e8c7067ccf05e39a40044f8ca53
-SIZE (giflib-5.1.8.tar.gz) = 419065
+TIMESTAMP = 1557928206
+SHA256 (giflib-5.1.9.tar.gz) = 36ccab06aa43e5d608cdd74902f89c47fd55c348009798434ba5798967454057
+SIZE (giflib-5.1.9.tar.gz) = 385068
diff --git a/graphics/giflib/files/patch-Makefile b/graphics/giflib/files/patch-Makefile
index d93996b23520..d5bcc189744b 100644
--- a/graphics/giflib/files/patch-Makefile
+++ b/graphics/giflib/files/patch-Makefile
@@ -1,29 +1,43 @@
---- Makefile.orig 2019-03-17 16:33:02 UTC
+--- Makefile.orig 2019-03-28 18:57:23 UTC
+++ Makefile
-@@ -9,7 +9,7 @@
- CC = gcc
+@@ -8,7 +8,7 @@
+ #
OFLAGS = -O0 -g
- #OFLAGS = -O2 -fwhole-program
+ OFLAGS = -O2
-CFLAGS = -std=gnu99 -fPIC -Wall -Wno-format-truncation $(OFLAGS)
+CFLAGS = -std=gnu99 -fPIC -Wall $(OFLAGS)
- LDFLAGS = -g
SHELL = /bin/sh
-@@ -58,15 +58,21 @@ UTILS = $(INSTALLABLE) \
+ TAR = tar
+@@ -29,11 +29,11 @@ LIBPOINT=0
+ LIBVER=$(LIBMAJOR).$(LIBMINOR).$(LIBPOINT)
+
+ SOURCES = dgif_lib.c egif_lib.c gifalloc.c gif_err.c gif_font.c \
+- gif_hash.c openbsd-reallocarray.c
++ gif_hash.c openbsd-reallocarray.c quantize.c
+ HEADERS = gif_hash.h gif_lib.h gif_lib_private.h
+ OBJECTS = $(SOURCES:.c=.o)
+
+-USOURCES = qprintf.c quantize.c getarg.c
++USOURCES = qprintf.c getarg.c
+ UHEADERS = getarg.h
+ UOBJECTS = $(USOURCES:.c=.o)
+
+@@ -60,15 +60,21 @@ UTILS = $(INSTALLABLE) \
gifsponge \
gifwedge
-LDLIBS=libgif.a -lm
+LDLIBS=-Wl,-rpath -Wl,$(LIBDIR) -lm
- all: libgif.so libgif.a $(UTILS)
+ all: libgif.so libgif.a libutil.so libutil.a $(UTILS)
$(MAKE) -C doc
--$(UTILS):: libgif.a
-+$(UTILS):: libgif.so
+-$(UTILS):: libgif.a libutil.a
++$(UTILS):: libgif.so libutil.a
-libgif.so: $(OBJECTS) $(HEADERS)
-- $(CC) $(CFLAGS) -shared $(OFLAGS) -Wl,-soname -Wl,libgif.so.$(LIBMAJOR) -o libgif.so $(OBJECTS)
+- $(CC) $(CFLAGS) -shared $(LDFLAGS) -Wl,-soname -Wl,libgif.so.$(LIBMAJOR) -o libgif.so $(OBJECTS)
+libgif.so.$(LIBVER): $(OBJECTS) $(HEADERS)
+ $(CC) -shared $(LDFLAGS) -Wl,-soname -Wl,libgif.so.$(LIBMAJOR) -o $@ $(OBJECTS)
+
@@ -35,7 +49,7 @@
libgif.a: $(OBJECTS) $(HEADERS)
$(AR) rcs libgif.a $(OBJECTS)
-@@ -92,7 +98,7 @@ install-include:
+@@ -100,7 +106,7 @@ install-include:
install-lib:
$(INSTALL) -d "$(DESTDIR)$(LIBDIR)"
$(INSTALL) -m 644 libgif.a "$(DESTDIR)$(LIBDIR)/libgif.a"
diff --git a/graphics/giflib/files/patch-tests_makefile b/graphics/giflib/files/patch-tests_makefile
index 3569fef5d53f..d8ceec702425 100644
--- a/graphics/giflib/files/patch-tests_makefile
+++ b/graphics/giflib/files/patch-tests_makefile
@@ -1,4 +1,4 @@
---- tests/makefile.orig 2019-02-10 22:36:27 UTC
+--- tests/makefile.orig 2019-03-28 17:05:25 UTC
+++ tests/makefile
@@ -3,6 +3,8 @@
@@ -9,7 +9,7 @@
# This is what to do by default
test: render-regress \
gifbuild-regress \
-@@ -103,10 +105,10 @@ giffilter-regress:
+@@ -104,10 +106,10 @@ giffilter-regress:
giffix-rebuild:
@echo "Rebuilding giffix test."
diff --git a/graphics/giflib/pkg-plist b/graphics/giflib/pkg-plist
index 993499ffcd34..f615c7637203 100644
--- a/graphics/giflib/pkg-plist
+++ b/graphics/giflib/pkg-plist
@@ -28,8 +28,6 @@ man/man1/giftool.1.gz
man/man1/gifwedge.1.gz
%%PORTDOCS%%%%DOCSDIR%%/00README
%%PORTDOCS%%%%DOCSDIR%%/gif2rgb.html
-%%PORTDOCS%%%%DOCSDIR%%/gif87.txt
-%%PORTDOCS%%%%DOCSDIR%%/gif89.txt
%%PORTDOCS%%%%DOCSDIR%%/gif_lib.html
%%PORTDOCS%%%%DOCSDIR%%/gifbg.html
%%PORTDOCS%%%%DOCSDIR%%/gifbuild.html
@@ -45,7 +43,6 @@ man/man1/gifwedge.1.gz
%%PORTDOCS%%%%DOCSDIR%%/gifwedge.html
%%PORTDOCS%%%%DOCSDIR%%/index.html
%%PORTDOCS%%%%DOCSDIR%%/intro.html
-%%PORTDOCS%%%%DOCSDIR%%/lzgif.txt
%%PORTDOCS%%%%DOCSDIR%%/whatsinagif/animation_and_transparency.html
%%PORTDOCS%%%%DOCSDIR%%/whatsinagif/bits_and_bytes.html
%%PORTDOCS%%%%DOCSDIR%%/whatsinagif/comment_ext.gif