aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-05-29 07:30:00 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-05-29 07:30:00 +0000
commit1bdeb191e96affe67b27880f9a7c5b7d20d2c67b (patch)
tree664fb2f33d173c7684171db92e2ad99720298204
parent9c1df109f25cb5faa5513df66b94b1b14089df8e (diff)
downloadports-1bdeb191e96affe67b27880f9a7c5b7d20d2c67b.tar.gz
ports-1bdeb191e96affe67b27880f9a7c5b7d20d2c67b.zip
Notes
-rw-r--r--security/Makefile1
-rw-r--r--security/tor-devel/Makefile30
-rw-r--r--security/tor-devel/distinfo2
-rw-r--r--security/tor-devel/files/patch-configure11
-rw-r--r--security/tor-devel/files/patch-src::common::or.c13
-rw-r--r--security/tor-devel/files/patch-src::common::util.c13
-rw-r--r--security/tor-devel/pkg-descr11
-rw-r--r--security/tor-devel/pkg-plist6
-rw-r--r--security/tor/Makefile30
-rw-r--r--security/tor/distinfo2
-rw-r--r--security/tor/files/patch-configure11
-rw-r--r--security/tor/files/patch-src::common::or.c13
-rw-r--r--security/tor/files/patch-src::common::util.c13
-rw-r--r--security/tor/pkg-descr11
-rw-r--r--security/tor/pkg-plist6
15 files changed, 173 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 044173186385..c27c14c6abe4 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -418,6 +418,7 @@
SUBDIR += termlog
SUBDIR += tinc
SUBDIR += tinyca
+ SUBDIR += tor
SUBDIR += trinokiller
SUBDIR += tripwire
SUBDIR += tripwire-131
diff --git a/security/tor-devel/Makefile b/security/tor-devel/Makefile
new file mode 100644
index 000000000000..ff21c9f181f6
--- /dev/null
+++ b/security/tor-devel/Makefile
@@ -0,0 +1,30 @@
+# ports collection makefile for: tor
+# Date created: 2004.05.28
+# Whom: freebsd-ports@rikrose.net
+#
+# $FreeBSD$
+#
+
+PORTNAME= tor
+PORTVERSION= 0.0.6.2
+CATEGORIES= security
+MASTER_SITES= http://freehaven.net/tor/dist/
+
+MAINTAINER= freebsd-ports@rikrose.net
+COMMENT= An anonymizing overlay network for TCP
+
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+USE_OPENSSL= yes
+USE_REINPLACE= yes
+
+MANCOMPRESSED= no
+MAN1= tor.1 torify.1
+
+post-patch:
+ @${MV} ${WRKSRC}/contrib/tor-tsocks.conf \
+ ${WRKSRC}/contrib/tor-tsocks.conf.sample
+ @${REINPLACE_CMD} -e "s|tor-tsocks.conf|tor-tsocks.conf.sample|g" \
+ ${WRKSRC}/contrib/Makefile.in
+
+.include <bsd.port.mk>
diff --git a/security/tor-devel/distinfo b/security/tor-devel/distinfo
new file mode 100644
index 000000000000..76880e9ecc72
--- /dev/null
+++ b/security/tor-devel/distinfo
@@ -0,0 +1,2 @@
+MD5 (tor-0.0.6.2.tar.gz) = e09fbe0756521024ef8e0011f8e02545
+SIZE (tor-0.0.6.2.tar.gz) = 322317
diff --git a/security/tor-devel/files/patch-configure b/security/tor-devel/files/patch-configure
new file mode 100644
index 000000000000..d23194a9c07a
--- /dev/null
+++ b/security/tor-devel/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig Fri May 28 18:55:36 2004
++++ configure Fri May 28 18:57:37 2004
+@@ -1559,7 +1559,7 @@
+ ac_config_commands="$ac_config_commands default-1"
+
+
+-CFLAGS="$CFLAGS -Wall -g -O2 -I/usr/kerberos/include"
++CFLAGS="$CFLAGS -Wall -g -O2"
+
+ # Check whether --enable-debug or --disable-debug was given.
+ if test "${enable_debug+set}" = set; then
diff --git a/security/tor-devel/files/patch-src::common::or.c b/security/tor-devel/files/patch-src::common::or.c
new file mode 100644
index 000000000000..e4d39a4a17be
--- /dev/null
+++ b/security/tor-devel/files/patch-src::common::or.c
@@ -0,0 +1,13 @@
+diff -ur /tmp/tor-0.0.6.2/src/or/or.h ./src/or/or.h
+--- /tmp/tor-0.0.6.2/src/or/or.h Sun May 2 04:15:55 2004
++++ ./src/or/or.h Fri May 28 14:49:34 2004
+@@ -38,7 +38,9 @@
+ #include <sys/limits.h>
+ #endif
+ #ifdef HAVE_MACHINE_LIMITS_H
++#ifndef __FreeBSD__
+ #include <machine/limits.h>
++#endif
+ #endif
+ #ifdef HAVE_SYS_TYPES_H
+ #include <sys/types.h> /* Must be included before sys/stat.h for Ultrix */
diff --git a/security/tor-devel/files/patch-src::common::util.c b/security/tor-devel/files/patch-src::common::util.c
new file mode 100644
index 000000000000..44c2290a71f8
--- /dev/null
+++ b/security/tor-devel/files/patch-src::common::util.c
@@ -0,0 +1,13 @@
+diff -ur /tmp/tor-0.0.6.2/src/common/util.c ./src/common/util.c
+--- /tmp/tor-0.0.6.2/src/common/util.c Sun May 2 00:29:20 2004
++++ ./src/common/util.c Fri May 28 14:49:22 2004
+@@ -56,7 +56,9 @@
+ #include <sys/limits.h>
+ #endif
+ #ifdef HAVE_MACHINE_LIMITS_H
++#ifndef __FreeBSD__
+ #include <machine/limits.h>
++#endif
+ #endif
+ #ifdef HAVE_SYS_TYPES_H
+ #include <sys/types.h> /* Must be included before sys/stat.h for Ultrix */
diff --git a/security/tor-devel/pkg-descr b/security/tor-devel/pkg-descr
new file mode 100644
index 000000000000..2f4ab73019d8
--- /dev/null
+++ b/security/tor-devel/pkg-descr
@@ -0,0 +1,11 @@
+Tor: an anonymizing overlay network for TCP
+
+Tor is a connection-based low-latency anonymous communication system which
+addresses many flaws in the original onion routing design.
+
+Remember that this is development code -- DON'T RELY ON THE CURRENT TOR
+NETWORK FOR ANONYMITY!
+
+WWW: http://freehaven.net/tor/
+- rik
+freebsd-ports@rikrose.net
diff --git a/security/tor-devel/pkg-plist b/security/tor-devel/pkg-plist
new file mode 100644
index 000000000000..9a5b0e76d74a
--- /dev/null
+++ b/security/tor-devel/pkg-plist
@@ -0,0 +1,6 @@
+bin/tor
+bin/torify
+etc/tor/dirservers
+etc/tor/torrc.sample
+etc/tor/tor-tsocks.conf.sample
+@dirrm etc/tor
diff --git a/security/tor/Makefile b/security/tor/Makefile
new file mode 100644
index 000000000000..ff21c9f181f6
--- /dev/null
+++ b/security/tor/Makefile
@@ -0,0 +1,30 @@
+# ports collection makefile for: tor
+# Date created: 2004.05.28
+# Whom: freebsd-ports@rikrose.net
+#
+# $FreeBSD$
+#
+
+PORTNAME= tor
+PORTVERSION= 0.0.6.2
+CATEGORIES= security
+MASTER_SITES= http://freehaven.net/tor/dist/
+
+MAINTAINER= freebsd-ports@rikrose.net
+COMMENT= An anonymizing overlay network for TCP
+
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+USE_OPENSSL= yes
+USE_REINPLACE= yes
+
+MANCOMPRESSED= no
+MAN1= tor.1 torify.1
+
+post-patch:
+ @${MV} ${WRKSRC}/contrib/tor-tsocks.conf \
+ ${WRKSRC}/contrib/tor-tsocks.conf.sample
+ @${REINPLACE_CMD} -e "s|tor-tsocks.conf|tor-tsocks.conf.sample|g" \
+ ${WRKSRC}/contrib/Makefile.in
+
+.include <bsd.port.mk>
diff --git a/security/tor/distinfo b/security/tor/distinfo
new file mode 100644
index 000000000000..76880e9ecc72
--- /dev/null
+++ b/security/tor/distinfo
@@ -0,0 +1,2 @@
+MD5 (tor-0.0.6.2.tar.gz) = e09fbe0756521024ef8e0011f8e02545
+SIZE (tor-0.0.6.2.tar.gz) = 322317
diff --git a/security/tor/files/patch-configure b/security/tor/files/patch-configure
new file mode 100644
index 000000000000..d23194a9c07a
--- /dev/null
+++ b/security/tor/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig Fri May 28 18:55:36 2004
++++ configure Fri May 28 18:57:37 2004
+@@ -1559,7 +1559,7 @@
+ ac_config_commands="$ac_config_commands default-1"
+
+
+-CFLAGS="$CFLAGS -Wall -g -O2 -I/usr/kerberos/include"
++CFLAGS="$CFLAGS -Wall -g -O2"
+
+ # Check whether --enable-debug or --disable-debug was given.
+ if test "${enable_debug+set}" = set; then
diff --git a/security/tor/files/patch-src::common::or.c b/security/tor/files/patch-src::common::or.c
new file mode 100644
index 000000000000..e4d39a4a17be
--- /dev/null
+++ b/security/tor/files/patch-src::common::or.c
@@ -0,0 +1,13 @@
+diff -ur /tmp/tor-0.0.6.2/src/or/or.h ./src/or/or.h
+--- /tmp/tor-0.0.6.2/src/or/or.h Sun May 2 04:15:55 2004
++++ ./src/or/or.h Fri May 28 14:49:34 2004
+@@ -38,7 +38,9 @@
+ #include <sys/limits.h>
+ #endif
+ #ifdef HAVE_MACHINE_LIMITS_H
++#ifndef __FreeBSD__
+ #include <machine/limits.h>
++#endif
+ #endif
+ #ifdef HAVE_SYS_TYPES_H
+ #include <sys/types.h> /* Must be included before sys/stat.h for Ultrix */
diff --git a/security/tor/files/patch-src::common::util.c b/security/tor/files/patch-src::common::util.c
new file mode 100644
index 000000000000..44c2290a71f8
--- /dev/null
+++ b/security/tor/files/patch-src::common::util.c
@@ -0,0 +1,13 @@
+diff -ur /tmp/tor-0.0.6.2/src/common/util.c ./src/common/util.c
+--- /tmp/tor-0.0.6.2/src/common/util.c Sun May 2 00:29:20 2004
++++ ./src/common/util.c Fri May 28 14:49:22 2004
+@@ -56,7 +56,9 @@
+ #include <sys/limits.h>
+ #endif
+ #ifdef HAVE_MACHINE_LIMITS_H
++#ifndef __FreeBSD__
+ #include <machine/limits.h>
++#endif
+ #endif
+ #ifdef HAVE_SYS_TYPES_H
+ #include <sys/types.h> /* Must be included before sys/stat.h for Ultrix */
diff --git a/security/tor/pkg-descr b/security/tor/pkg-descr
new file mode 100644
index 000000000000..2f4ab73019d8
--- /dev/null
+++ b/security/tor/pkg-descr
@@ -0,0 +1,11 @@
+Tor: an anonymizing overlay network for TCP
+
+Tor is a connection-based low-latency anonymous communication system which
+addresses many flaws in the original onion routing design.
+
+Remember that this is development code -- DON'T RELY ON THE CURRENT TOR
+NETWORK FOR ANONYMITY!
+
+WWW: http://freehaven.net/tor/
+- rik
+freebsd-ports@rikrose.net
diff --git a/security/tor/pkg-plist b/security/tor/pkg-plist
new file mode 100644
index 000000000000..9a5b0e76d74a
--- /dev/null
+++ b/security/tor/pkg-plist
@@ -0,0 +1,6 @@
+bin/tor
+bin/torify
+etc/tor/dirservers
+etc/tor/torrc.sample
+etc/tor/tor-tsocks.conf.sample
+@dirrm etc/tor