aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Helfman <jgh@FreeBSD.org>2013-03-20 06:28:43 +0000
committerJason Helfman <jgh@FreeBSD.org>2013-03-20 06:28:43 +0000
commit1c09104064e5dbe34c77ee1855bf9190e1f9ef52 (patch)
treea0e0a49b6032d2e8832a99ae9ee7a5cfd5bcbcfb
parent939edcb67d1a6ab84c15a7f93ba8db7758d3d277 (diff)
downloadports-1c09104064e5dbe34c77ee1855bf9190e1f9ef52.tar.gz
ports-1c09104064e5dbe34c77ee1855bf9190e1f9ef52.zip
Notes
-rw-r--r--CHANGES7
-rw-r--r--Mk/Uses/zenoss.mk (renamed from Mk/bsd.zenoss.mk)18
-rw-r--r--net-mgmt/zenpack-apachemonitor/Makefile5
-rw-r--r--net-mgmt/zenpack-checkping/Makefile11
-rw-r--r--net-mgmt/zenpack-dellmon/Makefile11
-rw-r--r--net-mgmt/zenpack-dellmonitor/Makefile5
-rw-r--r--net-mgmt/zenpack-deviceadvdetail/Makefile11
-rw-r--r--net-mgmt/zenpack-devicesearch/Makefile11
-rw-r--r--net-mgmt/zenpack-graphportlet/Makefile11
-rw-r--r--net-mgmt/zenpack-interfacegraphs/Makefile11
-rw-r--r--net-mgmt/zenpack-libvirt/Makefile5
-rw-r--r--net-mgmt/zenpack-macreport/Makefile11
-rw-r--r--net-mgmt/zenpack-ntpmonitor/Makefile5
13 files changed, 50 insertions, 72 deletions
diff --git a/CHANGES b/CHANGES
index c10fba43969b..e15dd1e66aa5 100644
--- a/CHANGES
+++ b/CHANGES
@@ -10,6 +10,13 @@ in the release notes and/or placed into UPDATING.
All ports committers are allowed to commit to this file.
+20130320:
+AUTHOR: jgh@FreeBSD.org
+
+ * New USES macro to handle support for Zenoss ports and Zenpacks:
+
+ USES= zenoss
+
20130319:
AUTHOR: makc@FreeBSD.org
diff --git a/Mk/bsd.zenoss.mk b/Mk/Uses/zenoss.mk
index c5763e94fd98..829432dfe3be 100644
--- a/Mk/bsd.zenoss.mk
+++ b/Mk/Uses/zenoss.mk
@@ -1,6 +1,3 @@
-#-*- mode: makefile; tab-width: 4; -*-
-# ex:ts=4
-#
# $FreeBSD$
#
# bsd.zenoss.mk - Support for Zenoss ports and Zenpacks.
@@ -8,8 +5,19 @@
# For FreeBSD committers:
# Please send all suggested changes to the maintainer instead of committing
# them yourself.
+#
+# MAINTAINER: zenoss@experts-exchange.com
+#
+# Feature: zenoss
+# Usage: USES=zenoss
+# Valid ARGS: does not require args
-bsd_zenoss_mk_MAINTAINER= zenoss@experts-exchange.com
+.if !defined(_INCLUDE_ZENOSS_MK)
+_INCLUDE_ZENOSS_MK= yes
+
+.if defined(zenoss_ARGS)
+IGNORE= USES=zenoss does not require args
+.endif
BUILD_DEPENDS+= zenoss>=3.1.0:${PORTSDIR}/net-mgmt/zenoss
RUN_DEPENDS+= zenoss>=3.1.0:${PORTSDIR}/net-mgmt/zenoss
@@ -71,3 +79,5 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/dist/${ZPACK} ${ZPACKHOME}
@${CAT} ${PKGMESSAGE}
.endif
+
+.endif
diff --git a/net-mgmt/zenpack-apachemonitor/Makefile b/net-mgmt/zenpack-apachemonitor/Makefile
index bbd815f68598..9714aecef200 100644
--- a/net-mgmt/zenpack-apachemonitor/Makefile
+++ b/net-mgmt/zenpack-apachemonitor/Makefile
@@ -12,6 +12,7 @@ COMMENT= Provides performance monitoring of the Apache HTTP Server
PLIST_FILES= zenoss/ZenPack/${ZPACK}
PLIST_DIRS= zenoss/ZenPack
+USES= zenoss
BROKEN= fails to fetch
@@ -19,6 +20,4 @@ USE_ZIP= yes
ZPACKGROUP= core
WRKSRC= ${WRKDIR}/tags/zenoss-3.1.0/zenpacks/${ZPACKPREFIX}${PORTNAME}/
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/Mk/bsd.zenoss.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net-mgmt/zenpack-checkping/Makefile b/net-mgmt/zenpack-checkping/Makefile
index 0988230c4b0f..17cc71bd0a31 100644
--- a/net-mgmt/zenpack-checkping/Makefile
+++ b/net-mgmt/zenpack-checkping/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: CheckPing
-# Date created: 08 June 2011
-# Whom: Zenoss <zenoss@experts-exchange.com>
-#
+# Created by: Zenoss <zenoss@experts-exchange.com>
# $FreeBSD$
-#
PORTNAME= CheckPing
PORTVERSION= 1.0
@@ -16,12 +12,11 @@ COMMENT= Provides nagios ping check for Zenoss monitoring
PLIST_FILES= zenoss/ZenPack/${ZPACK}
PLIST_DIRS= zenoss/ZenPack
+USES= zenoss
ZPACKPREFIX= ZenPacks.Nagios.
ZPACKGROUP= community
WRKSRC= ${WRKDIR}/zenoss-${ZPACKPREFIX}${PORTNAME}-${TAG}
TAG= 0088e17
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/Mk/bsd.zenoss.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net-mgmt/zenpack-dellmon/Makefile b/net-mgmt/zenpack-dellmon/Makefile
index 9341ff2ad9e0..17628284cf75 100644
--- a/net-mgmt/zenpack-dellmon/Makefile
+++ b/net-mgmt/zenpack-dellmon/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: DellMon
-# Date created: 13 May 2011
-# Whom: Zenoss <zenoss@experts-exchange.com>
-#
+# Created by: Zenoss <zenoss@experts-exchange.com>
# $FreeBSD$
-#
PORTNAME= DellMon
PORTVERSION= 2.4
@@ -17,11 +13,10 @@ COMMENT= Provides additional monitoring options for Dell machines
PLIST_FILES= zenoss/ZenPack/${ZPACK}
PLIST_DIRS= zenoss/ZenPack
+USES= zenoss
ZPACKGROUP= community
WRKSRC= ${WRKDIR}/epuzanov-${ZPACKPREFIX}${PORTNAME}-a4ae347
ZPACKPREFIX= ZenPacks.community.
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/Mk/bsd.zenoss.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net-mgmt/zenpack-dellmonitor/Makefile b/net-mgmt/zenpack-dellmonitor/Makefile
index 55feb24e2970..955675b96cdb 100644
--- a/net-mgmt/zenpack-dellmonitor/Makefile
+++ b/net-mgmt/zenpack-dellmonitor/Makefile
@@ -12,6 +12,7 @@ COMMENT= Provides Zenoss monitoring options for Dell machines
PLIST_FILES= zenoss/ZenPack/${ZPACK}
PLIST_DIRS= zenoss/ZenPack
+USES= zenoss
BROKEN= fails to fetch
@@ -19,6 +20,4 @@ USE_ZIP= yes
ZPACKGROUP= core
WRKSRC= ${WRKDIR}/tags/zenoss-3.1.0/zenpacks/${ZPACKPREFIX}${PORTNAME}/
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/Mk/bsd.zenoss.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net-mgmt/zenpack-deviceadvdetail/Makefile b/net-mgmt/zenpack-deviceadvdetail/Makefile
index c41a05b8c9c5..f7622894c056 100644
--- a/net-mgmt/zenpack-deviceadvdetail/Makefile
+++ b/net-mgmt/zenpack-deviceadvdetail/Makefile
@@ -1,9 +1,5 @@
-# New ports collection Makefile for: deviceAdvDetail
-# Date created: 11 May 2011
-# Whom: Zenoss <zenoss@experts-exchange.com>
-#
+# Created by: Zenoss <zenoss@experts-exchange.com>
# $FreeBSD$
-#
PORTNAME= deviceAdvDetail
PORTVERSION= 2.7.3
@@ -16,6 +12,7 @@ COMMENT= Provides additional hardware details for Zenoss
PLIST_FILES= zenoss/ZenPack/${ZPACK}
PLIST_DIRS= zenoss/ZenPack
+USES= zenoss
ZPACKGROUP= community
WRKSRC= ${WRKDIR}/epuzanov-${ZPACKPREFIX}${PORTNAME}-cfbd596
@@ -23,6 +20,4 @@ WRKSRC= ${WRKDIR}/epuzanov-${ZPACKPREFIX}${PORTNAME}-cfbd596
ZPACK= ${ZPACKPREFIX}${PORTNAME}-2.7-${PYTHON_VERSION:S/thon//}.egg
ZPACKPREFIX= ZenPacks.community.
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/Mk/bsd.zenoss.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net-mgmt/zenpack-devicesearch/Makefile b/net-mgmt/zenpack-devicesearch/Makefile
index 74f320ed17c6..c2c929b9d4dd 100644
--- a/net-mgmt/zenpack-devicesearch/Makefile
+++ b/net-mgmt/zenpack-devicesearch/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: DeviceSearch
-# Date created: 26 May 2011
-# Whom: Zenoss <zenoss@experts-exchange.com>
-#
+# Created by: Zenoss <zenoss@experts-exchange.com>
# $FreeBSD$
-#
PORTNAME= DeviceSearch
PORTVERSION= 1.0.0
@@ -15,9 +11,8 @@ COMMENT= Provides the ability to quickly search for devices in Zenoss
PLIST_FILES= zenoss/ZenPack/${ZPACK}
PLIST_DIRS= zenoss/ZenPack
+USES= zenoss
ZPACKGROUP= core
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/Mk/bsd.zenoss.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net-mgmt/zenpack-graphportlet/Makefile b/net-mgmt/zenpack-graphportlet/Makefile
index b2c2ee0b39e6..98e6f3d206ec 100644
--- a/net-mgmt/zenpack-graphportlet/Makefile
+++ b/net-mgmt/zenpack-graphportlet/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: ShowGraphPortlet
-# Date created: 12 May 2011
-# Whom: Zenoss <zenoss@experts-exchange.com>
-#
+# Created by: Zenoss <zenoss@experts-exchange.com>
# $FreeBSD$
-#
PORTNAME= ShowGraphPortlet
PORTVERSION= 1.03
@@ -16,12 +12,11 @@ COMMENT= Enables users to show any graph/multi graph reports on their dashboard
PLIST_FILES= zenoss/ZenPack/${ZPACK}
PLIST_DIRS= zenoss/ZenPack
+USES= zenoss
ZPACKGROUP= community
ZPACKPREFIX= ZenPacks.SCC.
WRKSRC= ${WRKDIR}/zenoss-${ZPACKPREFIX}${PORTNAME}-${TAG}
TAG= 0cf7678
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/Mk/bsd.zenoss.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net-mgmt/zenpack-interfacegraphs/Makefile b/net-mgmt/zenpack-interfacegraphs/Makefile
index cce3b74832f9..3fdb5cab7e06 100644
--- a/net-mgmt/zenpack-interfacegraphs/Makefile
+++ b/net-mgmt/zenpack-interfacegraphs/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: InterfaceGraphs
-# Date created: 26 May 2011
-# Whom: Zenoss <zenoss@experts-exchange.com>
-#
+# Created by: Zenoss <zenoss@experts-exchange.com>
# $FreeBSD$
-#
PORTNAME= InterfaceGraphs
PORTVERSION= 1.0
@@ -16,12 +12,11 @@ COMMENT= Provides a link that graphs all network interfaces for a device
PLIST_FILES= zenoss/ZenPack/${ZPACK}
PLIST_DIRS= zenoss/ZenPack
+USES= zenoss
ZPACKGROUP= community
ZPACKPREFIX= ZenPacks.community.
WRKSRC= ${WRKDIR}/zenoss-${ZPACKPREFIX}${PORTNAME}-${TAG}
TAG= 7ed2d7d
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/Mk/bsd.zenoss.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net-mgmt/zenpack-libvirt/Makefile b/net-mgmt/zenpack-libvirt/Makefile
index a6095798f3ca..02d7d8d72eba 100644
--- a/net-mgmt/zenpack-libvirt/Makefile
+++ b/net-mgmt/zenpack-libvirt/Makefile
@@ -17,12 +17,11 @@ RUN_DEPENDS= libvirt>=0.9.1:${PORTSDIR}/devel/libvirt
PLIST_FILES= zenoss/ZenPack/${ZPACK}
PLIST_DIRS= zenoss/ZenPack
+USES= zenoss
ZPACKPREFIX= ZenPacks.community.
ZPACKGROUP= community
WRKSRC= ${WRKDIR}/zenoss-${ZPACKPREFIX}${PORTNAME}-${TAG}
TAG= 4113cfe
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/Mk/bsd.zenoss.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net-mgmt/zenpack-macreport/Makefile b/net-mgmt/zenpack-macreport/Makefile
index fab09b1ec3f1..58516da4d35d 100644
--- a/net-mgmt/zenpack-macreport/Makefile
+++ b/net-mgmt/zenpack-macreport/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: MACReport
-# Date created: 13 May 2011
-# Whom: Zenoss <zenoss@experts-exchange.com>
-#
+# Created by: Zenoss <zenoss@experts-exchange.com>
# $FreeBSD$
-#
PORTNAME= MACReport
PORTVERSION= 1.0.1
@@ -16,6 +12,7 @@ COMMENT= Lists MAC address and the Device and Interface associated info
PLIST_FILES= zenoss/ZenPack/${ZPACK}
PLIST_DIRS= zenoss/ZenPack
+USES= zenoss
USE_ZIP= yes
ZPACKGROUP= community
@@ -24,6 +21,4 @@ TAG= b345f53
ZPACKPREFIX= ZenPacks.sodonnell.
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/Mk/bsd.zenoss.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net-mgmt/zenpack-ntpmonitor/Makefile b/net-mgmt/zenpack-ntpmonitor/Makefile
index 35cc2c121cc9..60cd88339836 100644
--- a/net-mgmt/zenpack-ntpmonitor/Makefile
+++ b/net-mgmt/zenpack-ntpmonitor/Makefile
@@ -12,6 +12,7 @@ COMMENT= Monitors the offset between system time and a target NTP servers time
PLIST_FILES= zenoss/ZenPack/${ZPACK}
PLIST_DIRS= zenoss/ZenPack
+USES= zenoss
BROKEN= fails to fetch
@@ -19,6 +20,4 @@ USE_ZIP= yes
ZPACKGROUP= core
WRKSRC= ${WRKDIR}/tags/zenoss-3.1.0/zenpacks/${ZPACKPREFIX}${PORTNAME}/
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/Mk/bsd.zenoss.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>