aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaho Nakata <maho@FreeBSD.org>2006-04-24 11:48:16 +0000
committerMaho Nakata <maho@FreeBSD.org>2006-04-24 11:48:16 +0000
commit24d097620485a56ef9a7089e493c378ab8bc7cde (patch)
tree7ea38797933fdf946f822b1c538ff8bc9b1c3903
parente3f9c476fc9a26bae8c733cb4f8babff8d9f8546 (diff)
downloadports-24d097620485a56ef9a7089e493c378ab8bc7cde.tar.gz
ports-24d097620485a56ef9a7089e493c378ab8bc7cde.zip
Notes
-rw-r--r--editors/openoffice-3-devel/Makefile4
-rw-r--r--editors/openoffice-3-devel/files/Makefile.knobs14
-rw-r--r--editors/openoffice-3/Makefile4
-rw-r--r--editors/openoffice-3/files/Makefile.knobs14
-rw-r--r--editors/openoffice.org-2-RC/Makefile4
-rw-r--r--editors/openoffice.org-2-RC/files/Makefile.knobs14
-rw-r--r--editors/openoffice.org-2-devel/Makefile4
-rw-r--r--editors/openoffice.org-2-devel/files/Makefile.knobs14
-rw-r--r--editors/openoffice.org-2.0-devel/Makefile4
-rw-r--r--editors/openoffice.org-2.0-devel/files/Makefile.knobs14
-rw-r--r--editors/openoffice.org-2.0/Makefile4
-rw-r--r--editors/openoffice.org-2.0/files/Makefile.knobs14
-rw-r--r--editors/openoffice.org-2/Makefile4
-rw-r--r--editors/openoffice.org-2/files/Makefile.knobs14
-rw-r--r--editors/openoffice.org-3-RC/Makefile4
-rw-r--r--editors/openoffice.org-3-RC/files/Makefile.knobs14
-rw-r--r--editors/openoffice.org-3-devel/Makefile4
-rw-r--r--editors/openoffice.org-3-devel/files/Makefile.knobs14
-rw-r--r--editors/openoffice.org-3/Makefile4
-rw-r--r--editors/openoffice.org-3/files/Makefile.knobs14
-rw-r--r--editors/openoffice.org-vcltesttool/Makefile4
-rw-r--r--editors/openoffice.org-vcltesttool/files/Makefile.knobs14
22 files changed, 44 insertions, 154 deletions
diff --git a/editors/openoffice-3-devel/Makefile b/editors/openoffice-3-devel/Makefile
index bc3b1fea2dec..37d837ab1218 100644
--- a/editors/openoffice-3-devel/Makefile
+++ b/editors/openoffice-3-devel/Makefile
@@ -48,7 +48,7 @@ WITHOUT_CPU_CFLAGS= true
ONLY_FOR_ARCHS= i386
-.if !defined(WITHOUT_JAVA) && !defined(WITH_GNUGCJ)
+.if !defined(WITH_GNUGCJ)
USE_JAVA= yes
JAVA_VERSION= 1.4+
JAVA_BUILD= jdk
@@ -120,7 +120,7 @@ BUILD_DEPENDS+= zip:${PORTSDIR}/archivers/zip \
${SITE_PERL}/Archive/Zip.pm:${PORTSDIR}/archivers/p5-Archive-Zip \
bison2:${PORTSDIR}/devel/bison2 \
imake:${X_IMAKE_PORT}
-.if !defined(WITHOUT_JAVA) && !defined(WITH_GNUGCJ)
+.if !defined(WITH_GNUGCJ)
BUILD_DEPENDS+= ant:${PORTSDIR}/devel/apache-ant
.else
LIB_DEPENDS+= xslt.2:${PORTSDIR}/textproc/libxslt
diff --git a/editors/openoffice-3-devel/files/Makefile.knobs b/editors/openoffice-3-devel/files/Makefile.knobs
index 7cd35078b44b..5645c9a1a859 100644
--- a/editors/openoffice-3-devel/files/Makefile.knobs
+++ b/editors/openoffice-3-devel/files/Makefile.knobs
@@ -2,15 +2,11 @@
# Whom: Maho Nakata <maho@FreeBSD.org>
# $FreeBSD$
-.if !defined(WITHOUT_JAVA) && !defined(WITH_GNUGCJ)
+.if !defined(WITH_GNUGCJ)
CONFIGURE_ARGS+= --with-jdk-home="${JAVA_HOME}" --with-ant-home=${LOCALBASE}/ant
-.endif
-.if !defined(WITHOUT_JAVA) && defined(WITH_GNUGCJ)
+else
CONFIGURE_ARGS+= --with-jdk-home="${WRKDIR}/gnugcj" --with-java=gij --with-ant-home="${WRKDIR}/apache-ant-${ANT_VERSION}"
.endif
-.if defined(WITHOUT_JAVA)
-CONFIGURE_ARGS+= --without-java
-.endif
.if defined(WITH_KDE)
CONFIGURE_ARGS+= --enable-kde QTDIR="${QT_PREFIX}"
@@ -92,12 +88,6 @@ pre-fetch:
@${ECHO} "st sv sw sw-TZ sx ta-IN th tn tr ts ve vi xh zh-CN"
@${ECHO} "zh-TW zu"
@${ECHO} "Default: en-US"
-#XXX currently broken
-#.if !defined(WITHOUT_JAVA)
-# @${ECHO}
-# @${ECHO} "You can compile OOo without Java support with"
-# @${ECHO} "make -DWITHOUT_JAVA"
-#.endif
.if !defined(WITH_GNUGCJ)
@${ECHO}
@${ECHO} "You can compile OOo with GNU GCJ instead of SUN's JDK with"
diff --git a/editors/openoffice-3/Makefile b/editors/openoffice-3/Makefile
index 025f0f29a1f1..12e8dbb3da1f 100644
--- a/editors/openoffice-3/Makefile
+++ b/editors/openoffice-3/Makefile
@@ -47,7 +47,7 @@ WITHOUT_CPU_CFLAGS= true
ONLY_FOR_ARCHS= i386
-.if !defined(WITHOUT_JAVA) && !defined(WITH_GNUGCJ)
+.if !defined(WITH_GNUGCJ)
USE_JAVA= yes
JAVA_VERSION= 1.4+
JAVA_BUILD= jdk
@@ -117,7 +117,7 @@ BUILD_DEPENDS+= zip:${PORTSDIR}/archivers/zip \
${SITE_PERL}/Archive/Zip.pm:${PORTSDIR}/archivers/p5-Archive-Zip \
bison2:${PORTSDIR}/devel/bison2 \
imake:${X_IMAKE_PORT}
-.if !defined(WITHOUT_JAVA) && !defined(WITH_GNUGCJ)
+.if !defined(WITH_GNUGCJ)
BUILD_DEPENDS+= ant:${PORTSDIR}/devel/apache-ant
.else
LIB_DEPENDS+= xslt.2:${PORTSDIR}/textproc/libxslt
diff --git a/editors/openoffice-3/files/Makefile.knobs b/editors/openoffice-3/files/Makefile.knobs
index 7cd35078b44b..c4a0a84ac1c9 100644
--- a/editors/openoffice-3/files/Makefile.knobs
+++ b/editors/openoffice-3/files/Makefile.knobs
@@ -2,15 +2,11 @@
# Whom: Maho Nakata <maho@FreeBSD.org>
# $FreeBSD$
-.if !defined(WITHOUT_JAVA) && !defined(WITH_GNUGCJ)
+.if !defined(WITH_GNUGCJ)
CONFIGURE_ARGS+= --with-jdk-home="${JAVA_HOME}" --with-ant-home=${LOCALBASE}/ant
-.endif
-.if !defined(WITHOUT_JAVA) && defined(WITH_GNUGCJ)
+.else
CONFIGURE_ARGS+= --with-jdk-home="${WRKDIR}/gnugcj" --with-java=gij --with-ant-home="${WRKDIR}/apache-ant-${ANT_VERSION}"
.endif
-.if defined(WITHOUT_JAVA)
-CONFIGURE_ARGS+= --without-java
-.endif
.if defined(WITH_KDE)
CONFIGURE_ARGS+= --enable-kde QTDIR="${QT_PREFIX}"
@@ -92,12 +88,6 @@ pre-fetch:
@${ECHO} "st sv sw sw-TZ sx ta-IN th tn tr ts ve vi xh zh-CN"
@${ECHO} "zh-TW zu"
@${ECHO} "Default: en-US"
-#XXX currently broken
-#.if !defined(WITHOUT_JAVA)
-# @${ECHO}
-# @${ECHO} "You can compile OOo without Java support with"
-# @${ECHO} "make -DWITHOUT_JAVA"
-#.endif
.if !defined(WITH_GNUGCJ)
@${ECHO}
@${ECHO} "You can compile OOo with GNU GCJ instead of SUN's JDK with"
diff --git a/editors/openoffice.org-2-RC/Makefile b/editors/openoffice.org-2-RC/Makefile
index 025f0f29a1f1..12e8dbb3da1f 100644
--- a/editors/openoffice.org-2-RC/Makefile
+++ b/editors/openoffice.org-2-RC/Makefile
@@ -47,7 +47,7 @@ WITHOUT_CPU_CFLAGS= true
ONLY_FOR_ARCHS= i386
-.if !defined(WITHOUT_JAVA) && !defined(WITH_GNUGCJ)
+.if !defined(WITH_GNUGCJ)
USE_JAVA= yes
JAVA_VERSION= 1.4+
JAVA_BUILD= jdk
@@ -117,7 +117,7 @@ BUILD_DEPENDS+= zip:${PORTSDIR}/archivers/zip \
${SITE_PERL}/Archive/Zip.pm:${PORTSDIR}/archivers/p5-Archive-Zip \
bison2:${PORTSDIR}/devel/bison2 \
imake:${X_IMAKE_PORT}
-.if !defined(WITHOUT_JAVA) && !defined(WITH_GNUGCJ)
+.if !defined(WITH_GNUGCJ)
BUILD_DEPENDS+= ant:${PORTSDIR}/devel/apache-ant
.else
LIB_DEPENDS+= xslt.2:${PORTSDIR}/textproc/libxslt
diff --git a/editors/openoffice.org-2-RC/files/Makefile.knobs b/editors/openoffice.org-2-RC/files/Makefile.knobs
index 7cd35078b44b..c4a0a84ac1c9 100644
--- a/editors/openoffice.org-2-RC/files/Makefile.knobs
+++ b/editors/openoffice.org-2-RC/files/Makefile.knobs
@@ -2,15 +2,11 @@
# Whom: Maho Nakata <maho@FreeBSD.org>
# $FreeBSD$
-.if !defined(WITHOUT_JAVA) && !defined(WITH_GNUGCJ)
+.if !defined(WITH_GNUGCJ)
CONFIGURE_ARGS+= --with-jdk-home="${JAVA_HOME}" --with-ant-home=${LOCALBASE}/ant
-.endif
-.if !defined(WITHOUT_JAVA) && defined(WITH_GNUGCJ)
+.else
CONFIGURE_ARGS+= --with-jdk-home="${WRKDIR}/gnugcj" --with-java=gij --with-ant-home="${WRKDIR}/apache-ant-${ANT_VERSION}"
.endif
-.if defined(WITHOUT_JAVA)
-CONFIGURE_ARGS+= --without-java
-.endif
.if defined(WITH_KDE)
CONFIGURE_ARGS+= --enable-kde QTDIR="${QT_PREFIX}"
@@ -92,12 +88,6 @@ pre-fetch:
@${ECHO} "st sv sw sw-TZ sx ta-IN th tn tr ts ve vi xh zh-CN"
@${ECHO} "zh-TW zu"
@${ECHO} "Default: en-US"
-#XXX currently broken
-#.if !defined(WITHOUT_JAVA)
-# @${ECHO}
-# @${ECHO} "You can compile OOo without Java support with"
-# @${ECHO} "make -DWITHOUT_JAVA"
-#.endif
.if !defined(WITH_GNUGCJ)
@${ECHO}
@${ECHO} "You can compile OOo with GNU GCJ instead of SUN's JDK with"
diff --git a/editors/openoffice.org-2-devel/Makefile b/editors/openoffice.org-2-devel/Makefile
index bc3b1fea2dec..37d837ab1218 100644
--- a/editors/openoffice.org-2-devel/Makefile
+++ b/editors/openoffice.org-2-devel/Makefile
@@ -48,7 +48,7 @@ WITHOUT_CPU_CFLAGS= true
ONLY_FOR_ARCHS= i386
-.if !defined(WITHOUT_JAVA) && !defined(WITH_GNUGCJ)
+.if !defined(WITH_GNUGCJ)
USE_JAVA= yes
JAVA_VERSION= 1.4+
JAVA_BUILD= jdk
@@ -120,7 +120,7 @@ BUILD_DEPENDS+= zip:${PORTSDIR}/archivers/zip \
${SITE_PERL}/Archive/Zip.pm:${PORTSDIR}/archivers/p5-Archive-Zip \
bison2:${PORTSDIR}/devel/bison2 \
imake:${X_IMAKE_PORT}
-.if !defined(WITHOUT_JAVA) && !defined(WITH_GNUGCJ)
+.if !defined(WITH_GNUGCJ)
BUILD_DEPENDS+= ant:${PORTSDIR}/devel/apache-ant
.else
LIB_DEPENDS+= xslt.2:${PORTSDIR}/textproc/libxslt
diff --git a/editors/openoffice.org-2-devel/files/Makefile.knobs b/editors/openoffice.org-2-devel/files/Makefile.knobs
index 7cd35078b44b..5645c9a1a859 100644
--- a/editors/openoffice.org-2-devel/files/Makefile.knobs
+++ b/editors/openoffice.org-2-devel/files/Makefile.knobs
@@ -2,15 +2,11 @@
# Whom: Maho Nakata <maho@FreeBSD.org>
# $FreeBSD$
-.if !defined(WITHOUT_JAVA) && !defined(WITH_GNUGCJ)
+.if !defined(WITH_GNUGCJ)
CONFIGURE_ARGS+= --with-jdk-home="${JAVA_HOME}" --with-ant-home=${LOCALBASE}/ant
-.endif
-.if !defined(WITHOUT_JAVA) && defined(WITH_GNUGCJ)
+else
CONFIGURE_ARGS+= --with-jdk-home="${WRKDIR}/gnugcj" --with-java=gij --with-ant-home="${WRKDIR}/apache-ant-${ANT_VERSION}"
.endif
-.if defined(WITHOUT_JAVA)
-CONFIGURE_ARGS+= --without-java
-.endif
.if defined(WITH_KDE)
CONFIGURE_ARGS+= --enable-kde QTDIR="${QT_PREFIX}"
@@ -92,12 +88,6 @@ pre-fetch:
@${ECHO} "st sv sw sw-TZ sx ta-IN th tn tr ts ve vi xh zh-CN"
@${ECHO} "zh-TW zu"
@${ECHO} "Default: en-US"
-#XXX currently broken
-#.if !defined(WITHOUT_JAVA)
-# @${ECHO}
-# @${ECHO} "You can compile OOo without Java support with"
-# @${ECHO} "make -DWITHOUT_JAVA"
-#.endif
.if !defined(WITH_GNUGCJ)
@${ECHO}
@${ECHO} "You can compile OOo with GNU GCJ instead of SUN's JDK with"
diff --git a/editors/openoffice.org-2.0-devel/Makefile b/editors/openoffice.org-2.0-devel/Makefile
index bc3b1fea2dec..37d837ab1218 100644
--- a/editors/openoffice.org-2.0-devel/Makefile
+++ b/editors/openoffice.org-2.0-devel/Makefile
@@ -48,7 +48,7 @@ WITHOUT_CPU_CFLAGS= true
ONLY_FOR_ARCHS= i386
-.if !defined(WITHOUT_JAVA) && !defined(WITH_GNUGCJ)
+.if !defined(WITH_GNUGCJ)
USE_JAVA= yes
JAVA_VERSION= 1.4+
JAVA_BUILD= jdk
@@ -120,7 +120,7 @@ BUILD_DEPENDS+= zip:${PORTSDIR}/archivers/zip \
${SITE_PERL}/Archive/Zip.pm:${PORTSDIR}/archivers/p5-Archive-Zip \
bison2:${PORTSDIR}/devel/bison2 \
imake:${X_IMAKE_PORT}
-.if !defined(WITHOUT_JAVA) && !defined(WITH_GNUGCJ)
+.if !defined(WITH_GNUGCJ)
BUILD_DEPENDS+= ant:${PORTSDIR}/devel/apache-ant
.else
LIB_DEPENDS+= xslt.2:${PORTSDIR}/textproc/libxslt
diff --git a/editors/openoffice.org-2.0-devel/files/Makefile.knobs b/editors/openoffice.org-2.0-devel/files/Makefile.knobs
index 7cd35078b44b..5645c9a1a859 100644
--- a/editors/openoffice.org-2.0-devel/files/Makefile.knobs
+++ b/editors/openoffice.org-2.0-devel/files/Makefile.knobs
@@ -2,15 +2,11 @@
# Whom: Maho Nakata <maho@FreeBSD.org>
# $FreeBSD$
-.if !defined(WITHOUT_JAVA) && !defined(WITH_GNUGCJ)
+.if !defined(WITH_GNUGCJ)
CONFIGURE_ARGS+= --with-jdk-home="${JAVA_HOME}" --with-ant-home=${LOCALBASE}/ant
-.endif
-.if !defined(WITHOUT_JAVA) && defined(WITH_GNUGCJ)
+else
CONFIGURE_ARGS+= --with-jdk-home="${WRKDIR}/gnugcj" --with-java=gij --with-ant-home="${WRKDIR}/apache-ant-${ANT_VERSION}"
.endif
-.if defined(WITHOUT_JAVA)
-CONFIGURE_ARGS+= --without-java
-.endif
.if defined(WITH_KDE)
CONFIGURE_ARGS+= --enable-kde QTDIR="${QT_PREFIX}"
@@ -92,12 +88,6 @@ pre-fetch:
@${ECHO} "st sv sw sw-TZ sx ta-IN th tn tr ts ve vi xh zh-CN"
@${ECHO} "zh-TW zu"
@${ECHO} "Default: en-US"
-#XXX currently broken
-#.if !defined(WITHOUT_JAVA)
-# @${ECHO}
-# @${ECHO} "You can compile OOo without Java support with"
-# @${ECHO} "make -DWITHOUT_JAVA"
-#.endif
.if !defined(WITH_GNUGCJ)
@${ECHO}
@${ECHO} "You can compile OOo with GNU GCJ instead of SUN's JDK with"
diff --git a/editors/openoffice.org-2.0/Makefile b/editors/openoffice.org-2.0/Makefile
index 025f0f29a1f1..12e8dbb3da1f 100644
--- a/editors/openoffice.org-2.0/Makefile
+++ b/editors/openoffice.org-2.0/Makefile
@@ -47,7 +47,7 @@ WITHOUT_CPU_CFLAGS= true
ONLY_FOR_ARCHS= i386
-.if !defined(WITHOUT_JAVA) && !defined(WITH_GNUGCJ)
+.if !defined(WITH_GNUGCJ)
USE_JAVA= yes
JAVA_VERSION= 1.4+
JAVA_BUILD= jdk
@@ -117,7 +117,7 @@ BUILD_DEPENDS+= zip:${PORTSDIR}/archivers/zip \
${SITE_PERL}/Archive/Zip.pm:${PORTSDIR}/archivers/p5-Archive-Zip \
bison2:${PORTSDIR}/devel/bison2 \
imake:${X_IMAKE_PORT}
-.if !defined(WITHOUT_JAVA) && !defined(WITH_GNUGCJ)
+.if !defined(WITH_GNUGCJ)
BUILD_DEPENDS+= ant:${PORTSDIR}/devel/apache-ant
.else
LIB_DEPENDS+= xslt.2:${PORTSDIR}/textproc/libxslt
diff --git a/editors/openoffice.org-2.0/files/Makefile.knobs b/editors/openoffice.org-2.0/files/Makefile.knobs
index 7cd35078b44b..c4a0a84ac1c9 100644
--- a/editors/openoffice.org-2.0/files/Makefile.knobs
+++ b/editors/openoffice.org-2.0/files/Makefile.knobs
@@ -2,15 +2,11 @@
# Whom: Maho Nakata <maho@FreeBSD.org>
# $FreeBSD$
-.if !defined(WITHOUT_JAVA) && !defined(WITH_GNUGCJ)
+.if !defined(WITH_GNUGCJ)
CONFIGURE_ARGS+= --with-jdk-home="${JAVA_HOME}" --with-ant-home=${LOCALBASE}/ant
-.endif
-.if !defined(WITHOUT_JAVA) && defined(WITH_GNUGCJ)
+.else
CONFIGURE_ARGS+= --with-jdk-home="${WRKDIR}/gnugcj" --with-java=gij --with-ant-home="${WRKDIR}/apache-ant-${ANT_VERSION}"
.endif
-.if defined(WITHOUT_JAVA)
-CONFIGURE_ARGS+= --without-java
-.endif
.if defined(WITH_KDE)
CONFIGURE_ARGS+= --enable-kde QTDIR="${QT_PREFIX}"
@@ -92,12 +88,6 @@ pre-fetch:
@${ECHO} "st sv sw sw-TZ sx ta-IN th tn tr ts ve vi xh zh-CN"
@${ECHO} "zh-TW zu"
@${ECHO} "Default: en-US"
-#XXX currently broken
-#.if !defined(WITHOUT_JAVA)
-# @${ECHO}
-# @${ECHO} "You can compile OOo without Java support with"
-# @${ECHO} "make -DWITHOUT_JAVA"
-#.endif
.if !defined(WITH_GNUGCJ)
@${ECHO}
@${ECHO} "You can compile OOo with GNU GCJ instead of SUN's JDK with"
diff --git a/editors/openoffice.org-2/Makefile b/editors/openoffice.org-2/Makefile
index 025f0f29a1f1..12e8dbb3da1f 100644
--- a/editors/openoffice.org-2/Makefile
+++ b/editors/openoffice.org-2/Makefile
@@ -47,7 +47,7 @@ WITHOUT_CPU_CFLAGS= true
ONLY_FOR_ARCHS= i386
-.if !defined(WITHOUT_JAVA) && !defined(WITH_GNUGCJ)
+.if !defined(WITH_GNUGCJ)
USE_JAVA= yes
JAVA_VERSION= 1.4+
JAVA_BUILD= jdk
@@ -117,7 +117,7 @@ BUILD_DEPENDS+= zip:${PORTSDIR}/archivers/zip \
${SITE_PERL}/Archive/Zip.pm:${PORTSDIR}/archivers/p5-Archive-Zip \
bison2:${PORTSDIR}/devel/bison2 \
imake:${X_IMAKE_PORT}
-.if !defined(WITHOUT_JAVA) && !defined(WITH_GNUGCJ)
+.if !defined(WITH_GNUGCJ)
BUILD_DEPENDS+= ant:${PORTSDIR}/devel/apache-ant
.else
LIB_DEPENDS+= xslt.2:${PORTSDIR}/textproc/libxslt
diff --git a/editors/openoffice.org-2/files/Makefile.knobs b/editors/openoffice.org-2/files/Makefile.knobs
index 7cd35078b44b..c4a0a84ac1c9 100644
--- a/editors/openoffice.org-2/files/Makefile.knobs
+++ b/editors/openoffice.org-2/files/Makefile.knobs
@@ -2,15 +2,11 @@
# Whom: Maho Nakata <maho@FreeBSD.org>
# $FreeBSD$
-.if !defined(WITHOUT_JAVA) && !defined(WITH_GNUGCJ)
+.if !defined(WITH_GNUGCJ)
CONFIGURE_ARGS+= --with-jdk-home="${JAVA_HOME}" --with-ant-home=${LOCALBASE}/ant
-.endif
-.if !defined(WITHOUT_JAVA) && defined(WITH_GNUGCJ)
+.else
CONFIGURE_ARGS+= --with-jdk-home="${WRKDIR}/gnugcj" --with-java=gij --with-ant-home="${WRKDIR}/apache-ant-${ANT_VERSION}"
.endif
-.if defined(WITHOUT_JAVA)
-CONFIGURE_ARGS+= --without-java
-.endif
.if defined(WITH_KDE)
CONFIGURE_ARGS+= --enable-kde QTDIR="${QT_PREFIX}"
@@ -92,12 +88,6 @@ pre-fetch:
@${ECHO} "st sv sw sw-TZ sx ta-IN th tn tr ts ve vi xh zh-CN"
@${ECHO} "zh-TW zu"
@${ECHO} "Default: en-US"
-#XXX currently broken
-#.if !defined(WITHOUT_JAVA)
-# @${ECHO}
-# @${ECHO} "You can compile OOo without Java support with"
-# @${ECHO} "make -DWITHOUT_JAVA"
-#.endif
.if !defined(WITH_GNUGCJ)
@${ECHO}
@${ECHO} "You can compile OOo with GNU GCJ instead of SUN's JDK with"
diff --git a/editors/openoffice.org-3-RC/Makefile b/editors/openoffice.org-3-RC/Makefile
index 025f0f29a1f1..12e8dbb3da1f 100644
--- a/editors/openoffice.org-3-RC/Makefile
+++ b/editors/openoffice.org-3-RC/Makefile
@@ -47,7 +47,7 @@ WITHOUT_CPU_CFLAGS= true
ONLY_FOR_ARCHS= i386
-.if !defined(WITHOUT_JAVA) && !defined(WITH_GNUGCJ)
+.if !defined(WITH_GNUGCJ)
USE_JAVA= yes
JAVA_VERSION= 1.4+
JAVA_BUILD= jdk
@@ -117,7 +117,7 @@ BUILD_DEPENDS+= zip:${PORTSDIR}/archivers/zip \
${SITE_PERL}/Archive/Zip.pm:${PORTSDIR}/archivers/p5-Archive-Zip \
bison2:${PORTSDIR}/devel/bison2 \
imake:${X_IMAKE_PORT}
-.if !defined(WITHOUT_JAVA) && !defined(WITH_GNUGCJ)
+.if !defined(WITH_GNUGCJ)
BUILD_DEPENDS+= ant:${PORTSDIR}/devel/apache-ant
.else
LIB_DEPENDS+= xslt.2:${PORTSDIR}/textproc/libxslt
diff --git a/editors/openoffice.org-3-RC/files/Makefile.knobs b/editors/openoffice.org-3-RC/files/Makefile.knobs
index 7cd35078b44b..c4a0a84ac1c9 100644
--- a/editors/openoffice.org-3-RC/files/Makefile.knobs
+++ b/editors/openoffice.org-3-RC/files/Makefile.knobs
@@ -2,15 +2,11 @@
# Whom: Maho Nakata <maho@FreeBSD.org>
# $FreeBSD$
-.if !defined(WITHOUT_JAVA) && !defined(WITH_GNUGCJ)
+.if !defined(WITH_GNUGCJ)
CONFIGURE_ARGS+= --with-jdk-home="${JAVA_HOME}" --with-ant-home=${LOCALBASE}/ant
-.endif
-.if !defined(WITHOUT_JAVA) && defined(WITH_GNUGCJ)
+.else
CONFIGURE_ARGS+= --with-jdk-home="${WRKDIR}/gnugcj" --with-java=gij --with-ant-home="${WRKDIR}/apache-ant-${ANT_VERSION}"
.endif
-.if defined(WITHOUT_JAVA)
-CONFIGURE_ARGS+= --without-java
-.endif
.if defined(WITH_KDE)
CONFIGURE_ARGS+= --enable-kde QTDIR="${QT_PREFIX}"
@@ -92,12 +88,6 @@ pre-fetch:
@${ECHO} "st sv sw sw-TZ sx ta-IN th tn tr ts ve vi xh zh-CN"
@${ECHO} "zh-TW zu"
@${ECHO} "Default: en-US"
-#XXX currently broken
-#.if !defined(WITHOUT_JAVA)
-# @${ECHO}
-# @${ECHO} "You can compile OOo without Java support with"
-# @${ECHO} "make -DWITHOUT_JAVA"
-#.endif
.if !defined(WITH_GNUGCJ)
@${ECHO}
@${ECHO} "You can compile OOo with GNU GCJ instead of SUN's JDK with"
diff --git a/editors/openoffice.org-3-devel/Makefile b/editors/openoffice.org-3-devel/Makefile
index bc3b1fea2dec..37d837ab1218 100644
--- a/editors/openoffice.org-3-devel/Makefile
+++ b/editors/openoffice.org-3-devel/Makefile
@@ -48,7 +48,7 @@ WITHOUT_CPU_CFLAGS= true
ONLY_FOR_ARCHS= i386
-.if !defined(WITHOUT_JAVA) && !defined(WITH_GNUGCJ)
+.if !defined(WITH_GNUGCJ)
USE_JAVA= yes
JAVA_VERSION= 1.4+
JAVA_BUILD= jdk
@@ -120,7 +120,7 @@ BUILD_DEPENDS+= zip:${PORTSDIR}/archivers/zip \
${SITE_PERL}/Archive/Zip.pm:${PORTSDIR}/archivers/p5-Archive-Zip \
bison2:${PORTSDIR}/devel/bison2 \
imake:${X_IMAKE_PORT}
-.if !defined(WITHOUT_JAVA) && !defined(WITH_GNUGCJ)
+.if !defined(WITH_GNUGCJ)
BUILD_DEPENDS+= ant:${PORTSDIR}/devel/apache-ant
.else
LIB_DEPENDS+= xslt.2:${PORTSDIR}/textproc/libxslt
diff --git a/editors/openoffice.org-3-devel/files/Makefile.knobs b/editors/openoffice.org-3-devel/files/Makefile.knobs
index 7cd35078b44b..5645c9a1a859 100644
--- a/editors/openoffice.org-3-devel/files/Makefile.knobs
+++ b/editors/openoffice.org-3-devel/files/Makefile.knobs
@@ -2,15 +2,11 @@
# Whom: Maho Nakata <maho@FreeBSD.org>
# $FreeBSD$
-.if !defined(WITHOUT_JAVA) && !defined(WITH_GNUGCJ)
+.if !defined(WITH_GNUGCJ)
CONFIGURE_ARGS+= --with-jdk-home="${JAVA_HOME}" --with-ant-home=${LOCALBASE}/ant
-.endif
-.if !defined(WITHOUT_JAVA) && defined(WITH_GNUGCJ)
+else
CONFIGURE_ARGS+= --with-jdk-home="${WRKDIR}/gnugcj" --with-java=gij --with-ant-home="${WRKDIR}/apache-ant-${ANT_VERSION}"
.endif
-.if defined(WITHOUT_JAVA)
-CONFIGURE_ARGS+= --without-java
-.endif
.if defined(WITH_KDE)
CONFIGURE_ARGS+= --enable-kde QTDIR="${QT_PREFIX}"
@@ -92,12 +88,6 @@ pre-fetch:
@${ECHO} "st sv sw sw-TZ sx ta-IN th tn tr ts ve vi xh zh-CN"
@${ECHO} "zh-TW zu"
@${ECHO} "Default: en-US"
-#XXX currently broken
-#.if !defined(WITHOUT_JAVA)
-# @${ECHO}
-# @${ECHO} "You can compile OOo without Java support with"
-# @${ECHO} "make -DWITHOUT_JAVA"
-#.endif
.if !defined(WITH_GNUGCJ)
@${ECHO}
@${ECHO} "You can compile OOo with GNU GCJ instead of SUN's JDK with"
diff --git a/editors/openoffice.org-3/Makefile b/editors/openoffice.org-3/Makefile
index 025f0f29a1f1..12e8dbb3da1f 100644
--- a/editors/openoffice.org-3/Makefile
+++ b/editors/openoffice.org-3/Makefile
@@ -47,7 +47,7 @@ WITHOUT_CPU_CFLAGS= true
ONLY_FOR_ARCHS= i386
-.if !defined(WITHOUT_JAVA) && !defined(WITH_GNUGCJ)
+.if !defined(WITH_GNUGCJ)
USE_JAVA= yes
JAVA_VERSION= 1.4+
JAVA_BUILD= jdk
@@ -117,7 +117,7 @@ BUILD_DEPENDS+= zip:${PORTSDIR}/archivers/zip \
${SITE_PERL}/Archive/Zip.pm:${PORTSDIR}/archivers/p5-Archive-Zip \
bison2:${PORTSDIR}/devel/bison2 \
imake:${X_IMAKE_PORT}
-.if !defined(WITHOUT_JAVA) && !defined(WITH_GNUGCJ)
+.if !defined(WITH_GNUGCJ)
BUILD_DEPENDS+= ant:${PORTSDIR}/devel/apache-ant
.else
LIB_DEPENDS+= xslt.2:${PORTSDIR}/textproc/libxslt
diff --git a/editors/openoffice.org-3/files/Makefile.knobs b/editors/openoffice.org-3/files/Makefile.knobs
index 7cd35078b44b..c4a0a84ac1c9 100644
--- a/editors/openoffice.org-3/files/Makefile.knobs
+++ b/editors/openoffice.org-3/files/Makefile.knobs
@@ -2,15 +2,11 @@
# Whom: Maho Nakata <maho@FreeBSD.org>
# $FreeBSD$
-.if !defined(WITHOUT_JAVA) && !defined(WITH_GNUGCJ)
+.if !defined(WITH_GNUGCJ)
CONFIGURE_ARGS+= --with-jdk-home="${JAVA_HOME}" --with-ant-home=${LOCALBASE}/ant
-.endif
-.if !defined(WITHOUT_JAVA) && defined(WITH_GNUGCJ)
+.else
CONFIGURE_ARGS+= --with-jdk-home="${WRKDIR}/gnugcj" --with-java=gij --with-ant-home="${WRKDIR}/apache-ant-${ANT_VERSION}"
.endif
-.if defined(WITHOUT_JAVA)
-CONFIGURE_ARGS+= --without-java
-.endif
.if defined(WITH_KDE)
CONFIGURE_ARGS+= --enable-kde QTDIR="${QT_PREFIX}"
@@ -92,12 +88,6 @@ pre-fetch:
@${ECHO} "st sv sw sw-TZ sx ta-IN th tn tr ts ve vi xh zh-CN"
@${ECHO} "zh-TW zu"
@${ECHO} "Default: en-US"
-#XXX currently broken
-#.if !defined(WITHOUT_JAVA)
-# @${ECHO}
-# @${ECHO} "You can compile OOo without Java support with"
-# @${ECHO} "make -DWITHOUT_JAVA"
-#.endif
.if !defined(WITH_GNUGCJ)
@${ECHO}
@${ECHO} "You can compile OOo with GNU GCJ instead of SUN's JDK with"
diff --git a/editors/openoffice.org-vcltesttool/Makefile b/editors/openoffice.org-vcltesttool/Makefile
index bc3b1fea2dec..37d837ab1218 100644
--- a/editors/openoffice.org-vcltesttool/Makefile
+++ b/editors/openoffice.org-vcltesttool/Makefile
@@ -48,7 +48,7 @@ WITHOUT_CPU_CFLAGS= true
ONLY_FOR_ARCHS= i386
-.if !defined(WITHOUT_JAVA) && !defined(WITH_GNUGCJ)
+.if !defined(WITH_GNUGCJ)
USE_JAVA= yes
JAVA_VERSION= 1.4+
JAVA_BUILD= jdk
@@ -120,7 +120,7 @@ BUILD_DEPENDS+= zip:${PORTSDIR}/archivers/zip \
${SITE_PERL}/Archive/Zip.pm:${PORTSDIR}/archivers/p5-Archive-Zip \
bison2:${PORTSDIR}/devel/bison2 \
imake:${X_IMAKE_PORT}
-.if !defined(WITHOUT_JAVA) && !defined(WITH_GNUGCJ)
+.if !defined(WITH_GNUGCJ)
BUILD_DEPENDS+= ant:${PORTSDIR}/devel/apache-ant
.else
LIB_DEPENDS+= xslt.2:${PORTSDIR}/textproc/libxslt
diff --git a/editors/openoffice.org-vcltesttool/files/Makefile.knobs b/editors/openoffice.org-vcltesttool/files/Makefile.knobs
index 7cd35078b44b..5645c9a1a859 100644
--- a/editors/openoffice.org-vcltesttool/files/Makefile.knobs
+++ b/editors/openoffice.org-vcltesttool/files/Makefile.knobs
@@ -2,15 +2,11 @@
# Whom: Maho Nakata <maho@FreeBSD.org>
# $FreeBSD$
-.if !defined(WITHOUT_JAVA) && !defined(WITH_GNUGCJ)
+.if !defined(WITH_GNUGCJ)
CONFIGURE_ARGS+= --with-jdk-home="${JAVA_HOME}" --with-ant-home=${LOCALBASE}/ant
-.endif
-.if !defined(WITHOUT_JAVA) && defined(WITH_GNUGCJ)
+else
CONFIGURE_ARGS+= --with-jdk-home="${WRKDIR}/gnugcj" --with-java=gij --with-ant-home="${WRKDIR}/apache-ant-${ANT_VERSION}"
.endif
-.if defined(WITHOUT_JAVA)
-CONFIGURE_ARGS+= --without-java
-.endif
.if defined(WITH_KDE)
CONFIGURE_ARGS+= --enable-kde QTDIR="${QT_PREFIX}"
@@ -92,12 +88,6 @@ pre-fetch:
@${ECHO} "st sv sw sw-TZ sx ta-IN th tn tr ts ve vi xh zh-CN"
@${ECHO} "zh-TW zu"
@${ECHO} "Default: en-US"
-#XXX currently broken
-#.if !defined(WITHOUT_JAVA)
-# @${ECHO}
-# @${ECHO} "You can compile OOo without Java support with"
-# @${ECHO} "make -DWITHOUT_JAVA"
-#.endif
.if !defined(WITH_GNUGCJ)
@${ECHO}
@${ECHO} "You can compile OOo with GNU GCJ instead of SUN's JDK with"