aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGabor Kovesdan <gabor@FreeBSD.org>2008-07-13 14:36:46 +0000
committerGabor Kovesdan <gabor@FreeBSD.org>2008-07-13 14:36:46 +0000
commit29788e5255a0307b208b085ef4d98f726dec8bac (patch)
tree266da172a9be46528318572c062ff4ca1b2bba96
parent897f8576a1d3a9edf34a95c0524590d87f314168 (diff)
The DocBook DTD defines structural and content-based SGML markup
for computer documentation, with a primary emphasis on software documentation and related classes of technical documents. Its main high-level hierarchical structures are for books, reference entries (for example, ``man pages''), and articles. It is maintained by the DocBook Technical Committee of OASIS. This port contains DocBook 4.4. Note that DocBook 4.4 includes the XML DocBook DTD as part of the SGML DTD distribution. If you do not need SGML DTD you should install: textproc/docbook-xml-440 instead. There are no conflicts if both ports are installed but you will have duplicates of most of the files. WWW: http://www.docbook.org/specs/cd-docbook-docbook-4.4.html
Notes
Notes: svn path=/head/; revision=216774
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/docbook-440/Makefile74
-rw-r--r--textproc/docbook-440/distinfo3
-rw-r--r--textproc/docbook-440/files/patch-catalog68
-rw-r--r--textproc/docbook-440/pkg-descr15
5 files changed, 161 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 5750f12ab053..854d1a1934eb 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -100,6 +100,7 @@
SUBDIR += docbook-410
SUBDIR += docbook-420
SUBDIR += docbook-430
+ SUBDIR += docbook-440
SUBDIR += docbook-sk
SUBDIR += docbook-tdg
SUBDIR += docbook-to-man
diff --git a/textproc/docbook-440/Makefile b/textproc/docbook-440/Makefile
new file mode 100644
index 000000000000..2c31fd06bc17
--- /dev/null
+++ b/textproc/docbook-440/Makefile
@@ -0,0 +1,74 @@
+# New ports collection makefile for: docbook-440
+# Date created: 12 Jul 2008
+# Whom: Gabor Kovesdan <gabor@kovesdan.org>
+#
+# $FreeBSD$
+
+PORTNAME= docbook
+PORTVERSION= 4.4
+CATEGORIES= textproc
+MASTER_SITES= http://www.oasis-open.org/docbook/sgml/${PORTVERSION}/
+
+MAINTAINER= gabor@FreeBSD.org
+COMMENT= DocBook/SGML DTD V4.4, designed for technical documentation
+
+RUN_DEPENDS= ${LOCALBASE}/${ISOCAT}:${PORTSDIR}/textproc/iso8879 \
+ ${XMLCATMGR}:${PORTSDIR}/textproc/xmlcatmgr
+
+USE_ZIP= yes
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+LATEST_LINK= ${PORTNAME}-450
+PLIST= ${WRKSRC}/pkg-plist
+
+SGMLCATBASE= share/sgml
+DTD_NAME= ${PORTNAME}
+DTD_VERSION= ${PORTVERSION}
+ISOCAT= ${SGMLCATBASE}/iso8879/catalog
+
+XMLCATMGR= ${LOCALBASE}/bin/xmlcatmgr
+CATALOG_PORTS_SGML= ${PREFIX}/${SGMLCATBASE}/catalog.ports
+REGIST_CAT_FLAGS_SGML= -sc ${CATALOG_PORTS_SGML} \
+ add CATALOG ${DTD_NAME}/${DTD_VERSION}/catalog
+UNREGIST_CAT_FLAGS_SGML= -sc ${CATALOG_PORTS_SGML} \
+ remove CATALOG ${DTD_NAME}/${DTD_VERSION}/catalog
+
+DOC_FILES= ChangeLog README
+DTDDIR= ${SGMLCATBASE}/${DTD_NAME}/${DTD_VERSION}
+DTD_FILES= calstblx.dtd catalog.xml dbcentx.mod dbgenent.mod \
+ dbhierx.mod dbnotnx.mod dbpoolx.mod docbook.cat docbook.dcl \
+ docbook.dtd docbookx.dtd htmltblx.mod soextblx.dtd catalog
+
+post-extract:
+ ${CP} ${WRKSRC}/docbook.cat ${WRKSRC}/catalog
+
+post-patch:
+ ${ECHO_CMD} 'CATALOG "${LOCALBASE}/${ISOCAT}"' >> ${WRKSRC}/catalog
+
+pre-install:
+ (for F in ${DTD_FILES}; do \
+ ${ECHO_CMD} "${DTDDIR}/$${F}"; \
+ done;\
+ ${ECHO_CMD} "@dirrm ${DTDDIR}";\
+ ${ECHO_CMD} "@dirrmtry ${SGMLCATBASE}/${DTD_NAME}"; ) > ${PLIST}
+.if !defined(NOPORTDOCS)
+ (for F in ${DOC_FILES}; do \
+ ${ECHO_CMD} "${DOCSDIR:S,^${PREFIX}/,,}/$${F}"; \
+ done;\
+ ${ECHO_CMD} "@dirrm ${DOCSDIR:S,^${PREFIX}/,,}" ) >> ${PLIST}
+.endif
+ ${ECHO_CMD} "@exec ${XMLCATMGR} ${REGIST_CAT_FLAGS_SGML}" >> ${PLIST}
+ ${ECHO_CMD} "@unexec ${XMLCATMGR} ${UNREGIST_CAT_FLAGS_SGML}" >> ${PLIST}
+
+do-install:
+ ${MKDIR} ${PREFIX}/${DTDDIR}
+ ${INSTALL_DATA} ${DTD_FILES:S,^,${WRKSRC}/,} ${PREFIX}/${DTDDIR}
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${DOC_FILES:S,^,${WRKSRC}/,} ${DOCSDIR}
+.endif
+
+post-install:
+ -${XMLCATMGR} ${REGIST_CAT_FLAGS_SGML}
+
+.include <bsd.port.mk>
diff --git a/textproc/docbook-440/distinfo b/textproc/docbook-440/distinfo
new file mode 100644
index 000000000000..d7cf1b798808
--- /dev/null
+++ b/textproc/docbook-440/distinfo
@@ -0,0 +1,3 @@
+MD5 (docbook-4.4.zip) = f89e1bd0b2c7a361e3f1f739e16b5d0d
+SHA256 (docbook-4.4.zip) = 0ac7960409b032c8e517483523ecb92af4e59196a33b3e2c5617daa22b7a8a6c
+SIZE (docbook-4.4.zip) = 66879
diff --git a/textproc/docbook-440/files/patch-catalog b/textproc/docbook-440/files/patch-catalog
new file mode 100644
index 000000000000..65fff5bd2eb7
--- /dev/null
+++ b/textproc/docbook-440/files/patch-catalog
@@ -0,0 +1,68 @@
+--- catalog.orig Sat Apr 3 19:51:36 2004
++++ catalog Sat Apr 3 19:52:15 2004
+@@ -49,65 +49,5 @@
+ PUBLIC "-//OASIS//ENTITIES DocBook Character Entities V4.3//EN"
+ "dbcentx.mod"
+
+- -- ...................................................................... --
+- -- ISO entity sets ...................................................... --
+-
+-PUBLIC "ISO 8879:1986//ENTITIES Diacritical Marks//EN"
+- "iso-dia.gml"
+-
+-PUBLIC "ISO 8879:1986//ENTITIES Numeric and Special Graphic//EN"
+- "iso-num.gml"
+-
+-PUBLIC "ISO 8879:1986//ENTITIES Publishing//EN"
+- "iso-pub.gml"
+-
+-PUBLIC "ISO 8879:1986//ENTITIES General Technical//EN"
+- "iso-tech.gml"
+-
+-PUBLIC "ISO 8879:1986//ENTITIES Added Latin 1//EN"
+- "iso-lat1.gml"
+-
+-PUBLIC "ISO 8879:1986//ENTITIES Added Latin 2//EN"
+- "iso-lat2.gml"
+-
+-PUBLIC "ISO 8879:1986//ENTITIES Greek Letters//EN"
+- "iso-grk1.gml"
+-
+-PUBLIC "ISO 8879:1986//ENTITIES Monotoniko Greek//EN"
+- "iso-grk2.gml"
+-
+-PUBLIC "ISO 8879:1986//ENTITIES Greek Symbols//EN"
+- "iso-grk3.gml"
+-
+-PUBLIC "ISO 8879:1986//ENTITIES Alternative Greek Symbols//EN"
+- "iso-grk4.gml"
+-
+-PUBLIC "ISO 8879:1986//ENTITIES Added Math Symbols: Arrow Relations//EN"
+- "iso-amsa.gml"
+-
+-PUBLIC "ISO 8879:1986//ENTITIES Added Math Symbols: Binary Operators//EN"
+- "iso-amsb.gml"
+-
+-PUBLIC "ISO 8879:1986//ENTITIES Added Math Symbols: Delimiters//EN"
+- "iso-amsc.gml"
+-
+-PUBLIC "ISO 8879:1986//ENTITIES Added Math Symbols: Negated Relations//EN"
+- "iso-amsn.gml"
+-
+-PUBLIC "ISO 8879:1986//ENTITIES Added Math Symbols: Ordinary//EN"
+- "iso-amso.gml"
+-
+-PUBLIC "ISO 8879:1986//ENTITIES Added Math Symbols: Relations//EN"
+- "iso-amsr.gml"
+-
+-PUBLIC "ISO 8879:1986//ENTITIES Box and Line Drawing//EN"
+- "iso-box.gml"
+-
+-PUBLIC "ISO 8879:1986//ENTITIES Russian Cyrillic//EN"
+- "iso-cyr1.gml"
+-
+-PUBLIC "ISO 8879:1986//ENTITIES Non-Russian Cyrillic//EN"
+- "iso-cyr2.gml"
+-
+ -- End of catalog data for DocBook V4.3 ................................. --
+ -- ...................................................................... --
diff --git a/textproc/docbook-440/pkg-descr b/textproc/docbook-440/pkg-descr
new file mode 100644
index 000000000000..8cbcb6c3b43f
--- /dev/null
+++ b/textproc/docbook-440/pkg-descr
@@ -0,0 +1,15 @@
+The DocBook DTD defines structural and content-based SGML markup
+for computer documentation, with a primary emphasis on software
+documentation and related classes of technical documents. Its
+main high-level hierarchical structures are for books, reference
+entries (for example, ``man pages''), and articles. It is
+maintained by the DocBook Technical Committee of OASIS.
+
+This port contains DocBook 4.4. Note that DocBook 4.4 includes
+the XML DocBook DTD as part of the SGML DTD distribution. If
+you do not need SGML DTD you should install:
+ textproc/docbook-xml-440
+instead. There are no conflicts if both ports are installed
+but you will have duplicates of most of the files.
+
+WWW: http://www.docbook.org/specs/cd-docbook-docbook-4.4.html