aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Thegler <lth@FreeBSD.org>2007-05-03 10:21:05 +0000
committerLars Thegler <lth@FreeBSD.org>2007-05-03 10:21:05 +0000
commit325348f568497425adc293859a96b8fd0b02b890 (patch)
treea8d7f4d45846e33c25bc6932060571fe3bf3f5a0
parent5a1c645f1cd90fa156750773b44684919e8982ba (diff)
Add p5-UML-Class-Simple 0.09, render simple UML class diagrams, by
loading the code.
Notes
Notes: svn path=/head/; revision=191472
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/p5-UML-Class-Simple/Makefile36
-rw-r--r--textproc/p5-UML-Class-Simple/distinfo3
-rw-r--r--textproc/p5-UML-Class-Simple/pkg-descr5
-rw-r--r--textproc/p5-UML-Class-Simple/pkg-plist8
5 files changed, 53 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 02dd130904e6..29a6b7abffb6 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -575,6 +575,7 @@
SUBDIR += p5-Tk-XMLViewer
SUBDIR += p5-Tree-Nary
SUBDIR += p5-Tree-Suffix
+ SUBDIR += p5-UML-Class-Simple
SUBDIR += p5-UML-Sequence
SUBDIR += p5-UML-State
SUBDIR += p5-URI-Find
diff --git a/textproc/p5-UML-Class-Simple/Makefile b/textproc/p5-UML-Class-Simple/Makefile
new file mode 100644
index 000000000000..03207bac34c9
--- /dev/null
+++ b/textproc/p5-UML-Class-Simple/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: textproc/p5-UML-Class-Simple
+# Date created: 03 May 2007
+# Whom: Lars Thegler <lth@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= UML-Class-Simple
+PORTVERSION= 0.09
+CATEGORIES= textproc perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= UML
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lth@FreeBSD.org
+COMMENT= Render simple UML class diagrams, by loading the code
+
+RUN_DEPENDS= p5-PPI>0:${PORTSDIR}/textproc/p5-PPI \
+ p5-Template-Toolkit>0:${PORTSDIR}/www/p5-Template-Toolkit \
+ p5-YAML-Syck>0:${PORTSDIR}/textproc/p5-YAML-Syck \
+ p5-IPC-Run3>0:${PORTSDIR}/devel/p5-IPC-Run3 \
+ p5-Class-Inspector>=1.16:${PORTSDIR}/devel/p5-Class-Inspector \
+ p5-List-MoreUtils>0:${PORTSDIR}/lang/p5-List-MoreUtils \
+ p5-File-Slurp>0:${PORTSDIR}/devel/p5-File-Slurp \
+ dot:${PORTSDIR}/graphics/graphviz
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN1= umlclass.pl.1
+MAN3= UML::Class::Simple.3
+
+post-patch:
+ ${PERL} -pi -e '$$_="" if /auto_install/' ${WRKSRC}/Makefile.PL
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-UML-Class-Simple/distinfo b/textproc/p5-UML-Class-Simple/distinfo
new file mode 100644
index 000000000000..448fea7edab2
--- /dev/null
+++ b/textproc/p5-UML-Class-Simple/distinfo
@@ -0,0 +1,3 @@
+MD5 (UML-Class-Simple-0.09.tar.gz) = d2012ad95e826a14f819c65bee02bbc1
+SHA256 (UML-Class-Simple-0.09.tar.gz) = b95b33e2a1b49c2262d853b141764836f9f034398dae534bf8df620715330954
+SIZE (UML-Class-Simple-0.09.tar.gz) = 73503
diff --git a/textproc/p5-UML-Class-Simple/pkg-descr b/textproc/p5-UML-Class-Simple/pkg-descr
new file mode 100644
index 000000000000..4ae068227bf7
--- /dev/null
+++ b/textproc/p5-UML-Class-Simple/pkg-descr
@@ -0,0 +1,5 @@
+UML::Class::Simple is a Perl CPAN module that generates UML class
+diagrams (PNG format, GIF format, or dot source) automatically from
+Perl 5 source or Perl 5 runtime.
+
+WWW: http://search.cpan.org/dist/UML-Class-Simple/
diff --git a/textproc/p5-UML-Class-Simple/pkg-plist b/textproc/p5-UML-Class-Simple/pkg-plist
new file mode 100644
index 000000000000..54b1b2b18227
--- /dev/null
+++ b/textproc/p5-UML-Class-Simple/pkg-plist
@@ -0,0 +1,8 @@
+bin/umlclass.pl
+%%SITE_PERL%%/UML/Class/Simple.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/UML/Class/Simple/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/UML/Class/Simple
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/UML/Class
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/UML
+@dirrmtry %%SITE_PERL%%/UML/Class
+@dirrmtry %%SITE_PERL%%/UML