aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-04-15 18:55:20 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-04-15 18:55:20 +0000
commit32704f5009658751d3bba21ecb6ea0088a239e36 (patch)
tree31a5507748f8846ea9555d1340da78177feee040
parent9d1d001794f0ebf42bb227b6d86a7b5c38baba97 (diff)
downloadports-32704f5009658751d3bba21ecb6ea0088a239e36.tar.gz
ports-32704f5009658751d3bba21ecb6ea0088a239e36.zip
Notes
-rw-r--r--audio/herrie/Makefile23
-rw-r--r--audio/herrie/distinfo6
-rw-r--r--audio/herrie/pkg-descr2
-rw-r--r--audio/herrie/pkg-plist5
4 files changed, 26 insertions, 10 deletions
diff --git a/audio/herrie/Makefile b/audio/herrie/Makefile
index 54b06a37af25..07190eb3c044 100644
--- a/audio/herrie/Makefile
+++ b/audio/herrie/Makefile
@@ -6,9 +6,9 @@
#
PORTNAME= herrie
-PORTVERSION= 1.5.1
+PORTVERSION= 1.6
CATEGORIES= audio
-MASTER_SITES= http://g-rave.nl/projects/herrie/distfiles/ \
+MASTER_SITES= http://herrie.info/distfiles/ \
http://www.il.fontys.nl/~ed/projects/herrie/distfiles/ \
http://www.stack.nl/~ed/projects/herrie/distfiles/
@@ -20,16 +20,17 @@ LIB_DEPENDS+= curl:${PORTSDIR}/ftp/curl
HAS_CONFIGURE= yes
CONFIGURE_ENV+= PREFIX=${PREFIX}
+USE_BZIP2= yes
USE_OPENSSL= yes
USE_GNOME= glib20
-USE_GETTEXT= yes
OPTIONS= MAD "MAD MP3 support" on \
VORBIS "Ogg Vorbis support" on \
SNDFILE "libsndfile support" on \
MODPLUG "libmodplug support" off \
LIBAO "LibAO support (breaks chroot)" off \
- XCURSES "Build XCurses version" off
+ XCURSES "Build XCurses version" off \
+ XSPF "Support for XSPF playlists" on
MAN1= herrie.1
MANCOMPRESSED= yes
@@ -65,5 +66,19 @@ CONFIGURE_ARGS+=ao
LIB_DEPENDS+= XCurses.2:${PORTSDIR}/devel/pdcurses
CONFIGURE_ARGS+=xcurses
.endif
+.if !defined(WITHOUT_XSPF)
+# We need 0.6.3, which has proper C bindings
+BUILD_DEPENDS+= libspiff>=0.6.3:${PORTSDIR}/multimedia/libspiff
+RUN_DEPENDS+= libspiff>=0.6.3:${PORTSDIR}/multimedia/libspiff
+.else
+CONFIGURE_ARGS+=no_xspf
+.endif
+.if !defined(WITHOUT_NLS)
+PLIST_SUB+= NLS=""
+USE_GETTEXT= yes
+.else
+PLIST_SUB+= NLS="@comment "
+CONFIGURE_ARGS+=no_trans
+.endif
.include <bsd.port.post.mk>
diff --git a/audio/herrie/distinfo b/audio/herrie/distinfo
index 0593aadaf91c..cc7e2920b09e 100644
--- a/audio/herrie/distinfo
+++ b/audio/herrie/distinfo
@@ -1,3 +1,3 @@
-MD5 (herrie-1.5.1.tar.gz) = a4b208a6486d175787cff36b886fc06e
-SHA256 (herrie-1.5.1.tar.gz) = cf12a622541ab3954ef08dbad097a4c20eb38c99ecba200f332a2ae8eca80800
-SIZE (herrie-1.5.1.tar.gz) = 53842
+MD5 (herrie-1.6.tar.bz2) = 4ce7ebeb10d21ec52cd7b1ca3158bbbb
+SHA256 (herrie-1.6.tar.bz2) = 17a92c4b5dfe5c2ff2ae7897cbce963258dc44b7b4c6bd288f273a56b7d9d2ae
+SIZE (herrie-1.6.tar.bz2) = 49747
diff --git a/audio/herrie/pkg-descr b/audio/herrie/pkg-descr
index f724ffb0f634..dc5c5d874811 100644
--- a/audio/herrie/pkg-descr
+++ b/audio/herrie/pkg-descr
@@ -3,4 +3,4 @@ and has some unique features, like chroot()'ing and dropping privileges.
It also supports submission of songs to AudioScrobbler. This makes it an
ideal application for low-end jukeboxes.
-WWW: http://g-rave.nl/projects/herrie/
+WWW: http://herrie.info/
diff --git a/audio/herrie/pkg-plist b/audio/herrie/pkg-plist
index 1d2d2ce9ba35..47db707e853e 100644
--- a/audio/herrie/pkg-plist
+++ b/audio/herrie/pkg-plist
@@ -1,4 +1,5 @@
bin/herrie
etc/herrie.conf.sample
-share/locale/nl/LC_MESSAGES/herrie.mo
-share/locale/tr/LC_MESSAGES/herrie.mo
+%%NLS%%share/locale/de/LC_MESSAGES/herrie.mo
+%%NLS%%share/locale/nl/LC_MESSAGES/herrie.mo
+%%NLS%%share/locale/tr/LC_MESSAGES/herrie.mo