aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSylvio Cesar Teixeira <sylvio@FreeBSD.org>2011-02-28 13:57:38 +0000
committerSylvio Cesar Teixeira <sylvio@FreeBSD.org>2011-02-28 13:57:38 +0000
commit3dd70d87f6279377bf039a6c2c889bea5e691778 (patch)
treed24a6ae1180ac413a9e4cc94db105e18b072f260
parente100a3f5e8805377895e33f66cf7fecce7495f80 (diff)
downloadports-3dd70d87f6279377bf039a6c2c889bea5e691778.tar.gz
ports-3dd70d87f6279377bf039a6c2c889bea5e691778.zip
Notes
-rw-r--r--net/Makefile1
-rw-r--r--net/crtmpserver/Makefile39
-rw-r--r--net/crtmpserver/distinfo2
-rw-r--r--net/crtmpserver/files/crtmpserver.in37
-rw-r--r--net/crtmpserver/pkg-descr15
-rw-r--r--net/crtmpserver/pkg-plist27
6 files changed, 121 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 85b39d17cef6..caaabc80fca5 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -93,6 +93,7 @@
SUBDIR += courier-authlib-ldap
SUBDIR += cphone
SUBDIR += crescendo
+ SUBDIR += crtmpserver
SUBDIR += cryptcat
SUBDIR += csocks
SUBDIR += csync2
diff --git a/net/crtmpserver/Makefile b/net/crtmpserver/Makefile
new file mode 100644
index 000000000000..9a4c2e11033b
--- /dev/null
+++ b/net/crtmpserver/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: crtmpserver
+# Date created: 5 December 1994
+# Whom: shiretu
+#
+# $FreeBSD$
+#
+
+PORTNAME= crtmpserver
+PORTVERSION= 0.355
+CATEGORIES= net
+MASTER_SITES= http://freebsd.rtmpd.com/
+
+MAINTAINER= support@rtmpd.com
+COMMENT= C++ RTSP/RTMP/MPEG-TS Server
+
+LIB_DEPENDS= execinfo:${PORTSDIR}/devel/libexecinfo
+
+USE_CMAKE= yes
+CMAKE_OUTSOURCE= yes
+CMAKE_SOURCE_PATH= ${WRKSRC}/builders/cmake
+CMAKE_ARGS= -DCRTMPSERVER_INSTALL_PREFIX:STRING=${CMAKE_INSTALL_PREFIX} -DTEMP_FRAMEWORK_VER=0.355
+USE_LDCONFIG= 1
+
+USERS= crtmpserver
+GROUPS= crtmpserver
+
+USE_RC_SUBR= crtmpserver
+
+MAN1= crtmpserver.1
+
+pre-install:
+ @sh $(WRKSRC)/fixConfFile.sh "${WRKSRC}/builders/cmake/crtmpserver/crtmpserver.lua" "${PREFIX}" "${WRKSRC}"
+
+post-install:
+ @if [ ! -f ${PREFIX}/etc/crtmpserver.lua ]; then \
+ ${CP} -p ${PREFIX}/etc/crtmpserver.lua.sample ${PREFIX}/etc/crtmpserver.lua ; \
+ fi
+
+.include <bsd.port.mk>
diff --git a/net/crtmpserver/distinfo b/net/crtmpserver/distinfo
new file mode 100644
index 000000000000..9a9c02f18e81
--- /dev/null
+++ b/net/crtmpserver/distinfo
@@ -0,0 +1,2 @@
+SHA256 (crtmpserver-0.355.tar.gz) = 27b36755782879f97151a70103351a0369620b735809bcde7dbe023279885883
+SIZE (crtmpserver-0.355.tar.gz) = 1422310
diff --git a/net/crtmpserver/files/crtmpserver.in b/net/crtmpserver/files/crtmpserver.in
new file mode 100644
index 000000000000..b0a8f345c626
--- /dev/null
+++ b/net/crtmpserver/files/crtmpserver.in
@@ -0,0 +1,37 @@
+#!/bin/sh
+
+# $FreeBSD$
+#
+# PROVIDE: crtmpserver
+# REQUIRE: LOGIN
+# KEYWORD: shutdown
+#
+# Add the following lines to /etc/rc.conf.local or /etc/rc.conf
+# to enable this service:
+#
+# crtmpserver_enable (bool): Set to NO by default.
+# Set it to YES to enable doormand.
+# crtmpserver_config (path): Set to %%PREFIX%%/etc/crtmpserver.lua
+# by default.
+# crtmpserver_username (username): Set to crtmpserver
+# by default.
+#
+
+. /etc/rc.subr
+
+name="crtmpserver"
+rcvar=${name}_enable
+
+command=%%PREFIX%%/sbin/${name}
+pidfile=/var/run/${name}.pid
+
+load_rc_config $name
+
+: ${crtmpserver_enable="NO"}
+: ${crtmpserver_config="%%PREFIX%%/etc/crtmpserver.lua"}
+
+crtmpserver_username="%%USERS%%"
+command_args="--daemon --uid=`id -u ${crtmpserver_username}` $crtmpserver_config"
+
+run_rc_command "$1"
+ps -axo pid,comm|grep crtmpserver|cut -d " " -f1 >/var/run/crtmpserver.pid
diff --git a/net/crtmpserver/pkg-descr b/net/crtmpserver/pkg-descr
new file mode 100644
index 000000000000..3bc18a30417a
--- /dev/null
+++ b/net/crtmpserver/pkg-descr
@@ -0,0 +1,15 @@
+High performance RTMP/RTSP streaming server
+ rtmpd is a high performance streaming server able to stream
+ (live or recorded) in the following technologies:
+ - To and from Flash (RTMP,RTMPE, RTMPS, RTMPT, RTMPTE)
+ - To and from embedded devices: iPhone, Android
+ - From surveillance cameras
+ - IP-TV using MPEG-TS and RTSP/RTCP/RTP protocols
+ Also, rtmpd can be used as a high performance rendes-vous server.
+ For example, it enables you to do:
+ - Audio/Video conferencing
+ - Online gaming
+ - Online collaboration
+ - Simple/complex chat applications
+
+WWW: http://www.rtmpd.com
diff --git a/net/crtmpserver/pkg-plist b/net/crtmpserver/pkg-plist
new file mode 100644
index 000000000000..fba2ba014c62
--- /dev/null
+++ b/net/crtmpserver/pkg-plist
@@ -0,0 +1,27 @@
+@stopdaemon crtmpserver
+@unexec if cmp -s %D/etc/crtmpserver.lua.sample %D/etc/crtmpserver.lua; then rm -f %D/etc/crtmpserver.lua; fi
+etc/crtmpserver.lua.sample
+@exec if [ ! -f %D/etc/crtmpserver.lua ] ; then cp -p %D/%F %B/crtmpserver.lua; fi
+
+lib/crtmpserver/liblua.so
+lib/crtmpserver/libcommon.so
+lib/crtmpserver/libthelib.so
+lib/crtmpserver/applications/flvplayback/libflvplayback.so
+lib/crtmpserver/applications/appselector/libappselector.so
+lib/crtmpserver/applications/samplefactory/libsamplefactory.so
+lib/crtmpserver/applications/vptests/libvptests.so
+lib/crtmpserver/applications/admin/libadmin.so
+lib/crtmpserver/applications/proxypublish/libproxypublish.so
+lib/crtmpserver/applications/stresstest/libstresstest.so
+lib/crtmpserver/applications/applestreamingclient/libapplestreamingclient.so
+sbin/crtmpserver
+@dirrmtry lib/crtmpserver/applications/flvplayback
+@dirrmtry lib/crtmpserver/applications/appselector
+@dirrmtry lib/crtmpserver/applications/samplefactory
+@dirrmtry lib/crtmpserver/applications/vptests
+@dirrmtry lib/crtmpserver/applications/admin
+@dirrmtry lib/crtmpserver/applications/proxypublish
+@dirrmtry lib/crtmpserver/applications/stresstest
+@dirrmtry lib/crtmpserver/applications/applestreamingclient
+@dirrmtry lib/crtmpserver/applications
+@dirrmtry lib/crtmpserver