aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Scheidell <scheidell@FreeBSD.org>2012-05-24 21:20:06 +0000
committerMichael Scheidell <scheidell@FreeBSD.org>2012-05-24 21:20:06 +0000
commit424a416d854d229e7bf90cc5b5e009585dae893b (patch)
treeeae5e740dcffc1b52a1734efed00b45e48b06821
parent6aa57199265bb53393112de35ec87519dbcacad1 (diff)
downloadports-424a416d854d229e7bf90cc5b5e009585dae893b.tar.gz
ports-424a416d854d229e7bf90cc5b5e009585dae893b.zip
Notes
-rw-r--r--mail/gmime24/Makefile19
-rw-r--r--mail/gmime24/distinfo4
-rw-r--r--mail/gmime24/files/patch-Makefile.in14
-rw-r--r--mail/gmime24/files/patch-mono_Makefile.in21
-rw-r--r--mail/gmime24/files/patch-src_Makefile.in35
-rw-r--r--mail/gmime24/pkg-plist104
6 files changed, 26 insertions, 171 deletions
diff --git a/mail/gmime24/Makefile b/mail/gmime24/Makefile
index 84e5879f4d64..efbfec45c98a 100644
--- a/mail/gmime24/Makefile
+++ b/mail/gmime24/Makefile
@@ -6,15 +6,17 @@
#
PORTNAME= gmime
-PORTVERSION= 2.4.24
+PORTVERSION= 2.4.32
PORTREVISION?= 0
CATEGORIES?= mail
MASTER_SITES= GNOME
PKGNAMESUFFIX?= -24
-MAINTAINER?= ports@FreeBSD.org
+MAINTAINER?= ahicks@p-o.co.uk
COMMENT?= Library (written in C) for parsing and creating messages using MIME
+LICENSE= LGPL21
+
CONFLICTS= gmime-1.0.*
SLAVEDIRS= mail/gmime2-sharp
@@ -24,19 +26,26 @@ USE_ICONV= yes
USE_GMAKE= yes
USE_GNOME?= gnomehack glib20
USE_LDCONFIG= yes
+USE_XZ= yes
GNU_CONFIGURE= yes
+# www.freebsd.org/cgi/query-pr.cgi?pr=118092
+# Rename uudecode and uuencode to gmime-* to not conflict with userland
+# fix kept in case issue returns
CONFIGURE_ARGS?=--with-html-dir=${PREFIX}/share/doc \
- --enable-mono=no
+ --enable-mono=no \
+ --program-transform-name="s/uuencode/gmime-uuencode/;s/uudecode/gmime-uudecode/;"
CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib"
CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
LATEST_LINK?= ${PORTNAME}24
+PORTDOCS= *
+
post-install:
.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}/
+ @${MKDIR} ${DOCSDIR}
.for i in docs/reference/html/*
- ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
.endfor
.endif
diff --git a/mail/gmime24/distinfo b/mail/gmime24/distinfo
index 960b7fc8a22c..df10063c7a75 100644
--- a/mail/gmime24/distinfo
+++ b/mail/gmime24/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gmime-2.4.24.tar.gz) = 2f538d68e215f075d16575a6da9acb87983db9e2df0d7d403858048881a0dd15
-SIZE (gmime-2.4.24.tar.gz) = 1118949
+SHA256 (gmime-2.4.32.tar.xz) = a0e8f3a1949e7281e92edc5dd6309a7ca34b6838c6acf7b7f1563a41b5ddd74b
+SIZE (gmime-2.4.32.tar.xz) = 685512
diff --git a/mail/gmime24/files/patch-Makefile.in b/mail/gmime24/files/patch-Makefile.in
deleted file mode 100644
index e028bad28971..000000000000
--- a/mail/gmime24/files/patch-Makefile.in
+++ /dev/null
@@ -1,14 +0,0 @@
-
-$FreeBSD$
-
---- Makefile.in.orig 2009-04-25 12:01:47.000000000 -0300
-+++ Makefile.in 2009-04-25 12:04:34.000000000 -0300
-@@ -233,7 +233,7 @@
- top_build_prefix = @top_build_prefix@
- top_builddir = @top_builddir@
- top_srcdir = @top_srcdir@
--SUBDIRS = build util gmime src $(am__append_1) tests docs \
-+SUBDIRS = build util gmime $(am__append_1) tests docs \
- $(am__append_2) tools .
- DISTCLEANFILES = iconv-detect.h
- EXTRA_DIST = \
diff --git a/mail/gmime24/files/patch-mono_Makefile.in b/mail/gmime24/files/patch-mono_Makefile.in
deleted file mode 100644
index 299831f92557..000000000000
--- a/mail/gmime24/files/patch-mono_Makefile.in
+++ /dev/null
@@ -1,21 +0,0 @@
-
-$FreeBSD$
-
---- mono/Makefile.in.orig
-+++ mono/Makefile.in
-@@ -471,11 +471,11 @@
- install-data-local:
- @if test -n '$(TARGET)'; then \
- if test -n '$(DESTDIR)'; then \
-- echo "$(GACUTIL) /i $(ASSEMBLY) /f /package $(PACKAGE_SHARP) /root $(DESTDIR)$(prefix)/lib"; \
-- $(GACUTIL) /i $(ASSEMBLY) /f /package $(PACKAGE_SHARP) /root $(DESTDIR)$(prefix)/lib || exit 1; \
-+ echo "$(GACUTIL) /i $(ASSEMBLY) /f /package $(PACKAGE_SHARP) /gacdir $(DESTDIR)$(libdir) /root $(DESTDIR)$(libdir)"; \
-+ $(GACUTIL) /i $(ASSEMBLY) /f /package $(PACKAGE_SHARP) /gacdir $(DESTDIR)$(libdir) /root $(DESTDIR)$(libdir) || exit 1; \
- else \
-- echo "$(GACUTIL) /i $(ASSEMBLY) /f /package $(PACKAGE_SHARP) /gacdir $(prefix)/lib"; \
-- $(GACUTIL) /i $(ASSEMBLY) /f /package $(PACKAGE_SHARP) /gacdir $(prefix)/lib || exit 1; \
-+ echo "$(GACUTIL) /i $(ASSEMBLY) /f /package $(PACKAGE_SHARP) /gacdir $(DESTDIR)$(libdir) /root $(DESTDIR)$(libdir)"; \
-+ $(GACUTIL) /i $(ASSEMBLY) /f /package $(PACKAGE_SHARP) /gacdir $(DESTDIR)$(libdir) /root $(DESTDIR)$(libdir) || exit 1; \
- fi; \
- fi
-
diff --git a/mail/gmime24/files/patch-src_Makefile.in b/mail/gmime24/files/patch-src_Makefile.in
deleted file mode 100644
index d5e0116235b9..000000000000
--- a/mail/gmime24/files/patch-src_Makefile.in
+++ /dev/null
@@ -1,35 +0,0 @@
-
-$FreeBSD$
-
-http://www.freebsd.org/cgi/query-pr.cgi?pr=118092
-
-Rename uudecode and uuencode to gmime-* to not conflict with userland
-
---- src/Makefile.in.orig
-+++ src/Makefile.in
-@@ -26,6 +26,7 @@
- install_sh_SCRIPT = $(install_sh) -c
- INSTALL_HEADER = $(INSTALL_DATA)
- transform = $(program_transform_name)
-+add_gmime = s/^/gmime-/
- NORMAL_INSTALL = :
- PRE_INSTALL = :
- POST_INSTALL = :
-@@ -333,7 +334,7 @@
- then echo "$$p"; echo "$$p"; else :; fi; \
- done | \
- sed -e 'p;s,.*/,,;n;h' -e 's|.*|.|' \
-- -e 'p;x;s,.*/,,;s/$(EXEEXT)$$//;$(transform);s/$$/$(EXEEXT)/' | \
-+ -e 'p;x;s,.*/,,;s/$(EXEEXT)$$//;$(transform);s/$$/$(EXEEXT)/;$(add_gmime)' | \
- sed 'N;N;N;s,\n, ,g' | \
- $(AWK) 'BEGIN { files["."] = ""; dirs["."] = 1 } \
- { d=$$3; if (dirs[d] != 1) { print "d", d; dirs[d] = 1 } \
-@@ -352,7 +353,7 @@
- @$(NORMAL_UNINSTALL)
- @list='$(bin_PROGRAMS)'; test -n "$(bindir)" || list=; \
- files=`for p in $$list; do echo "$$p"; done | \
-- sed -e 'h;s,^.*/,,;s/$(EXEEXT)$$//;$(transform)' \
-+ sed -e 'h;s,^.*/,,;s/$(EXEEXT)$$//;$(transform);$(add_gmime)' \
- -e 's/$$/$(EXEEXT)/' `; \
- test -n "$$list" || exit 0; \
- echo " ( cd '$(DESTDIR)$(bindir)' && rm -f" $$files ")"; \
diff --git a/mail/gmime24/pkg-plist b/mail/gmime24/pkg-plist
index 70439e115693..16f06859646d 100644
--- a/mail/gmime24/pkg-plist
+++ b/mail/gmime24/pkg-plist
@@ -1,4 +1,3 @@
-include/gmime-2.4/gmime/gmime.h
include/gmime-2.4/gmime/gmime-charset.h
include/gmime-2.4/gmime/gmime-cipher-context.h
include/gmime-2.4/gmime/gmime-content-type.h
@@ -6,7 +5,6 @@ include/gmime-2.4/gmime/gmime-data-wrapper.h
include/gmime-2.4/gmime/gmime-disposition.h
include/gmime-2.4/gmime/gmime-encodings.h
include/gmime-2.4/gmime/gmime-error.h
-include/gmime-2.4/gmime/gmime-filter.h
include/gmime-2.4/gmime/gmime-filter-basic.h
include/gmime-2.4/gmime/gmime-filter-best.h
include/gmime-2.4/gmime/gmime-filter-charset.h
@@ -19,24 +17,24 @@ include/gmime-2.4/gmime/gmime-filter-md5.h
include/gmime-2.4/gmime/gmime-filter-strip.h
include/gmime-2.4/gmime/gmime-filter-windows.h
include/gmime-2.4/gmime/gmime-filter-yenc.h
+include/gmime-2.4/gmime/gmime-filter.h
include/gmime-2.4/gmime/gmime-gpg-context.h
include/gmime-2.4/gmime/gmime-header.h
-include/gmime-2.4/gmime/gmime-iconv.h
include/gmime-2.4/gmime/gmime-iconv-utils.h
-include/gmime-2.4/gmime/gmime-message.h
+include/gmime-2.4/gmime/gmime-iconv.h
include/gmime-2.4/gmime/gmime-message-part.h
include/gmime-2.4/gmime/gmime-message-partial.h
-include/gmime-2.4/gmime/gmime-multipart.h
+include/gmime-2.4/gmime/gmime-message.h
include/gmime-2.4/gmime/gmime-multipart-encrypted.h
include/gmime-2.4/gmime/gmime-multipart-signed.h
+include/gmime-2.4/gmime/gmime-multipart.h
include/gmime-2.4/gmime/gmime-object.h
include/gmime-2.4/gmime/gmime-param.h
include/gmime-2.4/gmime/gmime-parse-utils.h
include/gmime-2.4/gmime/gmime-parser.h
include/gmime-2.4/gmime/gmime-part.h
-include/gmime-2.4/gmime/gmime-session.h
include/gmime-2.4/gmime/gmime-session-simple.h
-include/gmime-2.4/gmime/gmime-stream.h
+include/gmime-2.4/gmime/gmime-session.h
include/gmime-2.4/gmime/gmime-stream-buffer.h
include/gmime-2.4/gmime/gmime-stream-cat.h
include/gmime-2.4/gmime/gmime-stream-file.h
@@ -45,96 +43,14 @@ include/gmime-2.4/gmime/gmime-stream-fs.h
include/gmime-2.4/gmime/gmime-stream-mem.h
include/gmime-2.4/gmime/gmime-stream-mmap.h
include/gmime-2.4/gmime/gmime-stream-null.h
+include/gmime-2.4/gmime/gmime-stream.h
include/gmime-2.4/gmime/gmime-utils.h
+include/gmime-2.4/gmime/gmime.h
include/gmime-2.4/gmime/internet-address.h
-lib/libgmime-2.4.so.6
-lib/libgmime-2.4.so
-lib/libgmime-2.4.la
lib/libgmime-2.4.a
+lib/libgmime-2.4.la
+lib/libgmime-2.4.so
+lib/libgmime-2.4.so.6
libdata/pkgconfig/gmime-2.4.pc
-%%PORTDOCS%%%%DOCSDIR%%/CipherContexts.html
-%%PORTDOCS%%%%DOCSDIR%%/DataWrappers.html
-%%PORTDOCS%%%%DOCSDIR%%/Filters.html
-%%PORTDOCS%%%%DOCSDIR%%/GMimeCipherContext.html
-%%PORTDOCS%%%%DOCSDIR%%/GMimeContentDisposition.html
-%%PORTDOCS%%%%DOCSDIR%%/GMimeContentType.html
-%%PORTDOCS%%%%DOCSDIR%%/GMimeDataWrapper.html
-%%PORTDOCS%%%%DOCSDIR%%/GMimeFilter.html
-%%PORTDOCS%%%%DOCSDIR%%/GMimeFilterBasic.html
-%%PORTDOCS%%%%DOCSDIR%%/GMimeFilterBest.html
-%%PORTDOCS%%%%DOCSDIR%%/GMimeFilterCRLF.html
-%%PORTDOCS%%%%DOCSDIR%%/GMimeFilterCharset.html
-%%PORTDOCS%%%%DOCSDIR%%/GMimeFilterEnriched.html
-%%PORTDOCS%%%%DOCSDIR%%/GMimeFilterFrom.html
-%%PORTDOCS%%%%DOCSDIR%%/GMimeFilterGZip.html
-%%PORTDOCS%%%%DOCSDIR%%/GMimeFilterHTML.html
-%%PORTDOCS%%%%DOCSDIR%%/GMimeFilterMd5.html
-%%PORTDOCS%%%%DOCSDIR%%/GMimeFilterStrip.html
-%%PORTDOCS%%%%DOCSDIR%%/GMimeFilterWindows.html
-%%PORTDOCS%%%%DOCSDIR%%/GMimeFilterYenc.html
-%%PORTDOCS%%%%DOCSDIR%%/GMimeGpgContext.html
-%%PORTDOCS%%%%DOCSDIR%%/GMimeMessage.html
-%%PORTDOCS%%%%DOCSDIR%%/GMimeMessagePart.html
-%%PORTDOCS%%%%DOCSDIR%%/GMimeMessagePartial.html
-%%PORTDOCS%%%%DOCSDIR%%/GMimeMultipart.html
-%%PORTDOCS%%%%DOCSDIR%%/GMimeMultipartEncrypted.html
-%%PORTDOCS%%%%DOCSDIR%%/GMimeMultipartSigned.html
-%%PORTDOCS%%%%DOCSDIR%%/GMimeObject.html
-%%PORTDOCS%%%%DOCSDIR%%/GMimeParser.html
-%%PORTDOCS%%%%DOCSDIR%%/GMimePart.html
-%%PORTDOCS%%%%DOCSDIR%%/GMimeSession.html
-%%PORTDOCS%%%%DOCSDIR%%/GMimeSessionSimple.html
-%%PORTDOCS%%%%DOCSDIR%%/GMimeStream.html
-%%PORTDOCS%%%%DOCSDIR%%/GMimeStreamBuffer.html
-%%PORTDOCS%%%%DOCSDIR%%/GMimeStreamCat.html
-%%PORTDOCS%%%%DOCSDIR%%/GMimeStreamFile.html
-%%PORTDOCS%%%%DOCSDIR%%/GMimeStreamFilter.html
-%%PORTDOCS%%%%DOCSDIR%%/GMimeStreamFs.html
-%%PORTDOCS%%%%DOCSDIR%%/GMimeStreamMem.html
-%%PORTDOCS%%%%DOCSDIR%%/GMimeStreamMmap.html
-%%PORTDOCS%%%%DOCSDIR%%/GMimeStreamNull.html
-%%PORTDOCS%%%%DOCSDIR%%/Headers.html
-%%PORTDOCS%%%%DOCSDIR%%/InternetAddress.html
-%%PORTDOCS%%%%DOCSDIR%%/InternetAddressGroup.html
-%%PORTDOCS%%%%DOCSDIR%%/InternetAddressList.html
-%%PORTDOCS%%%%DOCSDIR%%/InternetAddressMailbox.html
-%%PORTDOCS%%%%DOCSDIR%%/InternetAddresses.html
-%%PORTDOCS%%%%DOCSDIR%%/MimeParts.html
-%%PORTDOCS%%%%DOCSDIR%%/Parsers.html
-%%PORTDOCS%%%%DOCSDIR%%/Sessions.html
-%%PORTDOCS%%%%DOCSDIR%%/Streams.html
-%%PORTDOCS%%%%DOCSDIR%%/ch01.html
-%%PORTDOCS%%%%DOCSDIR%%/classes.html
-%%PORTDOCS%%%%DOCSDIR%%/core.html
-%%PORTDOCS%%%%DOCSDIR%%/fundamentals.html
-%%PORTDOCS%%%%DOCSDIR%%/gmime-GMimeHeader.html
-%%PORTDOCS%%%%DOCSDIR%%/gmime-GMimeParam.html
-%%PORTDOCS%%%%DOCSDIR%%/gmime-building.html
-%%PORTDOCS%%%%DOCSDIR%%/gmime-changes-2-0.html
-%%PORTDOCS%%%%DOCSDIR%%/gmime-changes-2-2.html
-%%PORTDOCS%%%%DOCSDIR%%/gmime-changes-2-4.html
-%%PORTDOCS%%%%DOCSDIR%%/gmime-compiling.html
-%%PORTDOCS%%%%DOCSDIR%%/gmime-data-wrappers.html
-%%PORTDOCS%%%%DOCSDIR%%/gmime-filters.html
-%%PORTDOCS%%%%DOCSDIR%%/gmime-gmime-charset.html
-%%PORTDOCS%%%%DOCSDIR%%/gmime-gmime-encodings.html
-%%PORTDOCS%%%%DOCSDIR%%/gmime-gmime-iconv-utils.html
-%%PORTDOCS%%%%DOCSDIR%%/gmime-gmime-iconv.html
-%%PORTDOCS%%%%DOCSDIR%%/gmime-gmime-utils.html
-%%PORTDOCS%%%%DOCSDIR%%/gmime-gmime.html
-%%PORTDOCS%%%%DOCSDIR%%/gmime-question-index.html
-%%PORTDOCS%%%%DOCSDIR%%/gmime-resources.html
-%%PORTDOCS%%%%DOCSDIR%%/gmime-streams.html
-%%PORTDOCS%%%%DOCSDIR%%/gmime.devhelp
-%%PORTDOCS%%%%DOCSDIR%%/gmime.devhelp2
-%%PORTDOCS%%%%DOCSDIR%%/gmime.html
-%%PORTDOCS%%%%DOCSDIR%%/home.png
-%%PORTDOCS%%%%DOCSDIR%%/index.html
-%%PORTDOCS%%%%DOCSDIR%%/index.sgml
-%%PORTDOCS%%%%DOCSDIR%%/left.png
-%%PORTDOCS%%%%DOCSDIR%%/right.png
-%%PORTDOCS%%%%DOCSDIR%%/style.css
-%%PORTDOCS%%%%DOCSDIR%%/up.png
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrm include/gmime-2.4/gmime
@dirrm include/gmime-2.4