aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-06-14 07:21:10 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-06-14 07:21:10 +0000
commit43e80d5a4bcfc342b200fd0ff07cbbab6fd52588 (patch)
tree25dcc091ce9032e57453942a45ff9ded737107f1
parent29218a1abaedd1c9155a21b9b7f12bdc41fa0e5e (diff)
downloadports-43e80d5a4bcfc342b200fd0ff07cbbab6fd52588.tar.gz
ports-43e80d5a4bcfc342b200fd0ff07cbbab6fd52588.zip
Notes
-rw-r--r--devel/hat/Makefile2
-rw-r--r--devel/hs-hat/Makefile2
-rw-r--r--lang/nhc98/Makefile2
-rw-r--r--net/rsync/Makefile6
-rw-r--r--x11-fm/gentoo/Makefile2
-rw-r--r--x11/xbindkeys_config/Makefile2
6 files changed, 8 insertions, 8 deletions
diff --git a/devel/hat/Makefile b/devel/hat/Makefile
index 18e9fcf2be00..d21c0b855c56 100644
--- a/devel/hat/Makefile
+++ b/devel/hat/Makefile
@@ -67,7 +67,7 @@ pre-fetch:
.endif
post-patch:
- @${PERL} -pi.orig -e 's|-O3|${CFLAGS}|' ${WRKSRC}/Makefile.inc
+ @${REINPLACE_CMD} -e 's|-O3|${CFLAGS}|' ${WRKSRC}/Makefile.inc
pre-install:
.if exists(${PREFIX}/bin/hmake) && !defined(OVERRIDE_HMAKE)
diff --git a/devel/hs-hat/Makefile b/devel/hs-hat/Makefile
index 18e9fcf2be00..d21c0b855c56 100644
--- a/devel/hs-hat/Makefile
+++ b/devel/hs-hat/Makefile
@@ -67,7 +67,7 @@ pre-fetch:
.endif
post-patch:
- @${PERL} -pi.orig -e 's|-O3|${CFLAGS}|' ${WRKSRC}/Makefile.inc
+ @${REINPLACE_CMD} -e 's|-O3|${CFLAGS}|' ${WRKSRC}/Makefile.inc
pre-install:
.if exists(${PREFIX}/bin/hmake) && !defined(OVERRIDE_HMAKE)
diff --git a/lang/nhc98/Makefile b/lang/nhc98/Makefile
index 18e9fcf2be00..d21c0b855c56 100644
--- a/lang/nhc98/Makefile
+++ b/lang/nhc98/Makefile
@@ -67,7 +67,7 @@ pre-fetch:
.endif
post-patch:
- @${PERL} -pi.orig -e 's|-O3|${CFLAGS}|' ${WRKSRC}/Makefile.inc
+ @${REINPLACE_CMD} -e 's|-O3|${CFLAGS}|' ${WRKSRC}/Makefile.inc
pre-install:
.if exists(${PREFIX}/bin/hmake) && !defined(OVERRIDE_HMAKE)
diff --git a/net/rsync/Makefile b/net/rsync/Makefile
index bc1a191426ea..3e695f5df9c2 100644
--- a/net/rsync/Makefile
+++ b/net/rsync/Makefile
@@ -45,12 +45,12 @@ MAN1= rsync.1
MAN5= rsyncd.conf.5
pre-configure:
- @${PERL} -pi.orig -e 's:/etc/:${PREFIX}/etc/:g' \
+ @${REINPLACE_CMD} -e 's:/etc/:${PREFIX}/etc/:g' \
${WRKSRC}/rsync.h ${WRKSRC}/rsync.1 ${WRKSRC}/rsyncd.conf.5
- @${PERL} -pi.orig -e 's|malloc.h|stdlib.h|g' \
+ @${REINPLACE_CMD} -e 's|malloc.h|stdlib.h|g' \
${WRKSRC}/rsync.h ${WRKSRC}/zlib/zutil.h
.if defined(WITH_SSH)
- @${PERL} -pi.orig-rsh -e 's/"rsh"/"ssh"/g' ${WRKSRC}/rsync.h
+ @${REINPLACE_CMD} -e 's/"rsh"/"ssh"/g' ${WRKSRC}/rsync.h
.endif
post-install:
diff --git a/x11-fm/gentoo/Makefile b/x11-fm/gentoo/Makefile
index b042671300c2..bbb4bcd1e849 100644
--- a/x11-fm/gentoo/Makefile
+++ b/x11-fm/gentoo/Makefile
@@ -22,7 +22,7 @@ PORTDOCS= BUGS CONFIG-CHANGES CREDITS NEWS README README.NLS \
README.gtkrc TODO
post-patch:
- @${PERL} -pi -e 's|icons|${DATADIR}/icons|g' ${WRKSRC}/gentoorc.in
+ @${REINPLACE_CMD} -e 's|icons|${DATADIR}/icons|g' ${WRKSRC}/gentoorc.in
post-install:
${INSTALL_MAN} ${WRKSRC}/docs/gentoo.1x ${MANPREFIX}/man/man1/gentoo.1
diff --git a/x11/xbindkeys_config/Makefile b/x11/xbindkeys_config/Makefile
index 5d3506f922e1..b623bff80a4a 100644
--- a/x11/xbindkeys_config/Makefile
+++ b/x11/xbindkeys_config/Makefile
@@ -17,7 +17,7 @@ USE_GTK= yes
MAKE_ENV= CC="${CC} ${CFLAGS}"
post-patch:
- @${PERL} -pi -e "s,gtk-config,${GTK_CONFIG},g ; \
+ @${REINPLACE_CMD} -e "s,gtk-config,${GTK_CONFIG},g ; \
s,^CC,#CC,g" ${WRKSRC}/Makefile
do-install: