aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2019-02-02 06:57:27 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2019-02-02 06:57:27 +0000
commit4bb68bf8ae215c92b84b860aacb6ae1c6fd2e66e (patch)
tree4c10cf9bc78883039fded5d792b4618b861f2b8c
parentfe714039fb44e310e99f2408976d2f17dd3f358b (diff)
downloadports-4bb68bf8ae215c92b84b860aacb6ae1c6fd2e66e.tar.gz
ports-4bb68bf8ae215c92b84b860aacb6ae1c6fd2e66e.zip
Notes
-rw-r--r--x11-fonts/cyberbit-ttfonts/Makefile4
-rw-r--r--x11-themes/cursor-polar-theme/Makefile4
-rw-r--r--x11-themes/gnome-icons-jini/Makefile18
-rw-r--r--x11/xascii/Makefile6
-rw-r--r--x11/xforward/Makefile12
5 files changed, 24 insertions, 20 deletions
diff --git a/x11-fonts/cyberbit-ttfonts/Makefile b/x11-fonts/cyberbit-ttfonts/Makefile
index bf2c6a3bf026..5933644ab820 100644
--- a/x11-fonts/cyberbit-ttfonts/Makefile
+++ b/x11-fonts/cyberbit-ttfonts/Makefile
@@ -17,9 +17,9 @@ COMMENT= Bitstream Cyberbit TrueType font that covers Unicode 2.0
RESTRICTED= Redistribution not permitted; single user license only
USES= fonts zip
-NO_BUILD= yes
-WRKSRC= ${WRKDIR}
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
SUB_FILES= pkg-message
PORTDOCS= 97CyberBase.Doc 97CyberBit.Doc 97CyberCJK.Doc \
diff --git a/x11-themes/cursor-polar-theme/Makefile b/x11-themes/cursor-polar-theme/Makefile
index 60dc5fe1909c..d8dc9c40a520 100644
--- a/x11-themes/cursor-polar-theme/Makefile
+++ b/x11-themes/cursor-polar-theme/Makefile
@@ -12,10 +12,10 @@ DISTNAME= 27913-PolarCursorThemes
MAINTAINER= ports@FreeBSD.org
COMMENT= Polar is a smooth and simple cursor set
-NO_BUILD= yes
USES= tar:bzip2
-WRKSRC= ${WRKDIR}
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
do-install:
@${MKDIR} ${STAGEDIR}${PREFIX}/share/icons/polar/cursors
diff --git a/x11-themes/gnome-icons-jini/Makefile b/x11-themes/gnome-icons-jini/Makefile
index d10d8ecd69f5..c7e24a8fb610 100644
--- a/x11-themes/gnome-icons-jini/Makefile
+++ b/x11-themes/gnome-icons-jini/Makefile
@@ -10,20 +10,22 @@ DISTNAME= jini-icon-theme-${PORTVERSION}
MAINTAINER= olgeni@FreeBSD.org
COMMENT= Jini Icons for Gnome
-NO_BUILD= yes
-WRKSRC= ${WRKDIR}
+USES= gnome
INSTALLS_ICONS= yes
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+
post-extract:
- @for FILE in ${WRKDIR}/JiniOrange/scalable/apps/haansoft-hwp.svg \
- ${WRKDIR}/JiniYellowishGreen/scalable/apps/haansoft-hwp.svg \
- ${WRKDIR}/JiniBrown/scalable/apps/haansoft-hwp.svg \
- ${WRKDIR}/JiniOrange/scalable/apps/haansoft-hwp.svg \
- ${WRKDIR}/JiniYellowishGreen/scalable/apps/haansoft-hwp.svg; do \
+ @for FILE in ${WRKSRC}/JiniOrange/scalable/apps/haansoft-hwp.svg \
+ ${WRKSRC}/JiniYellowishGreen/scalable/apps/haansoft-hwp.svg \
+ ${WRKSRC}/JiniBrown/scalable/apps/haansoft-hwp.svg \
+ ${WRKSRC}/JiniOrange/scalable/apps/haansoft-hwp.svg \
+ ${WRKSRC}/JiniYellowishGreen/scalable/apps/haansoft-hwp.svg; do \
${LN} -sf ../../../JiniBlueSky/scalable/apps/haansoft-hwp.svg $${FILE}; \
done
do-install:
- cd ${WRKDIR} && ${FIND} Jini* | ${CPIO} -pdu ${STAGEDIR}${PREFIX}/share/icons
+ cd ${WRKSRC} && ${FIND} Jini* | ${CPIO} -pdu ${STAGEDIR}${PREFIX}/share/icons
.include <bsd.port.mk>
diff --git a/x11/xascii/Makefile b/x11/xascii/Makefile
index 27c5593e05de..bacd3c5edbff 100644
--- a/x11/xascii/Makefile
+++ b/x11/xascii/Makefile
@@ -7,14 +7,14 @@ CATEGORIES= x11
MASTER_SITES= http://komquats.com/distfiles/ \
http://people.freebsd.org/~cy/distfiles/
-WRKSRC= ${WRKDIR}
-
MAINTAINER= cy@FreeBSD.org
COMMENT= Display an ASCII table in decimal, octal, and hexadecimal
-MAKE_ARGS+= PREFIX=${PREFIX}
USES= imake
USE_XORG= x11 xt xaw
+
+MAKE_ARGS= PREFIX=${PREFIX}
+NO_WRKSUBDIR= yes
PLIST_FILES= bin/xascii man/man1/xascii.1.gz
.include <bsd.port.mk>
diff --git a/x11/xforward/Makefile b/x11/xforward/Makefile
index 2f18cb243c70..a16773755114 100644
--- a/x11/xforward/Makefile
+++ b/x11/xforward/Makefile
@@ -8,23 +8,25 @@ MASTER_SITES= http://komquats.com/distfiles/ \
http://people.freebsd.org/~cy/distfiles/
DISTNAME= ${PORTNAME}
-WRKSRC= ${WRKDIR}
-
MAINTAINER= cy@FreeBSD.org
COMMENT= Provide user-level X forwarding service
LICENSE_FILE= ${WRKSRC}/NOTICE
-MAKE_ARGS+= PREFIX=${PREFIX} LOCALBASE=${LOCALBASE}
-USE_XORG= x11 xt xaw xmu xt xext sm ice xp xft xau xcb xdmcp xrender
-USES= motif
LIB_DEPENDS= libpng.so:graphics/png \
libfontconfig.so:x11-fonts/fontconfig \
libexpat.so:textproc/expat2 \
libfreetype.so:print/freetype2
+
+USES= motif
+USE_XORG= x11 xt xaw xmu xt xext sm ice xp xft xau xcb xdmcp xrender
+
+MAKE_ARGS= PREFIX=${PREFIX} LOCALBASE=${LOCALBASE}
+NO_WRKSUBDIR= yes
PLIST_FILES= bin/xforward man/man1/xforward.1.gz
OPTIONS_DEFINE= STATIC
+
STATIC_ALL_TARGET= all-static
STATIC_INSTALL_TARGET= install-static
STATIC_PLIST_FILES= bin/xforward-static