aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2003-01-06 09:08:19 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>2003-01-06 09:08:19 +0000
commit4f3ac38ebb8b54978cba0c108457c9df633f7d76 (patch)
tree497c7a14205614985bfb374d9aa368ec877f6b11
parent3420c5a55ca9490dd09970f9384be45fde24c534 (diff)
downloadports-4f3ac38ebb8b54978cba0c108457c9df633f7d76.tar.gz
ports-4f3ac38ebb8b54978cba0c108457c9df633f7d76.zip
Notes
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/opensp/Makefile33
-rw-r--r--textproc/opensp/distinfo1
-rw-r--r--textproc/opensp/files/patch-doc:Makefile.in11
-rw-r--r--textproc/opensp/pkg-comment1
-rw-r--r--textproc/opensp/pkg-descr3
-rw-r--r--textproc/opensp/pkg-plist215
7 files changed, 265 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 2d15cf3d261d..82c09123915d 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -144,6 +144,7 @@
SUBDIR += no-ispell
SUBDIR += openjade
SUBDIR += opensched
+ SUBDIR += opensp
SUBDIR += orchard-c
SUBDIR += p5-Apache-ParseLog
SUBDIR += p5-CSS-SAC
diff --git a/textproc/opensp/Makefile b/textproc/opensp/Makefile
new file mode 100644
index 000000000000..e91e4f08905b
--- /dev/null
+++ b/textproc/opensp/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: OpenSP
+# Date created: Jan 6, 2003
+# Whom: kuriyama
+#
+# $FreeBSD$
+#
+
+PORTNAME= OpenSP
+PORTVERSION= 1.5
+CATEGORIES= textproc
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= openjade
+
+MAINTAINER= kuriyama@FreeBSD.org
+
+USE_GMAKE= YES
+USE_LIBTOOL= YES
+USE_PERL5= yes
+CONFIGURE_ARGS= --enable-default-catalog=${PREFIX}/share/sgml/catalog \
+ --datadir=${PREFIX}/share/sgml/openjade
+INSTALLS_SHLIB= yes
+
+MAN1= onsgmls.1 osgmlnorm.1 ospam.1 ospent.1 osx.1
+
+.include <bsd.port.pre.mk>
+
+# This port cannot be CFLAGS safe, using optimizations such as
+# 'march=-mpentium -Os' produces core dumps with certain input files
+# Therefore, we'd better remove all machine optimizations and any -O
+# other than -O{0,1,}. Idea taken from palm/prc-tools-gcc.
+CPPFLAGS:= -O ${CFLAGS:N-O*:N-m*}
+
+.include <bsd.port.post.mk>
diff --git a/textproc/opensp/distinfo b/textproc/opensp/distinfo
new file mode 100644
index 000000000000..6075fbf0d86a
--- /dev/null
+++ b/textproc/opensp/distinfo
@@ -0,0 +1 @@
+MD5 (OpenSP-1.5.tar.gz) = 87f56e79ae0c20397f4207d61d154303
diff --git a/textproc/opensp/files/patch-doc:Makefile.in b/textproc/opensp/files/patch-doc:Makefile.in
new file mode 100644
index 000000000000..592abaeb6e12
--- /dev/null
+++ b/textproc/opensp/files/patch-doc:Makefile.in
@@ -0,0 +1,11 @@
+--- doc/Makefile.in.orig Mon Nov 25 04:31:16 2002
++++ doc/Makefile.in Mon Jan 6 17:31:57 2003
+@@ -105,7 +105,7 @@
+ am__quote = @am__quote@
+ install_sh = @install_sh@
+
+-docdir = $(prefix)/doc
++docdir = $(prefix)/share/doc
+ pkgdocdir = $(docdir)/@PACKAGE@
+
+ MAINTAINERCLEANFILES = Makefile.in
diff --git a/textproc/opensp/pkg-comment b/textproc/opensp/pkg-comment
new file mode 100644
index 000000000000..caed1c421cbe
--- /dev/null
+++ b/textproc/opensp/pkg-comment
@@ -0,0 +1 @@
+This package is a collection of SGML/XML tools called OpenSP
diff --git a/textproc/opensp/pkg-descr b/textproc/opensp/pkg-descr
new file mode 100644
index 000000000000..ab8424990266
--- /dev/null
+++ b/textproc/opensp/pkg-descr
@@ -0,0 +1,3 @@
+This package is a collection of SGML/XML tools called OpenSP.
+It is a fork from James Clark's SP suite. These tools are used
+to parse, validate, and normalize SGML and XML files.
diff --git a/textproc/opensp/pkg-plist b/textproc/opensp/pkg-plist
new file mode 100644
index 000000000000..57363dc6951c
--- /dev/null
+++ b/textproc/opensp/pkg-plist
@@ -0,0 +1,215 @@
+bin/onsgmls
+bin/osgmlnorm
+bin/ospam
+bin/ospcat
+bin/ospent
+bin/osx
+include/OpenSP/Allocator.h
+include/OpenSP/ArcEngine.h
+include/OpenSP/Attribute.h
+include/OpenSP/Attributed.h
+include/OpenSP/Big5CodingSystem.h
+include/OpenSP/Boolean.h
+include/OpenSP/CharMap.cxx
+include/OpenSP/CharMap.h
+include/OpenSP/CharsetDecl.h
+include/OpenSP/CharsetInfo.h
+include/OpenSP/CharsetRegistry.h
+include/OpenSP/CmdLineApp.h
+include/OpenSP/CodingSystem.h
+include/OpenSP/CodingSystemKit.h
+include/OpenSP/ConsoleOutput.h
+include/OpenSP/ContentState.h
+include/OpenSP/ContentToken.h
+include/OpenSP/CopyOwner.cxx
+include/OpenSP/CopyOwner.h
+include/OpenSP/DescriptorManager.h
+include/OpenSP/Dtd.h
+include/OpenSP/EUCJPCodingSystem.h
+include/OpenSP/ElementType.h
+include/OpenSP/Entity.h
+include/OpenSP/EntityApp.h
+include/OpenSP/EntityCatalog.h
+include/OpenSP/EntityDecl.h
+include/OpenSP/EntityManager.h
+include/OpenSP/ErrnoMessageArg.h
+include/OpenSP/ErrorCountEventHandler.h
+include/OpenSP/Event.h
+include/OpenSP/EventGenerator.h
+include/OpenSP/EventsWanted.h
+include/OpenSP/ExtendEntityManager.h
+include/OpenSP/ExternalId.h
+include/OpenSP/Fixed2CodingSystem.h
+include/OpenSP/Fixed4CodingSystem.h
+include/OpenSP/GenericEventHandler.h
+include/OpenSP/Hash.h
+include/OpenSP/HashTable.cxx
+include/OpenSP/HashTable.h
+include/OpenSP/HashTableItemBase.cxx
+include/OpenSP/HashTableItemBase.h
+include/OpenSP/IList.h
+include/OpenSP/IListBase.h
+include/OpenSP/IListIter.h
+include/OpenSP/IListIterBase.h
+include/OpenSP/IQueue.cxx
+include/OpenSP/IQueue.h
+include/OpenSP/ISet.cxx
+include/OpenSP/ISet.h
+include/OpenSP/ISetIter.h
+include/OpenSP/IdentityCodingSystem.h
+include/OpenSP/InputSource.h
+include/OpenSP/InternalInputSource.h
+include/OpenSP/Link.h
+include/OpenSP/LinkProcess.h
+include/OpenSP/List.cxx
+include/OpenSP/List.h
+include/OpenSP/ListIter.h
+include/OpenSP/LiteralStorage.h
+include/OpenSP/Location.h
+include/OpenSP/Lpd.h
+include/OpenSP/Markup.h
+include/OpenSP/Message.h
+include/OpenSP/MessageArg.h
+include/OpenSP/MessageBuilder.h
+include/OpenSP/MessageEventHandler.h
+include/OpenSP/MessageFormatter.h
+include/OpenSP/MessageModule.h
+include/OpenSP/MessageReporter.h
+include/OpenSP/MessageTable.h
+include/OpenSP/Mode.h
+include/OpenSP/NCVector.h
+include/OpenSP/Named.h
+include/OpenSP/NamedResource.h
+include/OpenSP/NamedResourceTable.h
+include/OpenSP/NamedTable.h
+include/OpenSP/Notation.h
+include/OpenSP/NotationStorage.h
+include/OpenSP/OpenElement.h
+include/OpenSP/Options.cxx
+include/OpenSP/Options.h
+include/OpenSP/OutputByteStream.h
+include/OpenSP/OutputCharStream.h
+include/OpenSP/Owner.cxx
+include/OpenSP/Owner.h
+include/OpenSP/OwnerTable.cxx
+include/OpenSP/OwnerTable.h
+include/OpenSP/ParserApp.h
+include/OpenSP/ParserEventGeneratorKit.h
+include/OpenSP/ParserOptions.h
+include/OpenSP/PointerTable.cxx
+include/OpenSP/PointerTable.h
+include/OpenSP/PosixStorage.h
+include/OpenSP/Ptr.cxx
+include/OpenSP/Ptr.h
+include/OpenSP/RangeMap.cxx
+include/OpenSP/RangeMap.h
+include/OpenSP/Resource.h
+include/OpenSP/RewindStorageObject.h
+include/OpenSP/SGMLApplication.h
+include/OpenSP/SJISCodingSystem.h
+include/OpenSP/SOEntityCatalog.h
+include/OpenSP/Sd.h
+include/OpenSP/SdText.h
+include/OpenSP/SearchResultMessageArg.h
+include/OpenSP/SgmlParser.h
+include/OpenSP/ShortReferenceMap.h
+include/OpenSP/StdioStorage.h
+include/OpenSP/StorageManager.h
+include/OpenSP/StringC.h
+include/OpenSP/StringOf.cxx
+include/OpenSP/StringOf.h
+include/OpenSP/StringResource.h
+include/OpenSP/SubstTable.h
+include/OpenSP/Syntax.h
+include/OpenSP/Text.h
+include/OpenSP/TranslateCodingSystem.h
+include/OpenSP/TypeId.h
+include/OpenSP/URLStorage.h
+include/OpenSP/UTF16CodingSystem.h
+include/OpenSP/UTF8CodingSystem.h
+include/OpenSP/UnicodeCodingSystem.h
+include/OpenSP/UnivCharsetDesc.h
+include/OpenSP/Vector.cxx
+include/OpenSP/Vector.h
+include/OpenSP/XMLCodingSystem.h
+include/OpenSP/XcharMap.cxx
+include/OpenSP/XcharMap.h
+include/OpenSP/config.h
+include/OpenSP/constant.h
+include/OpenSP/macros.h
+include/OpenSP/rtti.h
+include/OpenSP/sptchar.h
+include/OpenSP/types.h
+include/OpenSP/xnew.h
+lib/charset.alias
+lib/libosp.a
+lib/libosp.la
+lib/libosp.so
+lib/libosp.so.3
+share/doc/OpenSP/archform.htm
+share/doc/OpenSP/autoconf.htm
+share/doc/OpenSP/build.htm
+share/doc/OpenSP/catalog.htm
+share/doc/OpenSP/charset.htm
+share/doc/OpenSP/features.htm
+share/doc/OpenSP/generic.htm
+share/doc/OpenSP/ideas.htm
+share/doc/OpenSP/index.htm
+share/doc/OpenSP/new.htm
+share/doc/OpenSP/nsgmls.htm
+share/doc/OpenSP/sgmldecl.htm
+share/doc/OpenSP/sgmlnorm.htm
+share/doc/OpenSP/sgmlsout.htm
+share/doc/OpenSP/spam.htm
+share/doc/OpenSP/spcat.htm
+share/doc/OpenSP/spent.htm
+share/doc/OpenSP/sx.htm
+share/doc/OpenSP/sysdecl.htm
+share/doc/OpenSP/sysid.htm
+share/doc/OpenSP/xml.htm
+share/doc/OpenSP/xmlwarn.htm
+share/sgml/openjade/OpenSP/HTML32.dcl
+share/sgml/openjade/OpenSP/HTML32.dtd
+share/sgml/openjade/OpenSP/HTML32.soc
+share/sgml/openjade/OpenSP/HTML4-f.dtd
+share/sgml/openjade/OpenSP/HTML4-s.dtd
+share/sgml/openjade/OpenSP/HTML4.dcl
+share/sgml/openjade/OpenSP/HTML4.dtd
+share/sgml/openjade/OpenSP/HTML4.soc
+share/sgml/openjade/OpenSP/HTMLlat1.ent
+share/sgml/openjade/OpenSP/HTMLspec.ent
+share/sgml/openjade/OpenSP/HTMLsym.ent
+share/sgml/openjade/OpenSP/ISOlat1.ent
+share/sgml/openjade/OpenSP/ISOlat1.sgm
+share/sgml/openjade/OpenSP/catalog
+share/sgml/openjade/OpenSP/demo.sgm
+share/sgml/openjade/OpenSP/gensyntax.pl
+share/sgml/openjade/OpenSP/html-1.dtd
+share/sgml/openjade/OpenSP/html-1s.dtd
+share/sgml/openjade/OpenSP/html-s.dtd
+share/sgml/openjade/OpenSP/html.dcl
+share/sgml/openjade/OpenSP/html.dtd
+share/sgml/openjade/OpenSP/html.soc
+share/sgml/openjade/OpenSP/japan.dcl
+share/sgml/openjade/OpenSP/opensp-implied.dcl
+share/sgml/openjade/OpenSP/unicode.sd
+share/sgml/openjade/OpenSP/unicode.syn
+share/sgml/openjade/OpenSP/xml.dcl
+share/sgml/openjade/OpenSP/xml.soc
+share/sgml/openjade/doc/OpenSP/ABOUT-NLS
+share/sgml/openjade/doc/OpenSP/AUTHORS
+share/sgml/openjade/doc/OpenSP/COPYING
+share/sgml/openjade/doc/OpenSP/ChangeLog
+share/sgml/openjade/doc/OpenSP/NEWS
+share/sgml/openjade/doc/OpenSP/README
+share/sgml/openjade/doc/OpenSP/releasenotes.html
+share/sgml/openjade/doc/OpenSP/releasenotes.pdf
+share/sgml/openjade/doc/OpenSP/releasenotes.ps
+share/sgml/openjade/locale/locale.alias
+@dirrm share/doc/OpenSP
+@dirrm include/OpenSP
+@dirrm share/sgml/openjade/OpenSP
+@dirrm share/sgml/openjade/doc/OpenSP
+@dirrm share/sgml/openjade/doc
+@dirrm share/sgml/openjade/locale
+@dirrm share/sgml/openjade