aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEd Maste <emaste@FreeBSD.org>2018-09-18 14:48:48 +0000
committerEd Maste <emaste@FreeBSD.org>2018-09-18 14:48:48 +0000
commit635e6cc2e3f343d3970ed82bd55469234faaaadc (patch)
treeeb714b6159c7c511c1f29417bdc1398e0953e472
parent1bc9d18ba61eafe2c837fb9539a95c086c0581f4 (diff)
downloadports-635e6cc2e3f343d3970ed82bd55469234faaaadc.tar.gz
ports-635e6cc2e3f343d3970ed82bd55469234faaaadc.zip
Notes
-rw-r--r--Mk/bsd.port.mk5
-rw-r--r--archivers/p7zip/Makefile1
-rw-r--r--multimedia/libx264/Makefile2
-rw-r--r--multimedia/xmms/Makefile2
4 files changed, 5 insertions, 5 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 688a38c2cdd2..c8e1008a5c81 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -363,6 +363,7 @@ FreeBSD_MAINTAINER= portmgr@FreeBSD.org
# CXXFLAGS_${ARCH}
# Append the cxxflags to CXXFLAGS only on the specified architecture
##
+# LDFLAGS_${ARCH} Append the ldflags to LDFLAGS only on the specified architecture
# USE_SDL - If set, this port uses the sdl libraries.
# See bsd.sdl.mk for more information.
##
@@ -2050,6 +2051,10 @@ ${lang}FLAGS+= ${${lang}FLAGS_${ARCH}}
.endif
.endfor
+.if defined(LDFLAGS_${ARCH})
+LDFLAGS+= ${LDFLAGS_${ARCH}}
+.endif
+
# Multiple make jobs support
.if defined(DISABLE_MAKE_JOBS) || defined(MAKE_JOBS_UNSAFE)
_MAKE_JOBS?= #
diff --git a/archivers/p7zip/Makefile b/archivers/p7zip/Makefile
index befaaa19da1b..7da9fd4ee1a8 100644
--- a/archivers/p7zip/Makefile
+++ b/archivers/p7zip/Makefile
@@ -31,7 +31,6 @@ CFLAGS_sparc64= -fPIC
# Fix the build for i386 when WITH_LLD_IS_LD is set
# https://bugs.freebsd.org/230210
-LDFLAGS+= ${LDFLAGS_${ARCH}}
LDFLAGS_i386= -Wl,-z,notext
OPTIONS_DEFINE= DOCS
diff --git a/multimedia/libx264/Makefile b/multimedia/libx264/Makefile
index 343f9dd95547..831dfeffd0d2 100644
--- a/multimedia/libx264/Makefile
+++ b/multimedia/libx264/Makefile
@@ -13,8 +13,6 @@ PLIST= ${.CURDIR}/pkg-plist
LIB_DEPENDS= #
USES= pathfix
-
-LDFLAGS+= ${LDFLAGS_${ARCH}}
LDFLAGS_i386= -Wl,-znotext
OPTIONS_DEFINE= ASM OPENCL
diff --git a/multimedia/xmms/Makefile b/multimedia/xmms/Makefile
index 1724dadbb43d..289d5209ed34 100644
--- a/multimedia/xmms/Makefile
+++ b/multimedia/xmms/Makefile
@@ -23,9 +23,7 @@ USE_GNOME= gtk12
USE_LDCONFIG= yes
USE_XORG= sm x11 xxf86vm
-LDFLAGS+= ${LDFLAGS_${ARCH}}
LDFLAGS_i386= -Wl,-znotext
-
CONFIGURE_ARGS= xmms_cv_newpcm_driver=yes --disable-static
CONFIGURE_ENV= INPUT_PLUGINS="${INPUT_PLUGINS}" \
OUTPUT_PLUGINS="${OUTPUT_PLUGINS}" \