aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2004-08-08 09:05:35 +0000
committerMathieu Arnold <mat@FreeBSD.org>2004-08-08 09:05:35 +0000
commit6489d7ebc954c537256c844253ad7ea11d534dd2 (patch)
treebad091eb858eba916881b326fb6a2510da5159d8
parent28b43aa64361383471553d8b561f4c24a0947c1b (diff)
downloadports-6489d7ebc954c537256c844253ad7ea11d534dd2.tar.gz
ports-6489d7ebc954c537256c844253ad7ea11d534dd2.zip
Notes
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Alzabo/Makefile93
-rw-r--r--devel/p5-Alzabo/distinfo2
-rw-r--r--devel/p5-Alzabo/files/patch-Build.PL21
-rw-r--r--devel/p5-Alzabo/pkg-descr11
-rw-r--r--devel/p5-Alzabo/pkg-plist59
6 files changed, 187 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index ea020b211ca6..e1cdd52da33c 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -587,6 +587,7 @@
SUBDIR += p5-Algorithm-Permute
SUBDIR += p5-Algorithm-SVM
SUBDIR += p5-Alias
+ SUBDIR += p5-Alzabo
SUBDIR += p5-App-Info
SUBDIR += p5-AppConfig
SUBDIR += p5-AppConfig-Std
diff --git a/devel/p5-Alzabo/Makefile b/devel/p5-Alzabo/Makefile
new file mode 100644
index 000000000000..82ebb8b0b469
--- /dev/null
+++ b/devel/p5-Alzabo/Makefile
@@ -0,0 +1,93 @@
+# New ports collection makefile for: p5-Alzabo
+# Date created: 8 Aug 2004
+# Whom: mat
+#
+# $FreeBSD$
+#
+
+PORTNAME= Alzabo
+PORTVERSION= 0.83
+CATEGORIES= devel databases perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../by-authors/id/D/DR/DROLSKY/
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= mat@FreeBSD.org
+COMMENT= A data modelling tool and RDBMS-OO mapper
+
+BUILD_DEPENDS= ${SITE_PERL}/Exception/Class.pm:${PORTSDIR}/devel/p5-Exception-Class \
+ ${SITE_PERL}/Class/Factory/Util.pm:${PORTSDIR}/devel/p5-Class-Factory-Util \
+ ${SITE_PERL}/${PERL_ARCH}//Params/Validate.pm:${PORTSDIR}/devel/p5-Params-Validate \
+ ${SITE_PERL}/Tie/IxHash.pm:${PORTSDIR}/devel/p5-Tie-IxHash \
+ ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_MODBUILD= yes
+
+MAN3= \
+ Alzabo.3 \
+ Alzabo::BackCompat.3 \
+ Alzabo::ChangeTracker.3 \
+ Alzabo::Column.3 \
+ Alzabo::ColumnDefinition.3 \
+ Alzabo::Config.3 \
+ Alzabo::Create.3 \
+ Alzabo::Create::Column.3 \
+ Alzabo::Create::ColumnDefinition.3 \
+ Alzabo::Create::ForeignKey.3 \
+ Alzabo::Create::Index.3 \
+ Alzabo::Create::Schema.3 \
+ Alzabo::Create::Table.3 \
+ Alzabo::Debug.3 \
+ Alzabo::Design.3 \
+ Alzabo::Driver.3 \
+ Alzabo::Driver::MySQL.3 \
+ Alzabo::Driver::PostgreSQL.3 \
+ Alzabo::Exceptions.3 \
+ Alzabo::FAQ.3 \
+ Alzabo::ForeignKey.3 \
+ Alzabo::Index.3 \
+ Alzabo::Intro.3 \
+ Alzabo::MethodMaker.3 \
+ Alzabo::MySQL.3 \
+ Alzabo::PostgreSQL.3 \
+ Alzabo::QuickRef.3 \
+ Alzabo::RDBMSRules.3 \
+ Alzabo::RDBMSRules::MySQL.3 \
+ Alzabo::RDBMSRules::PostgreSQL.3 \
+ Alzabo::Runtime.3 \
+ Alzabo::Runtime::Column.3 \
+ Alzabo::Runtime::ColumnDefinition.3 \
+ Alzabo::Runtime::Cursor.3 \
+ Alzabo::Runtime::ForeignKey.3 \
+ Alzabo::Runtime::Index.3 \
+ Alzabo::Runtime::InsertHandle.3 \
+ Alzabo::Runtime::JoinCursor.3 \
+ Alzabo::Runtime::Row.3 \
+ Alzabo::Runtime::RowCursor.3 \
+ Alzabo::Runtime::RowState::Deleted.3 \
+ Alzabo::Runtime::RowState::InCache.3 \
+ Alzabo::Runtime::RowState::Live.3 \
+ Alzabo::Runtime::RowState::Potential.3 \
+ Alzabo::Runtime::Schema.3 \
+ Alzabo::Runtime::Table.3 \
+ Alzabo::Runtime::UniqueRowCache.3 \
+ Alzabo::SQLMaker.3 \
+ Alzabo::SQLMaker::MySQL.3 \
+ Alzabo::SQLMaker::PostgreSQL.3 \
+ Alzabo::Schema.3 \
+ Alzabo::Table.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/devel/p5-Storable \
+ ${SITE_PERL}/${PERL_ARCH}/Scalar/Util.pm:${PORTSDIR}/lang/p5-Scalar-List-Utils \
+ ${SITE_PERL}/${PERL_ARCH}/Time/HiRes.pm:${PORTSDIR}/devel/p5-Time-HiRes \
+ ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5
+.if ${PERL_LEVEL} < 500600
+IGNORE= Needs perl 5.6+, install lang/perl5 or lang/perl5.8 and try again
+.endif
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Alzabo/distinfo b/devel/p5-Alzabo/distinfo
new file mode 100644
index 000000000000..150db8a7a859
--- /dev/null
+++ b/devel/p5-Alzabo/distinfo
@@ -0,0 +1,2 @@
+MD5 (Alzabo-0.83.tar.gz) = 8bcd61c48afdef7a551ae731a5f7d2ee
+SIZE (Alzabo-0.83.tar.gz) = 202120
diff --git a/devel/p5-Alzabo/files/patch-Build.PL b/devel/p5-Alzabo/files/patch-Build.PL
new file mode 100644
index 000000000000..13d25823a4cd
--- /dev/null
+++ b/devel/p5-Alzabo/files/patch-Build.PL
@@ -0,0 +1,21 @@
+--- Build.PL~ Thu Jun 10 01:00:41 2004
++++ Build.PL Sun Aug 8 10:55:14 2004
+@@ -90,7 +90,7 @@
+ EOF
+
+ my $root_dir = Alzabo::Config::root_dir() if %Alzabo::Config::CONFIG;
+- return Module::Build->prompt( ' Alzabo root?', $root_dir || find_possible_root() );
++ return undef;
+ }
+
+ sub find_possible_root
+@@ -182,8 +182,7 @@
+
+ print "\u$feature->{phrase} $mods.\n";
+
+- my $wanted =
+- Module::Build->y_n( " Do you want $feature->{phrase}?", $has ? 'yes' : 'no' );
++ my $wanted;
+
+ if ($wanted)
+ {
diff --git a/devel/p5-Alzabo/pkg-descr b/devel/p5-Alzabo/pkg-descr
new file mode 100644
index 000000000000..bba5c29c4f69
--- /dev/null
+++ b/devel/p5-Alzabo/pkg-descr
@@ -0,0 +1,11 @@
+Alzabo is a suite of modules with two core functions. Its first use is as a
+data modelling tool. Through either a schema creation GUI, a perl program, or
+reverse engineering, you can create a set objects to represent a schema.
+
+Its second function is as an RDBMS to object mapping system. Once you have
+created a schema, you can use the Alzabo::Runtime::Table and
+Alzabo::Runtime::Row classes to access its data. These classes offer a high
+level interface to common operations such as SQL SELECT, INSERT, DELETE, and
+UPDATE commands.
+
+WWW: http://search.cpan.org/dist/Alzabo/
diff --git a/devel/p5-Alzabo/pkg-plist b/devel/p5-Alzabo/pkg-plist
new file mode 100644
index 000000000000..7aac6a148bad
--- /dev/null
+++ b/devel/p5-Alzabo/pkg-plist
@@ -0,0 +1,59 @@
+%%SITE_PERL%%/Alzabo.pm
+%%SITE_PERL%%/Alzabo/BackCompat.pm
+%%SITE_PERL%%/Alzabo/ChangeTracker.pm
+%%SITE_PERL%%/Alzabo/Column.pm
+%%SITE_PERL%%/Alzabo/ColumnDefinition.pm
+%%SITE_PERL%%/Alzabo/Config.pm
+%%SITE_PERL%%/Alzabo/Create.pm
+%%SITE_PERL%%/Alzabo/Create/Column.pm
+%%SITE_PERL%%/Alzabo/Create/ColumnDefinition.pm
+%%SITE_PERL%%/Alzabo/Create/ForeignKey.pm
+%%SITE_PERL%%/Alzabo/Create/Index.pm
+%%SITE_PERL%%/Alzabo/Create/Schema.pm
+%%SITE_PERL%%/Alzabo/Create/Table.pm
+%%SITE_PERL%%/Alzabo/Debug.pm
+%%SITE_PERL%%/Alzabo/Design.pod
+%%SITE_PERL%%/Alzabo/Driver.pm
+%%SITE_PERL%%/Alzabo/Driver/MySQL.pm
+%%SITE_PERL%%/Alzabo/Driver/PostgreSQL.pm
+%%SITE_PERL%%/Alzabo/Exceptions.pm
+%%SITE_PERL%%/Alzabo/FAQ.pod
+%%SITE_PERL%%/Alzabo/ForeignKey.pm
+%%SITE_PERL%%/Alzabo/Index.pm
+%%SITE_PERL%%/Alzabo/Intro.pod
+%%SITE_PERL%%/Alzabo/MethodMaker.pm
+%%SITE_PERL%%/Alzabo/MySQL.pod
+%%SITE_PERL%%/Alzabo/PostgreSQL.pod
+%%SITE_PERL%%/Alzabo/QuickRef.pod
+%%SITE_PERL%%/Alzabo/RDBMSRules.pm
+%%SITE_PERL%%/Alzabo/RDBMSRules/MySQL.pm
+%%SITE_PERL%%/Alzabo/RDBMSRules/PostgreSQL.pm
+%%SITE_PERL%%/Alzabo/Runtime.pm
+%%SITE_PERL%%/Alzabo/Runtime/Column.pm
+%%SITE_PERL%%/Alzabo/Runtime/ColumnDefinition.pm
+%%SITE_PERL%%/Alzabo/Runtime/Cursor.pm
+%%SITE_PERL%%/Alzabo/Runtime/ForeignKey.pm
+%%SITE_PERL%%/Alzabo/Runtime/Index.pm
+%%SITE_PERL%%/Alzabo/Runtime/InsertHandle.pm
+%%SITE_PERL%%/Alzabo/Runtime/JoinCursor.pm
+%%SITE_PERL%%/Alzabo/Runtime/Row.pm
+%%SITE_PERL%%/Alzabo/Runtime/RowCursor.pm
+%%SITE_PERL%%/Alzabo/Runtime/RowState/Deleted.pm
+%%SITE_PERL%%/Alzabo/Runtime/RowState/InCache.pm
+%%SITE_PERL%%/Alzabo/Runtime/RowState/Live.pm
+%%SITE_PERL%%/Alzabo/Runtime/RowState/Potential.pm
+%%SITE_PERL%%/Alzabo/Runtime/Schema.pm
+%%SITE_PERL%%/Alzabo/Runtime/Table.pm
+%%SITE_PERL%%/Alzabo/Runtime/UniqueRowCache.pm
+%%SITE_PERL%%/Alzabo/SQLMaker.pm
+%%SITE_PERL%%/Alzabo/SQLMaker/MySQL.pm
+%%SITE_PERL%%/Alzabo/SQLMaker/PostgreSQL.pm
+%%SITE_PERL%%/Alzabo/Schema.pm
+%%SITE_PERL%%/Alzabo/Table.pm
+@dirrm %%SITE_PERL%%/Alzabo/SQLMaker
+@dirrm %%SITE_PERL%%/Alzabo/Runtime/RowState
+@dirrm %%SITE_PERL%%/Alzabo/Runtime
+@dirrm %%SITE_PERL%%/Alzabo/RDBMSRules
+@dirrm %%SITE_PERL%%/Alzabo/Driver
+@dirrm %%SITE_PERL%%/Alzabo/Create
+@dirrm %%SITE_PERL%%/Alzabo