aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2016-04-27 19:02:49 +0000
committerPawel Pekala <pawel@FreeBSD.org>2016-04-27 19:02:49 +0000
commit665b18b1f74e4950487db7c0830b7b0f75f8e098 (patch)
tree85bd9d4800ecb94995ad978f679e4f3f1919085f
parent07ff769ab7c936c5a36df9dc281d599ffe58cf39 (diff)
downloadports-665b18b1f74e4950487db7c0830b7b0f75f8e098.tar.gz
ports-665b18b1f74e4950487db7c0830b7b0f75f8e098.zip
Notes
-rw-r--r--net-im/qTox/Makefile13
-rw-r--r--net-im/qTox/distinfo4
-rw-r--r--net-im/qTox/files/patch-qtox.pro22
-rw-r--r--net-im/qTox/files/patch-src_main.cpp6
-rw-r--r--net-im/qTox/files/patch-src_platform_camera_v4l2.h2
-rw-r--r--net-im/qTox/files/patch-src_video_cameradevice.cpp16
-rw-r--r--net-im/qTox/files/patch-src_widget_form_settings_aboutsettings.ui12
-rw-r--r--net-im/qTox/pkg-descr3
8 files changed, 54 insertions, 24 deletions
diff --git a/net-im/qTox/Makefile b/net-im/qTox/Makefile
index 7be5c027bc94..834fcd67ac4c 100644
--- a/net-im/qTox/Makefile
+++ b/net-im/qTox/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= qTox
-PORTVERSION= 1.3.0
-PORTREVISION= 1
+PORTVERSION= 1.4.0
DISTVERSIONPREFIX= v
CATEGORIES= net-im net-p2p
@@ -21,19 +20,23 @@ LIB_DEPENDS= libtoxcore.so:net-im/tox \
libfilteraudio.so:audio/libfilteraudio \
libsodium.so:security/libsodium \
libqrencode.so:graphics/libqrencode \
- libsqlcipher.so:databases/sqlcipher
+ libsqlcipher.so:databases/sqlcipher \
+ libfreetype.so:print/freetype2 \
+ libfontconfig.so:x11-fonts/fontconfig
USE_GITHUB= yes
GH_ACCOUNT= tux3
SUB_FILES= pkg-message
-USES= compiler:c++11-lib desktop-file-utils openal:soft qmake gmake
+USES= compiler:c++11-lib desktop-file-utils gettext gmake openal:soft pkgconfig qmake
USE_GNOME= glib20 gtk20 cairo gdkpixbuf2
USE_XORG= x11 xscrnsaver
+USE_GL= gl
USE_QT5= core gui network xml opengl sql sql-sqlite3_run widgets svg \
concurrent buildtools_build linguisttools_build
ICON_SIZES= 14x14 16x16 22x22 24x24 32x32 36x36 48x48 64x64 72x72 96x96 128x128 192x192 256x256 512x512
+QMAKE_ARGS= FREEBSD_PKGVERSION=${PKGVERSION}
PLIST_FILES= bin/qtox \
share/applications/qTox.desktop \
@@ -66,7 +69,7 @@ post-install:
@${GZIP_CMD} ${GZIP} < ${WRKSRC}/img/icons/qtox.svg > ${STAGEDIR}${PREFIX}/share/icons/hicolor/scalable/apps/qtox.svgz
.for SZ in ${ICON_SIZES}
@${MKDIR} ${STAGEDIR}${PREFIX}/share/icons/hicolor/${SZ}/apps
- @${CP} ${WRKSRC}/img/icons/qtox-${SZ}.png ${STAGEDIR}${PREFIX}/share/icons/hicolor/${SZ}/apps/qtox.png
+ @${CP} ${WRKSRC}/img/icons/${SZ}/qtox.png ${STAGEDIR}${PREFIX}/share/icons/hicolor/${SZ}/apps/qtox.png
.endfor
.include <bsd.port.mk>
diff --git a/net-im/qTox/distinfo b/net-im/qTox/distinfo
index 848306b39203..98aca75764fd 100644
--- a/net-im/qTox/distinfo
+++ b/net-im/qTox/distinfo
@@ -1,2 +1,2 @@
-SHA256 (tux3-qTox-v1.3.0_GH0.tar.gz) = a2d1483a9aa6e99684853733a0a0a04c8cde168a775b9d2bdab94771fd82bc0a
-SIZE (tux3-qTox-v1.3.0_GH0.tar.gz) = 4679256
+SHA256 (tux3-qTox-v1.4.0_GH0.tar.gz) = f869aafddb597286dc03b828b48e2560a97983f180914c396fdcf2f1ca07ae79
+SIZE (tux3-qTox-v1.4.0_GH0.tar.gz) = 3021956
diff --git a/net-im/qTox/files/patch-qtox.pro b/net-im/qTox/files/patch-qtox.pro
index c3322ca2f839..ef6509748c43 100644
--- a/net-im/qTox/files/patch-qtox.pro
+++ b/net-im/qTox/files/patch-qtox.pro
@@ -1,8 +1,22 @@
---- qtox.pro.orig 2015-06-12 10:53:59 UTC
+--- qtox.pro.orig 2016-04-24 12:44:18 UTC
+++ qtox.pro
-@@ -483,6 +483,18 @@ SOURCES += \
- src/widget/translator.cpp \
- src/persistence/settingsserializer.cpp
+@@ -49,11 +49,11 @@ include(translations/i18n.pri)
+ system($$fromfile(translations/i18n.pri, updateallqm))
+
+ isEmpty(GIT_VERSION) {
+- GIT_VERSION = $$system(git rev-parse HEAD 2> /dev/null || echo "built without git")
++ GIT_VERSION = $$system(echo "n/a")
+ }
+ DEFINES += GIT_VERSION=\"\\\"$$quote($$GIT_VERSION)\\\"\"
+ isEmpty(GIT_DESCRIBE) {
+- GIT_DESCRIBE = $$system(git describe --tags 2> /dev/null || echo "Nightly")
++ GIT_DESCRIBE = $$FREEBSD_PKGVERSION
+ }
+ DEFINES += GIT_DESCRIBE=\"\\\"$$quote($$GIT_DESCRIBE)\\\"\"
+ # date works on linux/mac, but it would hangs qmake on windows
+@@ -485,6 +485,18 @@ SOURCES += \
+ src/persistence/history.cpp \
+ src/widget/form/groupinviteform.cpp
+unix {
+ target.path = $$PREFIX/bin
diff --git a/net-im/qTox/files/patch-src_main.cpp b/net-im/qTox/files/patch-src_main.cpp
index 83ba303deb38..21b36602fcb0 100644
--- a/net-im/qTox/files/patch-src_main.cpp
+++ b/net-im/qTox/files/patch-src_main.cpp
@@ -1,7 +1,7 @@
---- src/main.cpp.orig 2015-11-14 22:51:30 UTC
+--- src/main.cpp.orig 2016-04-24 12:44:18 UTC
+++ src/main.cpp
-@@ -269,3 +269,10 @@ int main(int argc, char *argv[])
- qDebug() << "Clean exit with status"<<errorcode;
+@@ -303,3 +303,10 @@ int main(int argc, char *argv[])
+ #endif
return errorcode;
}
+
diff --git a/net-im/qTox/files/patch-src_platform_camera_v4l2.h b/net-im/qTox/files/patch-src_platform_camera_v4l2.h
index 94c7968c76dd..6da51cd5314f 100644
--- a/net-im/qTox/files/patch-src_platform_camera_v4l2.h
+++ b/net-im/qTox/files/patch-src_platform_camera_v4l2.h
@@ -1,4 +1,4 @@
---- src/platform/camera/v4l2.h.orig 2015-11-14 22:51:30 UTC
+--- src/platform/camera/v4l2.h.orig 2016-04-24 12:44:18 UTC
+++ src/platform/camera/v4l2.h
@@ -24,7 +24,7 @@
#include <QPair>
diff --git a/net-im/qTox/files/patch-src_video_cameradevice.cpp b/net-im/qTox/files/patch-src_video_cameradevice.cpp
index 88a28521c434..373bdd00422e 100644
--- a/net-im/qTox/files/patch-src_video_cameradevice.cpp
+++ b/net-im/qTox/files/patch-src_video_cameradevice.cpp
@@ -1,4 +1,4 @@
---- src/video/cameradevice.cpp.orig 2015-11-15 08:11:58 UTC
+--- src/video/cameradevice.cpp.orig 2016-04-24 12:44:18 UTC
+++ src/video/cameradevice.cpp
@@ -31,7 +31,7 @@ extern "C" {
#ifdef Q_OS_WIN
@@ -8,8 +8,8 @@
+#ifdef Q_OS_UNIX
#include "src/platform/camera/v4l2.h"
#endif
-
-@@ -105,7 +105,7 @@ CameraDevice* CameraDevice::open(QString
+ #ifdef Q_OS_OSX
+@@ -122,7 +122,7 @@ CameraDevice* CameraDevice::open(QString
AVDictionary* options = nullptr;
if (!iformat);
@@ -18,7 +18,7 @@
else if (devName.startsWith("x11grab#"))
{
QSize screen;
-@@ -142,7 +142,7 @@ CameraDevice* CameraDevice::open(QString
+@@ -168,7 +168,7 @@ CameraDevice* CameraDevice::open(QString
av_dict_set(&options, "framerate", QString().setNum(mode.FPS).toStdString().c_str(), 0);
}
#endif
@@ -27,7 +27,7 @@
else if (iformat->name == QString("video4linux2,v4l2") && mode)
{
av_dict_set(&options, "video_size", QString("%1x%2").arg(mode.width).arg(mode.height).toStdString().c_str(), 0);
-@@ -264,7 +264,7 @@ QVector<QPair<QString, QString>> CameraD
+@@ -311,7 +311,7 @@ QVector<QPair<QString, QString>> CameraD
else if (iformat->name == QString("dshow"))
devices += DirectShow::getDeviceList();
#endif
@@ -36,7 +36,7 @@
else if (iformat->name == QString("video4linux2,v4l2"))
devices += v4l2::getDeviceList();
#endif
-@@ -307,7 +307,7 @@ QVector<VideoMode> CameraDevice::getVide
+@@ -358,7 +358,7 @@ QVector<VideoMode> CameraDevice::getVide
else if (iformat->name == QString("dshow"))
return DirectShow::getDeviceModes(devName);
#endif
@@ -45,7 +45,7 @@
else if (iformat->name == QString("video4linux2,v4l2"))
return v4l2::getDeviceModes(devName);
#endif
-@@ -327,7 +327,7 @@ bool CameraDevice::getDefaultInputFormat
+@@ -400,7 +400,7 @@ bool CameraDevice::getDefaultInputFormat
avdevice_register_all();
// Desktop capture input formats
@@ -54,7 +54,7 @@
idesktopFormat = av_find_input_format("x11grab");
#endif
#ifdef Q_OS_WIN
-@@ -335,7 +335,7 @@ bool CameraDevice::getDefaultInputFormat
+@@ -408,7 +408,7 @@ bool CameraDevice::getDefaultInputFormat
#endif
// Webcam input formats
diff --git a/net-im/qTox/files/patch-src_widget_form_settings_aboutsettings.ui b/net-im/qTox/files/patch-src_widget_form_settings_aboutsettings.ui
new file mode 100644
index 000000000000..ecd791433d93
--- /dev/null
+++ b/net-im/qTox/files/patch-src_widget_form_settings_aboutsettings.ui
@@ -0,0 +1,12 @@
+--- src/widget/form/settings/aboutsettings.ui.orig 2016-04-25 21:28:44 UTC
++++ src/widget/form/settings/aboutsettings.ui
+@@ -111,6 +111,9 @@
+ <property name="text">
+ <string>Commit hash: &lt;a href=&quot;https://github.com/tux3/qTox/commit/$GIT_VERSION&quot;&gt;$GIT_VERSION&lt;/a&gt;</string>
+ </property>
++ <property name="visible">
++ <bool>false</bool>
++ </property>
+ <property name="openExternalLinks">
+ <bool>true</bool>
+ </property>
diff --git a/net-im/qTox/pkg-descr b/net-im/qTox/pkg-descr
index b92cc829af24..279d5d004503 100644
--- a/net-im/qTox/pkg-descr
+++ b/net-im/qTox/pkg-descr
@@ -1,3 +1,4 @@
-qTox is a graphical user interface for Tox written using Qt 5.
+Powerful Tox chat client written using Qt 5 that follows the Tox
+design guidelines.
WWW: https://github.com/tux3/qTox