aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2015-01-14 05:25:44 +0000
committerKurt Jaeger <pi@FreeBSD.org>2015-01-14 05:25:44 +0000
commit72768e644a7adde141c59f7dc4418c165f88f54c (patch)
treecc81ed50a3cae40bf01cd411e2187771a2452b79
parent432f44171da6eca8a921cbb8b01cab02dbc3334e (diff)
Notes
-rw-r--r--net-mgmt/Makefile1
-rw-r--r--net-mgmt/statsite/Makefile30
-rw-r--r--net-mgmt/statsite/distinfo2
-rw-r--r--net-mgmt/statsite/files/patch-src_networking.c14
-rw-r--r--net-mgmt/statsite/pkg-descr6
5 files changed, 53 insertions, 0 deletions
diff --git a/net-mgmt/Makefile b/net-mgmt/Makefile
index b3d7c3b99c07..55c7485f72f3 100644
--- a/net-mgmt/Makefile
+++ b/net-mgmt/Makefile
@@ -296,6 +296,7 @@
SUBDIR += spectools
SUBDIR += ssgless
SUBDIR += statsd
+ SUBDIR += statsite
SUBDIR += subcalc
SUBDIR += sx
SUBDIR += sysmon
diff --git a/net-mgmt/statsite/Makefile b/net-mgmt/statsite/Makefile
new file mode 100644
index 000000000000..0dfe8276c2ce
--- /dev/null
+++ b/net-mgmt/statsite/Makefile
@@ -0,0 +1,30 @@
+# $FreeBSD$
+
+PORTNAME= statsite
+PORTVERSION= 0.6.5
+CATEGORIES= net-mgmt
+MASTER_SITES= https://github.com/armon/statsite/archive/
+DISTNAME= v${PORTVERSION}
+
+MAINTAINER= rbarabas@rbarabas.info
+COMMENT= C implementation of statsd
+
+LICENSE= BSD3CLAUSE
+
+BUILD_DEPENDS= scons:${PORTSDIR}/devel/scons
+
+USERS= statsd
+GROUPS= statsd
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+PLIST_FILES= bin/statsite
+
+do-build:
+ cd ${WRKSRC} && make
+
+do-install:
+ ${STRIP_CMD} ${WRKSRC}/statsite
+ ${CP} ${WRKSRC}/statsite ${STAGEDIR}/${PREFIX}/bin/
+
+.include <bsd.port.mk>
diff --git a/net-mgmt/statsite/distinfo b/net-mgmt/statsite/distinfo
new file mode 100644
index 000000000000..c4b4894e5858
--- /dev/null
+++ b/net-mgmt/statsite/distinfo
@@ -0,0 +1,2 @@
+SHA256 (v0.6.5.tar.gz) = 8d582d654d76045b8199075e0a1f4a7173b61977120ca9299453136593bfb0a3
+SIZE (v0.6.5.tar.gz) = 1169883
diff --git a/net-mgmt/statsite/files/patch-src_networking.c b/net-mgmt/statsite/files/patch-src_networking.c
new file mode 100644
index 000000000000..46319bc18ab4
--- /dev/null
+++ b/net-mgmt/statsite/files/patch-src_networking.c
@@ -0,0 +1,14 @@
+--- src/networking.c.orig 2015-01-14 05:12:08 UTC
++++ src/networking.c
+@@ -1,9 +1,9 @@
+ #include <arpa/inet.h>
+ #include <fcntl.h>
+-#include <netinet/in.h>
+-#include <netinet/tcp.h>
+ #include <sys/socket.h>
+ #include <sys/types.h>
++#include <netinet/in.h>
++#include <netinet/tcp.h>
+ #include <sys/uio.h>
+ #include <syslog.h>
+ #include <unistd.h>
diff --git a/net-mgmt/statsite/pkg-descr b/net-mgmt/statsite/pkg-descr
new file mode 100644
index 000000000000..921a1f5b72d0
--- /dev/null
+++ b/net-mgmt/statsite/pkg-descr
@@ -0,0 +1,6 @@
+Statsite is a metrics aggregation server.
+
+Statsite is based on Etsy's StatsD, https://github.com/etsy/statsd,
+wire compatible and implemented in C.
+
+WWW: https://github.com/armon/statsite