aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2003-06-28 02:35:31 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2003-06-28 02:35:31 +0000
commit7389edd51c4f18edb4bd6a01716e49c27f051feb (patch)
tree41193f9c1e4eaa1d9151618ac4ee2331a3a89d8e
parente85a6a23ae9995fd3a6a9cc4645ee235ff8f1685 (diff)
downloadports-7389edd51c4f18edb4bd6a01716e49c27f051feb.tar.gz
ports-7389edd51c4f18edb4bd6a01716e49c27f051feb.zip
Notes
-rw-r--r--devel/anjuta-devel/Makefile3
-rw-r--r--devel/anjuta-devel/distinfo2
-rw-r--r--devel/anjuta-devel/files/patch-configure6
-rw-r--r--devel/anjuta-devel/files/patch-src_getline.c80
-rw-r--r--devel/anjuta-devel/pkg-plist30
5 files changed, 9 insertions, 112 deletions
diff --git a/devel/anjuta-devel/Makefile b/devel/anjuta-devel/Makefile
index befea91f817a..965bbecee4ea 100644
--- a/devel/anjuta-devel/Makefile
+++ b/devel/anjuta-devel/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= anjuta
-PORTVERSION= 1.1.1
-PORTREVISION= 3
+PORTVERSION= 1.1.97
CATEGORIES= devel gnome
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= anjuta
diff --git a/devel/anjuta-devel/distinfo b/devel/anjuta-devel/distinfo
index abc0c36d12dc..a97add2137f5 100644
--- a/devel/anjuta-devel/distinfo
+++ b/devel/anjuta-devel/distinfo
@@ -1 +1 @@
-MD5 (anjuta-1.1.1.tar.gz) = 377ae3ad98242f50970da985b484eb15
+MD5 (anjuta-1.1.97.tar.gz) = fc938d304f29f62353ab5fdf48c93685
diff --git a/devel/anjuta-devel/files/patch-configure b/devel/anjuta-devel/files/patch-configure
index 07c1d452624c..18957041874d 100644
--- a/devel/anjuta-devel/files/patch-configure
+++ b/devel/anjuta-devel/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig Thu May 8 13:51:57 2003
-+++ configure Wed May 14 14:18:35 2003
-@@ -13335,11 +13335,11 @@
+--- configure.orig Thu Jun 26 06:50:27 2003
++++ configure Fri Jun 27 20:02:38 2003
+@@ -12994,11 +12995,11 @@
packageprefix=${prefix}
fi
diff --git a/devel/anjuta-devel/files/patch-src_getline.c b/devel/anjuta-devel/files/patch-src_getline.c
deleted file mode 100644
index 847ab8d9e82e..000000000000
--- a/devel/anjuta-devel/files/patch-src_getline.c
+++ /dev/null
@@ -1,80 +0,0 @@
---- src/getline.c.orig Tue Mar 25 14:58:33 2003
-+++ src/getline.c Sun May 18 14:45:40 2003
-@@ -1,5 +1,5 @@
- /*
-- * getline.c Copyright (C) 2003 Michael Tindal
-+ * getline.c Copyright (C) 2003 Alexander Nedotsukov
- *
- * This program is free software; you can redistribute it and/or modify it
- * under the terms of the GNU General Public License as published by the Free
-@@ -20,35 +20,48 @@
- #include <stdio.h>
- #include <string.h>
- #include <stdlib.h>
-+#include <errno.h>
-
--int getline (char** line, int* size, int fd)
-+/* GNU libc getline() compatibility */
-+
-+int
-+getline(char** line, size_t* size, FILE* fp)
- {
-- int len, res;
-- short brk = 0;
-- char* buf = malloc(2096);
-- char buf2[1];
--
-- strcpy (buf, "");
-+ static const size_t line_grow_by = 80; /* in most texts line fits console */
-+ int ch;
-+ size_t i;
-
-- while (!brk)
-- {
-- if ((res = read(fd, buf2, 1)) < 0)
-- return -1;
-- if (res != 0) // check for end-of-line
-- strcat(buf, buf2);
-- if (buf2[0] == '\n' || res == 0)
-- brk = 1;
-+ if (line == NULL || size == NULL || fp == NULL) { /* illegal call */
-+ errno = EINVAL;
-+ return -1;
- }
--
-- if (*line == NULL)
-- {
-- *line = (char*)malloc(strlen(buf));
-+ if (*line == NULL && *size) { /* logically incorrect */
-+ errno = EINVAL;
-+ return -1;
-+ }
-+
-+ i = 0;
-+ while (1) {
-+ ch = fgetc(fp);
-+ if (ch == EOF)
-+ break;
-+ /* ensure bufer still large enough for ch and trailing null */
-+ if ((*size - i) <= 1) {
-+ *line = (char*)realloc(*line, *size += line_grow_by);
-+ if (*line == NULL) {
-+ errno = ENOMEM;
-+ return -1;
-+ }
-+ }
-+ *(*line + i++) = (char)ch;
-+ if (ch == '\n')
-+ break;
- }
-
-- strcpy(*line, buf);
-- *size = strlen(*line);
-+ *(*line + i) = 0;
-
-- return *size;
-+ return ferror(fp) ? -1 : i;
- }
-
- #endif
-+
diff --git a/devel/anjuta-devel/pkg-plist b/devel/anjuta-devel/pkg-plist
index f2c374a38b7a..86e052e9ab48 100644
--- a/devel/anjuta-devel/pkg-plist
+++ b/devel/anjuta-devel/pkg-plist
@@ -25,8 +25,6 @@ share/gnome/anjuta/glade/applogo.png
share/gnome/anjuta/glade/start-with-import.png
share/gnome/anjuta/glade/start-with-open.png
share/gnome/anjuta/glade/start-with-wizard.png
-share/gnome/anjuta/glade/windows-style-docked.png
-share/gnome/anjuta/glade/windows-style-undocked.png
share/gnome/anjuta/gnome/ChangeLog
share/gnome/anjuta/gnome/Makefile.am
share/gnome/anjuta/gnome/aclocal-include.m4
@@ -82,6 +80,7 @@ share/gnome/anjuta/properties/bullant.properties
share/gnome/anjuta/properties/conf.properties
share/gnome/anjuta/properties/cpp.properties
share/gnome/anjuta/properties/cs.properties
+share/gnome/anjuta/properties/css.properties
share/gnome/anjuta/properties/eiffel.properties
share/gnome/anjuta/properties/fortran.properties
share/gnome/anjuta/properties/html.properties
@@ -121,7 +120,7 @@ share/gnome/anjuta/welcome.txt
%%PORTDOCS%%share/doc/anjuta/ScintillaDoc.html
%%PORTDOCS%%share/doc/anjuta/TODO
share/gnome/anjuta/gdl/glade/layout.glade
-share/gnome/apps/Development/anjuta.desktop
+share/gnome/applications/anjuta.desktop
share/gnome/mime-info/anjuta.mime
share/gnome/pixmaps/anjuta/anjuta_icon.png
share/gnome/pixmaps/anjuta/anjuta_logo.png
@@ -169,12 +168,10 @@ share/gnome/pixmaps/anjuta/breakpoint.xpm
share/gnome/pixmaps/anjuta/build.xpm
share/gnome/pixmaps/anjuta/build_all.xpm
share/gnome/pixmaps/anjuta/calltip.xpm
-share/gnome/pixmaps/anjuta/cfolder.xpm
share/gnome/pixmaps/anjuta/close_file_small.xpm
share/gnome/pixmaps/anjuta/close_project.png
share/gnome/pixmaps/anjuta/compile.xpm
share/gnome/pixmaps/anjuta/configure.xpm
-share/gnome/pixmaps/anjuta/console.xpm
share/gnome/pixmaps/anjuta/continue.xpm
share/gnome/pixmaps/anjuta/debug.xpm
share/gnome/pixmaps/anjuta/debug_stop.xpm
@@ -183,18 +180,6 @@ share/gnome/pixmaps/anjuta/error-next-16.png
share/gnome/pixmaps/anjuta/error-next.png
share/gnome/pixmaps/anjuta/error-prev-16.png
share/gnome/pixmaps/anjuta/error-prev.png
-share/gnome/pixmaps/anjuta/file_c.png
-share/gnome/pixmaps/anjuta/file_core.png
-share/gnome/pixmaps/anjuta/file_cpp.png
-share/gnome/pixmaps/anjuta/file_exec.png
-share/gnome/pixmaps/anjuta/file_file.png
-share/gnome/pixmaps/anjuta/file_h.png
-share/gnome/pixmaps/anjuta/file_html.png
-share/gnome/pixmaps/anjuta/file_i18n.png
-share/gnome/pixmaps/anjuta/file_icon.png
-share/gnome/pixmaps/anjuta/file_pix.png
-share/gnome/pixmaps/anjuta/file_text.png
-share/gnome/pixmaps/anjuta/file_unknown.png
share/gnome/pixmaps/anjuta/fold_close.xpm
share/gnome/pixmaps/anjuta/fold_open.xpm
share/gnome/pixmaps/anjuta/fold_toggle.xpm
@@ -209,8 +194,6 @@ share/gnome/pixmaps/anjuta/indent_inc.xpm
share/gnome/pixmaps/anjuta/indent_set.xpm
share/gnome/pixmaps/anjuta/inspect.xpm
share/gnome/pixmaps/anjuta/interrupt.xpm
-share/gnome/pixmaps/anjuta/ledgreen.xpm
-share/gnome/pixmaps/anjuta/ledred.xpm
share/gnome/pixmaps/anjuta/madeinanjuta.xcf
share/gnome/pixmaps/anjuta/messages.xpm
share/gnome/pixmaps/anjuta/mini-modules.xpm
@@ -222,23 +205,18 @@ share/gnome/pixmaps/anjuta/mini_find.xpm
share/gnome/pixmaps/anjuta/mini_locals.xpm
share/gnome/pixmaps/anjuta/mini_term.xpm
share/gnome/pixmaps/anjuta/new_folder.xpm
-share/gnome/pixmaps/anjuta/ofolder.xpm
share/gnome/pixmaps/anjuta/open_project.png
share/gnome/pixmaps/anjuta/password.png
share/gnome/pixmaps/anjuta/pointer.xpm
share/gnome/pixmaps/anjuta/preferences-build.png
share/gnome/pixmaps/anjuta/preferences-cvs.png
share/gnome/pixmaps/anjuta/preferences-editor.png
+share/gnome/pixmaps/anjuta/preferences-encodings.png
share/gnome/pixmaps/anjuta/preferences-general.png
share/gnome/pixmaps/anjuta/preferences-indentation.png
share/gnome/pixmaps/anjuta/preferences-messages.png
share/gnome/pixmaps/anjuta/preferences-print.png
share/gnome/pixmaps/anjuta/preferences-terminal.png
-share/gnome/pixmaps/anjuta/print_color.xpm
-share/gnome/pixmaps/anjuta/print_landscape.xpm
-share/gnome/pixmaps/anjuta/print_layout.xpm
-share/gnome/pixmaps/anjuta/print_nocolor.xpm
-share/gnome/pixmaps/anjuta/print_portrait.xpm
share/gnome/pixmaps/anjuta/project.xpm
share/gnome/pixmaps/anjuta/registers.xpm
share/gnome/pixmaps/anjuta/run_to_cursor.xpm
@@ -276,6 +254,7 @@ share/locale/fr/LC_MESSAGES/anjuta.mo
share/locale/hi/LC_MESSAGES/anjuta.mo
share/locale/it/LC_MESSAGES/anjuta.mo
share/locale/ja/LC_MESSAGES/anjuta.mo
+share/locale/ml/LC_MESSAGES/anjuta.mo
share/locale/nl/LC_MESSAGES/anjuta.mo
share/locale/no/LC_MESSAGES/anjuta.mo
share/locale/pl/LC_MESSAGES/anjuta.mo
@@ -284,7 +263,6 @@ share/locale/pt_BR/LC_MESSAGES/anjuta.mo
share/locale/ru/LC_MESSAGES/anjuta.mo
share/locale/sk/LC_MESSAGES/anjuta.mo
share/locale/sv/LC_MESSAGES/anjuta.mo
-share/locale/ta/LC_MESSAGES/anjuta.mo
share/locale/tr/LC_MESSAGES/anjuta.mo
share/locale/uk/LC_MESSAGES/anjuta.mo
share/locale/zh_CN/LC_MESSAGES/anjuta.mo