aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGreg Larkin <glarkin@FreeBSD.org>2010-09-23 21:35:22 +0000
committerGreg Larkin <glarkin@FreeBSD.org>2010-09-23 21:35:22 +0000
commit7657dd846adb6d9defaeabfd42571be4feca79e7 (patch)
tree71781d187a36ed928a905f09b89887d0527a3c70
parente0e9d6908d260186504ef9accb5e3f047d87350e (diff)
downloadports-7657dd846adb6d9defaeabfd42571be4feca79e7.tar.gz
ports-7657dd846adb6d9defaeabfd42571be4feca79e7.zip
Notes
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-subvertpy/Makefile28
-rw-r--r--devel/py-subvertpy/distinfo3
-rw-r--r--devel/py-subvertpy/pkg-descr9
-rw-r--r--devel/py-subvertpy/pkg-plist58
5 files changed, 99 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index d5dd4a0cd56d..7bf24fe4b9d8 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2836,6 +2836,7 @@
SUBDIR += py-sqlcc
SUBDIR += py-statgrab
SUBDIR += py-subversion
+ SUBDIR += py-subvertpy
SUBDIR += py-tables
SUBDIR += py-tconfpy
SUBDIR += py-testgears
diff --git a/devel/py-subvertpy/Makefile b/devel/py-subvertpy/Makefile
new file mode 100644
index 000000000000..f001c7888905
--- /dev/null
+++ b/devel/py-subvertpy/Makefile
@@ -0,0 +1,28 @@
+# Ports collection makefile for: subvertpy
+# Date created: 9 August 2010
+# Whom: Carlo Strub (c-s@c-s.li)
+#
+# $FreeBSD$
+#
+
+PORTNAME= subvertpy
+PORTVERSION= 0.7.3.1
+CATEGORIES= devel
+MASTER_SITES= https://launchpadlibrarian.net/52613338/ \
+ http://samba.org/~jelmer/subvertpy/ \
+ http://www.c-s.li/ports/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= c-s@c-s.li
+COMMENT= Python bindings for subversion
+
+BUILD_DEPENDS+= svn:${PORTSDIR}/devel/subversion
+
+LICENSE= GPLv2
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+USE_PYTHON= 2.4+
+USE_PYDISTUTILS= yes
+PYDISTUTILS_PKGNAME= subvertpy
+
+.include <bsd.port.mk>
diff --git a/devel/py-subvertpy/distinfo b/devel/py-subvertpy/distinfo
new file mode 100644
index 000000000000..c11e9dca14b1
--- /dev/null
+++ b/devel/py-subvertpy/distinfo
@@ -0,0 +1,3 @@
+MD5 (subvertpy-0.7.3.1.tar.gz) = 33b80a6a00cdbbb768995dc067cfcc70
+SHA256 (subvertpy-0.7.3.1.tar.gz) = cc4516889697a70684dda23b5a519ee986bfec826e40789708584a5bc5b4de7c
+SIZE (subvertpy-0.7.3.1.tar.gz) = 84238
diff --git a/devel/py-subvertpy/pkg-descr b/devel/py-subvertpy/pkg-descr
new file mode 100644
index 000000000000..32058339f5f3
--- /dev/null
+++ b/devel/py-subvertpy/pkg-descr
@@ -0,0 +1,9 @@
+This is an implementation of Python bindings for the Subversion
+version control system, aiming to be complete, fast and feel native
+to Python programmers.
+
+Bindings are provided for the working copy, client, delta, remote
+access and repository APIs. A hookable server side implementation
+of the custom Subversion protocol (svn_ra) is also provided.
+
+www: https://launchpad.net/subvertpy
diff --git a/devel/py-subvertpy/pkg-plist b/devel/py-subvertpy/pkg-plist
new file mode 100644
index 000000000000..4310f7e01512
--- /dev/null
+++ b/devel/py-subvertpy/pkg-plist
@@ -0,0 +1,58 @@
+bin/subvertpy-fast-export
+%%PYTHON_SITELIBDIR%%/subvertpy/__init__.py
+%%PYTHON_SITELIBDIR%%/subvertpy/__init__.pyc
+%%PYTHON_SITELIBDIR%%/subvertpy/__init__.pyo
+%%PYTHON_SITELIBDIR%%/subvertpy/_ra.so
+%%PYTHON_SITELIBDIR%%/subvertpy/client.so
+%%PYTHON_SITELIBDIR%%/subvertpy/delta.py
+%%PYTHON_SITELIBDIR%%/subvertpy/delta.pyc
+%%PYTHON_SITELIBDIR%%/subvertpy/delta.pyo
+%%PYTHON_SITELIBDIR%%/subvertpy/marshall.py
+%%PYTHON_SITELIBDIR%%/subvertpy/marshall.pyc
+%%PYTHON_SITELIBDIR%%/subvertpy/marshall.pyo
+%%PYTHON_SITELIBDIR%%/subvertpy/properties.py
+%%PYTHON_SITELIBDIR%%/subvertpy/properties.pyc
+%%PYTHON_SITELIBDIR%%/subvertpy/properties.pyo
+%%PYTHON_SITELIBDIR%%/subvertpy/ra.py
+%%PYTHON_SITELIBDIR%%/subvertpy/ra.pyc
+%%PYTHON_SITELIBDIR%%/subvertpy/ra.pyo
+%%PYTHON_SITELIBDIR%%/subvertpy/ra_svn.py
+%%PYTHON_SITELIBDIR%%/subvertpy/ra_svn.pyc
+%%PYTHON_SITELIBDIR%%/subvertpy/ra_svn.pyo
+%%PYTHON_SITELIBDIR%%/subvertpy/repos.so
+%%PYTHON_SITELIBDIR%%/subvertpy/server.py
+%%PYTHON_SITELIBDIR%%/subvertpy/server.pyc
+%%PYTHON_SITELIBDIR%%/subvertpy/server.pyo
+%%PYTHON_SITELIBDIR%%/subvertpy/tests/__init__.py
+%%PYTHON_SITELIBDIR%%/subvertpy/tests/__init__.pyc
+%%PYTHON_SITELIBDIR%%/subvertpy/tests/__init__.pyo
+%%PYTHON_SITELIBDIR%%/subvertpy/tests/test_client.py
+%%PYTHON_SITELIBDIR%%/subvertpy/tests/test_client.pyc
+%%PYTHON_SITELIBDIR%%/subvertpy/tests/test_client.pyo
+%%PYTHON_SITELIBDIR%%/subvertpy/tests/test_core.py
+%%PYTHON_SITELIBDIR%%/subvertpy/tests/test_core.pyc
+%%PYTHON_SITELIBDIR%%/subvertpy/tests/test_core.pyo
+%%PYTHON_SITELIBDIR%%/subvertpy/tests/test_delta.py
+%%PYTHON_SITELIBDIR%%/subvertpy/tests/test_delta.pyc
+%%PYTHON_SITELIBDIR%%/subvertpy/tests/test_delta.pyo
+%%PYTHON_SITELIBDIR%%/subvertpy/tests/test_marshall.py
+%%PYTHON_SITELIBDIR%%/subvertpy/tests/test_marshall.pyc
+%%PYTHON_SITELIBDIR%%/subvertpy/tests/test_marshall.pyo
+%%PYTHON_SITELIBDIR%%/subvertpy/tests/test_properties.py
+%%PYTHON_SITELIBDIR%%/subvertpy/tests/test_properties.pyc
+%%PYTHON_SITELIBDIR%%/subvertpy/tests/test_properties.pyo
+%%PYTHON_SITELIBDIR%%/subvertpy/tests/test_ra.py
+%%PYTHON_SITELIBDIR%%/subvertpy/tests/test_ra.pyc
+%%PYTHON_SITELIBDIR%%/subvertpy/tests/test_ra.pyo
+%%PYTHON_SITELIBDIR%%/subvertpy/tests/test_repos.py
+%%PYTHON_SITELIBDIR%%/subvertpy/tests/test_repos.pyc
+%%PYTHON_SITELIBDIR%%/subvertpy/tests/test_repos.pyo
+%%PYTHON_SITELIBDIR%%/subvertpy/tests/test_server.py
+%%PYTHON_SITELIBDIR%%/subvertpy/tests/test_server.pyc
+%%PYTHON_SITELIBDIR%%/subvertpy/tests/test_server.pyo
+%%PYTHON_SITELIBDIR%%/subvertpy/tests/test_wc.py
+%%PYTHON_SITELIBDIR%%/subvertpy/tests/test_wc.pyc
+%%PYTHON_SITELIBDIR%%/subvertpy/tests/test_wc.pyo
+%%PYTHON_SITELIBDIR%%/subvertpy/wc.so
+@dirrmtry %%PYTHON_SITELIBDIR%%/subvertpy/tests
+@dirrmtry %%PYTHON_SITELIBDIR%%/subvertpy