aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2007-01-28 04:54:25 +0000
committerRong-En Fan <rafan@FreeBSD.org>2007-01-28 04:54:25 +0000
commit8de095b25dde3dc7aa092ba570f6c49db3a99ca6 (patch)
tree21a69c2f81da833446a6ba0d12c2d3aa1edd5011
parent3be4f1347e0e73fb3184399626b7e57059d7b5c2 (diff)
downloadports-8de095b25dde3dc7aa092ba570f6c49db3a99ca6.tar.gz
ports-8de095b25dde3dc7aa092ba570f6c49db3a99ca6.zip
Notes
-rw-r--r--x11-clocks/Makefile1
-rw-r--r--x11-clocks/cairo-clock/Makefile55
-rw-r--r--x11-clocks/cairo-clock/distinfo3
-rw-r--r--x11-clocks/cairo-clock/pkg-descr6
-rw-r--r--x11-clocks/cairo-clock/pkg-plist237
5 files changed, 302 insertions, 0 deletions
diff --git a/x11-clocks/Makefile b/x11-clocks/Makefile
index 2e5c83c5580c..59664551c8a2 100644
--- a/x11-clocks/Makefile
+++ b/x11-clocks/Makefile
@@ -16,6 +16,7 @@
SUBDIR += bdesktopclock
SUBDIR += bmp-alarm
SUBDIR += buici-clock
+ SUBDIR += cairo-clock
SUBDIR += dclock
SUBDIR += emiclock
SUBDIR += eyeclock
diff --git a/x11-clocks/cairo-clock/Makefile b/x11-clocks/cairo-clock/Makefile
new file mode 100644
index 000000000000..58f14ceb3dcb
--- /dev/null
+++ b/x11-clocks/cairo-clock/Makefile
@@ -0,0 +1,55 @@
+# New ports collection makefile for: cairo-clock
+# Date created: 2007/01/16
+# Whom: chinsan
+#
+# $FreeBSD$
+#
+
+PORTNAME= cairo-clock
+PORTVERSION= 0.3.2
+CATEGORIES= x11-clocks net gnome
+MASTER_SITES= http://macslow.thepimp.net/projects/cairo-clock/
+
+MAINTAINER= chinsan@FreeBSD.org
+COMMENT= MacSlow's Cairo-Clock
+
+USE_BZIP2= yes
+USE_GNOME= gtk20 intlhack gnomehack libglade2 librsvg2
+USE_GCC= 3.3+
+USE_GMAKE= yes
+USE_ICONV= yes
+GNU_CONFIGURE= yes
+USE_XLIB= yes
+USE_LDCONFIG= yes
+GZIP_CMD?= /usr/bin/gzip
+MAN1= cairo-clock.1
+
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+.else
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
+post-patch:
+ @${GZIP_CMD} -d ${WRKSRC}/man/cairo-clock.1.gz
+ @${REINPLACE_CMD} -e 's,.gz,,; s,datadir)\/man,prefix)\/man,' \
+ ${WRKSRC}/man/Makefile.in
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for file in README NEWS AUTHORS TODO
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+.endfor
+.endif
+ @${ECHO} ""
+ @${ECHO} "************************************************************************"
+ @${ECHO} " Please note that you need composite extension enabled in X.org or Xgl. "
+ @${ECHO} "************************************************************************"
+
+.include <bsd.port.mk>
diff --git a/x11-clocks/cairo-clock/distinfo b/x11-clocks/cairo-clock/distinfo
new file mode 100644
index 000000000000..54d99dab4bb9
--- /dev/null
+++ b/x11-clocks/cairo-clock/distinfo
@@ -0,0 +1,3 @@
+MD5 (cairo-clock-0.3.2.tar.bz2) = 6af19fc0df603f92e4f99c3bb5fb78cb
+SHA256 (cairo-clock-0.3.2.tar.bz2) = 226f84eb2ea1f609fbf65dda181015417c4f55e20a4e8d11c9f0d9c71e7bbf06
+SIZE (cairo-clock-0.3.2.tar.bz2) = 718103
diff --git a/x11-clocks/cairo-clock/pkg-descr b/x11-clocks/cairo-clock/pkg-descr
new file mode 100644
index 000000000000..0dcce3d4c195
--- /dev/null
+++ b/x11-clocks/cairo-clock/pkg-descr
@@ -0,0 +1,6 @@
+It is an analog clock displaying the system-time.
+It leverages the new visual features offered by Xorg 6.9/7.0 in combination
+with a compositing-manager (e.g. like xcompmgr), gtk+ 2.8.x, cairo 1.0.2 and
+librsvg 2.13.93 to produce a time-display with pretty-pixels.
+
+WWW: http://macslow.thepimp.net/?page_id=23
diff --git a/x11-clocks/cairo-clock/pkg-plist b/x11-clocks/cairo-clock/pkg-plist
new file mode 100644
index 000000000000..f1394caa3776
--- /dev/null
+++ b/x11-clocks/cairo-clock/pkg-plist
@@ -0,0 +1,237 @@
+bin/cairo-clock
+%%DATADIR%%/glade/cairo-clock.glade
+%%DATADIR%%/themes/antique/clock-drop-shadow.svg
+%%DATADIR%%/themes/antique/clock-face-shadow.svg
+%%DATADIR%%/themes/antique/clock-face.svg
+%%DATADIR%%/themes/antique/clock-frame.svg
+%%DATADIR%%/themes/antique/clock-glass.svg
+%%DATADIR%%/themes/antique/clock-hour-hand-shadow.svg
+%%DATADIR%%/themes/antique/clock-hour-hand.svg
+%%DATADIR%%/themes/antique/clock-marks.svg
+%%DATADIR%%/themes/antique/clock-minute-hand-shadow.svg
+%%DATADIR%%/themes/antique/clock-minute-hand.svg
+%%DATADIR%%/themes/antique/clock-second-hand-shadow.svg
+%%DATADIR%%/themes/antique/clock-second-hand.svg
+%%DATADIR%%/themes/default/clock-drop-shadow.svg
+%%DATADIR%%/themes/default/clock-face-shadow.svg
+%%DATADIR%%/themes/default/clock-face.svg
+%%DATADIR%%/themes/default/clock-frame.svg
+%%DATADIR%%/themes/default/clock-glass.svg
+%%DATADIR%%/themes/default/clock-hour-hand-shadow.svg
+%%DATADIR%%/themes/default/clock-hour-hand.svg
+%%DATADIR%%/themes/default/clock-marks.svg
+%%DATADIR%%/themes/default/clock-minute-hand-shadow.svg
+%%DATADIR%%/themes/default/clock-minute-hand.svg
+%%DATADIR%%/themes/default/clock-second-hand-shadow.svg
+%%DATADIR%%/themes/default/clock-second-hand.svg
+%%DATADIR%%/themes/default-24/clock-drop-shadow.svg
+%%DATADIR%%/themes/default-24/clock-face-shadow.svg
+%%DATADIR%%/themes/default-24/clock-face.svg
+%%DATADIR%%/themes/default-24/clock-frame.svg
+%%DATADIR%%/themes/default-24/clock-glass.svg
+%%DATADIR%%/themes/default-24/clock-hour-hand-shadow.svg
+%%DATADIR%%/themes/default-24/clock-hour-hand.svg
+%%DATADIR%%/themes/default-24/clock-marks.svg
+%%DATADIR%%/themes/default-24/clock-minute-hand-shadow.svg
+%%DATADIR%%/themes/default-24/clock-minute-hand.svg
+%%DATADIR%%/themes/default-24/clock-second-hand-shadow.svg
+%%DATADIR%%/themes/default-24/clock-second-hand.svg
+%%DATADIR%%/themes/fdo/clock-drop-shadow.svg
+%%DATADIR%%/themes/fdo/clock-face-shadow.svg
+%%DATADIR%%/themes/fdo/clock-face.svg
+%%DATADIR%%/themes/fdo/clock-frame.svg
+%%DATADIR%%/themes/fdo/clock-glass.svg
+%%DATADIR%%/themes/fdo/clock-hour-hand-shadow.svg
+%%DATADIR%%/themes/fdo/clock-hour-hand.svg
+%%DATADIR%%/themes/fdo/clock-marks.svg
+%%DATADIR%%/themes/fdo/clock-minute-hand-shadow.svg
+%%DATADIR%%/themes/fdo/clock-minute-hand.svg
+%%DATADIR%%/themes/fdo/clock-second-hand-shadow.svg
+%%DATADIR%%/themes/fdo/clock-second-hand.svg
+%%DATADIR%%/themes/funky/clock-drop-shadow.svg
+%%DATADIR%%/themes/funky/clock-face-shadow.svg
+%%DATADIR%%/themes/funky/clock-face.svg
+%%DATADIR%%/themes/funky/clock-frame.svg
+%%DATADIR%%/themes/funky/clock-glass.svg
+%%DATADIR%%/themes/funky/clock-hour-hand-shadow.svg
+%%DATADIR%%/themes/funky/clock-hour-hand.svg
+%%DATADIR%%/themes/funky/clock-marks.svg
+%%DATADIR%%/themes/funky/clock-minute-hand-shadow.svg
+%%DATADIR%%/themes/funky/clock-minute-hand.svg
+%%DATADIR%%/themes/funky/clock-second-hand-shadow.svg
+%%DATADIR%%/themes/funky/clock-second-hand.svg
+%%DATADIR%%/themes/glassy/clock-drop-shadow.svg
+%%DATADIR%%/themes/glassy/clock-face-shadow.svg
+%%DATADIR%%/themes/glassy/clock-face.svg
+%%DATADIR%%/themes/glassy/clock-frame.svg
+%%DATADIR%%/themes/glassy/clock-glass.svg
+%%DATADIR%%/themes/glassy/clock-hour-hand-shadow.svg
+%%DATADIR%%/themes/glassy/clock-hour-hand.svg
+%%DATADIR%%/themes/glassy/clock-marks.svg
+%%DATADIR%%/themes/glassy/clock-minute-hand-shadow.svg
+%%DATADIR%%/themes/glassy/clock-minute-hand.svg
+%%DATADIR%%/themes/glassy/clock-second-hand-shadow.svg
+%%DATADIR%%/themes/glassy/clock-second-hand.svg
+%%DATADIR%%/themes/ipulse/clock-drop-shadow.svg
+%%DATADIR%%/themes/ipulse/clock-face-shadow.svg
+%%DATADIR%%/themes/ipulse/clock-face.svg
+%%DATADIR%%/themes/ipulse/clock-frame.svg
+%%DATADIR%%/themes/ipulse/clock-glass.svg
+%%DATADIR%%/themes/ipulse/clock-hour-hand-shadow.svg
+%%DATADIR%%/themes/ipulse/clock-hour-hand.svg
+%%DATADIR%%/themes/ipulse/clock-marks.svg
+%%DATADIR%%/themes/ipulse/clock-minute-hand-shadow.svg
+%%DATADIR%%/themes/ipulse/clock-minute-hand.svg
+%%DATADIR%%/themes/ipulse/clock-second-hand-shadow.svg
+%%DATADIR%%/themes/ipulse/clock-second-hand.svg
+%%DATADIR%%/themes/ipulse-24/clock-drop-shadow.svg
+%%DATADIR%%/themes/ipulse-24/clock-face-shadow.svg
+%%DATADIR%%/themes/ipulse-24/clock-face.svg
+%%DATADIR%%/themes/ipulse-24/clock-frame.svg
+%%DATADIR%%/themes/ipulse-24/clock-glass.svg
+%%DATADIR%%/themes/ipulse-24/clock-hour-hand-shadow.svg
+%%DATADIR%%/themes/ipulse-24/clock-hour-hand.svg
+%%DATADIR%%/themes/ipulse-24/clock-marks.svg
+%%DATADIR%%/themes/ipulse-24/clock-minute-hand-shadow.svg
+%%DATADIR%%/themes/ipulse-24/clock-minute-hand.svg
+%%DATADIR%%/themes/ipulse-24/clock-second-hand-shadow.svg
+%%DATADIR%%/themes/ipulse-24/clock-second-hand.svg
+%%DATADIR%%/themes/quartz-24/clock-drop-shadow.svg
+%%DATADIR%%/themes/quartz-24/clock-face-shadow.svg
+%%DATADIR%%/themes/quartz-24/clock-face.svg
+%%DATADIR%%/themes/quartz-24/clock-frame.svg
+%%DATADIR%%/themes/quartz-24/clock-glass.svg
+%%DATADIR%%/themes/quartz-24/clock-hour-hand-shadow.svg
+%%DATADIR%%/themes/quartz-24/clock-hour-hand.svg
+%%DATADIR%%/themes/quartz-24/clock-marks.svg
+%%DATADIR%%/themes/quartz-24/clock-minute-hand-shadow.svg
+%%DATADIR%%/themes/quartz-24/clock-minute-hand.svg
+%%DATADIR%%/themes/quartz-24/clock-second-hand-shadow.svg
+%%DATADIR%%/themes/quartz-24/clock-second-hand.svg
+%%DATADIR%%/themes/radium/clock-drop-shadow.svg
+%%DATADIR%%/themes/radium/clock-face-shadow.svg
+%%DATADIR%%/themes/radium/clock-face.svg
+%%DATADIR%%/themes/radium/clock-frame.svg
+%%DATADIR%%/themes/radium/clock-glass.svg
+%%DATADIR%%/themes/radium/clock-hour-hand-shadow.svg
+%%DATADIR%%/themes/radium/clock-hour-hand.svg
+%%DATADIR%%/themes/radium/clock-marks.svg
+%%DATADIR%%/themes/radium/clock-minute-hand-shadow.svg
+%%DATADIR%%/themes/radium/clock-minute-hand.svg
+%%DATADIR%%/themes/radium/clock-second-hand-shadow.svg
+%%DATADIR%%/themes/radium/clock-second-hand.svg
+%%DATADIR%%/themes/radium-24/clock-drop-shadow.svg
+%%DATADIR%%/themes/radium-24/clock-face-shadow.svg
+%%DATADIR%%/themes/radium-24/clock-face.svg
+%%DATADIR%%/themes/radium-24/clock-frame.svg
+%%DATADIR%%/themes/radium-24/clock-glass.svg
+%%DATADIR%%/themes/radium-24/clock-hour-hand-shadow.svg
+%%DATADIR%%/themes/radium-24/clock-hour-hand.svg
+%%DATADIR%%/themes/radium-24/clock-marks.svg
+%%DATADIR%%/themes/radium-24/clock-minute-hand-shadow.svg
+%%DATADIR%%/themes/radium-24/clock-minute-hand.svg
+%%DATADIR%%/themes/radium-24/clock-second-hand-shadow.svg
+%%DATADIR%%/themes/radium-24/clock-second-hand.svg
+%%DATADIR%%/themes/silvia/clock-drop-shadow.svg
+%%DATADIR%%/themes/silvia/clock-face-shadow.svg
+%%DATADIR%%/themes/silvia/clock-face.svg
+%%DATADIR%%/themes/silvia/clock-frame.svg
+%%DATADIR%%/themes/silvia/clock-glass.svg
+%%DATADIR%%/themes/silvia/clock-hour-hand-shadow.svg
+%%DATADIR%%/themes/silvia/clock-hour-hand.svg
+%%DATADIR%%/themes/silvia/clock-marks.svg
+%%DATADIR%%/themes/silvia/clock-minute-hand-shadow.svg
+%%DATADIR%%/themes/silvia/clock-minute-hand.svg
+%%DATADIR%%/themes/silvia/clock-second-hand-shadow.svg
+%%DATADIR%%/themes/silvia/clock-second-hand.svg
+%%DATADIR%%/themes/silvia-24/clock-drop-shadow.svg
+%%DATADIR%%/themes/silvia-24/clock-face-shadow.svg
+%%DATADIR%%/themes/silvia-24/clock-face.svg
+%%DATADIR%%/themes/silvia-24/clock-frame.svg
+%%DATADIR%%/themes/silvia-24/clock-glass.svg
+%%DATADIR%%/themes/silvia-24/clock-hour-hand-shadow.svg
+%%DATADIR%%/themes/silvia-24/clock-hour-hand.svg
+%%DATADIR%%/themes/silvia-24/clock-marks.svg
+%%DATADIR%%/themes/silvia-24/clock-minute-hand-shadow.svg
+%%DATADIR%%/themes/silvia-24/clock-minute-hand.svg
+%%DATADIR%%/themes/silvia-24/clock-second-hand-shadow.svg
+%%DATADIR%%/themes/silvia-24/clock-second-hand.svg
+%%DATADIR%%/themes/simple/clock-drop-shadow.svg
+%%DATADIR%%/themes/simple/clock-face-shadow.svg
+%%DATADIR%%/themes/simple/clock-face.svg
+%%DATADIR%%/themes/simple/clock-frame.svg
+%%DATADIR%%/themes/simple/clock-glass.svg
+%%DATADIR%%/themes/simple/clock-hour-hand-shadow.svg
+%%DATADIR%%/themes/simple/clock-hour-hand.svg
+%%DATADIR%%/themes/simple/clock-marks.svg
+%%DATADIR%%/themes/simple/clock-minute-hand-shadow.svg
+%%DATADIR%%/themes/simple/clock-minute-hand.svg
+%%DATADIR%%/themes/simple/clock-second-hand-shadow.svg
+%%DATADIR%%/themes/simple/clock-second-hand.svg
+%%DATADIR%%/themes/simple-24/clock-drop-shadow.svg
+%%DATADIR%%/themes/simple-24/clock-face-shadow.svg
+%%DATADIR%%/themes/simple-24/clock-face.svg
+%%DATADIR%%/themes/simple-24/clock-frame.svg
+%%DATADIR%%/themes/simple-24/clock-glass.svg
+%%DATADIR%%/themes/simple-24/clock-hour-hand-shadow.svg
+%%DATADIR%%/themes/simple-24/clock-hour-hand.svg
+%%DATADIR%%/themes/simple-24/clock-marks.svg
+%%DATADIR%%/themes/simple-24/clock-minute-hand-shadow.svg
+%%DATADIR%%/themes/simple-24/clock-minute-hand.svg
+%%DATADIR%%/themes/simple-24/clock-second-hand-shadow.svg
+%%DATADIR%%/themes/simple-24/clock-second-hand.svg
+%%DATADIR%%/themes/tango/clock-drop-shadow.svg
+%%DATADIR%%/themes/tango/clock-face-shadow.svg
+%%DATADIR%%/themes/tango/clock-face.svg
+%%DATADIR%%/themes/tango/clock-frame.svg
+%%DATADIR%%/themes/tango/clock-glass.svg
+%%DATADIR%%/themes/tango/clock-hour-hand-shadow.svg
+%%DATADIR%%/themes/tango/clock-hour-hand.svg
+%%DATADIR%%/themes/tango/clock-marks.svg
+%%DATADIR%%/themes/tango/clock-minute-hand-shadow.svg
+%%DATADIR%%/themes/tango/clock-minute-hand.svg
+%%DATADIR%%/themes/tango/clock-second-hand-shadow.svg
+%%DATADIR%%/themes/tango/clock-second-hand.svg
+%%DATADIR%%/themes/zen/clock-drop-shadow.svg
+%%DATADIR%%/themes/zen/clock-face-shadow.svg
+%%DATADIR%%/themes/zen/clock-face.svg
+%%DATADIR%%/themes/zen/clock-frame.svg
+%%DATADIR%%/themes/zen/clock-glass.svg
+%%DATADIR%%/themes/zen/clock-hour-hand-shadow.svg
+%%DATADIR%%/themes/zen/clock-hour-hand.svg
+%%DATADIR%%/themes/zen/clock-marks.svg
+%%DATADIR%%/themes/zen/clock-minute-hand-shadow.svg
+%%DATADIR%%/themes/zen/clock-minute-hand.svg
+%%DATADIR%%/themes/zen/clock-second-hand-shadow.svg
+%%DATADIR%%/themes/zen/clock-second-hand.svg
+%%DATADIR%%/pixmaps/cairo-clock-logo.png
+%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
+%%PORTDOCS%%%%DOCSDIR%%/NEWS
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/TODO
+share/applications/cairo-clock.desktop
+share/pixmaps/cairo-clock.png
+@dirrmtry share/applications
+@dirrmtry share/pixmaps
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrmtry %%DATADIR%%/themes/zen
+@dirrmtry %%DATADIR%%/themes/tango
+@dirrmtry %%DATADIR%%/themes/simple-24
+@dirrmtry %%DATADIR%%/themes/simple
+@dirrmtry %%DATADIR%%/themes/silvia-24
+@dirrmtry %%DATADIR%%/themes/silvia
+@dirrmtry %%DATADIR%%/themes/radium-24
+@dirrmtry %%DATADIR%%/themes/radium
+@dirrmtry %%DATADIR%%/themes/quartz-24
+@dirrmtry %%DATADIR%%/themes/ipulse-24
+@dirrmtry %%DATADIR%%/themes/ipulse
+@dirrmtry %%DATADIR%%/themes/glassy
+@dirrmtry %%DATADIR%%/themes/funky
+@dirrmtry %%DATADIR%%/themes/fdo
+@dirrmtry %%DATADIR%%/themes/default-24
+@dirrmtry %%DATADIR%%/themes/default
+@dirrmtry %%DATADIR%%/themes/antique
+@dirrmtry %%DATADIR%%/themes
+@dirrmtry %%DATADIR%%/pixmaps
+@dirrmtry %%DATADIR%%/glade
+@dirrmtry %%DATADIR%%