aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-04-13 12:28:23 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-04-13 12:28:23 +0000
commit927c9c2190303cbf488da40b21aa8f687198bb23 (patch)
treeb50875b389c063d1bcadc768e710973b1992efd2
parent2a6d3bd8e2df3f99bd5bc37be426951c272419b9 (diff)
downloadports-927c9c2190303cbf488da40b21aa8f687198bb23.tar.gz
ports-927c9c2190303cbf488da40b21aa8f687198bb23.zip
Notes
-rw-r--r--databases/p5-MLDBM/Makefile13
-rw-r--r--devel/p5-Cache-Mmap/Makefile13
-rw-r--r--devel/p5-ResourcePool/Makefile9
-rw-r--r--devel/p5-Test-Class/Makefile18
-rw-r--r--devel/p5-Test-Differences/Makefile13
-rw-r--r--devel/p5-Test-Differences/pkg-plist1
-rw-r--r--devel/p5-Test-Exception/Makefile9
-rw-r--r--devel/p5-Test-Inline/Makefile11
-rw-r--r--dns/p5-Net-DNS-SEC/Makefile16
-rw-r--r--mail/p5-Net-SMTP-Server/Makefile14
-rw-r--r--net/p5-Net-DNS-SEC/Makefile16
-rw-r--r--net/p5-Net-SNPP/Makefile13
-rw-r--r--security/p5-Crypt-SSLeay/Makefile13
-rw-r--r--www/p5-Apache-ASP/Makefile14
-rw-r--r--www/p5-Apache-Gallery/Makefile9
-rw-r--r--www/p5-CGI-Session/Makefile12
-rw-r--r--www/p5-WWW-Search/Makefile14
17 files changed, 138 insertions, 70 deletions
diff --git a/databases/p5-MLDBM/Makefile b/databases/p5-MLDBM/Makefile
index 1a8216a90f1b..512f10a909b5 100644
--- a/databases/p5-MLDBM/Makefile
+++ b/databases/p5-MLDBM/Makefile
@@ -15,12 +15,19 @@ PKGNAMEPREFIX= p5-
MAINTAINER= erwin@lansing.dk
COMMENT= Store multi-level hash structure in single level tied hash
-BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/FreezeThaw.pm:${PORTSDIR}/devel/p5-FreezeThaw \
- ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/devel/p5-Storable
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/FreezeThaw.pm:${PORTSDIR}/devel/p5-FreezeThaw
+RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
MAN3= MLDBM.3
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+BUILD_DEPENDS+= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/devel/p5-Storable
+RUN_DEPENDS+= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/devel/p5-Storable
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Cache-Mmap/Makefile b/devel/p5-Cache-Mmap/Makefile
index 2e2be1d44796..a741892f5a12 100644
--- a/devel/p5-Cache-Mmap/Makefile
+++ b/devel/p5-Cache-Mmap/Makefile
@@ -15,12 +15,15 @@ PKGNAMEPREFIX= p5-
MAINTAINER= erwin@lansing.dk
COMMENT= Cache::Mmap - Shared data cache using memory mapped files
-BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/devel/p5-Storable
-RUN_DEPENDS= ${BUILD_DEPENDS}
-
PERL_CONFIGURE= yes
-MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN3= Cache::Mmap.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+BUILD_DEPENDS+= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/devel/p5-Storable
+RUN_DEPENDS+= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/devel/p5-Storable
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-ResourcePool/Makefile b/devel/p5-ResourcePool/Makefile
index 86258353db78..f0b43ab98084 100644
--- a/devel/p5-ResourcePool/Makefile
+++ b/devel/p5-ResourcePool/Makefile
@@ -35,4 +35,11 @@ MAN3= ResourcePool.3 \
post-install:
@${CAT} pkg-message
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+BUILD_DEPENDS+= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/devel/p5-Storable
+RUN_DEPENDS+= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/devel/p5-Storable
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Test-Class/Makefile b/devel/p5-Test-Class/Makefile
index 6234484bda29..bb6fc8532592 100644
--- a/devel/p5-Test-Class/Makefile
+++ b/devel/p5-Test-Class/Makefile
@@ -15,18 +15,13 @@ PKGNAMEPREFIX= p5-
MAINTAINER= erwin@lansing.dk
COMMENT= Test::Class - Easily create test classes in an xUnit style
-BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple \
- ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/devel/p5-Storable \
- ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Class/ISA.pm:${PORTSDIR}/devel/p5-Class-ISA \
- ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Attribute/Handlers.pm:${PORTSDIR}/devel/p5-Attribute-Handlers \
- ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Test/Builder/Tester.pm:${PORTSDIR}/devel/p5-Test-Builder-Tester \
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Test/Builder/Tester.pm:${PORTSDIR}/devel/p5-Test-Builder-Tester \
${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Test/Exception.pm:${PORTSDIR}/devel/p5-Test-Exception \
${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Test/Differences.pm:${PORTSDIR}/devel/p5-Test-Differences
RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
-MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN3= Test::Class.3
.include <bsd.port.pre.mk>
@@ -38,4 +33,15 @@ MAN3= Test::Class.3
IGNORE= Port requires perl 5.6.x or later. Install lang/perl5 then try again
.endif
+.if ${PERL_LEVEL} < 500800
+BUILD_DEPENDS+= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/devel/p5-Storable \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Class/ISA.pm:${PORTSDIR}/devel/p5-Class-ISA \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Attribute/Handlers.pm:${PORTSDIR}/devel/p5-Attribute-Handlers
+RUN_DEPENDS+= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/devel/p5-Storable \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Class/ISA.pm:${PORTSDIR}/devel/p5-Class-ISA \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Attribute/Handlers.pm:${PORTSDIR}/devel/p5-Attribute-Handlers
+.endif
+
.include <bsd.port.post.mk>
diff --git a/devel/p5-Test-Differences/Makefile b/devel/p5-Test-Differences/Makefile
index eccb1990ab4a..2eb51d4bcec0 100644
--- a/devel/p5-Test-Differences/Makefile
+++ b/devel/p5-Test-Differences/Makefile
@@ -15,13 +15,18 @@ PKGNAMEPREFIX= p5-
MAINTAINER= erwin@lansing.dk
COMMENT= Test::Differences - Test strings and data structures for differences
-BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Text/Diff.pm:${PORTSDIR}/textproc/p5-Text-Diff \
- ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Text/Diff.pm:${PORTSDIR}/textproc/p5-Text-Diff
RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
-MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN3= Test::Differences.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+BUILD_DEPENDS+= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
+RUN_DEPENDS+= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Test-Differences/pkg-plist b/devel/p5-Test-Differences/pkg-plist
index 8aa384cfe880..aaa76fc4d837 100644
--- a/devel/p5-Test-Differences/pkg-plist
+++ b/devel/p5-Test-Differences/pkg-plist
@@ -1,4 +1,5 @@
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Test/Differences/.packlist
lib/perl5/site_perl/%%PERL_VER%%/Test/Differences.pm
@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Test/Differences
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/mach/auto/Test 2>/dev/null || true
@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Test 2>/dev/null || true
diff --git a/devel/p5-Test-Exception/Makefile b/devel/p5-Test-Exception/Makefile
index 7fb13a07c51a..e4e30641276b 100644
--- a/devel/p5-Test-Exception/Makefile
+++ b/devel/p5-Test-Exception/Makefile
@@ -15,14 +15,12 @@ PKGNAMEPREFIX= p5-
MAINTAINER= erwin@lansing.dk
COMMENT= Test::Exception - test functions for exception based code
-BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple \
- ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Test/Builder/Tester.pm:${PORTSDIR}/devel/p5-Test-Builder-Tester \
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Test/Builder/Tester.pm:${PORTSDIR}/devel/p5-Test-Builder-Tester \
${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Sub/Uplevel.pm:${PORTSDIR}/devel/p5-Sub-Uplevel
RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
-MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN3= Test::Exception.3
.include <bsd.port.pre.mk>
@@ -35,4 +33,9 @@ MAN3= Test::Exception.3
IGNORE= Port requires perl 5.6.x or later. Install lang/perl5 then try again
.endif
+.if ${PERL_LEVEL} < 500800
+BUILD_DEPENDS+= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
+RUN_DEPENDS+= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
+.endif
+
.include <bsd.port.post.mk>
diff --git a/devel/p5-Test-Inline/Makefile b/devel/p5-Test-Inline/Makefile
index de0c460046ac..176aa9279992 100644
--- a/devel/p5-Test-Inline/Makefile
+++ b/devel/p5-Test-Inline/Makefile
@@ -15,23 +15,24 @@ PKGNAMEPREFIX= p5-
MAINTAINER= erwin@lansing.dk
COMMENT= Test::Inline - Inlining your tests next to the code being tested
-BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Test/Harness.pm:${PORTSDIR}/devel/p5-Test-Harness \
- ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Test/Harness.pm:${PORTSDIR}/devel/p5-Test-Harness
RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
MAN1= pod2test.1
-MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN3= Pod::Tests.3 Pod::Tests::Tutorial.3 Test::Inline.3 Test::Inline::Tutorial.3
.include <bsd.port.pre.mk>
-SITE_PERL?= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}
-
.if ${PERL_LEVEL} < 500601
BUILD_DEPENDS+= ${SITE_PERL}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec
RUN_DEPENDS+= ${SITE_PERL}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec
.endif
+.if ${PERL_LEVEL} < 500800
+BUILD_DEPENDS+= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
+RUN_DEPENDS+= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
+.endif
+
.include <bsd.port.post.mk>
diff --git a/dns/p5-Net-DNS-SEC/Makefile b/dns/p5-Net-DNS-SEC/Makefile
index d2de181426c6..55393d6f0395 100644
--- a/dns/p5-Net-DNS-SEC/Makefile
+++ b/dns/p5-Net-DNS-SEC/Makefile
@@ -19,16 +19,22 @@ COMMENT= DNSSEC extensions to Net::DNS
BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Net/DNS.pm:${PORTSDIR}/net/p5-Net-DNS \
${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Crypt/OpenSSL/RSA.pm:${PORTSDIR}/security/p5-Crypt-OpenSSL-RSA \
${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Crypt/OpenSSL/DSA.pm:${PORTSDIR}/security/p5-Crypt-OpenSSL-DSA \
- ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Digest/BubbleBabble.pm:${PORTSDIR}/security/p5-Digest-BubbleBabble \
- ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple \
- ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Digest/BubbleBabble.pm:${PORTSDIR}/security/p5-Digest-BubbleBabble
RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
-MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN3= Net::DNS::Keyset.3 Net::DNS::RR::DS.3 Net::DNS::RR::KEY.3 \
Net::DNS::RR::NXT.3 Net::DNS::RR::SIG.3 \
Net::DNS::RR::SIG::Private.3 Net::DNS::SEC.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+BUILD_DEPENDS+= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64
+RUN_DEPENDS+= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/mail/p5-Net-SMTP-Server/Makefile b/mail/p5-Net-SMTP-Server/Makefile
index 88d1cce3627e..68113abf0600 100644
--- a/mail/p5-Net-SMTP-Server/Makefile
+++ b/mail/p5-Net-SMTP-Server/Makefile
@@ -16,16 +16,22 @@ DISTNAME= SMTP-Server-${PORTVERSION}
MAINTAINER= erwin@lansing.dk
COMMENT= A native Perl SMTP Server
-RUN_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Net/SMTP.pm:${PORTSDIR}/net/p5-Net \
- ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Net/DNS.pm:${PORTSDIR}/net/p5-Net-DNS
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Net/DNS.pm:${PORTSDIR}/net/p5-Net-DNS
+RUN_DEPENDS= ${BUILD_DEPENDS}
MASTER_SITE_BACKUP+= http://www.macgyver.org/software/perl/
PERL_CONFIGURE= yes
-MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN3= Net::SMTP::Server.3 \
Net::SMTP::Server::Client.3 \
Net::SMTP::Server::Relay.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+BUILD_DEPENDS+= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Net/SMTP.pm:${PORTSDIR}/net/p5-Net
+RUN_DEPENDS+= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Net/SMTP.pm:${PORTSDIR}/net/p5-Net
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net/p5-Net-DNS-SEC/Makefile b/net/p5-Net-DNS-SEC/Makefile
index d2de181426c6..55393d6f0395 100644
--- a/net/p5-Net-DNS-SEC/Makefile
+++ b/net/p5-Net-DNS-SEC/Makefile
@@ -19,16 +19,22 @@ COMMENT= DNSSEC extensions to Net::DNS
BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Net/DNS.pm:${PORTSDIR}/net/p5-Net-DNS \
${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Crypt/OpenSSL/RSA.pm:${PORTSDIR}/security/p5-Crypt-OpenSSL-RSA \
${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Crypt/OpenSSL/DSA.pm:${PORTSDIR}/security/p5-Crypt-OpenSSL-DSA \
- ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Digest/BubbleBabble.pm:${PORTSDIR}/security/p5-Digest-BubbleBabble \
- ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple \
- ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Digest/BubbleBabble.pm:${PORTSDIR}/security/p5-Digest-BubbleBabble
RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
-MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN3= Net::DNS::Keyset.3 Net::DNS::RR::DS.3 Net::DNS::RR::KEY.3 \
Net::DNS::RR::NXT.3 Net::DNS::RR::SIG.3 \
Net::DNS::RR::SIG::Private.3 Net::DNS::SEC.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+BUILD_DEPENDS+= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64
+RUN_DEPENDS+= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net/p5-Net-SNPP/Makefile b/net/p5-Net-SNPP/Makefile
index f51491873445..36f5d8b819ca 100644
--- a/net/p5-Net-SNPP/Makefile
+++ b/net/p5-Net-SNPP/Makefile
@@ -15,12 +15,15 @@ PKGNAMEPREFIX= p5-
MAINTAINER= erwin@lansing.dk
COMMENT= Net::SNPP - Perl Simple Network Pager Protocol Client
-BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Net/Cmd.pm:${PORTSDIR}/net/p5-Net
-RUN_DEPENDS= ${BUILD_DEPENDS}
-
PERL_CONFIGURE= yes
-MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN3= Net::SNPP.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Net/Cmd.pm:${PORTSDIR}/net/p5-Net
+RUN_DEPENDS= ${BUILD_DEPENDS}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/security/p5-Crypt-SSLeay/Makefile b/security/p5-Crypt-SSLeay/Makefile
index 47f95779ae65..5c216aced13d 100644
--- a/security/p5-Crypt-SSLeay/Makefile
+++ b/security/p5-Crypt-SSLeay/Makefile
@@ -15,8 +15,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= erwin@lansing.dk
COMMENT= Perl5 interface to allow p5-libwww LWP to make https connections
-BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64 \
- ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/URI/URL.pm:${PORTSDIR}/net/p5-URI
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/URI/URL.pm:${PORTSDIR}/net/p5-URI
RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
@@ -26,4 +25,12 @@ USE_OPENSSL= yes
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN3= Crypt::SSLeay.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+BUILD_DEPENDS+= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64
+RUN_DEPENDS+= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64
+.endif
+
+.include <bsd.port.post.mk>
+
diff --git a/www/p5-Apache-ASP/Makefile b/www/p5-Apache-ASP/Makefile
index 5066f3b3397c..f6f8e981506d 100644
--- a/www/p5-Apache-ASP/Makefile
+++ b/www/p5-Apache-ASP/Makefile
@@ -26,18 +26,24 @@ BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Apache/Filter.pm:${P
${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/XML/XSLT.pm:${PORTSDIR}/textproc/p5-XML-XSLT \
${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/mod_perl.pm:${PORTSDIR}/www/mod_perl \
${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Compress/Zlib.pm:${PORTSDIR}/archivers/p5-Compress-Zlib \
- ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
- ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Time/HiRes.pm:${PORTSDIR}/devel/p5-Time-HiRes \
${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/XML/Sablotron.pm:${PORTSDIR}/textproc/p5-XML-Sablotron
RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
MAN1= asp-perl.1
-MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN3= Apache::ASP.3 \
Apache::ASP::CGI::Table.3 \
Bundle::Apache::ASP.3 \
Bundle::Apache::ASP::Extra.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+BUILD_DEPENDS+= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Time/HiRes.pm:${PORTSDIR}/devel/p5-Time-HiRes
+RUN_DEPENDS+= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Time/HiRes.pm:${PORTSDIR}/devel/p5-Time-HiRes
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/p5-Apache-Gallery/Makefile b/www/p5-Apache-Gallery/Makefile
index 53995cd4b578..d153d95ea7b5 100644
--- a/www/p5-Apache-Gallery/Makefile
+++ b/www/p5-Apache-Gallery/Makefile
@@ -22,14 +22,12 @@ BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Apache/
${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Image/Info.pm:${PORTSDIR}/graphics/p5-Image-Info \
${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/CGI/FastTemplate.pm:${PORTSDIR}/www/p5-CGI-FastTemplate \
${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Inline.pm:${PORTSDIR}/devel/p5-Inline \
- ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Image/Size.pm:${PORTSDIR}/graphics/p5-Image-Size \
- ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Image/Size.pm:${PORTSDIR}/graphics/p5-Image-Size
RUN_DEPENDS= ${BUILD_DEPENDS}
PKGMESSAGE= ${WRKDIR}/pkg-message
PERL_CONFIGURE= yes
-MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN3= Apache::Gallery.3
TEMPLATEFILES= directory.tpl error.tpl index.tpl info.tpl layout.tpl \
@@ -66,4 +64,9 @@ post-install:
IGNORE= Port requires perl 5.6.x or later. Install lang/perl5 then try again
.endif
+.if ${PERL_LEVEL} < 500800
+BUILD_DEPENDS+= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
+RUN_DEPENDS+= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
+.endif
+
.include <bsd.port.post.mk>
diff --git a/www/p5-CGI-Session/Makefile b/www/p5-CGI-Session/Makefile
index 0aeb2962ccb4..a6555ac0fa46 100644
--- a/www/p5-CGI-Session/Makefile
+++ b/www/p5-CGI-Session/Makefile
@@ -15,9 +15,6 @@ PKGNAMEPREFIX= p5-
MAINTAINER= erwin@lansing.dk
COMMENT= Perl extension for persistent session management
-BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5
-RUN_DEPENDS= ${BUILD_DEPENDS}
-
PERL_CONFIGURE= yes
MAN3= CGI::Session::DB_File.3 \
@@ -35,4 +32,11 @@ MAN3= CGI::Session::DB_File.3 \
CGI::Session::CookBook.3 \
CGI::Session::Serialize::Storable.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5
+RUN_DEPENDS= ${BUILD_DEPENDS}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/p5-WWW-Search/Makefile b/www/p5-WWW-Search/Makefile
index 86f6494a7643..f4201c4507b5 100644
--- a/www/p5-WWW-Search/Makefile
+++ b/www/p5-WWW-Search/Makefile
@@ -19,7 +19,6 @@ BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/LWP.pm:${PORTSDIR}/w
${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/HTML/TreeBuilder.pm:${PORTSDIR}/www/p5-HTML-Tree \
${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/URI.pm:${PORTSDIR}/net/p5-URI \
${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/MIME/Lite.pm:${PORTSDIR}/mail/p5-MIME-Lite \
- ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple \
${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Test/Inline.pm:${PORTSDIR}/devel/p5-Test-Inline \
${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/User.pm:${PORTSDIR}/sysutils/p5-User \
${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Getopt/Long.pm:${PORTSDIR}/devel/p5-Getopt-Long \
@@ -30,7 +29,6 @@ PERL_CONFIGURE= yes
MAN1= AutoSearch.1 \
WebSearch.1
-MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN3= WWW::Search.3 \
WWW::SearchResult.3 \
WWW::Search::Null.3 \
@@ -42,13 +40,9 @@ MAN3= WWW::Search.3 \
.include <bsd.port.pre.mk>
-SITE_PERL?= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}
-
-PERL_MAJOR=${PERL_VER:C|^([1-9]+).*|\1|}
-PERL_MINOR=${PERL_VER:C|^[1-9]+\.0*([1-9]+).*|\1|}
-
-.if ${PERL_MAJOR} < 5 || ${PERL_MAJOR} == 5 && ${PERL_MINOR} < 8
-BUILD_DEPENDS+= ${SITE_PERL}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec
-.endif # ${PERL_MAJOR} < 5 || ${PERL_MAJOR} == 5 && ${PERL_MINOR} < 8
+.if ${PERL_LEVEL} < 500800
+BUILD_DEPENDS+= ${SITE_PERL}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
+.endif
.include <bsd.port.post.mk>