aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2018-09-23 04:38:22 +0000
committerMark Linimon <linimon@FreeBSD.org>2018-09-23 04:38:22 +0000
commitc12220ba5f28c13e21482b0db5f7eedc6aa1eb46 (patch)
treeb772c551484940d33b6e2a6952432258f10b213a
parent9862c19ac1d15a47b97591f7320180b8f5bc4d1f (diff)
downloadports-c12220ba5f28c13e21482b0db5f7eedc6aa1eb46.tar.gz
ports-c12220ba5f28c13e21482b0db5f7eedc6aa1eb46.zip
Notes
-rw-r--r--databases/ldb12/Makefile2
-rw-r--r--games/powder-toy/Makefile2
-rw-r--r--graphics/maim/Makefile2
-rw-r--r--net/haproxy-devel/Makefile2
-rw-r--r--www/davix/Makefile2
-rw-r--r--www/mod_security3/Makefile2
6 files changed, 6 insertions, 6 deletions
diff --git a/databases/ldb12/Makefile b/databases/ldb12/Makefile
index 2d5594077bf1..9673603b639c 100644
--- a/databases/ldb12/Makefile
+++ b/databases/ldb12/Makefile
@@ -31,7 +31,7 @@ CONFLICTS_INSTALL= ldb-1.1.* ldb13-1.3.*
#nopython_CONFLICTS= ldb
#default_CONFLICTS= ldb-nopython
-USES= compiler pkgconfig waf
+USES= compiler:c++11-lang pkgconfig waf
USE_LDCONFIG= yes
WAF_CMD= buildtools/bin/waf
CONFIGURE_LOG= bin/config.log
diff --git a/games/powder-toy/Makefile b/games/powder-toy/Makefile
index 2997066bfc8e..502923d89f0b 100644
--- a/games/powder-toy/Makefile
+++ b/games/powder-toy/Makefile
@@ -19,7 +19,7 @@ USE_GITHUB= yes
GH_ACCOUNT= ThePowderToy
GH_PROJECT= The-Powder-Toy
-USES= scons localbase:ldflags lua:51 pkgconfig
+USES= compiler:c++11-lang scons localbase:ldflags lua:51 pkgconfig
USE_SDL= sdl
USE_XORG= x11
diff --git a/graphics/maim/Makefile b/graphics/maim/Makefile
index 8b2dfa4eb0cd..82c7da700a9b 100644
--- a/graphics/maim/Makefile
+++ b/graphics/maim/Makefile
@@ -17,7 +17,7 @@ LIB_DEPENDS= libImlib2.so:graphics/imlib2 \
libpng.so:graphics/png \
libslopy.so:x11/slop
-USES= cmake jpeg
+USES= cmake compiler:c++11-lang jpeg
USE_GITHUB= yes
GH_ACCOUNT= naelstrof
USE_GL= gl glut
diff --git a/net/haproxy-devel/Makefile b/net/haproxy-devel/Makefile
index c06ef75fef8e..a301651c17a3 100644
--- a/net/haproxy-devel/Makefile
+++ b/net/haproxy-devel/Makefile
@@ -16,7 +16,7 @@ LICENSE_COMB= multi
CONFLICTS_INSTALL= haproxy-[0-9]* haproxy17-[0-9]*
-USES= cpe gmake
+USES= compiler:c++11-lang cpe gmake
USE_RC_SUBR= haproxy
MAKE_ARGS= TARGET=freebsd DEFINE=-DFREEBSD_PORTS USE_GETADDRINFO=1 \
diff --git a/www/davix/Makefile b/www/davix/Makefile
index 1ed83ca18926..89739b398dde 100644
--- a/www/davix/Makefile
+++ b/www/davix/Makefile
@@ -15,7 +15,7 @@ LIB_DEPENDS= libuuid.so:misc/e2fsprogs-libuuid
PORTSCOUT= limit:^.*\.[0-9]+$$
-USES= cmake localbase ssl
+USES= cmake compiler:c++11-lang localbase ssl
USE_GITHUB= yes
GH_ACCOUNT= cern-it-sdc-id
USE_GNOME= libxml2
diff --git a/www/mod_security3/Makefile b/www/mod_security3/Makefile
index 5a47e272cbdb..f3395e62a872 100644
--- a/www/mod_security3/Makefile
+++ b/www/mod_security3/Makefile
@@ -17,7 +17,7 @@ LIB_DEPENDS= libcurl.so:ftp/curl \
libyajl.so:devel/yajl \
libGeoIP.so:net/GeoIP
-USES= gmake autoreconf libtool pkgconfig:build
+USES= autoreconf compiler:c++11-lang gmake libtool pkgconfig:build
USE_GNOME= libxml2
# GCC because of https://github.com/SpiderLabs/ModSecurity/issues/1411
USE_GCC= yes