aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarc G. Fournier <scrappy@FreeBSD.org>2006-04-15 16:23:50 +0000
committerMarc G. Fournier <scrappy@FreeBSD.org>2006-04-15 16:23:50 +0000
commitc39f14401355954a0c5d01b7a2a0a655ee06a993 (patch)
tree285584564ec9b81936af2e4de9c9d55fc8bef643
parentf25b2bf7b337aa5ae1b5ef58078aa0b09b1ee539 (diff)
Notes
-rw-r--r--devel/chora/files/pkg-deinstall.in9
-rw-r--r--devel/chora/files/pkg-install.in23
-rw-r--r--devel/horde-chora/files/pkg-deinstall.in9
-rw-r--r--devel/horde-chora/files/pkg-install.in23
-rw-r--r--mail/horde-imp/files/pkg-deinstall.in10
-rw-r--r--mail/horde-imp/files/pkg-install.in23
-rw-r--r--mail/horde-ingo/Makefile11
-rw-r--r--mail/horde-ingo/files/pkg-deinstall.in9
-rw-r--r--mail/horde-ingo/files/pkg-install.in23
-rw-r--r--mail/horde-ingo/pkg-plist3
-rw-r--r--mail/horde4-imp/files/pkg-deinstall.in10
-rw-r--r--mail/horde4-imp/files/pkg-install.in23
-rw-r--r--mail/horde4-ingo/Makefile11
-rw-r--r--mail/horde4-ingo/files/pkg-deinstall.in9
-rw-r--r--mail/horde4-ingo/files/pkg-install.in23
-rw-r--r--mail/horde4-ingo/pkg-plist3
-rw-r--r--mail/imp/files/pkg-deinstall.in10
-rw-r--r--mail/imp/files/pkg-install.in23
-rw-r--r--mail/ingo/Makefile11
-rw-r--r--mail/ingo/files/pkg-deinstall.in9
-rw-r--r--mail/ingo/files/pkg-install.in23
-rw-r--r--mail/ingo/pkg-plist3
-rw-r--r--www/horde-base/files/pkg-deinstall.in9
-rw-r--r--www/horde-base/files/pkg-install.in13
-rw-r--r--www/horde-base/files/pkg-message.in5
-rw-r--r--www/horde-passwd/files/pkg-deinstall.in10
-rw-r--r--www/horde-passwd/files/pkg-install.in23
-rw-r--r--www/horde/files/pkg-deinstall.in9
-rw-r--r--www/horde/files/pkg-install.in13
-rw-r--r--www/horde/files/pkg-message.in5
-rw-r--r--www/horde4-base/files/pkg-deinstall.in9
-rw-r--r--www/horde4-base/files/pkg-install.in13
-rw-r--r--www/horde4-base/files/pkg-message.in5
33 files changed, 273 insertions, 142 deletions
diff --git a/devel/chora/files/pkg-deinstall.in b/devel/chora/files/pkg-deinstall.in
index 0ef032fe5654..ca19b4bfa602 100644
--- a/devel/chora/files/pkg-deinstall.in
+++ b/devel/chora/files/pkg-deinstall.in
@@ -12,13 +12,10 @@ if [ -z "${PACKAGE_BUILDING}" ]; then
for cf in `ls %%CHORADIR%%/config/*php %%CHORADIR%%/config/*txt`; do
diff -bBqw $cf $cf.dist >/dev/null 2>&1
case $? in
- 0) # original config file, will be deleted by pkg-plist
+ 0) # original config file, delete it
+ rm -f $cf
;;
- 1) # config file has been updated, must be backuped
- cp -p $cf $cf.previous
- echo "===> Backing-up..."
- echo "---> $cf has been saved ***"
- echo "---> as $cf.previous ***"
+ 1) # config file has been updated, leave it alone
;;
*) # not found?
;;
diff --git a/devel/chora/files/pkg-install.in b/devel/chora/files/pkg-install.in
new file mode 100644
index 000000000000..4c605270649a
--- /dev/null
+++ b/devel/chora/files/pkg-install.in
@@ -0,0 +1,23 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+PATH=/usr/sbin:/usr/bin:/bin ; export PATH
+
+case $2 in
+ PRE-INSTALL)
+ ;;
+
+ POST-INSTALL)
+ if [ -z "${PACKAGE_BUILDING}" ]; then
+ # Copy over sample config files unless they already exist
+
+ for cf in `ls %%CHORADIR%%/config/*.dist | sed -e 's/\.dist//g'`; do
+ if [ ! -f $cf ]; then
+ cp -p $cf.dist $cf
+ fi
+ done
+ fi
+ ;;
+esac
diff --git a/devel/horde-chora/files/pkg-deinstall.in b/devel/horde-chora/files/pkg-deinstall.in
index 0ef032fe5654..ca19b4bfa602 100644
--- a/devel/horde-chora/files/pkg-deinstall.in
+++ b/devel/horde-chora/files/pkg-deinstall.in
@@ -12,13 +12,10 @@ if [ -z "${PACKAGE_BUILDING}" ]; then
for cf in `ls %%CHORADIR%%/config/*php %%CHORADIR%%/config/*txt`; do
diff -bBqw $cf $cf.dist >/dev/null 2>&1
case $? in
- 0) # original config file, will be deleted by pkg-plist
+ 0) # original config file, delete it
+ rm -f $cf
;;
- 1) # config file has been updated, must be backuped
- cp -p $cf $cf.previous
- echo "===> Backing-up..."
- echo "---> $cf has been saved ***"
- echo "---> as $cf.previous ***"
+ 1) # config file has been updated, leave it alone
;;
*) # not found?
;;
diff --git a/devel/horde-chora/files/pkg-install.in b/devel/horde-chora/files/pkg-install.in
new file mode 100644
index 000000000000..4c605270649a
--- /dev/null
+++ b/devel/horde-chora/files/pkg-install.in
@@ -0,0 +1,23 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+PATH=/usr/sbin:/usr/bin:/bin ; export PATH
+
+case $2 in
+ PRE-INSTALL)
+ ;;
+
+ POST-INSTALL)
+ if [ -z "${PACKAGE_BUILDING}" ]; then
+ # Copy over sample config files unless they already exist
+
+ for cf in `ls %%CHORADIR%%/config/*.dist | sed -e 's/\.dist//g'`; do
+ if [ ! -f $cf ]; then
+ cp -p $cf.dist $cf
+ fi
+ done
+ fi
+ ;;
+esac
diff --git a/mail/horde-imp/files/pkg-deinstall.in b/mail/horde-imp/files/pkg-deinstall.in
index 13bb805c47d5..e4787a72dfe4 100644
--- a/mail/horde-imp/files/pkg-deinstall.in
+++ b/mail/horde-imp/files/pkg-deinstall.in
@@ -2,7 +2,6 @@
#
# $FreeBSD$
#
-# Backup IMP config files, if needed.
if [ x$2 != xDEINSTALL ]; then
exit
@@ -12,13 +11,10 @@ if [ -z "${PACKAGE_BUILDING}" ]; then
for cf in `ls %%IMPDIR%%/config/*php %%IMPDIR%%/config/*txt`; do
diff -bBqw $cf $cf.dist >/dev/null 2>&1
case $? in
- 0) # original config file, will be deleted by pkg-plist
+ 0) # original config file, delete it
+ rm -f $cf
;;
- 1) # config file has been updated, must be backuped
- cp -p $cf $cf.previous
- echo "===> Backing-up..."
- echo "---> $cf has been saved ***"
- echo "---> as $cf.previous ***"
+ 1) # config file has been updated, leave it alone
;;
*) # not found?
;;
diff --git a/mail/horde-imp/files/pkg-install.in b/mail/horde-imp/files/pkg-install.in
new file mode 100644
index 000000000000..7a19b9e2b9de
--- /dev/null
+++ b/mail/horde-imp/files/pkg-install.in
@@ -0,0 +1,23 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+PATH=/usr/sbin:/usr/bin:/bin ; export PATH
+
+case $2 in
+ PRE-INSTALL)
+ ;;
+
+ POST-INSTALL)
+ if [ -z "${PACKAGE_BUILDING}" ]; then
+ # Copy over sample config files unless they already exist
+
+ for cf in `ls %%IMPDIR%%/config/*.dist | sed -e 's/\.dist//g'`; do
+ if [ ! -f $cf ]; then
+ cp -p $cf.dist $cf
+ fi
+ done
+ fi
+ ;;
+esac
diff --git a/mail/horde-ingo/Makefile b/mail/horde-ingo/Makefile
index a588201045ea..cb777f1eba0f 100644
--- a/mail/horde-ingo/Makefile
+++ b/mail/horde-ingo/Makefile
@@ -20,7 +20,7 @@ MASTER_SITES= ftp://ftp.horde.org/pub/ingo/ \
DISTNAME= ${PORTNAME}-h3-${PORTVERSION}
MAINTAINER= shaun@inerd.com
-COMMENT= Horde's email-filter management application
+COMMENT= Horde\'s email-filter management application
#-----------------------------------------------------------------------
# You may define this option:
@@ -39,7 +39,7 @@ USE_APACHE= 1.3+ # needed to test APACHE_VERSION
PLIST_SUB= INGODIR=${LINGODIR} HORDE_INC=${HORDE_INC:S|^${LOCALBASE}/||}
PKGMESSAGE= ${WRKDIR}/pkg-message
PKGDEINSTALL= ${WRKDIR}/pkg-deinstall
-SUB_FILES= pkg-message pkg-deinstall
+SUB_FILES= pkg-message pkg-install pkg-deinstall
SUB_LIST= INGODIR=${INGODIR}
DOCS= LICENSE README docs/CHANGES docs/CREDITS docs/INSTALL \
@@ -76,11 +76,7 @@ do-install:
@${CP} -Rp ${WRKSRC}/${REP} ${INGODIR}
.endfor
@${CP} -p ${WRKSRC}/*.php ${INGODIR}
-.for FILE in ${CONFFILE}
- @if [ ! -f ${CONFDIR}/${FILE} ]; then \
- ${CP} ${CONFDIR}/${FILE}.dist ${CONFDIR}/${FILE} ; \
- fi
-.endfor
+
@${CHOWN} -R ${WWWOWN}:${WWWGRP} ${INGODIR}
@${CHMOD} -R o-rwx ${CONFDIR}
@${INSTALL_DATA} ${WRKDIR}/httpd-ingo.conf ${HORDE_INC}
@@ -93,6 +89,7 @@ do-install:
.endif
post-install:
+ @${SETENV} ${SCRIPTS_ENV} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
@${ECHO_MSG}
@${CAT} ${PKGMESSAGE}
@${ECHO_MSG}
diff --git a/mail/horde-ingo/files/pkg-deinstall.in b/mail/horde-ingo/files/pkg-deinstall.in
index 2289e8963491..9d8d08de9224 100644
--- a/mail/horde-ingo/files/pkg-deinstall.in
+++ b/mail/horde-ingo/files/pkg-deinstall.in
@@ -12,13 +12,10 @@ if [ -z "${PACKAGE_BUILDING}" ]; then
for cf in `ls %%INGODIR%%/config/*php`; do
diff -bBqw $cf $cf.dist >/dev/null 2>&1
case $? in
- 0) # original config file, will be deleted by pkg-plist
+ 0) # original config file, delete it
+ rm -f $cf
;;
- 1) # config file has been updated, must be backuped
- cp -p $cf $cf.previous
- echo "===> Backing-up..."
- echo "---> $cf has been saved ***"
- echo "---> as $cf.previous ***"
+ 1) # config file has been updated, leave it alone
;;
*) # not found?
;;
diff --git a/mail/horde-ingo/files/pkg-install.in b/mail/horde-ingo/files/pkg-install.in
new file mode 100644
index 000000000000..3a7bcda4b76a
--- /dev/null
+++ b/mail/horde-ingo/files/pkg-install.in
@@ -0,0 +1,23 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+PATH=/usr/sbin:/usr/bin:/bin ; export PATH
+
+case $2 in
+ PRE-INSTALL)
+ ;;
+
+ POST-INSTALL)
+ if [ -z "${PACKAGE_BUILDING}" ]; then
+ # Copy over sample config files unless they already exist
+
+ for cf in `ls %%INGODIR%%/config/*.dist | sed -e 's/\.dist//g'`; do
+ if [ ! -f $cf ]; then
+ cp -p $cf.dist $cf
+ fi
+ done
+ fi
+ ;;
+esac
diff --git a/mail/horde-ingo/pkg-plist b/mail/horde-ingo/pkg-plist
index d2a668f47dae..cf0f451d0826 100644
--- a/mail/horde-ingo/pkg-plist
+++ b/mail/horde-ingo/pkg-plist
@@ -8,12 +8,9 @@
%%PORTDOCS%%%%DOCSDIR%%/TODO
%%INGODIR%%/blacklist.php
%%INGODIR%%/config/.htaccess
-%%INGODIR%%/config/backends.php
%%INGODIR%%/config/backends.php.dist
%%INGODIR%%/config/conf.xml
-%%INGODIR%%/config/fields.php
%%INGODIR%%/config/fields.php.dist
-%%INGODIR%%/config/prefs.php
%%INGODIR%%/config/prefs.php.dist
%%INGODIR%%/filters.php
%%INGODIR%%/forward.php
diff --git a/mail/horde4-imp/files/pkg-deinstall.in b/mail/horde4-imp/files/pkg-deinstall.in
index 13bb805c47d5..e4787a72dfe4 100644
--- a/mail/horde4-imp/files/pkg-deinstall.in
+++ b/mail/horde4-imp/files/pkg-deinstall.in
@@ -2,7 +2,6 @@
#
# $FreeBSD$
#
-# Backup IMP config files, if needed.
if [ x$2 != xDEINSTALL ]; then
exit
@@ -12,13 +11,10 @@ if [ -z "${PACKAGE_BUILDING}" ]; then
for cf in `ls %%IMPDIR%%/config/*php %%IMPDIR%%/config/*txt`; do
diff -bBqw $cf $cf.dist >/dev/null 2>&1
case $? in
- 0) # original config file, will be deleted by pkg-plist
+ 0) # original config file, delete it
+ rm -f $cf
;;
- 1) # config file has been updated, must be backuped
- cp -p $cf $cf.previous
- echo "===> Backing-up..."
- echo "---> $cf has been saved ***"
- echo "---> as $cf.previous ***"
+ 1) # config file has been updated, leave it alone
;;
*) # not found?
;;
diff --git a/mail/horde4-imp/files/pkg-install.in b/mail/horde4-imp/files/pkg-install.in
new file mode 100644
index 000000000000..7a19b9e2b9de
--- /dev/null
+++ b/mail/horde4-imp/files/pkg-install.in
@@ -0,0 +1,23 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+PATH=/usr/sbin:/usr/bin:/bin ; export PATH
+
+case $2 in
+ PRE-INSTALL)
+ ;;
+
+ POST-INSTALL)
+ if [ -z "${PACKAGE_BUILDING}" ]; then
+ # Copy over sample config files unless they already exist
+
+ for cf in `ls %%IMPDIR%%/config/*.dist | sed -e 's/\.dist//g'`; do
+ if [ ! -f $cf ]; then
+ cp -p $cf.dist $cf
+ fi
+ done
+ fi
+ ;;
+esac
diff --git a/mail/horde4-ingo/Makefile b/mail/horde4-ingo/Makefile
index a588201045ea..cb777f1eba0f 100644
--- a/mail/horde4-ingo/Makefile
+++ b/mail/horde4-ingo/Makefile
@@ -20,7 +20,7 @@ MASTER_SITES= ftp://ftp.horde.org/pub/ingo/ \
DISTNAME= ${PORTNAME}-h3-${PORTVERSION}
MAINTAINER= shaun@inerd.com
-COMMENT= Horde's email-filter management application
+COMMENT= Horde\'s email-filter management application
#-----------------------------------------------------------------------
# You may define this option:
@@ -39,7 +39,7 @@ USE_APACHE= 1.3+ # needed to test APACHE_VERSION
PLIST_SUB= INGODIR=${LINGODIR} HORDE_INC=${HORDE_INC:S|^${LOCALBASE}/||}
PKGMESSAGE= ${WRKDIR}/pkg-message
PKGDEINSTALL= ${WRKDIR}/pkg-deinstall
-SUB_FILES= pkg-message pkg-deinstall
+SUB_FILES= pkg-message pkg-install pkg-deinstall
SUB_LIST= INGODIR=${INGODIR}
DOCS= LICENSE README docs/CHANGES docs/CREDITS docs/INSTALL \
@@ -76,11 +76,7 @@ do-install:
@${CP} -Rp ${WRKSRC}/${REP} ${INGODIR}
.endfor
@${CP} -p ${WRKSRC}/*.php ${INGODIR}
-.for FILE in ${CONFFILE}
- @if [ ! -f ${CONFDIR}/${FILE} ]; then \
- ${CP} ${CONFDIR}/${FILE}.dist ${CONFDIR}/${FILE} ; \
- fi
-.endfor
+
@${CHOWN} -R ${WWWOWN}:${WWWGRP} ${INGODIR}
@${CHMOD} -R o-rwx ${CONFDIR}
@${INSTALL_DATA} ${WRKDIR}/httpd-ingo.conf ${HORDE_INC}
@@ -93,6 +89,7 @@ do-install:
.endif
post-install:
+ @${SETENV} ${SCRIPTS_ENV} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
@${ECHO_MSG}
@${CAT} ${PKGMESSAGE}
@${ECHO_MSG}
diff --git a/mail/horde4-ingo/files/pkg-deinstall.in b/mail/horde4-ingo/files/pkg-deinstall.in
index 2289e8963491..9d8d08de9224 100644
--- a/mail/horde4-ingo/files/pkg-deinstall.in
+++ b/mail/horde4-ingo/files/pkg-deinstall.in
@@ -12,13 +12,10 @@ if [ -z "${PACKAGE_BUILDING}" ]; then
for cf in `ls %%INGODIR%%/config/*php`; do
diff -bBqw $cf $cf.dist >/dev/null 2>&1
case $? in
- 0) # original config file, will be deleted by pkg-plist
+ 0) # original config file, delete it
+ rm -f $cf
;;
- 1) # config file has been updated, must be backuped
- cp -p $cf $cf.previous
- echo "===> Backing-up..."
- echo "---> $cf has been saved ***"
- echo "---> as $cf.previous ***"
+ 1) # config file has been updated, leave it alone
;;
*) # not found?
;;
diff --git a/mail/horde4-ingo/files/pkg-install.in b/mail/horde4-ingo/files/pkg-install.in
new file mode 100644
index 000000000000..3a7bcda4b76a
--- /dev/null
+++ b/mail/horde4-ingo/files/pkg-install.in
@@ -0,0 +1,23 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+PATH=/usr/sbin:/usr/bin:/bin ; export PATH
+
+case $2 in
+ PRE-INSTALL)
+ ;;
+
+ POST-INSTALL)
+ if [ -z "${PACKAGE_BUILDING}" ]; then
+ # Copy over sample config files unless they already exist
+
+ for cf in `ls %%INGODIR%%/config/*.dist | sed -e 's/\.dist//g'`; do
+ if [ ! -f $cf ]; then
+ cp -p $cf.dist $cf
+ fi
+ done
+ fi
+ ;;
+esac
diff --git a/mail/horde4-ingo/pkg-plist b/mail/horde4-ingo/pkg-plist
index d2a668f47dae..cf0f451d0826 100644
--- a/mail/horde4-ingo/pkg-plist
+++ b/mail/horde4-ingo/pkg-plist
@@ -8,12 +8,9 @@
%%PORTDOCS%%%%DOCSDIR%%/TODO
%%INGODIR%%/blacklist.php
%%INGODIR%%/config/.htaccess
-%%INGODIR%%/config/backends.php
%%INGODIR%%/config/backends.php.dist
%%INGODIR%%/config/conf.xml
-%%INGODIR%%/config/fields.php
%%INGODIR%%/config/fields.php.dist
-%%INGODIR%%/config/prefs.php
%%INGODIR%%/config/prefs.php.dist
%%INGODIR%%/filters.php
%%INGODIR%%/forward.php
diff --git a/mail/imp/files/pkg-deinstall.in b/mail/imp/files/pkg-deinstall.in
index 13bb805c47d5..e4787a72dfe4 100644
--- a/mail/imp/files/pkg-deinstall.in
+++ b/mail/imp/files/pkg-deinstall.in
@@ -2,7 +2,6 @@
#
# $FreeBSD$
#
-# Backup IMP config files, if needed.
if [ x$2 != xDEINSTALL ]; then
exit
@@ -12,13 +11,10 @@ if [ -z "${PACKAGE_BUILDING}" ]; then
for cf in `ls %%IMPDIR%%/config/*php %%IMPDIR%%/config/*txt`; do
diff -bBqw $cf $cf.dist >/dev/null 2>&1
case $? in
- 0) # original config file, will be deleted by pkg-plist
+ 0) # original config file, delete it
+ rm -f $cf
;;
- 1) # config file has been updated, must be backuped
- cp -p $cf $cf.previous
- echo "===> Backing-up..."
- echo "---> $cf has been saved ***"
- echo "---> as $cf.previous ***"
+ 1) # config file has been updated, leave it alone
;;
*) # not found?
;;
diff --git a/mail/imp/files/pkg-install.in b/mail/imp/files/pkg-install.in
new file mode 100644
index 000000000000..7a19b9e2b9de
--- /dev/null
+++ b/mail/imp/files/pkg-install.in
@@ -0,0 +1,23 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+PATH=/usr/sbin:/usr/bin:/bin ; export PATH
+
+case $2 in
+ PRE-INSTALL)
+ ;;
+
+ POST-INSTALL)
+ if [ -z "${PACKAGE_BUILDING}" ]; then
+ # Copy over sample config files unless they already exist
+
+ for cf in `ls %%IMPDIR%%/config/*.dist | sed -e 's/\.dist//g'`; do
+ if [ ! -f $cf ]; then
+ cp -p $cf.dist $cf
+ fi
+ done
+ fi
+ ;;
+esac
diff --git a/mail/ingo/Makefile b/mail/ingo/Makefile
index a588201045ea..cb777f1eba0f 100644
--- a/mail/ingo/Makefile
+++ b/mail/ingo/Makefile
@@ -20,7 +20,7 @@ MASTER_SITES= ftp://ftp.horde.org/pub/ingo/ \
DISTNAME= ${PORTNAME}-h3-${PORTVERSION}
MAINTAINER= shaun@inerd.com
-COMMENT= Horde's email-filter management application
+COMMENT= Horde\'s email-filter management application
#-----------------------------------------------------------------------
# You may define this option:
@@ -39,7 +39,7 @@ USE_APACHE= 1.3+ # needed to test APACHE_VERSION
PLIST_SUB= INGODIR=${LINGODIR} HORDE_INC=${HORDE_INC:S|^${LOCALBASE}/||}
PKGMESSAGE= ${WRKDIR}/pkg-message
PKGDEINSTALL= ${WRKDIR}/pkg-deinstall
-SUB_FILES= pkg-message pkg-deinstall
+SUB_FILES= pkg-message pkg-install pkg-deinstall
SUB_LIST= INGODIR=${INGODIR}
DOCS= LICENSE README docs/CHANGES docs/CREDITS docs/INSTALL \
@@ -76,11 +76,7 @@ do-install:
@${CP} -Rp ${WRKSRC}/${REP} ${INGODIR}
.endfor
@${CP} -p ${WRKSRC}/*.php ${INGODIR}
-.for FILE in ${CONFFILE}
- @if [ ! -f ${CONFDIR}/${FILE} ]; then \
- ${CP} ${CONFDIR}/${FILE}.dist ${CONFDIR}/${FILE} ; \
- fi
-.endfor
+
@${CHOWN} -R ${WWWOWN}:${WWWGRP} ${INGODIR}
@${CHMOD} -R o-rwx ${CONFDIR}
@${INSTALL_DATA} ${WRKDIR}/httpd-ingo.conf ${HORDE_INC}
@@ -93,6 +89,7 @@ do-install:
.endif
post-install:
+ @${SETENV} ${SCRIPTS_ENV} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
@${ECHO_MSG}
@${CAT} ${PKGMESSAGE}
@${ECHO_MSG}
diff --git a/mail/ingo/files/pkg-deinstall.in b/mail/ingo/files/pkg-deinstall.in
index 2289e8963491..9d8d08de9224 100644
--- a/mail/ingo/files/pkg-deinstall.in
+++ b/mail/ingo/files/pkg-deinstall.in
@@ -12,13 +12,10 @@ if [ -z "${PACKAGE_BUILDING}" ]; then
for cf in `ls %%INGODIR%%/config/*php`; do
diff -bBqw $cf $cf.dist >/dev/null 2>&1
case $? in
- 0) # original config file, will be deleted by pkg-plist
+ 0) # original config file, delete it
+ rm -f $cf
;;
- 1) # config file has been updated, must be backuped
- cp -p $cf $cf.previous
- echo "===> Backing-up..."
- echo "---> $cf has been saved ***"
- echo "---> as $cf.previous ***"
+ 1) # config file has been updated, leave it alone
;;
*) # not found?
;;
diff --git a/mail/ingo/files/pkg-install.in b/mail/ingo/files/pkg-install.in
new file mode 100644
index 000000000000..3a7bcda4b76a
--- /dev/null
+++ b/mail/ingo/files/pkg-install.in
@@ -0,0 +1,23 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+PATH=/usr/sbin:/usr/bin:/bin ; export PATH
+
+case $2 in
+ PRE-INSTALL)
+ ;;
+
+ POST-INSTALL)
+ if [ -z "${PACKAGE_BUILDING}" ]; then
+ # Copy over sample config files unless they already exist
+
+ for cf in `ls %%INGODIR%%/config/*.dist | sed -e 's/\.dist//g'`; do
+ if [ ! -f $cf ]; then
+ cp -p $cf.dist $cf
+ fi
+ done
+ fi
+ ;;
+esac
diff --git a/mail/ingo/pkg-plist b/mail/ingo/pkg-plist
index d2a668f47dae..cf0f451d0826 100644
--- a/mail/ingo/pkg-plist
+++ b/mail/ingo/pkg-plist
@@ -8,12 +8,9 @@
%%PORTDOCS%%%%DOCSDIR%%/TODO
%%INGODIR%%/blacklist.php
%%INGODIR%%/config/.htaccess
-%%INGODIR%%/config/backends.php
%%INGODIR%%/config/backends.php.dist
%%INGODIR%%/config/conf.xml
-%%INGODIR%%/config/fields.php
%%INGODIR%%/config/fields.php.dist
-%%INGODIR%%/config/prefs.php
%%INGODIR%%/config/prefs.php.dist
%%INGODIR%%/filters.php
%%INGODIR%%/forward.php
diff --git a/www/horde-base/files/pkg-deinstall.in b/www/horde-base/files/pkg-deinstall.in
index 47cbca9552a2..7f9f6649e9fa 100644
--- a/www/horde-base/files/pkg-deinstall.in
+++ b/www/horde-base/files/pkg-deinstall.in
@@ -22,13 +22,10 @@ handle_config() {
for cf in `ls %%HORDEDIR%%/config/*php`; do
diff -bBqw $cf $cf.dist >/dev/null 2>&1
case $? in
- 0) # original config file, will be deleted by pkg-plist
+ 0) # original config file, delete
+ rm -f $cf
;;
- 1) # config file has been updated, must be backuped
- cp -p $cf $cf.previous
- echo "===> Backing-up..."
- echo "---> $cf has been saved ***"
- echo "---> as $cf.previous ***"
+ 1) # config file has been updated, leave it
;;
*) # not found?
;;
diff --git a/www/horde-base/files/pkg-install.in b/www/horde-base/files/pkg-install.in
index 28db88333734..a2dc1e225389 100644
--- a/www/horde-base/files/pkg-install.in
+++ b/www/horde-base/files/pkg-install.in
@@ -102,14 +102,11 @@ case $2 in
fi
if [ -z "${PACKAGE_BUILDING}" ]; then
- # Don't reset the config to default (PR ports/88621)
-
- for cf in `ls %%HORDEDIR%%/config/*php`; do
- if [ -f $cf.previous ]; then
- mv $cf $cf.new
- echo "---> $cf not installed ***"
- echo "---> please copy from $cf.previous ***"
- echo "---> or from $cf.new ***"
+ # Copy over sample config files unless they already exist
+
+ for cf in `ls %%HORDEDIR%%/config/*.dist | sed -e 's/\.dist//g'`; do
+ if [ ! -f $cf ]; then
+ cp -p $cf.dist $cf
fi
done
fi
diff --git a/www/horde-base/files/pkg-message.in b/www/horde-base/files/pkg-message.in
index c5a0ca6935e5..3226c28ff455 100644
--- a/www/horde-base/files/pkg-message.in
+++ b/www/horde-base/files/pkg-message.in
@@ -1,9 +1,6 @@
************************************************************************
Horde has been installed in %%HORDEDIR%% with your blank
-configuration files. After a reinstallation, you have to explicitely
-merge your files %%HORDEDIR%%/config/conf.php.new
-and %%HORDEDIR%%/config/conf.php.previous
-into %%HORDEDIR%%/config/conf.php .
+configuration files.
WARNING! the first user will get logged in as an administrator!
********
diff --git a/www/horde-passwd/files/pkg-deinstall.in b/www/horde-passwd/files/pkg-deinstall.in
index 7f79726e85c1..e3d33344b298 100644
--- a/www/horde-passwd/files/pkg-deinstall.in
+++ b/www/horde-passwd/files/pkg-deinstall.in
@@ -2,7 +2,6 @@
#
# $FreeBSD$
#
-# Backup horde-passwd config files, if needed.
if [ x$2 != xDEINSTALL ]; then
exit
@@ -12,13 +11,10 @@ if [ -z "${PACKAGE_BUILDING}" ]; then
for cf in `ls %%PWDDIR%%/config/*php`; do
diff -bBqw $cf $cf.dist >/dev/null 2>&1
case $? in
- 0) # original config file, will be deleted by pkg-plist
+ 0) # original config file, delete it
+ rm -f $cf
;;
- 1) # config file has been updated, must be backuped
- cp -p $cf $cf.previous
- echo "===> Backing-up..."
- echo "---> $cf has been saved ***"
- echo "---> as $cf.previous ***"
+ 1) # config file has been updated, leave it alone
;;
*) # not found?
;;
diff --git a/www/horde-passwd/files/pkg-install.in b/www/horde-passwd/files/pkg-install.in
new file mode 100644
index 000000000000..7ada28ff461b
--- /dev/null
+++ b/www/horde-passwd/files/pkg-install.in
@@ -0,0 +1,23 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+PATH=/usr/sbin:/usr/bin:/bin ; export PATH
+
+case $2 in
+ PRE-INSTALL)
+ ;;
+
+ POST-INSTALL)
+ if [ -z "${PACKAGE_BUILDING}" ]; then
+ # Copy over sample config files unless they already exist
+
+ for cf in `ls %%PWDDIR%%/config/*.dist | sed -e 's/\.dist//g'`; do
+ if [ ! -f $cf ]; then
+ cp -p $cf.dist $cf
+ fi
+ done
+ fi
+ ;;
+esac
diff --git a/www/horde/files/pkg-deinstall.in b/www/horde/files/pkg-deinstall.in
index 47cbca9552a2..7f9f6649e9fa 100644
--- a/www/horde/files/pkg-deinstall.in
+++ b/www/horde/files/pkg-deinstall.in
@@ -22,13 +22,10 @@ handle_config() {
for cf in `ls %%HORDEDIR%%/config/*php`; do
diff -bBqw $cf $cf.dist >/dev/null 2>&1
case $? in
- 0) # original config file, will be deleted by pkg-plist
+ 0) # original config file, delete
+ rm -f $cf
;;
- 1) # config file has been updated, must be backuped
- cp -p $cf $cf.previous
- echo "===> Backing-up..."
- echo "---> $cf has been saved ***"
- echo "---> as $cf.previous ***"
+ 1) # config file has been updated, leave it
;;
*) # not found?
;;
diff --git a/www/horde/files/pkg-install.in b/www/horde/files/pkg-install.in
index 28db88333734..a2dc1e225389 100644
--- a/www/horde/files/pkg-install.in
+++ b/www/horde/files/pkg-install.in
@@ -102,14 +102,11 @@ case $2 in
fi
if [ -z "${PACKAGE_BUILDING}" ]; then
- # Don't reset the config to default (PR ports/88621)
-
- for cf in `ls %%HORDEDIR%%/config/*php`; do
- if [ -f $cf.previous ]; then
- mv $cf $cf.new
- echo "---> $cf not installed ***"
- echo "---> please copy from $cf.previous ***"
- echo "---> or from $cf.new ***"
+ # Copy over sample config files unless they already exist
+
+ for cf in `ls %%HORDEDIR%%/config/*.dist | sed -e 's/\.dist//g'`; do
+ if [ ! -f $cf ]; then
+ cp -p $cf.dist $cf
fi
done
fi
diff --git a/www/horde/files/pkg-message.in b/www/horde/files/pkg-message.in
index c5a0ca6935e5..3226c28ff455 100644
--- a/www/horde/files/pkg-message.in
+++ b/www/horde/files/pkg-message.in
@@ -1,9 +1,6 @@
************************************************************************
Horde has been installed in %%HORDEDIR%% with your blank
-configuration files. After a reinstallation, you have to explicitely
-merge your files %%HORDEDIR%%/config/conf.php.new
-and %%HORDEDIR%%/config/conf.php.previous
-into %%HORDEDIR%%/config/conf.php .
+configuration files.
WARNING! the first user will get logged in as an administrator!
********
diff --git a/www/horde4-base/files/pkg-deinstall.in b/www/horde4-base/files/pkg-deinstall.in
index 47cbca9552a2..7f9f6649e9fa 100644
--- a/www/horde4-base/files/pkg-deinstall.in
+++ b/www/horde4-base/files/pkg-deinstall.in
@@ -22,13 +22,10 @@ handle_config() {
for cf in `ls %%HORDEDIR%%/config/*php`; do
diff -bBqw $cf $cf.dist >/dev/null 2>&1
case $? in
- 0) # original config file, will be deleted by pkg-plist
+ 0) # original config file, delete
+ rm -f $cf
;;
- 1) # config file has been updated, must be backuped
- cp -p $cf $cf.previous
- echo "===> Backing-up..."
- echo "---> $cf has been saved ***"
- echo "---> as $cf.previous ***"
+ 1) # config file has been updated, leave it
;;
*) # not found?
;;
diff --git a/www/horde4-base/files/pkg-install.in b/www/horde4-base/files/pkg-install.in
index 28db88333734..a2dc1e225389 100644
--- a/www/horde4-base/files/pkg-install.in
+++ b/www/horde4-base/files/pkg-install.in
@@ -102,14 +102,11 @@ case $2 in
fi
if [ -z "${PACKAGE_BUILDING}" ]; then
- # Don't reset the config to default (PR ports/88621)
-
- for cf in `ls %%HORDEDIR%%/config/*php`; do
- if [ -f $cf.previous ]; then
- mv $cf $cf.new
- echo "---> $cf not installed ***"
- echo "---> please copy from $cf.previous ***"
- echo "---> or from $cf.new ***"
+ # Copy over sample config files unless they already exist
+
+ for cf in `ls %%HORDEDIR%%/config/*.dist | sed -e 's/\.dist//g'`; do
+ if [ ! -f $cf ]; then
+ cp -p $cf.dist $cf
fi
done
fi
diff --git a/www/horde4-base/files/pkg-message.in b/www/horde4-base/files/pkg-message.in
index c5a0ca6935e5..3226c28ff455 100644
--- a/www/horde4-base/files/pkg-message.in
+++ b/www/horde4-base/files/pkg-message.in
@@ -1,9 +1,6 @@
************************************************************************
Horde has been installed in %%HORDEDIR%% with your blank
-configuration files. After a reinstallation, you have to explicitely
-merge your files %%HORDEDIR%%/config/conf.php.new
-and %%HORDEDIR%%/config/conf.php.previous
-into %%HORDEDIR%%/config/conf.php .
+configuration files.
WARNING! the first user will get logged in as an administrator!
********