aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlli Hauer <ohauer@FreeBSD.org>2013-03-27 16:19:19 +0000
committerOlli Hauer <ohauer@FreeBSD.org>2013-03-27 16:19:19 +0000
commitc54db8c7415e27ea524fcc1045d1197b02fd2852 (patch)
tree34eecf21d1e6bff52e0d15dc890667dee9613167
parentbdef052c5ab00f900dac454571e4f56bda372c99 (diff)
downloadports-c54db8c7415e27ea524fcc1045d1197b02fd2852.tar.gz
ports-c54db8c7415e27ea524fcc1045d1197b02fd2852.zip
Notes
-rw-r--r--www/Makefile1
-rw-r--r--www/mod_macro22/Makefile12
-rw-r--r--www/mod_macro24/Makefile34
-rw-r--r--www/mod_macro24/distinfo2
-rw-r--r--www/mod_macro24/pkg-descr6
5 files changed, 49 insertions, 6 deletions
diff --git a/www/Makefile b/www/Makefile
index d9efe4c885f0..646bd628ec4f 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -507,6 +507,7 @@
SUBDIR += mod_log_sql2
SUBDIR += mod_log_sql2-dtc
SUBDIR += mod_macro22
+ SUBDIR += mod_macro24
SUBDIR += mod_memcache
SUBDIR += mod_memcache_block
SUBDIR += mod_mono
diff --git a/www/mod_macro22/Makefile b/www/mod_macro22/Makefile
index 55f5cd359d39..77a892826b8b 100644
--- a/www/mod_macro22/Makefile
+++ b/www/mod_macro22/Makefile
@@ -1,9 +1,5 @@
-# Ports collection makefile for: mod_macro22
-# Date created: 31 May 2008
-# Whom: Lukasz Wasikowski <lukasz@wasikowski.net>
-#
+# Created by: Lukasz Wasikowski <lukasz@wasikowski.net>
# $FreeBSD$
-#
PORTNAME= mod_macro
PORTVERSION= 1.1.11
@@ -28,8 +24,12 @@ PORTDOCS= ${PORTNAME}.html
PORTSCOUT= limit:^1\.1\.
+OPTIONS_DEFINE= DOCS
+
+.include <bsd.port.options.mk>
+
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}/
${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} ${DOCSDIR}/
.endif
diff --git a/www/mod_macro24/Makefile b/www/mod_macro24/Makefile
new file mode 100644
index 000000000000..ba99098d4355
--- /dev/null
+++ b/www/mod_macro24/Makefile
@@ -0,0 +1,34 @@
+# $FreeBSD$
+
+PORTNAME= mod_macro
+PORTVERSION= 1.2.1
+CATEGORIES= www
+MASTER_SITES= http://www.cri.ensmp.fr/~coelho/mod_macro/
+
+MAINTAINER= lukasz@wasikowski.net
+COMMENT= Apache 2.4.x module for use macros in config files
+
+LICENSE= mod_macro
+LICENSE_NAME= mod_macro license (apache with postcard request)
+LICENSE_FILE= ${WRKSRC}/LICENSE
+LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
+
+MAKE_JOBS_SAFE= yes
+
+USE_APACHE= 24
+LATEST_LINK= mod_macro24
+AP_FAST_BUILD= yes
+AP_GENPLIST= yes
+PORTDOCS= ${PORTNAME}.html
+
+OPTIONS_DEFINE= DOCS
+
+.include <bsd.port.options.mk>
+
+post-install:
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${DOCSDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} ${DOCSDIR}/
+.endif
+
+.include <bsd.port.mk>
diff --git a/www/mod_macro24/distinfo b/www/mod_macro24/distinfo
new file mode 100644
index 000000000000..bca10d8ee057
--- /dev/null
+++ b/www/mod_macro24/distinfo
@@ -0,0 +1,2 @@
+SHA256 (mod_macro-1.2.1.tar.gz) = f22c6342b36526fb401dea4dba4c2b61a72083da973b9ca1c4777a77d5128fc3
+SIZE (mod_macro-1.2.1.tar.gz) = 16870
diff --git a/www/mod_macro24/pkg-descr b/www/mod_macro24/pkg-descr
new file mode 100644
index 000000000000..56b9607f76a5
--- /dev/null
+++ b/www/mod_macro24/pkg-descr
@@ -0,0 +1,6 @@
+mod_macro is a third-party module to the Apache Http Server, distributed with
+a BSD-style license like Apache. It allows the definition and use of macros
+within apache runtime configuration files. The syntax is a natural extension
+to apache html-like configuration style.
+
+WWW: http://www.cri.ensmp.fr/~coelho/mod_macro/