aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2002-11-23 14:18:47 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2002-11-23 14:18:47 +0000
commitccaff5eb61db4543b6b2c7ec214c36b021283754 (patch)
tree5ff5c54b7c6b74433ebd7ff1f165d0a8d4f7b110
parent137d75f63245468e5bd363d81da2cdad9f275823 (diff)
downloadports-ccaff5eb61db4543b6b2c7ec214c36b021283754.tar.gz
ports-ccaff5eb61db4543b6b2c7ec214c36b021283754.zip
Notes
-rw-r--r--devel/Makefile1
-rw-r--r--devel/aap/Makefile47
-rw-r--r--devel/aap/distinfo1
-rw-r--r--devel/aap/pkg-comment1
-rw-r--r--devel/aap/pkg-descr14
-rw-r--r--devel/aap/pkg-plist145
6 files changed, 209 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 1de59df091b8..20c7bdb2d238 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -8,6 +8,7 @@
SUBDIR += SN
SUBDIR += SpecTcl
SUBDIR += a2dev
+ SUBDIR += aap
SUBDIR += ac-archive
SUBDIR += acpicatools
SUBDIR += adabroker
diff --git a/devel/aap/Makefile b/devel/aap/Makefile
new file mode 100644
index 000000000000..19c9a70467e7
--- /dev/null
+++ b/devel/aap/Makefile
@@ -0,0 +1,47 @@
+# New ports collection makefile for: A-A-P Recipe Executive: aap
+# Date created: 28 October 2002
+# Whom: Bram Moolenaar <bram@a-a-p.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= aap
+PORTVERSION= 0.100
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= a-a-p
+DISTNAME= exec-${PORTVERSION}
+
+MAINTAINER= bram@a-a-p.org
+
+NO_WRKSUBDIR= yes
+
+USE_ZIP= yes
+USE_PYTHON= yes
+PLIST_SUB+= PORTVERSION=${PORTVERSION}
+
+# There is no Makefile for A-A-P; do the building and installing here.
+#
+# Building means compiling the Python files so that the .pyc and .pyo files are
+# generated.
+do-build:
+ cd ${WRKSRC}; ${PYTHON_CMD} -c "import compileall; compileall.compile_dir('.', 0)"
+ cd ${WRKSRC}; ${PYTHON_CMD} -O -c "import compileall; compileall.compile_dir('.', 0)"
+
+# The files are installed in lib/aap/Exec-${PORTVERSION} and below. Create
+# a symbolic link for bin/aap so that it's found in $PATH and still knows
+# where to find the Python modules.
+# Also create a link for share/doc/aap, so that more people can find the docs
+# without clobbering share/doc.
+do-install:
+ ${MKDIR} -m 0755 ${PREFIX}/lib/aap/Exec-${PORTVERSION}/doc
+ cd ${WRKSRC}; ${INSTALL_SCRIPT} *.py *.pyc *.pyo aap ${PREFIX}/lib/aap/Exec-${PORTVERSION}
+ cd ${WRKSRC}; ${INSTALL_DATA} -m 0744 COPYING README.txt filetype.txt default.aap ${PREFIX}/lib/aap/Exec-${PORTVERSION}
+ cd ${WRKSRC}; ${INSTALL_DATA} doc/*.html doc/exec.pdf ${PREFIX}/lib/aap/Exec-${PORTVERSION}/doc
+ cd ${PREFIX}/bin; ${LN} -fhs ../lib/aap/Exec-${PORTVERSION}/aap aap
+ cd ${PREFIX}/share/doc; ${LN} -fhs ../../lib/aap/Exec-${PORTVERSION}/doc aap
+
+test:
+ cd ${WRKSRC}; ./aap
+
+.include <bsd.port.mk>
diff --git a/devel/aap/distinfo b/devel/aap/distinfo
new file mode 100644
index 000000000000..ba25352d144c
--- /dev/null
+++ b/devel/aap/distinfo
@@ -0,0 +1 @@
+MD5 (exec-0.100.zip) = 22d40d2ae126c9adceac97057461ae0d
diff --git a/devel/aap/pkg-comment b/devel/aap/pkg-comment
new file mode 100644
index 000000000000..1cebd17fb40e
--- /dev/null
+++ b/devel/aap/pkg-comment
@@ -0,0 +1 @@
+A build tool alternative to make with internet access and CVS support
diff --git a/devel/aap/pkg-descr b/devel/aap/pkg-descr
new file mode 100644
index 000000000000..48bd11bfa37b
--- /dev/null
+++ b/devel/aap/pkg-descr
@@ -0,0 +1,14 @@
+A-A-P is an Open Source build tool. It does everything that make does in a
+better way. Includes internet access for uploading and downloading files.
+Integrated CVS support: obtain a module from a CVS server and check changes
+into a CVS server.
+
+Can be used to build programs, maintain web sites, distribute software,
+download and install an application, etc.
+
+Language: Python (version 1.5 or later)
+License: GNU GPL
+WWW: http://www.a-a-p.org/
+
+- Bram Moolenaar
+Bram@A-A-P.org
diff --git a/devel/aap/pkg-plist b/devel/aap/pkg-plist
new file mode 100644
index 000000000000..3dabff83d287
--- /dev/null
+++ b/devel/aap/pkg-plist
@@ -0,0 +1,145 @@
+bin/aap
+lib/aap/Exec-%%PORTVERSION%%/Action.py
+lib/aap/Exec-%%PORTVERSION%%/Action.pyc
+lib/aap/Exec-%%PORTVERSION%%/Action.pyo
+lib/aap/Exec-%%PORTVERSION%%/Args.py
+lib/aap/Exec-%%PORTVERSION%%/Args.pyc
+lib/aap/Exec-%%PORTVERSION%%/Args.pyo
+lib/aap/Exec-%%PORTVERSION%%/COPYING
+lib/aap/Exec-%%PORTVERSION%%/Cache.py
+lib/aap/Exec-%%PORTVERSION%%/Cache.pyc
+lib/aap/Exec-%%PORTVERSION%%/Cache.pyo
+lib/aap/Exec-%%PORTVERSION%%/Commands.py
+lib/aap/Exec-%%PORTVERSION%%/Commands.pyc
+lib/aap/Exec-%%PORTVERSION%%/Commands.pyo
+lib/aap/Exec-%%PORTVERSION%%/CopyMove.py
+lib/aap/Exec-%%PORTVERSION%%/CopyMove.pyc
+lib/aap/Exec-%%PORTVERSION%%/CopyMove.pyo
+lib/aap/Exec-%%PORTVERSION%%/Cvs.py
+lib/aap/Exec-%%PORTVERSION%%/Cvs.pyc
+lib/aap/Exec-%%PORTVERSION%%/Cvs.pyo
+lib/aap/Exec-%%PORTVERSION%%/Depend.py
+lib/aap/Exec-%%PORTVERSION%%/Depend.pyc
+lib/aap/Exec-%%PORTVERSION%%/Depend.pyo
+lib/aap/Exec-%%PORTVERSION%%/Dictlist.py
+lib/aap/Exec-%%PORTVERSION%%/Dictlist.pyc
+lib/aap/Exec-%%PORTVERSION%%/Dictlist.pyo
+lib/aap/Exec-%%PORTVERSION%%/DoAddDef.py
+lib/aap/Exec-%%PORTVERSION%%/DoAddDef.pyc
+lib/aap/Exec-%%PORTVERSION%%/DoAddDef.pyo
+lib/aap/Exec-%%PORTVERSION%%/DoArgs.py
+lib/aap/Exec-%%PORTVERSION%%/DoArgs.pyc
+lib/aap/Exec-%%PORTVERSION%%/DoArgs.pyo
+lib/aap/Exec-%%PORTVERSION%%/DoBuild.py
+lib/aap/Exec-%%PORTVERSION%%/DoBuild.pyc
+lib/aap/Exec-%%PORTVERSION%%/DoBuild.pyo
+lib/aap/Exec-%%PORTVERSION%%/DoRead.py
+lib/aap/Exec-%%PORTVERSION%%/DoRead.pyc
+lib/aap/Exec-%%PORTVERSION%%/DoRead.pyo
+lib/aap/Exec-%%PORTVERSION%%/Error.py
+lib/aap/Exec-%%PORTVERSION%%/Error.pyc
+lib/aap/Exec-%%PORTVERSION%%/Error.pyo
+lib/aap/Exec-%%PORTVERSION%%/Filetype.py
+lib/aap/Exec-%%PORTVERSION%%/Filetype.pyc
+lib/aap/Exec-%%PORTVERSION%%/Filetype.pyo
+lib/aap/Exec-%%PORTVERSION%%/Global.py
+lib/aap/Exec-%%PORTVERSION%%/Global.pyc
+lib/aap/Exec-%%PORTVERSION%%/Global.pyo
+lib/aap/Exec-%%PORTVERSION%%/Main.py
+lib/aap/Exec-%%PORTVERSION%%/Main.pyc
+lib/aap/Exec-%%PORTVERSION%%/Main.pyo
+lib/aap/Exec-%%PORTVERSION%%/Message.py
+lib/aap/Exec-%%PORTVERSION%%/Message.pyc
+lib/aap/Exec-%%PORTVERSION%%/Message.pyo
+lib/aap/Exec-%%PORTVERSION%%/Node.py
+lib/aap/Exec-%%PORTVERSION%%/Node.pyc
+lib/aap/Exec-%%PORTVERSION%%/Node.pyo
+lib/aap/Exec-%%PORTVERSION%%/ParsePos.py
+lib/aap/Exec-%%PORTVERSION%%/ParsePos.pyc
+lib/aap/Exec-%%PORTVERSION%%/ParsePos.pyo
+lib/aap/Exec-%%PORTVERSION%%/PkgInstall.py
+lib/aap/Exec-%%PORTVERSION%%/PkgInstall.pyc
+lib/aap/Exec-%%PORTVERSION%%/PkgInstall.pyo
+lib/aap/Exec-%%PORTVERSION%%/Port.py
+lib/aap/Exec-%%PORTVERSION%%/Port.pyc
+lib/aap/Exec-%%PORTVERSION%%/Port.pyo
+lib/aap/Exec-%%PORTVERSION%%/PrintProfile.py
+lib/aap/Exec-%%PORTVERSION%%/PrintProfile.pyc
+lib/aap/Exec-%%PORTVERSION%%/PrintProfile.pyo
+lib/aap/Exec-%%PORTVERSION%%/Process.py
+lib/aap/Exec-%%PORTVERSION%%/Process.pyc
+lib/aap/Exec-%%PORTVERSION%%/Process.pyo
+lib/aap/Exec-%%PORTVERSION%%/README.txt
+lib/aap/Exec-%%PORTVERSION%%/RecPos.py
+lib/aap/Exec-%%PORTVERSION%%/RecPos.pyc
+lib/aap/Exec-%%PORTVERSION%%/RecPos.pyo
+lib/aap/Exec-%%PORTVERSION%%/Remote.py
+lib/aap/Exec-%%PORTVERSION%%/Remote.pyc
+lib/aap/Exec-%%PORTVERSION%%/Remote.pyo
+lib/aap/Exec-%%PORTVERSION%%/Rule.py
+lib/aap/Exec-%%PORTVERSION%%/Rule.pyc
+lib/aap/Exec-%%PORTVERSION%%/Rule.pyo
+lib/aap/Exec-%%PORTVERSION%%/Sign.py
+lib/aap/Exec-%%PORTVERSION%%/Sign.pyc
+lib/aap/Exec-%%PORTVERSION%%/Sign.pyo
+lib/aap/Exec-%%PORTVERSION%%/Util.py
+lib/aap/Exec-%%PORTVERSION%%/Util.pyc
+lib/aap/Exec-%%PORTVERSION%%/Util.pyo
+lib/aap/Exec-%%PORTVERSION%%/VersCont.py
+lib/aap/Exec-%%PORTVERSION%%/VersCont.pyc
+lib/aap/Exec-%%PORTVERSION%%/VersCont.pyo
+lib/aap/Exec-%%PORTVERSION%%/Version.py
+lib/aap/Exec-%%PORTVERSION%%/Version.pyc
+lib/aap/Exec-%%PORTVERSION%%/Version.pyo
+lib/aap/Exec-%%PORTVERSION%%/Work.py
+lib/aap/Exec-%%PORTVERSION%%/Work.pyc
+lib/aap/Exec-%%PORTVERSION%%/Work.pyo
+lib/aap/Exec-%%PORTVERSION%%/__init__.py
+lib/aap/Exec-%%PORTVERSION%%/__init__.pyc
+lib/aap/Exec-%%PORTVERSION%%/__init__.pyo
+lib/aap/Exec-%%PORTVERSION%%/aap
+lib/aap/Exec-%%PORTVERSION%%/aapnetrc.py
+lib/aap/Exec-%%PORTVERSION%%/aapnetrc.pyc
+lib/aap/Exec-%%PORTVERSION%%/aapnetrc.pyo
+lib/aap/Exec-%%PORTVERSION%%/default.aap
+lib/aap/Exec-%%PORTVERSION%%/doc/exec.pdf
+lib/aap/Exec-%%PORTVERSION%%/doc/index.html
+lib/aap/Exec-%%PORTVERSION%%/doc/license.html
+lib/aap/Exec-%%PORTVERSION%%/doc/ln12.html
+lib/aap/Exec-%%PORTVERSION%%/doc/p1181.html
+lib/aap/Exec-%%PORTVERSION%%/doc/p27.html
+lib/aap/Exec-%%PORTVERSION%%/doc/p771.html
+lib/aap/Exec-%%PORTVERSION%%/doc/p836.html
+lib/aap/Exec-%%PORTVERSION%%/doc/ref-arguments.html
+lib/aap/Exec-%%PORTVERSION%%/doc/ref-attributes.html
+lib/aap/Exec-%%PORTVERSION%%/doc/ref-commands.html
+lib/aap/Exec-%%PORTVERSION%%/doc/ref-syntax.html
+lib/aap/Exec-%%PORTVERSION%%/doc/ref-variables.html
+lib/aap/Exec-%%PORTVERSION%%/doc/tutor-actions.html
+lib/aap/Exec-%%PORTVERSION%%/doc/tutor-compile.html
+lib/aap/Exec-%%PORTVERSION%%/doc/tutor-cvs.html
+lib/aap/Exec-%%PORTVERSION%%/doc/tutor-distribute.html
+lib/aap/Exec-%%PORTVERSION%%/doc/tutor-include.html
+lib/aap/Exec-%%PORTVERSION%%/doc/tutor-pipe.html
+lib/aap/Exec-%%PORTVERSION%%/doc/tutor-port.html
+lib/aap/Exec-%%PORTVERSION%%/doc/tutor-python.html
+lib/aap/Exec-%%PORTVERSION%%/doc/tutor-start.html
+lib/aap/Exec-%%PORTVERSION%%/doc/tutor-variant.html
+lib/aap/Exec-%%PORTVERSION%%/doc/tutor-website.html
+lib/aap/Exec-%%PORTVERSION%%/doc/user-autodep.html
+lib/aap/Exec-%%PORTVERSION%%/doc/user-cvs.html
+lib/aap/Exec-%%PORTVERSION%%/doc/user-debug.html
+lib/aap/Exec-%%PORTVERSION%%/doc/user-depend.html
+lib/aap/Exec-%%PORTVERSION%%/doc/user-fetch.html
+lib/aap/Exec-%%PORTVERSION%%/doc/user-filetype.html
+lib/aap/Exec-%%PORTVERSION%%/doc/user-issue.html
+lib/aap/Exec-%%PORTVERSION%%/doc/user-porting.html
+lib/aap/Exec-%%PORTVERSION%%/doc/user-publish.html
+lib/aap/Exec-%%PORTVERSION%%/doc/user-python.html
+lib/aap/Exec-%%PORTVERSION%%/doc/user-variant.html
+lib/aap/Exec-%%PORTVERSION%%/doc/user-version.html
+lib/aap/Exec-%%PORTVERSION%%/filetype.txt
+share/doc/aap
+@dirrm lib/aap/Exec-%%PORTVERSION%%/doc
+@dirrm lib/aap/Exec-%%PORTVERSION%%
+@unexec rmdir %D/lib/aap 2>/dev/null || true