aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Zverev <az@FreeBSD.org>2012-06-05 07:44:03 +0000
committerAndrej Zverev <az@FreeBSD.org>2012-06-05 07:44:03 +0000
commitcd14f625221f76ff658c90e1b7883f843e7aa6e2 (patch)
treee57ec24730f8313d6d5755c3b470c4528fcea8df
parent7338ec6fb1d45a32faa14ccbf54da7d02717fef0 (diff)
downloadports-cd14f625221f76ff658c90e1b7883f843e7aa6e2.tar.gz
ports-cd14f625221f76ff658c90e1b7883f843e7aa6e2.zip
Notes
-rw-r--r--www/p5-Apache-MP3/Makefile10
-rw-r--r--www/p5-Bigtop/Makefile6
-rw-r--r--www/p5-CGI-Kwiki/Makefile4
-rw-r--r--www/p5-CGI-Untaint-email/Makefile6
-rw-r--r--www/p5-CGI-XMLApplication/Makefile4
-rw-r--r--www/p5-Catalyst-Plugin-Browser/Makefile2
-rw-r--r--www/p5-Catalyst-Plugin-Captcha/Makefile6
-rw-r--r--www/p5-HTML-TokeParser-Simple/Makefile4
-rw-r--r--www/p5-Markup-Perl/Makefile2
-rw-r--r--www/p5-Maypole/Makefile2
-rw-r--r--www/p5-POE-Component-Client-UserAgent/Makefile4
-rw-r--r--www/p5-Syntax-Highlight-Shell/Makefile2
-rw-r--r--www/p5-Template-Plugin-MP3/Makefile4
-rw-r--r--www/p5-WWW-Dilbert/Makefile4
-rw-r--r--www/p5-WebService-CIA/Makefile6
15 files changed, 33 insertions, 33 deletions
diff --git a/www/p5-Apache-MP3/Makefile b/www/p5-Apache-MP3/Makefile
index 3e2b78544091..137f898c4f6a 100644
--- a/www/p5-Apache-MP3/Makefile
+++ b/www/p5-Apache-MP3/Makefile
@@ -15,11 +15,11 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= MP3 browsing and streaming under mod_perl and Apache
-BUILD_DEPENDS= ${SITE_PERL}/Audio/Wav.pm:${PORTSDIR}/audio/p5-Audio-Wav \
- ${SITE_PERL}/CGI/Session.pm:${PORTSDIR}/www/p5-CGI-Session \
- ${SITE_PERL}/MP3/Info.pm:${PORTSDIR}/audio/p5-MP3-Info \
- ${SITE_PERL}/${PERL_ARCH}/Ogg/Vorbis/Header.pm:${PORTSDIR}/audio/p5-Ogg-Vorbis-Header \
- ${SITE_PERL}/${PERL_ARCH}/mod_perl2.pm:${PORTSDIR}/www/mod_perl2
+BUILD_DEPENDS= p5-Audio-Wav>=0:${PORTSDIR}/audio/p5-Audio-Wav \
+ p5-CGI-Session>=0:${PORTSDIR}/www/p5-CGI-Session \
+ p5-MP3-Info>=0:${PORTSDIR}/audio/p5-MP3-Info \
+ p5-Ogg-Vorbis-Header>=0:${PORTSDIR}/audio/p5-Ogg-Vorbis-Header \
+ mod_perl2>=0:${PORTSDIR}/www/mod_perl2
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= YES
diff --git a/www/p5-Bigtop/Makefile b/www/p5-Bigtop/Makefile
index 08eb9e964739..e9acf6f48931 100644
--- a/www/p5-Bigtop/Makefile
+++ b/www/p5-Bigtop/Makefile
@@ -14,9 +14,9 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= A web application data language processor
-RUN_DEPENDS= ${SITE_PERL}/Config/General.pm:${PORTSDIR}/devel/p5-Config-General \
- ${SITE_PERL}/IO/Prompt.pm:${PORTSDIR}/devel/p5-IO-Prompt \
- ${SITE_PERL}/Parse/RecDescent.pm:${PORTSDIR}/devel/p5-Parse-RecDescent \
+RUN_DEPENDS= p5-Config-General>=0:${PORTSDIR}/devel/p5-Config-General \
+ p5-IO-Prompt>=0:${PORTSDIR}/devel/p5-IO-Prompt \
+ p5-Parse-RecDescent>=0:${PORTSDIR}/devel/p5-Parse-RecDescent \
p5-File-HomeDir>=0:${PORTSDIR}/devel/p5-File-HomeDir \
p5-DBIx-Class>=0:${PORTSDIR}/databases/p5-DBIx-Class \
p5-JSON>=0:${PORTSDIR}/converters/p5-JSON \
diff --git a/www/p5-CGI-Kwiki/Makefile b/www/p5-CGI-Kwiki/Makefile
index 77c61fd424b8..573ae875f19c 100644
--- a/www/p5-CGI-Kwiki/Makefile
+++ b/www/p5-CGI-Kwiki/Makefile
@@ -15,9 +15,9 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= A Quickie Wiki Package that's not too Tricky
-BUILD_DEPENDS= ${SITE_PERL}/CGI.pm:${PORTSDIR}/www/p5-CGI.pm
+BUILD_DEPENDS= p5-CGI.pm>=0:${PORTSDIR}/www/p5-CGI.pm
RUN_DEPENDS:= ${BUILD_DEPENDS} \
- ${SITE_PERL}/Locale/Maketext.pm:${PORTSDIR}/devel/p5-Locale-Maketext
+ p5-Locale-Maketext>=0:${PORTSDIR}/devel/p5-Locale-Maketext
PERL_CONFIGURE= yes
diff --git a/www/p5-CGI-Untaint-email/Makefile b/www/p5-CGI-Untaint-email/Makefile
index 37aa5b81094d..8bea58c21c50 100644
--- a/www/p5-CGI-Untaint-email/Makefile
+++ b/www/p5-CGI-Untaint-email/Makefile
@@ -14,9 +14,9 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Validate an email address in a CGI form
-RUN_DEPENDS= ${SITE_PERL}/CGI/Untaint.pm:${PORTSDIR}/www/p5-CGI-Untaint \
- ${SITE_PERL}/Email/Valid.pm:${PORTSDIR}/mail/p5-Email-Valid \
- ${SITE_PERL}/Mail/Address.pm:${PORTSDIR}/mail/p5-Mail-Tools
+RUN_DEPENDS= p5-CGI-Untaint>=0:${PORTSDIR}/www/p5-CGI-Untaint \
+ p5-Email-Valid>=0:${PORTSDIR}/mail/p5-Email-Valid \
+ p5-Mail-Tools>=0:${PORTSDIR}/mail/p5-Mail-Tools
BUILD_DEPENDS= ${RUN_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/www/p5-CGI-XMLApplication/Makefile b/www/p5-CGI-XMLApplication/Makefile
index 905dce4587fa..53ea74c53e80 100644
--- a/www/p5-CGI-XMLApplication/Makefile
+++ b/www/p5-CGI-XMLApplication/Makefile
@@ -14,8 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Object Oriented Interface for CGI Script Applications
-RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/XML/LibXML.pm:${PORTSDIR}/textproc/p5-XML-LibXML \
- ${SITE_PERL}/${PERL_ARCH}/XML/LibXSLT.pm:${PORTSDIR}/textproc/p5-XML-LibXSLT
+RUN_DEPENDS= p5-XML-LibXML>=0:${PORTSDIR}/textproc/p5-XML-LibXML \
+ p5-XML-LibXSLT>=0:${PORTSDIR}/textproc/p5-XML-LibXSLT
BUILD_DEPENDS= ${RUN_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/www/p5-Catalyst-Plugin-Browser/Makefile b/www/p5-Catalyst-Plugin-Browser/Makefile
index 6c5073a946fb..85110e6de9cb 100644
--- a/www/p5-Catalyst-Plugin-Browser/Makefile
+++ b/www/p5-Catalyst-Plugin-Browser/Makefile
@@ -14,7 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Browser Detection for Catalyst
-BUILD_DEPENDS= ${SITE_PERL}/Catalyst.pm:${PORTSDIR}/www/p5-Catalyst-Runtime \
+BUILD_DEPENDS= p5-Catalyst-Runtime>=0:${PORTSDIR}/www/p5-Catalyst-Runtime \
p5-Catalyst-TraitFor-Request-BrowserDetect>=0:${PORTSDIR}/www/p5-Catalyst-TraitFor-Request-BrowserDetect
RUN_DEPENDS:= ${BUILD_DEPENDS}
diff --git a/www/p5-Catalyst-Plugin-Captcha/Makefile b/www/p5-Catalyst-Plugin-Captcha/Makefile
index d775068a5900..391b1fc5e287 100644
--- a/www/p5-Catalyst-Plugin-Captcha/Makefile
+++ b/www/p5-Catalyst-Plugin-Captcha/Makefile
@@ -16,9 +16,9 @@ MAINTAINER= perl@FreeBSD.org
COMMENT= Create and validate Captcha for Catalyst
BUILD_DEPENDS= p5-Catalyst-Runtime>=5.7000:${PORTSDIR}/www/p5-Catalyst-Runtime \
- ${SITE_PERL}/Catalyst/Plugin/Session.pm:${PORTSDIR}/www/p5-Catalyst-Plugin-Session \
- ${SITE_PERL}/HTTP/Date.pm:${PORTSDIR}/www/p5-libwww \
- ${SITE_PERL}/GD/SecurityImage.pm:${PORTSDIR}/security/p5-GD-SecurityImage
+ p5-Catalyst-Plugin-Session>=0:${PORTSDIR}/www/p5-Catalyst-Plugin-Session \
+ p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
+ p5-GD-SecurityImage>=0:${PORTSDIR}/security/p5-GD-SecurityImage
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/www/p5-HTML-TokeParser-Simple/Makefile b/www/p5-HTML-TokeParser-Simple/Makefile
index 7d26aecad784..3c17f521efb6 100644
--- a/www/p5-HTML-TokeParser-Simple/Makefile
+++ b/www/p5-HTML-TokeParser-Simple/Makefile
@@ -14,8 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Subclass of HTML::TokeParser with easy-to-remember method calls
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/HTML/Parser.pm:${PORTSDIR}/www/p5-HTML-Parser \
- ${SITE_PERL}/Sub/Override.pm:${PORTSDIR}/devel/p5-Sub-Override
+BUILD_DEPENDS= p5-HTML-Parser>=0:${PORTSDIR}/www/p5-HTML-Parser \
+ p5-Sub-Override>=0:${PORTSDIR}/devel/p5-Sub-Override
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/www/p5-Markup-Perl/Makefile b/www/p5-Markup-Perl/Makefile
index 9a452566dd23..a4fed980526b 100644
--- a/www/p5-Markup-Perl/Makefile
+++ b/www/p5-Markup-Perl/Makefile
@@ -24,7 +24,7 @@ MAN3= Markup::Perl.3
.include <bsd.port.pre.mk>
.if ${PERL_LEVEL} < 500805
-RUN_DEPENDS= ${SITE_PERL}/CGI.pm:${PORTSDIR}/www/p5-CGI.pm
+RUN_DEPENDS= p5-CGI.pm>=0:${PORTSDIR}/www/p5-CGI.pm
.endif
.include <bsd.port.post.mk>
diff --git a/www/p5-Maypole/Makefile b/www/p5-Maypole/Makefile
index 63a61c5f743a..53c95867f419 100644
--- a/www/p5-Maypole/Makefile
+++ b/www/p5-Maypole/Makefile
@@ -53,7 +53,7 @@ PERL_CONFIGURE= yes
.if ${PORT_OPTIONS:MMODPERL2}
USE_APACHE_RUN= 20+
-BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Apache2/Request.pm:${PORTSDIR}/www/p5-libapreq2
+BUILD_DEPENDS+= p5-libapreq2>=0:${PORTSDIR}/www/p5-libapreq2
.endif
PKGMESSAGE= ${WRKDIR}/pkg-message
diff --git a/www/p5-POE-Component-Client-UserAgent/Makefile b/www/p5-POE-Component-Client-UserAgent/Makefile
index 50cb4ac21895..780fe8536560 100644
--- a/www/p5-POE-Component-Client-UserAgent/Makefile
+++ b/www/p5-POE-Component-Client-UserAgent/Makefile
@@ -15,8 +15,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= LWP and LWP::Parallel based POE component
-BUILD_DEPENDS= ${SITE_PERL}/POE.pm:${PORTSDIR}/devel/p5-POE \
- ${SITE_PERL}/LWP/Parallel.pm:${PORTSDIR}/www/p5-ParallelUA
+BUILD_DEPENDS= p5-POE>=0:${PORTSDIR}/devel/p5-POE \
+ p5-ParallelUA>=0:${PORTSDIR}/www/p5-ParallelUA
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/www/p5-Syntax-Highlight-Shell/Makefile b/www/p5-Syntax-Highlight-Shell/Makefile
index a07342083fe1..5097619eca51 100644
--- a/www/p5-Syntax-Highlight-Shell/Makefile
+++ b/www/p5-Syntax-Highlight-Shell/Makefile
@@ -14,7 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Syntax::Highlight::Shell - Highlight shell scripts
-BUILD_DEPENDS= ${SITE_PERL}/Shell/Parser.pm:${PORTSDIR}/devel/p5-Shell-Parser
+BUILD_DEPENDS= p5-Shell-Parser>=0:${PORTSDIR}/devel/p5-Shell-Parser
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/www/p5-Template-Plugin-MP3/Makefile b/www/p5-Template-Plugin-MP3/Makefile
index 5b2fa5b9c9c0..b5f89bb9d72a 100644
--- a/www/p5-Template-Plugin-MP3/Makefile
+++ b/www/p5-Template-Plugin-MP3/Makefile
@@ -14,8 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= TT Plugin that wraps around the MP3::Info module
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Template.pm:${PORTSDIR}/www/p5-Template-Toolkit \
- ${SITE_PERL}/MP3/Info.pm:${PORTSDIR}/audio/p5-MP3-Info
+BUILD_DEPENDS= p5-Template-Toolkit>=0:${PORTSDIR}/www/p5-Template-Toolkit \
+ p5-MP3-Info>=0:${PORTSDIR}/audio/p5-MP3-Info
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/www/p5-WWW-Dilbert/Makefile b/www/p5-WWW-Dilbert/Makefile
index 4a68c57a3058..a4195f09bf1b 100644
--- a/www/p5-WWW-Dilbert/Makefile
+++ b/www/p5-WWW-Dilbert/Makefile
@@ -15,9 +15,9 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Dilbert of the day comic strip archive and retrieval module
-RUN_DEPENDS= ${SITE_PERL}/LWP/Simple.pm:${PORTSDIR}/www/p5-libwww
+RUN_DEPENDS= p5-libwww>=0:${PORTSDIR}/www/p5-libwww
BUILD_DEPENDS= ${RUN_DEPENDS}
-BUILD_DEPENDS+= ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
+BUILD_DEPENDS+= p5-Test-Simple>=0:${PORTSDIR}/devel/p5-Test-Simple
PERL_MODBUILD= yes
diff --git a/www/p5-WebService-CIA/Makefile b/www/p5-WebService-CIA/Makefile
index 1f7bbdd13a18..0bcf891d9056 100644
--- a/www/p5-WebService-CIA/Makefile
+++ b/www/p5-WebService-CIA/Makefile
@@ -14,9 +14,9 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Information from the CIA World Factbook
-RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Crypt/SSLeay.pm:${PORTSDIR}/security/p5-Crypt-SSLeay \
- ${SITE_PERL}/LWP/UserAgent.pm:${PORTSDIR}/www/p5-libwww \
- ${SITE_PERL}/MLDBM.pm:${PORTSDIR}/databases/p5-MLDBM
+RUN_DEPENDS= p5-Crypt-SSLeay>=0:${PORTSDIR}/security/p5-Crypt-SSLeay \
+ p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
+ p5-MLDBM>=0:${PORTSDIR}/databases/p5-MLDBM
BUILD_DEPENDS= ${RUN_DEPENDS}
CONFIGURE_ARGS= </dev/null