aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-10-14 08:01:13 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-10-14 08:01:13 +0000
commitd19d17bd6460250c91329c24e0545c66c1c17d7c (patch)
treea24abebc7b4d4a1a4ecbd6f2f871ffd7f3a282ef
parent1ff1600008f5c120acd04a536ab14c0bfd8783d7 (diff)
downloadports-d19d17bd6460250c91329c24e0545c66c1c17d7c.tar.gz
ports-d19d17bd6460250c91329c24e0545c66c1c17d7c.zip
Notes
-rw-r--r--Mk/Uses/qt-dist.mk13
-rw-r--r--accessibility/qt5-speech/Makefile2
-rw-r--r--comms/qt5-sensors/Makefile2
-rw-r--r--comms/qt5-serialport/Makefile2
-rw-r--r--databases/qt5-sql/Makefile2
-rw-r--r--devel/qt5-assistant/Makefile2
-rw-r--r--devel/qt5-buildtools/Makefile2
-rw-r--r--devel/qt5-concurrent/Makefile2
-rw-r--r--devel/qt5-core/Makefile2
-rw-r--r--devel/qt5-dbus/Makefile2
-rw-r--r--devel/qt5-designer/Makefile2
-rw-r--r--devel/qt5-help/Makefile2
-rw-r--r--devel/qt5-linguisttools/Makefile2
-rw-r--r--devel/qt5-location/Makefile2
-rw-r--r--devel/qt5-qdbus/Makefile2
-rw-r--r--devel/qt5-qmake/Makefile2
-rw-r--r--devel/qt5-script/Makefile4
-rw-r--r--devel/qt5-scripttools/Makefile2
-rw-r--r--devel/qt5-testlib/Makefile2
-rw-r--r--devel/qt5-uitools/Makefile2
-rw-r--r--devel/qt5/Makefile.sqldrivers2
-rw-r--r--devel/qt5/files/extra-patch-mkspecs_common_g++-base.conf20
-rw-r--r--devel/qt5/files/extra-patch-mkspecs_common_gcc-base.conf11
-rw-r--r--graphics/qt5-imageformats/Makefile2
-rw-r--r--graphics/qt5-opengl/Makefile2
-rw-r--r--graphics/qt5-svg/Makefile2
-rw-r--r--lang/qt5-qml/Makefile4
-rw-r--r--multimedia/qt5-multimedia/Makefile3
-rw-r--r--net/qt5-network/Makefile2
-rw-r--r--print/qt5-printsupport/Makefile2
-rw-r--r--sysutils/qt5-qtpaths/Makefile2
-rw-r--r--textproc/qt5-xml/Makefile2
-rw-r--r--textproc/qt5-xmlpatterns/Makefile4
-rw-r--r--www/qt5-webchannel/Makefile2
-rw-r--r--x11-toolkits/qt5-gui/Makefile2
-rw-r--r--x11-toolkits/qt5-quick/Makefile3
-rw-r--r--x11-toolkits/qt5-quickcontrols/Makefile2
-rw-r--r--x11-toolkits/qt5-quickcontrols2/Makefile2
-rw-r--r--x11-toolkits/qt5-virtualkeyboard/Makefile2
-rw-r--r--x11-toolkits/qt5-widgets/Makefile2
-rw-r--r--x11/qt5-x11extras/Makefile2
41 files changed, 83 insertions, 45 deletions
diff --git a/Mk/Uses/qt-dist.mk b/Mk/Uses/qt-dist.mk
index 225fb2c2ca58..db8427aa7132 100644
--- a/Mk/Uses/qt-dist.mk
+++ b/Mk/Uses/qt-dist.mk
@@ -196,6 +196,11 @@ _EXTRA_PATCHES_QT4+= ${PORTSDIR}/devel/${_QT_RELNAME}/files/extrapatch-aarch64
_EXTRA_PATCHES_QT5= ${PORTSDIR}/devel/${_QT_RELNAME}/files/extrapatch-mkspecs_features_create__cmake.prf \
${PORTSDIR}/devel/${_QT_RELNAME}/files/extrapatch-mkspecs_features_qt__module.prf \
${PORTSDIR}/devel/${_QT_RELNAME}/files/extrapatch-mkspecs_common_bsd_bsd.conf
+. if ${ARCH:Mmips*} || ${ARCH:Mpowerpc*} || ${ARCH} == sparc64
+_EXTRA_PATCHES_QT5+= ${PORTSDIR}/devel/${_QT_RELNAME}/files/extra-patch-mkspecs_common_g++-base.conf \
+ ${PORTSDIR}/devel/${_QT_RELNAME}/files/extra-patch-mkspecs_common_gcc-base.conf
+USE_GCC= yes
+. endif
. endif
EXTRA_PATCHES?= ${PORTSDIR}/devel/${_QT_RELNAME}/files/extrapatch-configure \
${_EXTRA_PATCHES_QT4} ${_EXTRA_PATCHES_QT5}
@@ -268,6 +273,14 @@ _QT_TOOLS+= ${UIC}
# other QtBase ports. See below.
_QT5_BASE= core dbus gui network sql widgets
+.if ${_QT_VER:M5}
+post-patch: gcc-post-patch
+gcc-post-patch:
+ ${REINPLACE_CMD} 's|%%LOCALBASE%%|${LOCALBASE}|' ${WRKSRC}/mkspecs/common/gcc-base.conf
+ ${REINPLACE_CMD} 's|%%GCC_DEFAULT%%|${GCC_DEFAULT}|' ${WRKSRC}/mkspecs/common/gcc-base.conf \
+ ${WRKSRC}/mkspecs/common/g++-base.conf
+.endif
+
pre-configure: qtbase-pre-configure
qtbase-pre-configure:
. for tool in ${_QT_TOOLS}
diff --git a/accessibility/qt5-speech/Makefile b/accessibility/qt5-speech/Makefile
index 22bf69b4fe70..4da2e231ac51 100644
--- a/accessibility/qt5-speech/Makefile
+++ b/accessibility/qt5-speech/Makefile
@@ -10,7 +10,7 @@ COMMENT= Accessibilty features for Qt5
LIB_DEPENDS= libspeechd.so:accessibility/speech-dispatcher
-USES= pkgconfig qmake:outsource qt-dist:5,speech
+USES= compiler:c++11-lang pkgconfig qmake:outsource qt-dist:5,speech
USE_QT= core gui buildtools_build qmake_build
.include <bsd.port.mk>
diff --git a/comms/qt5-sensors/Makefile b/comms/qt5-sensors/Makefile
index 28616607e7ae..511812087551 100644
--- a/comms/qt5-sensors/Makefile
+++ b/comms/qt5-sensors/Makefile
@@ -9,7 +9,7 @@ MAINTAINER= kde@FreeBSD.org
COMMENT= Qt sensors module
USE_QT= core qml quick buildtools_build
-USES= qmake:norecursive qt-dist:5,sensors
+USES= compiler:c++11-lang qmake:norecursive qt-dist:5,sensors
USE_LDCONFIG= ${PREFIX}/${QT_LIBDIR_REL}
diff --git a/comms/qt5-serialport/Makefile b/comms/qt5-serialport/Makefile
index 54fdd7e8dfd3..ed28b40448fd 100644
--- a/comms/qt5-serialport/Makefile
+++ b/comms/qt5-serialport/Makefile
@@ -9,7 +9,7 @@ MAINTAINER= kde@FreeBSD.org
COMMENT= Qt functions to access serial ports
USE_QT= core buildtools_build
-USES= qmake qt-dist:5,serialport
+USES= compiler:c++11-lang libtool qmake qt-dist:5,serialport
USE_LDCONFIG= ${PREFIX}/${QT_LIBDIR_REL}
.include <bsd.port.mk>
diff --git a/databases/qt5-sql/Makefile b/databases/qt5-sql/Makefile
index fc004a64b94a..ae52f74ffee6 100644
--- a/databases/qt5-sql/Makefile
+++ b/databases/qt5-sql/Makefile
@@ -8,7 +8,7 @@ PKGNAMEPREFIX= qt5-
MAINTAINER= kde@FreeBSD.org
COMMENT= Qt SQL database integration module
-USES= qmake:no_env qt-dist:5,base
+USES= compiler:c++11-lang qmake:no_env qt-dist:5,base
USE_QT= core qmake_build buildtools_build
HAS_CONFIGURE= yes
CONFIGURE_ARGS= -no-gui -no-xcb
diff --git a/devel/qt5-assistant/Makefile b/devel/qt5-assistant/Makefile
index df3301d06515..f23a2dd64b37 100644
--- a/devel/qt5-assistant/Makefile
+++ b/devel/qt5-assistant/Makefile
@@ -10,7 +10,7 @@ COMMENT= Qt 5 documentation browser
USE_QT= core gui help network printsupport sql widgets \
buildtools_build sql-sqlite3_run
-USES= qmake qt-dist:5,tools
+USES= compiler:c++11-lang qmake qt-dist:5,tools
DESKTOP_ENTRIES="Qt 5 Assistant" "" \
"${PREFIX}/share/pixmaps/assistant-qt5.png" \
diff --git a/devel/qt5-buildtools/Makefile b/devel/qt5-buildtools/Makefile
index 9e599a819614..ab86eed4f1f4 100644
--- a/devel/qt5-buildtools/Makefile
+++ b/devel/qt5-buildtools/Makefile
@@ -8,7 +8,7 @@ PKGNAMEPREFIX= qt5-
MAINTAINER= kde@FreeBSD.org
COMMENT= Qt build tools
-USES= perl5 qmake:no_env qt-dist:5,base
+USES= compiler:c++11-lang libtool perl5 qmake:no_env qt-dist:5,base
HAS_CONFIGURE= yes
CONFIGURE_ARGS= -no-gui -no-xcb
USE_LDCONFIG= ${PREFIX}/${QT_LIBDIR_REL}
diff --git a/devel/qt5-concurrent/Makefile b/devel/qt5-concurrent/Makefile
index b9fd86f08012..cc9b3a04fc51 100644
--- a/devel/qt5-concurrent/Makefile
+++ b/devel/qt5-concurrent/Makefile
@@ -8,7 +8,7 @@ PKGNAMEPREFIX= qt5-
MAINTAINER= kde@FreeBSD.org
COMMENT= Qt multi-threading module
-USES= qmake:no_env qt-dist:5,base
+USES= compiler:c++11-lang qmake:no_env qt-dist:5,base
USE_QT= core qmake_build buildtools_build
HAS_CONFIGURE= yes
CONFIGURE_ARGS= -no-gui -no-xcb
diff --git a/devel/qt5-core/Makefile b/devel/qt5-core/Makefile
index e6012be7cbfd..464defa9ea59 100644
--- a/devel/qt5-core/Makefile
+++ b/devel/qt5-core/Makefile
@@ -11,7 +11,7 @@ COMMENT= Qt core non-graphical module
LIB_DEPENDS= libicui18n.so:devel/icu \
libpcre2-posix.so:devel/pcre2
-USES= qmake:no_env qt-dist:5,base
+USES= compiler:c++11-lang gnome qmake:no_env qt-dist:5,base
USE_GNOME= glib20
USE_QT= qmake_build buildtools_build
HAS_CONFIGURE= yes
diff --git a/devel/qt5-dbus/Makefile b/devel/qt5-dbus/Makefile
index 8ae9f09b63e1..bb1b65531d34 100644
--- a/devel/qt5-dbus/Makefile
+++ b/devel/qt5-dbus/Makefile
@@ -10,7 +10,7 @@ COMMENT= Qt D-Bus inter-process communication module
LIB_DEPENDS= libdbus-1.so:devel/dbus
-USES= qmake:no_env qt-dist:5,base
+USES= compiler:c++11-lang qmake:no_env qt-dist:5,base
USE_QT= core qmake_build buildtools_build
HAS_CONFIGURE= yes
CONFIGURE_ARGS= -no-gui -no-xcb
diff --git a/devel/qt5-designer/Makefile b/devel/qt5-designer/Makefile
index d6efdf9590c2..9f4986373ae6 100644
--- a/devel/qt5-designer/Makefile
+++ b/devel/qt5-designer/Makefile
@@ -10,7 +10,7 @@ COMMENT= Qt 5 graphical user interface designer
USE_QT= assistant_run core gui network printsupport quick uiplugin \
widgets xml buildtools_build
-USES= qmake qt-dist:5,tools
+USES= compiler:c++11-lang qmake qt-dist:5,tools
USE_LDCONFIG= ${PREFIX}/${QT_LIBDIR_REL}
DESKTOP_ENTRIES="Qt 5 Designer" "" \
diff --git a/devel/qt5-help/Makefile b/devel/qt5-help/Makefile
index 213c3d732f25..46cca30e9036 100644
--- a/devel/qt5-help/Makefile
+++ b/devel/qt5-help/Makefile
@@ -10,7 +10,7 @@ COMMENT= Qt online help integration module
USE_QT= core gui network sql widgets \
buildtools_build sql-sqlite3_run
-USES= qmake qt-dist:5,tools
+USES= compiler:c++11-lang qmake qt-dist:5,tools
USE_LDCONFIG= ${PREFIX}/${QT_LIBDIR_REL}
BUILD_WRKSRC= ${WRKSRC}/src/assistant
diff --git a/devel/qt5-linguisttools/Makefile b/devel/qt5-linguisttools/Makefile
index c465d0c371e4..4d926a37c921 100644
--- a/devel/qt5-linguisttools/Makefile
+++ b/devel/qt5-linguisttools/Makefile
@@ -9,7 +9,7 @@ MAINTAINER= kde@FreeBSD.org
COMMENT= Qt localization tools
USE_QT= core xml buildtools_build qml_build
-USES= qmake qt-dist:5,tools
+USES= compiler:c++11-lang qmake qt-dist:5,tools
BUILD_WRKSRC= ${WRKSRC}/src/linguist
INSTALL_WRKSRC= ${WRKSRC}/src/linguist
diff --git a/devel/qt5-location/Makefile b/devel/qt5-location/Makefile
index 4a22974b93a3..d62f4b5561b5 100644
--- a/devel/qt5-location/Makefile
+++ b/devel/qt5-location/Makefile
@@ -9,7 +9,7 @@ MAINTAINER= kde@FreeBSD.org
COMMENT= Qt location module
USE_QT= concurrent core dbus gui network qml quick buildtools_build
-USES= qmake:norecursive qt-dist:5,location
+USES= compiler:c++11-lang qmake:norecursive qt-dist:5,location
USE_LDCONFIG= ${PREFIX}/${QT_LIBDIR_REL}
diff --git a/devel/qt5-qdbus/Makefile b/devel/qt5-qdbus/Makefile
index 2fc0e4fa7691..1f43f0470b62 100644
--- a/devel/qt5-qdbus/Makefile
+++ b/devel/qt5-qdbus/Makefile
@@ -8,7 +8,7 @@ PKGNAMEPREFIX= qt5-
MAINTAINER= kde@FreeBSD.org
COMMENT= Qt command-line interface to D-Bus
-USES= qmake qt-dist:5,tools
+USES= compiler:c++11-lang qmake qt-dist:5,tools
USE_QT= core dbus xml buildtools_build
BUILD_WRKSRC= ${WRKSRC}/src/${PORTNAME}/${PORTNAME}
diff --git a/devel/qt5-qmake/Makefile b/devel/qt5-qmake/Makefile
index 898e660df592..85405afb13bc 100644
--- a/devel/qt5-qmake/Makefile
+++ b/devel/qt5-qmake/Makefile
@@ -30,8 +30,6 @@ CONFIGURE_ARGS= -no-accessibility -no-openssl -no-gui -no-cups \
QMAKESPEC= freebsd-${QMAKE_COMPILER}
INSTALL_TARGET= sub-qmake-qmake-aux-pro-install_subtargets install_mkspecs
-BROKEN_powerpc64= fails to compile: error: unrecognized command line option -std=c++11
-
BUILD_WRKSRC= ${WRKSRC}/${PORTNAME}
post-patch:
diff --git a/devel/qt5-script/Makefile b/devel/qt5-script/Makefile
index 00ce095c27c5..74f653129fb7 100644
--- a/devel/qt5-script/Makefile
+++ b/devel/qt5-script/Makefile
@@ -8,10 +8,8 @@ PKGNAMEPREFIX= qt5-
MAINTAINER= kde@FreeBSD.org
COMMENT= Qt 4-compatible scripting module
-BROKEN_powerpc64= Does not build
-
USE_QT= core buildtools_build
-USES= qmake qt-dist:5,script
+USES= compiler:c++11-lang qmake qt-dist:5,script
# Keep make(1) from descending into src/script/obj/ (qmake:outsource
# doesn't work).
MAKE_ENV= MAKEOBJDIR=.
diff --git a/devel/qt5-scripttools/Makefile b/devel/qt5-scripttools/Makefile
index acd1cafb9b3d..581786637cab 100644
--- a/devel/qt5-scripttools/Makefile
+++ b/devel/qt5-scripttools/Makefile
@@ -9,7 +9,7 @@ MAINTAINER= kde@FreeBSD.org
COMMENT= Qt Script additional components
USE_QT= core gui script widgets buildtools_build
-USES= qmake qt-dist:5,script
+USES= compiler:c++11-lang qmake qt-dist:5,script
USE_LDCONFIG= ${PREFIX}/${QT_LIBDIR_REL}
BUILD_WRKSRC= ${WRKSRC}/src/${PORTNAME}
diff --git a/devel/qt5-testlib/Makefile b/devel/qt5-testlib/Makefile
index 301905eaa64c..52a3d32e83a0 100644
--- a/devel/qt5-testlib/Makefile
+++ b/devel/qt5-testlib/Makefile
@@ -8,7 +8,7 @@ PKGNAMEPREFIX= qt5-
MAINTAINER= kde@FreeBSD.org
COMMENT= Qt unit testing module
-USES= qmake:no_env qt-dist:5,base
+USES= compiler:c++11-lang qmake:no_env qt-dist:5,base
USE_QT= core qmake_build buildtools_build
HAS_CONFIGURE= yes
CONFIGURE_ARGS= -no-gui -no-xcb
diff --git a/devel/qt5-uitools/Makefile b/devel/qt5-uitools/Makefile
index 873bdd3b775b..25c6e36acc5c 100644
--- a/devel/qt5-uitools/Makefile
+++ b/devel/qt5-uitools/Makefile
@@ -9,7 +9,7 @@ MAINTAINER= kde@FreeBSD.org
COMMENT= Qt Designer UI forms support module
USE_QT= core gui uiplugin widgets buildtools_build
-USES= qmake qt-dist:5,tools
+USES= compiler:c++11-lang qmake qt-dist:5,tools
USE_LDCONFIG= ${PREFIX}/${QT_LIBDIR_REL}
BUILD_WRKSRC= ${WRKSRC}/src/designer/src/${PORTNAME}
diff --git a/devel/qt5/Makefile.sqldrivers b/devel/qt5/Makefile.sqldrivers
index c9c57548b74c..724537ecc1b1 100644
--- a/devel/qt5/Makefile.sqldrivers
+++ b/devel/qt5/Makefile.sqldrivers
@@ -8,7 +8,7 @@ PKGNAMEPREFIX?= qt5-sqldrivers-
MAINTAINER?= kde@FreeBSD.org
COMMENT?= Qt ${DB_DESC} database plugin
-USES+= qmake:no_env qt-dist:5,base
+USES+= compiler:c++11-lang qmake:no_env qt-dist:5,base
USE_QT+= core sql qmake_build buildtools_build
HAS_CONFIGURE= yes
CONFIGURE_ARGS+=-no-gui -no-xcb
diff --git a/devel/qt5/files/extra-patch-mkspecs_common_g++-base.conf b/devel/qt5/files/extra-patch-mkspecs_common_g++-base.conf
new file mode 100644
index 000000000000..39db94d7f0d7
--- /dev/null
+++ b/devel/qt5/files/extra-patch-mkspecs_common_g++-base.conf
@@ -0,0 +1,20 @@
+--- mkspecs/common/g++-base.conf.orig 2018-09-21 12:02:35 UTC
++++ mkspecs/common/g++-base.conf
+@@ -8,14 +8,14 @@
+ # you can use the manual test in tests/manual/mkspecs.
+ #
+
+-QMAKE_COMPILER = gcc
++QMAKE_COMPILER = gcc%%GCC_DEFAULT%%
+
+-QMAKE_CC = gcc
++QMAKE_CC = gcc%%GCC_DEFAULT%%
+
+ QMAKE_LINK_C = $$QMAKE_CC
+ QMAKE_LINK_C_SHLIB = $$QMAKE_CC
+
+-QMAKE_CXX = g++
++QMAKE_CXX = g++%%GCC_DEFAULT%%
+
+ QMAKE_LINK = $$QMAKE_CXX
+ QMAKE_LINK_SHLIB = $$QMAKE_CXX
diff --git a/devel/qt5/files/extra-patch-mkspecs_common_gcc-base.conf b/devel/qt5/files/extra-patch-mkspecs_common_gcc-base.conf
new file mode 100644
index 000000000000..a88f09dbfcd8
--- /dev/null
+++ b/devel/qt5/files/extra-patch-mkspecs_common_gcc-base.conf
@@ -0,0 +1,11 @@
+--- mkspecs/common/gcc-base.conf.orig 2018-09-21 12:20:28 UTC
++++ mkspecs/common/gcc-base.conf
+@@ -73,7 +73,7 @@ QMAKE_CXXFLAGS_LTCG = $$QMAKE_CFLAGS_LTCG
+ QMAKE_CXXFLAGS_LTCG_FATOBJECTS = $$QMAKE_CFLAGS_LTCG_FATOBJECTS
+ QMAKE_CXXFLAGS_DISABLE_LTCG = $$QMAKE_CFLAGS_DISABLE_LTCG
+
+-QMAKE_LFLAGS +=
++QMAKE_LFLAGS += -Wl,-rpath=%%LOCALBASE%%/lib/gcc%%GCC_DEFAULT%%
+ QMAKE_LFLAGS_DEBUG +=
+ QMAKE_LFLAGS_APP +=
+ QMAKE_LFLAGS_RELEASE +=
diff --git a/graphics/qt5-imageformats/Makefile b/graphics/qt5-imageformats/Makefile
index fe10cb544beb..46e33960b8a2 100644
--- a/graphics/qt5-imageformats/Makefile
+++ b/graphics/qt5-imageformats/Makefile
@@ -14,6 +14,6 @@ LIB_DEPENDS= libjasper.so:graphics/jasper \
libwebp.so:graphics/webp
USE_QT= core gui buildtools_build
-USES= localbase qmake qt-dist:5,imageformats
+USES= compiler:c++11-lang localbase qmake qt-dist:5,imageformats
.include <bsd.port.mk>
diff --git a/graphics/qt5-opengl/Makefile b/graphics/qt5-opengl/Makefile
index aeba157cc2e5..be001a76ef30 100644
--- a/graphics/qt5-opengl/Makefile
+++ b/graphics/qt5-opengl/Makefile
@@ -8,7 +8,7 @@ PKGNAMEPREFIX= qt5-
MAINTAINER= kde@FreeBSD.org
COMMENT= Qt 5-compatible OpenGL support module
-USES= qmake:no_env qt-dist:5,base
+USES= compiler:c++11-lang gl qmake:no_env qt-dist:5,base
USE_GL= gl
USE_QT= core gui widgets qmake_build buildtools_build
HAS_CONFIGURE= yes
diff --git a/graphics/qt5-svg/Makefile b/graphics/qt5-svg/Makefile
index 27dc9bfb71d6..f02e59d7aec9 100644
--- a/graphics/qt5-svg/Makefile
+++ b/graphics/qt5-svg/Makefile
@@ -9,7 +9,7 @@ MAINTAINER= kde@FreeBSD.org
COMMENT= Qt SVG support module
USE_QT= core gui widgets buildtools_build
-USES= qmake qt-dist:5,svg
+USES= compiler:c++11-lang qmake qt-dist:5,svg
USE_LDCONFIG= ${PREFIX}/${QT_LIBDIR_REL}
.include <bsd.port.mk>
diff --git a/lang/qt5-qml/Makefile b/lang/qt5-qml/Makefile
index 0cccfd28e3b8..5b0fe3f7ed44 100644
--- a/lang/qt5-qml/Makefile
+++ b/lang/qt5-qml/Makefile
@@ -8,10 +8,8 @@ PKGNAMEPREFIX= qt5-
MAINTAINER= kde@FreeBSD.org
COMMENT= Qt QML and JavaScript language module
-BROKEN_powerpc64= Does not build
-
USE_QT= core network buildtools_build
-USES= python:build qmake qt-dist:5,declarative
+USES= compiler:c++11-lang python:build qmake qt-dist:5,declarative
USE_LDCONFIG= ${PREFIX}/${QT_LIBDIR_REL}
BUILD_WRKSRC= ${WRKSRC}/src
diff --git a/multimedia/qt5-multimedia/Makefile b/multimedia/qt5-multimedia/Makefile
index c998623cf501..3692af97aa52 100644
--- a/multimedia/qt5-multimedia/Makefile
+++ b/multimedia/qt5-multimedia/Makefile
@@ -11,7 +11,8 @@ COMMENT= Qt audio, video, radio and camera support module
# LICENSE set via USES_QT5 (bsd.qt.mk)
-USES= pkgconfig qmake:norecursive qt-dist:5,multimedia
+USES= compiler:c++11-lang gl gnome pkgconfig qmake:norecursive \
+ qt-dist:5,multimedia
USE_GL= gl
USE_GNOME= glib20
USE_QT= core gui network opengl qml quick widgets \
diff --git a/net/qt5-network/Makefile b/net/qt5-network/Makefile
index be2a9547dce0..f1f210feeca2 100644
--- a/net/qt5-network/Makefile
+++ b/net/qt5-network/Makefile
@@ -13,7 +13,7 @@ BROKEN_SSL_REASON_openssl-devel= error: member access into incomplete type 'X509
RUN_DEPENDS= ${LOCALBASE}/share/certs/ca-root-nss.crt:security/ca_root_nss
-USES= qmake:no_env qt-dist:5,base ssl
+USES= compiler:c++11-lang qmake:no_env qt-dist:5,base ssl
USE_QT= core buildtools_build
HAS_CONFIGURE= yes
CONFIGURE_ARGS= -no-gui -no-xcb
diff --git a/print/qt5-printsupport/Makefile b/print/qt5-printsupport/Makefile
index 935ddbf304d1..6cd3c690753c 100644
--- a/print/qt5-printsupport/Makefile
+++ b/print/qt5-printsupport/Makefile
@@ -8,7 +8,7 @@ PKGNAMEPREFIX= qt5-
MAINTAINER= kde@FreeBSD.org
COMMENT= Qt print support module
-USES= qmake:no_env qt-dist:5,base
+USES= compiler:c++11-lang qmake:no_env qt-dist:5,base
USE_QT= core gui widgets qmake_build buildtools_build
HAS_CONFIGURE= yes
USE_LDCONFIG= ${PREFIX}/${QT_LIBDIR_REL}
diff --git a/sysutils/qt5-qtpaths/Makefile b/sysutils/qt5-qtpaths/Makefile
index ae7d35bd8176..00c2a7e2bd5b 100644
--- a/sysutils/qt5-qtpaths/Makefile
+++ b/sysutils/qt5-qtpaths/Makefile
@@ -8,7 +8,7 @@ PKGNAMEPREFIX= qt5-
MAINTAINER= kde@FreeBSD.org
COMMENT= Command line client to QStandardPaths
-USES= qmake:outsource qt-dist:5,tools
+USES= compiler:c++11-lang qmake:outsource qt-dist:5,tools
USE_QT= core
PLIST_FILES= ${QT_BINDIR}/qtpaths
diff --git a/textproc/qt5-xml/Makefile b/textproc/qt5-xml/Makefile
index 0233af18d7d3..e5929d163a87 100644
--- a/textproc/qt5-xml/Makefile
+++ b/textproc/qt5-xml/Makefile
@@ -8,7 +8,7 @@ PKGNAMEPREFIX= qt5-
MAINTAINER= kde@FreeBSD.org
COMMENT= Qt SAX and DOM implementations
-USES= qmake:no_env qt-dist:5,base
+USES= compiler:c++11-lang qmake:no_env qt-dist:5,base
USE_QT= core qmake_build buildtools_build
HAS_CONFIGURE= yes
CONFIGURE_ARGS= -no-gui -no-xcb
diff --git a/textproc/qt5-xmlpatterns/Makefile b/textproc/qt5-xmlpatterns/Makefile
index 23d2aad9e3e6..e2b484d1a933 100644
--- a/textproc/qt5-xmlpatterns/Makefile
+++ b/textproc/qt5-xmlpatterns/Makefile
@@ -8,10 +8,8 @@ PKGNAMEPREFIX= qt5-
MAINTAINER= kde@FreeBSD.org
COMMENT= Qt support for XPath, XQuery, XSLT and XML Schema
-BROKEN_powerpc64= Does not build
-
USE_QT= core network buildtools_build
-USES= qmake:norecursive qt-dist:5,xmlpatterns
+USES= compiler:c++11-lang qmake:norecursive qt-dist:5,xmlpatterns
USE_LDCONFIG= ${PREFIX}/${QT_LIBDIR_REL}
.include <bsd.port.mk>
diff --git a/www/qt5-webchannel/Makefile b/www/qt5-webchannel/Makefile
index d37730636703..23120d2ea46a 100644
--- a/www/qt5-webchannel/Makefile
+++ b/www/qt5-webchannel/Makefile
@@ -9,7 +9,7 @@ MAINTAINER= kde@FreeBSD.org
COMMENT= Qt 5 library for integration of C++/QML with HTML/js clients
USE_QT= buildtools_build core qml quick
-USES= qmake:norecursive qt-dist:5,webchannel
+USES= compiler:c++11-lang qmake:norecursive qt-dist:5,webchannel
USE_LDCONFIG= ${PREFIX}/${QT_LIBDIR_REL}
# The default EXTRACT_AFTER_ARGS value excludes examples/ from the extracted
diff --git a/x11-toolkits/qt5-gui/Makefile b/x11-toolkits/qt5-gui/Makefile
index 36a9e109cba3..ee8ab105fa33 100644
--- a/x11-toolkits/qt5-gui/Makefile
+++ b/x11-toolkits/qt5-gui/Makefile
@@ -22,7 +22,7 @@ LIB_DEPENDS= libdbus-1.so:devel/dbus \
libxkbcommon.so:x11/libxkbcommon
RUN_DEPENDS= xdg-open:devel/xdg-utils
-USES= jpeg localbase qmake:no_env qt-dist:5,base
+USES= compiler:c++11-lang jpeg localbase qmake:no_env qt-dist:5,base
USE_GL= gl egl
USE_GNOME= glib20
USE_QT= core dbus network qmake_build buildtools_build
diff --git a/x11-toolkits/qt5-quick/Makefile b/x11-toolkits/qt5-quick/Makefile
index 8136051518f5..69b9bf4e8ab9 100644
--- a/x11-toolkits/qt5-quick/Makefile
+++ b/x11-toolkits/qt5-quick/Makefile
@@ -11,7 +11,8 @@ COMMENT= Qt declarative framework for dynamic user interfaces
USE_GL= gl
USE_QT= core gui network qml sql testlib \
widgets xmlpatterns buildtools_build
-USES= python:build qmake:norecursive qt-dist:5,declarative
+USES= compiler:c++11-lang gl python:build qmake:norecursive \
+ qt-dist:5,declarative
USE_LDCONFIG= ${PREFIX}/${QT_LIBDIR_REL}
CONFLICTS= qt5-declarative-render2d-*
diff --git a/x11-toolkits/qt5-quickcontrols/Makefile b/x11-toolkits/qt5-quickcontrols/Makefile
index 4a9f66ade484..ecfa3a69fd4f 100644
--- a/x11-toolkits/qt5-quickcontrols/Makefile
+++ b/x11-toolkits/qt5-quickcontrols/Makefile
@@ -10,7 +10,7 @@ COMMENT= Set of controls for building complete interfaces in Qt Quick
BROKEN_armv6= fails to install: pkg-static: Unable to access file ApplicationWindow.qmlc: No such file or directory
-USES= qmake qt-dist:5,quickcontrols
+USES= compiler:c++11-lang qmake qt-dist:5,quickcontrols
USE_QT= core gui qml quick widgets \
buildtools_build
USE_LDCONFIG= ${PREFIX}/${QT_LIBDIR_REL}
diff --git a/x11-toolkits/qt5-quickcontrols2/Makefile b/x11-toolkits/qt5-quickcontrols2/Makefile
index bccff2c319fd..5a108b43eefe 100644
--- a/x11-toolkits/qt5-quickcontrols2/Makefile
+++ b/x11-toolkits/qt5-quickcontrols2/Makefile
@@ -10,7 +10,7 @@ COMMENT= Set of controls for building complete interfaces in Qt Quick
BROKEN_armv6= fails to install: pkg-static: Unable to access file DayOfWeekRow.qmlc: No such file or directory
-USES= qmake:norecursive qt-dist:5
+USES= compiler:c++11-lang qmake:norecursive qt-dist:5
USE_QT= core gui qml quick widgets \
buildtools_build
QT_DIST= ${PORTNAME}
diff --git a/x11-toolkits/qt5-virtualkeyboard/Makefile b/x11-toolkits/qt5-virtualkeyboard/Makefile
index 1f347e09f521..65364f564b20 100644
--- a/x11-toolkits/qt5-virtualkeyboard/Makefile
+++ b/x11-toolkits/qt5-virtualkeyboard/Makefile
@@ -10,7 +10,7 @@ COMMENT= Qt 5 Virtual Keyboard Module
LIB_DEPENDS= libhunspell-1.6.so:textproc/hunspell
-USES= qmake qt-dist:5,virtualkeyboard
+USES= compiler:c++11-lang qmake qt-dist:5,virtualkeyboard
USE_QT= core network gui widgets svg qml quick buildtools_build
USE_LDCONFIG= ${PREFIX}/${QT_LIBDIR_REL}
diff --git a/x11-toolkits/qt5-widgets/Makefile b/x11-toolkits/qt5-widgets/Makefile
index 2a0223b0348d..7e63dac85b53 100644
--- a/x11-toolkits/qt5-widgets/Makefile
+++ b/x11-toolkits/qt5-widgets/Makefile
@@ -8,7 +8,7 @@ PKGNAMEPREFIX= qt5-
MAINTAINER= kde@FreeBSD.org
COMMENT= Qt C++ widgets module
-USES= qmake:no_env qt-dist:5,base
+USES= compiler:c++11-lang qmake:no_env qt-dist:5,base
USE_QT= core gui qmake_build buildtools_build
USE_XORG= x11
HAS_CONFIGURE= yes
diff --git a/x11/qt5-x11extras/Makefile b/x11/qt5-x11extras/Makefile
index c84cc938dc4e..cc4e2d9665ab 100644
--- a/x11/qt5-x11extras/Makefile
+++ b/x11/qt5-x11extras/Makefile
@@ -9,7 +9,7 @@ MAINTAINER= kde@FreeBSD.org
COMMENT= Qt platform-specific features for X11-based systems
USE_QT= core gui
-USES= qmake qt-dist:5,x11extras
+USES= compiler:c++11-lang qmake qt-dist:5,x11extras
USE_LDCONFIG= ${PREFIX}/${QT_LIBDIR_REL}
.include <bsd.port.mk>