aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2013-03-27 15:09:38 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2013-03-27 15:09:38 +0000
commitd39b2dff04df971f9e69db881b97967f1e55e7a4 (patch)
treecac734aad892a64ea59f649ab9196fb137b7ef0e
parent5bfc5e90620d57a76d5711a3613c5fd12b6e3911 (diff)
downloadports-d39b2dff04df971f9e69db881b97967f1e55e7a4.tar.gz
ports-d39b2dff04df971f9e69db881b97967f1e55e7a4.zip
Notes
-rw-r--r--www/rekonq/Makefile14
1 files changed, 10 insertions, 4 deletions
diff --git a/www/rekonq/Makefile b/www/rekonq/Makefile
index a88fbc638eb7..b3c522e0088e 100644
--- a/www/rekonq/Makefile
+++ b/www/rekonq/Makefile
@@ -2,6 +2,7 @@
PORTNAME= rekonq
PORTVERSION= 2.2.1
+PORTREVISION= 1
CATEGORIES= www kde
MASTER_SITES= SF/${PORTNAME}/${PORTVERSION:C,\..*,.0,}/
@@ -15,11 +16,10 @@ USE_QT4= script webkit \
moc_build qmake_build rcc_build uic_build
MAKE_JOBS_SAFE= yes
-# KDE SC 4.10 is required for Nepomuk support
-CMAKE_ARGS+= -DWITH_NepomukCore=off
-
-OPTIONS_DEFINE= OPERA
+OPTIONS_DEFINE= OPERA NUPOMUK
+OPTIONS_DEFAULT= NUPOMUK
OPERA_DESC= Support for Opera Sync service
+NUPOMUK_DESC= Bookmarks tagging via Nepomuk
.include <bsd.port.options.mk>
@@ -28,6 +28,12 @@ post-patch:
's,FIND_PACKAGE(NepomukCore,MACRO_OPTIONAL_FIND_PACKAGE(NepomukCore,' \
${WRKSRC}/CMakeLists.txt
+.if ${PORT_OPTIONS:MNUPOMUK}
+USE_KDE4+= nepomuk-core
+.else
+CMAKE_ARGS+= -DWITH_NepomukCore=off
+.endif
+
.if ${PORT_OPTIONS:MOPERA}
LIB_DEPENDS+= qca.2:${PORTSDIR}/devel/qca \
qoauth.1:${PORTSDIR}/net/qoauth