aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJordan K. Hubbard <jkh@FreeBSD.org>1995-01-03 11:52:01 +0000
committerJordan K. Hubbard <jkh@FreeBSD.org>1995-01-03 11:52:01 +0000
commite7c865345a8627644d852a845ed4e32bbb91f096 (patch)
tree0432c667911f8c9a4dcf079ef8d5736a9e8f3e18
parenteb497430f37a794c73d998269a028f9011c1e92a (diff)
downloadports-e7c865345a8627644d852a845ed4e32bbb91f096.tar.gz
ports-e7c865345a8627644d852a845ed4e32bbb91f096.zip
Notes
-rw-r--r--Mk/bsd.port.mk11
-rw-r--r--Mk/bsd.port.subdir.mk6
2 files changed, 15 insertions, 2 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 8e4bfceb3b79..9e11b96ab8bc 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -3,7 +3,7 @@
# bsd.port.mk - 940820 Jordan K. Hubbard.
# This file is in the public domain.
#
-# $Id: bsd.port.mk,v 1.89 1994/12/28 04:17:54 ache Exp $
+# $Id: bsd.port.mk,v 1.90 1995/01/01 20:06:20 ache Exp $
#
# Please view me with 4 column tabs!
@@ -277,6 +277,15 @@ patch:
# More standard targets start here.
+.if !target(describe)
+describe:
+ @if [ -f ${PKGDIR}/COMMENT ]; then \
+ echo "${.CURDIR}/${DISTNAME}: `cat ${PKGDIR}/COMMENT`"; \
+ else \
+ echo "${.CURDIR}/${DISTNAME}: ** No Description"; \
+ fi
+.endif
+
.if !target(reinstall)
reinstall: pre-reinstall install
diff --git a/Mk/bsd.port.subdir.mk b/Mk/bsd.port.subdir.mk
index 2fc73273c8d3..e1982e6ca084 100644
--- a/Mk/bsd.port.subdir.mk
+++ b/Mk/bsd.port.subdir.mk
@@ -1,5 +1,5 @@
# from: @(#)bsd.subdir.mk 5.9 (Berkeley) 2/1/91
-# $Id: bsd.port.subdir.mk,v 1.6 1994/11/17 16:02:56 jkh Exp $
+# $Id: bsd.port.subdir.mk,v 1.7 1994/12/17 20:50:44 gpalmer Exp $
.MAIN: all
@@ -65,6 +65,10 @@ clean: _SUBDIRUSE
depend: _SUBDIRUSE
.endif
+.if !target(describe)
+describe: _SUBDIRUSE
+.endif
+
.if !target(reinstall)
reinstall: _SUBDIRUSE
.endif