aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2014-07-18 00:43:30 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2014-07-18 00:43:30 +0000
commitec519e160e7481deda16c89b9c09f63e26fdf952 (patch)
tree9a5185fe497714c8dc36494f132c8e6084b5ac1b
parent6392965c18ac58f135d7d0409b57987633b047eb (diff)
downloadports-ec519e160e7481deda16c89b9c09f63e26fdf952.tar.gz
ports-ec519e160e7481deda16c89b9c09f63e26fdf952.zip
Notes
-rw-r--r--mail/squirrelmail-translations/Makefile8
-rw-r--r--mail/squirrelmail-translations/distinfo4
-rw-r--r--mail/squirrelmail/Makefile44
-rw-r--r--mail/squirrelmail/distinfo4
-rw-r--r--mail/squirrelmail/pkg-help5
-rw-r--r--mail/squirrelmail/pkg-plist2
6 files changed, 29 insertions, 38 deletions
diff --git a/mail/squirrelmail-translations/Makefile b/mail/squirrelmail-translations/Makefile
index cfa046552122..702c74350723 100644
--- a/mail/squirrelmail-translations/Makefile
+++ b/mail/squirrelmail-translations/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= squirrelmail-translations
-PORTVERSION= 20140420
+PORTVERSION= 20140717
CATEGORIES= mail www
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= adamw/squirrelmail
@@ -14,7 +14,7 @@ COMMENT= NLS translations for Squirrelmail (mail/squirrelmail)
LICENSE= GPLv2
-RUN_DEPENDS= ${SQUIRRELDIR}/index.php:${PORTSDIR}/mail/squirrelmail
+RUN_DEPENDS= squirrelmail=${PORTVERSION}:${PORTSDIR}/mail/squirrelmail
USES= tar:bzip2 gettext
WRKSRC= ${WRKDIR}/squirrelmail.locales
@@ -29,8 +29,6 @@ do-build:
do-install:
@${MKDIR} ${STAGEDIR}${SQUIRRELDIR}
-.for DIR in help images locale
- (cd ${WRKSRC} && ${COPYTREE_SHARE} ${DIR} ${STAGEDIR}${SQUIRRELDIR})
-.endfor
+ (cd ${WRKSRC} && ${COPYTREE_SHARE} "help images locale" ${STAGEDIR}${SQUIRRELDIR})
.include <bsd.port.mk>
diff --git a/mail/squirrelmail-translations/distinfo b/mail/squirrelmail-translations/distinfo
index 6fb609919de4..151364ec7705 100644
--- a/mail/squirrelmail-translations/distinfo
+++ b/mail/squirrelmail-translations/distinfo
@@ -1,2 +1,2 @@
-SHA256 (squirrelmail/squirrelmail-20140420_0200-SVN.locales.tar.bz2) = fc851a791907e6d7e3bc2fde94a655014545e9471ec81fc87b85f06f3934a906
-SIZE (squirrelmail/squirrelmail-20140420_0200-SVN.locales.tar.bz2) = 5254092
+SHA256 (squirrelmail/squirrelmail-20140717_0200-SVN.locales.tar.bz2) = 5c6c254e4865a52fd8606229932f1c1aab9ac5f6efc450327035fa689fb7c27b
+SIZE (squirrelmail/squirrelmail-20140717_0200-SVN.locales.tar.bz2) = 5253895
diff --git a/mail/squirrelmail/Makefile b/mail/squirrelmail/Makefile
index f332cf5faebc..0b609f06da8b 100644
--- a/mail/squirrelmail/Makefile
+++ b/mail/squirrelmail/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= squirrelmail
-PORTVERSION= 20140420
+PORTVERSION= 20140717
CATEGORIES= mail www
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= adamw/squirrelmail
@@ -49,15 +49,6 @@ CONFLICTS= squirreloutlook-[0-9]*
DATABASE_RUN_DEPENDS= ${LOCALBASE}/share/pear/DB.php:${PORTSDIR}/databases/pear-DB
LDAP_USE= PHP=ldap
-.include <bsd.port.options.mk>
-
-pre-everything::
-.if ${PORT_OPTIONS:MDATABASE}
- @${ECHO_CMD} "Note that the PEAR database framework still requires you to install a"
- @${ECHO_CMD} "database-specific PEAR driver, e.g. MySQL."
- @${ECHO_CMD}
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's|ispell|${LOCALBASE}/bin/ispell|g' \
${WRKSRC}/plugins/squirrelspell/sqspell_config.php
@@ -67,19 +58,20 @@ post-patch:
${WRKSRC}/config/conf.pl ${WRKSRC}/config/config_default.php ${WRKSRC}/doc/INSTALL
do-build:
-# Rearrange the documentation
- @${MV} ${WRKSRC}/themes/README.themes ${WRKSRC}/doc/
- @cd ${WRKSRC} ; for f in `${FIND} plugins -name "README*" -or \
- -name INSTALL -or -name CHANGES -or -name HISTORY`; \
+ # Rearrange the documentation
+ @${MV} ${WRKSRC}/themes/README.themes ${WRKSRC}/doc
+ @(cd ${WRKSRC} && \
+ for f in `${FIND} -E plugins -regex \
+ '.*(README.*|INSTALL|HISTORY)'`; \
do \
- ${MKDIR} doc/`dirname $$f` ; \
- ${MV} $$f doc/`dirname $$f` ; \
- done; \
- ${MV} doc/plugins/squirrelspell/doc/README doc/plugins/squirrelspell ; \
- ${RM} -rf doc/plugins/squirrelspell/doc ; \
- ${MV} plugins/squirrelspell/doc/* doc/plugins/squirrelspell ; \
- ${RM} -f doc/plugins/squirrelspell/index.php ; \
- ${RM} -rf plugins/squirrelspell/doc
+ ${MKDIR} doc/`dirname $$f`; \
+ ${MV} $$f doc/`dirname $$f`; \
+ done)
+ @${MV} ${WRKSRC}/doc/plugins/squirrelspell/doc/README ${WRKSRC}/doc/plugins/squirrelspell
+ @${RM} -rf ${WRKSRC}/doc/plugins/squirrelspell/doc
+ @${MV} ${WRKSRC}/plugins/squirrelspell/doc/* ${WRKSRC}/doc/plugins/squirrelspell
+ @${RM} -f ${WRKSRC}/doc/plugins/squirrelspell/index.php
+ @${RM} -rf ${WRKSRC}/plugins/squirrelspell/doc
@${ECHO} "left_refresh=300" >> ${WRKSRC}/data/default_pref
@${MV} ${WRKSRC}/config/config_local.php ${WRKSRC}/config/config_local.php.sample
@@ -87,10 +79,6 @@ do-build:
@${MKDIR} ${WRKSRC}/attach
@${CP} -p ${WRKSRC}/data/.htaccess ${WRKSRC}/attach/.htaccess
-pre-install:
- @${FIND} ${WRKSRC} -name '*.orig' -delete
- @${FIND} ${WRKSRC} -name '*.bak' -delete
-
do-install:
@${MKDIR} ${STAGEDIR}${PREFIX}/etc/periodic/daily
${INSTALL_SCRIPT} ${FILESDIR}/111.clean-squirrelmail ${STAGEDIR}${PREFIX}/etc/periodic/daily
@@ -98,8 +86,8 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/index.php ${STAGEDIR}${SQUIRRELDIR}
${INSTALL_SCRIPT} ${WRKSRC}/configure ${STAGEDIR}${SQUIRRELDIR}
(cd ${WRKSRC} && \
- ${FIND} attach class config data functions help images include locale plugins po scripts src themes \
- | ${CPIO} -pdmu --quiet ${STAGEDIR}${SQUIRRELDIR})
+ ${COPYTREE_SHARE} "attach class config data functions help images include locale plugins po scripts src themes" \
+ ${STAGEDIR}${SQUIRRELDIR})
@${MKDIR} ${STAGEDIR}${DOCSDIR}
(cd ${WRKSRC}/doc && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR})
diff --git a/mail/squirrelmail/distinfo b/mail/squirrelmail/distinfo
index 78bd8080e25e..e089c4b05bbd 100644
--- a/mail/squirrelmail/distinfo
+++ b/mail/squirrelmail/distinfo
@@ -1,2 +1,2 @@
-SHA256 (squirrelmail/squirrelmail-20140420_0200-SVN.stable.tar.bz2) = 1651f177a43aab7d07dbb1982adaf178000cb0ee6d208bfccd126bbb01415db9
-SIZE (squirrelmail/squirrelmail-20140420_0200-SVN.stable.tar.bz2) = 552142
+SHA256 (squirrelmail/squirrelmail-20140717_0200-SVN.stable.tar.bz2) = d7d42a6714a2e42a517b179b904e1860dbc5bf8ba1fc4c3923b0830002d1ef7f
+SIZE (squirrelmail/squirrelmail-20140717_0200-SVN.stable.tar.bz2) = 552821
diff --git a/mail/squirrelmail/pkg-help b/mail/squirrelmail/pkg-help
new file mode 100644
index 000000000000..0cb06997d081
--- /dev/null
+++ b/mail/squirrelmail/pkg-help
@@ -0,0 +1,5 @@
+If you enable the PEAR database framework option, you still need to install a
+database-specific PEAR driver.
+
+SquirrelMail is only compatible with old-style pear-DB drivers, not the newer
+MDB2 drivers.
diff --git a/mail/squirrelmail/pkg-plist b/mail/squirrelmail/pkg-plist
index e0a246602b10..f9f9a68fbba9 100644
--- a/mail/squirrelmail/pkg-plist
+++ b/mail/squirrelmail/pkg-plist
@@ -502,9 +502,9 @@ etc/periodic/daily/111.clean-squirrelmail
@group %%SMGROUP%%
@mode 0750
@dirrm %%SQUIRRELDIR%%/data
-@mode
@group
@owner
+@mode 0755
@dirrmtry %%SQUIRRELDIR%%/config
@dirrm %%SQUIRRELDIR%%/class/mime
@dirrm %%SQUIRRELDIR%%/class/helper