aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNorikatsu Shigemura <nork@FreeBSD.org>2008-09-27 20:02:36 +0000
committerNorikatsu Shigemura <nork@FreeBSD.org>2008-09-27 20:02:36 +0000
commitf5f04e336b19f4129e53a414e5b2a050acfc399f (patch)
tree7fe29d2a0fe9c02f28b81b1810db457cf13918be
parent7658303a9db3858fa812e389c80b14f397626cbb (diff)
downloadports-f5f04e336b19f4129e53a414e5b2a050acfc399f.tar.gz
ports-f5f04e336b19f4129e53a414e5b2a050acfc399f.zip
Notes
-rw-r--r--x11-drivers/Makefile1
-rw-r--r--x11-drivers/xf86-video-radeonhd-devel/Makefile31
-rw-r--r--x11-drivers/xf86-video-radeonhd-devel/distinfo6
-rw-r--r--x11-drivers/xf86-video-radeonhd/Makefile4
4 files changed, 29 insertions, 13 deletions
diff --git a/x11-drivers/Makefile b/x11-drivers/Makefile
index 573569868952..8a0ea07cf629 100644
--- a/x11-drivers/Makefile
+++ b/x11-drivers/Makefile
@@ -52,6 +52,7 @@
SUBDIR += xf86-video-openchrome
SUBDIR += xf86-video-r128
SUBDIR += xf86-video-radeonhd
+ SUBDIR += xf86-video-radeonhd-devel
SUBDIR += xf86-video-rendition
SUBDIR += xf86-video-s3
SUBDIR += xf86-video-s3virge
diff --git a/x11-drivers/xf86-video-radeonhd-devel/Makefile b/x11-drivers/xf86-video-radeonhd-devel/Makefile
index b7a039520efc..257ba2bb2d00 100644
--- a/x11-drivers/xf86-video-radeonhd-devel/Makefile
+++ b/x11-drivers/xf86-video-radeonhd-devel/Makefile
@@ -1,24 +1,37 @@
-# New ports collection makefile for: xf86-video-radeonhd
-# Date Created: 20 Oct 2007
-# Whom: Rene Ladan <r.c.ladan@gmail.com>
+# New ports collection makefile for: xf86-video-radeonhd-devel
+# Date Created: 2008-09-07
+# Whom: nork@FreeBSD.org
#
# $FreeBSD$
#
PORTNAME= xf86-video-radeonhd
-PORTVERSION= 1.2.1
-PORTREVISION= 1
+PORTVERSION= 1.2.1.20080906
CATEGORIES= x11-drivers
+MASTER_SITES= ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= nork
+PKGNAMESUFFIX= -devel
-MAINTAINER= x11@FreeBSD.org
-COMMENT= X.Org ati RadeonHD display driver
+MAINTAINER= nork@FreeBSD.org
+COMMENT= X.Org ati RadeonHD display driver development version
+
+BUILD_DEPENDS= ${LOCALBASE}/share/aclocal/xorg-macros.m4:${PORTSDIR}/devel/xorg-macros
OPTIONS= UTILS "Install rhd_conntest and rhd_dump utilities" off
XORG_CAT= driver
-USE_XORG= videoproto xextproto
+USE_XORG= damageproto videoproto xextproto xf86driproto
+USE_AUTOTOOLS= autoconf:262
+
+CONFLICT= xf86-video-radeonhd-[0-9]*
+
+MAN4= radeonhd.4x
+
+# EXA is usable rather than XAA. DRI is not usable in this time.
+CONFIGURE_ARGS= --enable-exa --disable-dri
-MAN4= radeonhd.4x
+pre-configure:
+ cd ${WRKSRC} && ${AUTORECONF} -i
.include <bsd.port.pre.mk>
diff --git a/x11-drivers/xf86-video-radeonhd-devel/distinfo b/x11-drivers/xf86-video-radeonhd-devel/distinfo
index 6a9e12483949..e451f67c0cb9 100644
--- a/x11-drivers/xf86-video-radeonhd-devel/distinfo
+++ b/x11-drivers/xf86-video-radeonhd-devel/distinfo
@@ -1,3 +1,3 @@
-MD5 (xorg/driver/xf86-video-radeonhd-1.2.1.tar.bz2) = 9db15e1f1f891f514ca72dd9a3cc360a
-SHA256 (xorg/driver/xf86-video-radeonhd-1.2.1.tar.bz2) = 2e06e8cd714e5345165c64e8a96ea0e7bae44ae2655760ef0eee17ab788ab388
-SIZE (xorg/driver/xf86-video-radeonhd-1.2.1.tar.bz2) = 512608
+MD5 (xorg/driver/xf86-video-radeonhd-1.2.1.20080906.tar.bz2) = 9465248a7cb9eacdebd1cb99046dfd67
+SHA256 (xorg/driver/xf86-video-radeonhd-1.2.1.20080906.tar.bz2) = adf884f1cc82a8f9a99db39ae7198d34845742c89ed39d27cce55036cfade4a7
+SIZE (xorg/driver/xf86-video-radeonhd-1.2.1.20080906.tar.bz2) = 343206
diff --git a/x11-drivers/xf86-video-radeonhd/Makefile b/x11-drivers/xf86-video-radeonhd/Makefile
index b7a039520efc..f25bf192a8b2 100644
--- a/x11-drivers/xf86-video-radeonhd/Makefile
+++ b/x11-drivers/xf86-video-radeonhd/Makefile
@@ -7,7 +7,7 @@
PORTNAME= xf86-video-radeonhd
PORTVERSION= 1.2.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11-drivers
MAINTAINER= x11@FreeBSD.org
@@ -18,6 +18,8 @@ OPTIONS= UTILS "Install rhd_conntest and rhd_dump utilities" off
XORG_CAT= driver
USE_XORG= videoproto xextproto
+CONFLICT= xf86-video-radeonhd-devel-[0-9]*
+
MAN4= radeonhd.4x
.include <bsd.port.pre.mk>