aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2019-10-01 14:33:24 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2019-10-01 14:33:24 +0000
commitf6fd84cfb5b90b0c0d1c956223fab8938d36660f (patch)
tree7b8c3b148e7f2ecce6346c5716ffb491778d9701
parent37203c22d9b7d640f787950f4f75e36b40e63219 (diff)
downloadports-f6fd84cfb5b90b0c0d1c956223fab8938d36660f.tar.gz
ports-f6fd84cfb5b90b0c0d1c956223fab8938d36660f.zip
Notes
-rw-r--r--CHANGES7
-rw-r--r--Mk/Wrappers/gm48
-rw-r--r--Mk/bsd.port.mk11
3 files changed, 26 insertions, 0 deletions
diff --git a/CHANGES b/CHANGES
index 3e2e710195ca..ed965f0e6d91 100644
--- a/CHANGES
+++ b/CHANGES
@@ -10,6 +10,13 @@ in the release notes and/or placed into UPDATING.
All ports committers are allowed to commit to this file.
+20191001:
+AUTHOR: bapt@FreeBSD.org
+
+ BINARY_WRAPPERS allow to push in front of the PATH wrappers for binaries.
+ This is useful when 2 tools do provide the same feature, but the configure
+ scripts do test for some variables which are not in one of the tool.
+
20190919:
AUTHOR: madpilot@FreeBSD.org
diff --git a/Mk/Wrappers/gm4 b/Mk/Wrappers/gm4
new file mode 100644
index 000000000000..a2c5c61047a4
--- /dev/null
+++ b/Mk/Wrappers/gm4
@@ -0,0 +1,8 @@
+#!/bin/sh
+#
+# $FreeBSD$
+
+case " $@ " in
+*" --version "*) echo "m4 (GNU M4) 1.4.18" ;;
+*) exec m4 -g $@ ;;
+esac
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 99f086827a83..272437af58c4 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -1334,6 +1334,7 @@ INDEXFILE?= INDEX-${OSVERSION:C/([0-9]*)[0-9]{5}/\1/}
PACKAGES?= ${PORTSDIR}/packages
TEMPLATES?= ${PORTSDIR}/Templates
KEYWORDS?= ${PORTSDIR}/Keywords
+WRAPPERSDIR?= ${PORTSDIR}/Mk/Wrappers/
PATCHDIR?= ${MASTERDIR}/files
FILESDIR?= ${MASTERDIR}/files
@@ -5101,6 +5102,15 @@ create-binary-alias: ${BINARY_LINKDIR}
.endif
.endif
+.if !empty(BINARY_WRAPPERS)
+.if !target(create-binary-wrappers)
+create-binary-wrappers: ${BINARY_LINKDIR}
+.for bin in ${BINARY_WRAPPERS}
+ @${INSTALL_SCRIPT} ${WRAPPERSDIR}/${bin} ${BINARY_LINKDIR}
+.endfor
+.endif
+.endif
+
.if defined(WARNING)
WARNING_WAIT?= 10
show-warnings:
@@ -5201,6 +5211,7 @@ _PATCH_SEQ= 050:ask-license 100:patch-message 150:patch-depends \
${_OPTIONS_patch} ${_USES_patch}
_CONFIGURE_DEP= patch
_CONFIGURE_SEQ= 150:build-depends 151:lib-depends 160:create-binary-alias \
+ 161:create-binary-wrappers \
200:configure-message \
300:pre-configure 450:pre-configure-script \
490:run-autotools-fixup 500:do-configure 700:post-configure \