aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYen-Ming Lee <leeym@FreeBSD.org>2005-09-17 02:20:35 +0000
committerYen-Ming Lee <leeym@FreeBSD.org>2005-09-17 02:20:35 +0000
commitfbeb272692ac948483603d57a3117d2b2ac63968 (patch)
treee1331f5ead945a1b10492caaee12aa1cfa64f670
parent5a3210b445d6dd1ecc684f281f197422adbbd2c0 (diff)
downloadports-fbeb272692ac948483603d57a3117d2b2ac63968.tar.gz
ports-fbeb272692ac948483603d57a3117d2b2ac63968.zip
Notes
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-accessors/Makefile32
-rw-r--r--devel/p5-accessors/distinfo2
-rw-r--r--devel/p5-accessors/pkg-descr15
4 files changed, 50 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index d23cddfde2ff..9e6e7cfde513 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1180,6 +1180,7 @@
SUBDIR += p5-VCS
SUBDIR += p5-VCS-CVS
SUBDIR += p5-Want
+ SUBDIR += p5-accessors
SUBDIR += p5-base
SUBDIR += p5-capitalization
SUBDIR += p5-enum
diff --git a/devel/p5-accessors/Makefile b/devel/p5-accessors/Makefile
new file mode 100644
index 000000000000..5ed262c4e164
--- /dev/null
+++ b/devel/p5-accessors/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: p5-accessors
+# Date created: 17 September 2005
+# Whom: Yen-Ming Lee <leeym@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= accessors
+PORTVERSION= 0.02
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../by-authors/id/S/SP/SPURKIS
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= leeym@FreeBSD.org
+COMMENT= Create accessor methods in caller's package #'
+
+PERL_MODBUILD= yes
+
+MAN3= accessors.3 accessors::chained.3 accessors::classic.3
+
+PLIST_FILES= ${SITE_PERL_REL}/accessors.pm ${SITE_PERL_REL}/accessors/chained.pm \
+ ${SITE_PERL_REL}/accessors/classic.pm
+PLIST_DIRS= ${SITE_PERL_REL}/accessors
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires perl 5.6.0 or above
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-accessors/distinfo b/devel/p5-accessors/distinfo
new file mode 100644
index 000000000000..f4b9d9c53a6f
--- /dev/null
+++ b/devel/p5-accessors/distinfo
@@ -0,0 +1,2 @@
+MD5 (accessors-0.02.tar.gz) = 01c4bf67f8d3f839b0a512dc990be5a8
+SIZE (accessors-0.02.tar.gz) = 6917
diff --git a/devel/p5-accessors/pkg-descr b/devel/p5-accessors/pkg-descr
new file mode 100644
index 000000000000..cd5dce06965f
--- /dev/null
+++ b/devel/p5-accessors/pkg-descr
@@ -0,0 +1,15 @@
+The accessors pragma lets you create simple accessors at compile-time.
+
+This saves you from writing them by hand, which tends to result in cut-n-paste
+errors and a mess of duplicated code. It can also help you reduce the ammount
+of unwanted direct-variable access that may creep into your codebase when
+you're feeling lazy. accessors was designed with laziness in mind.
+
+Method-chaining accessors are generated by default. This may be changed in
+future versions! If you want backwards compatability use accessors::chained
+and wait until the dust settles.
+
+See accessors::classic for accessors that always return the current value if
+you don't like method chaining.
+
+WWW: http://search.cpan.org/dist/accessors/