aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOliver Lehmann <oliver@FreeBSD.org>2005-05-31 16:41:49 +0000
committerOliver Lehmann <oliver@FreeBSD.org>2005-05-31 16:41:49 +0000
commitfbecb83eab5b750ec753a5057acd61a0b8c65670 (patch)
tree5c5c1b3566c6c4d53512709cc8318e97511a574b
parent63047f94b31d3faa2f500d0c019666f791797adb (diff)
downloadports-fbecb83eab5b750ec753a5057acd61a0b8c65670.tar.gz
ports-fbecb83eab5b750ec753a5057acd61a0b8c65670.zip
Notes
-rw-r--r--audio/sweep/Makefile2
-rw-r--r--audio/sweep/pkg-plist6
-rw-r--r--audio/vsound/Makefile2
-rw-r--r--audio/vsound/files/patch-configure19
-rw-r--r--audio/vsound/pkg-plist1
-rw-r--r--biology/libgenome/Makefile2
-rw-r--r--cad/qmls/Makefile2
-rw-r--r--comms/gsmlib/Makefile2
8 files changed, 19 insertions, 17 deletions
diff --git a/audio/sweep/Makefile b/audio/sweep/Makefile
index cdc0dfebc246..44d37a186571 100644
--- a/audio/sweep/Makefile
+++ b/audio/sweep/Makefile
@@ -24,7 +24,7 @@ LIB_DEPENDS= sndfile.1:${PORTSDIR}/audio/libsndfile \
USE_X_PREFIX= yes
USE_GMAKE= yes
-USE_LIBTOOL_VER= 13
+USE_LIBTOOL_VER=15
USE_GNOME= gnomeprefix gnomehier gnomehack gnometarget gtk12
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
diff --git a/audio/sweep/pkg-plist b/audio/sweep/pkg-plist
index 9a5420fe7b31..26d00a400f72 100644
--- a/audio/sweep/pkg-plist
+++ b/audio/sweep/pkg-plist
@@ -9,17 +9,11 @@ include/sweep/sweep_typeconvert.h
include/sweep/sweep_types.h
include/sweep/sweep_undo.h
include/sweep/sweep_version.h
-lib/sweep/libbyenergy.la
lib/sweep/libbyenergy.so
-lib/sweep/libecho.la
lib/sweep/libecho.so
-lib/sweep/libfade.la
lib/sweep/libfade.so
-lib/sweep/libladspameta.la
lib/sweep/libladspameta.so
-lib/sweep/libnormalise.la
lib/sweep/libnormalise.so
-lib/sweep/libreverse.la
lib/sweep/libreverse.so
share/gnome/apps/Multimedia/sweep.desktop
share/gnome/pixmaps/sweep.png
diff --git a/audio/vsound/Makefile b/audio/vsound/Makefile
index d9f372f57db1..410c8c8c72fd 100644
--- a/audio/vsound/Makefile
+++ b/audio/vsound/Makefile
@@ -16,7 +16,7 @@ COMMENT= Utility for capturing audio streams from programs with OSS output
BUILD_DEPENDS= sox:${PORTSDIR}/audio/sox
RUN_DEPENDS= sox:${PORTSDIR}/audio/sox
-USE_LIBTOOL_VER= 13
+USE_LIBTOOL_VER=15
.include <bsd.port.pre.mk>
diff --git a/audio/vsound/files/patch-configure b/audio/vsound/files/patch-configure
index b45e15c16de0..3e5cc7068f2e 100644
--- a/audio/vsound/files/patch-configure
+++ b/audio/vsound/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig Sun Feb 11 07:48:58 2001
-+++ configure Tue Apr 13 17:11:28 2004
-@@ -1183,21 +1194,21 @@
+--- configure.orig Tue May 31 16:40:06 2005
++++ configure Tue May 31 16:40:28 2005
+@@ -1183,21 +1183,21 @@
echo "$ac_t""$CPP" 1>&6
@@ -26,7 +26,7 @@
ac_err=`grep -v '^ *+' conftest.out | grep -v "^conftest.${ac_ext}\$"`
if test -z "$ac_err"; then
rm -rf conftest*
-@@ -1233,7 +1244,7 @@
+@@ -1233,7 +1233,7 @@
ac_cv_cpu_endian_ness="unknown"
case "$target_cpu" in
@@ -35,7 +35,16 @@
ac_cv_cpu_endian_ness="little"
;;
-@@ -1941,7 +1952,7 @@
+@@ -1674,7 +1674,7 @@
+ LD="$LD" LDFLAGS="$LDFLAGS" LIBS="$LIBS" \
+ LN_S="$LN_S" NM="$NM" RANLIB="$RANLIB" \
+ DLLTOOL="$DLLTOOL" AS="$AS" OBJDUMP="$OBJDUMP" \
+-${CONFIG_SHELL-/bin/sh} $ac_aux_dir/ltconfig --no-reexec \
++$ac_aux_dir/ltconfig --no-reexec \
+ $libtool_flags --no-verify $ac_aux_dir/ltmain.sh $host \
+ || { echo "configure: error: libtool configure failed" 1>&2; exit 1; }
+
+@@ -1941,7 +1941,7 @@
fi
if test "$ac_cv_prog_gcc" = yes ; then
diff --git a/audio/vsound/pkg-plist b/audio/vsound/pkg-plist
index 2a26e8d3c89d..5fd935da469f 100644
--- a/audio/vsound/pkg-plist
+++ b/audio/vsound/pkg-plist
@@ -1,5 +1,4 @@
bin/vsound
-lib/vsound/libvsound.la
lib/vsound/libvsound.so
@dirrm lib/vsound
%%PORTDOCS%%%%DOCSDIR%%/README
diff --git a/biology/libgenome/Makefile b/biology/libgenome/Makefile
index b6f3ffa28cf5..d621343d651d 100644
--- a/biology/libgenome/Makefile
+++ b/biology/libgenome/Makefile
@@ -17,7 +17,7 @@ COMMENT= Toolkit for developing bioinformatic related software in C++
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
USE_REINPLACE= yes
-USE_INC_LIBTOOL_VER= 13
+USE_LIBTOOL_VER=15
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
INSTALLS_SHLIB= yes
diff --git a/cad/qmls/Makefile b/cad/qmls/Makefile
index e10cba066c3c..c4b2f4b5178e 100644
--- a/cad/qmls/Makefile
+++ b/cad/qmls/Makefile
@@ -16,7 +16,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Quine-McCluskey Logic Simplifier
PLIST_FILES= bin/qmls
-USE_LIBTOOL_VER= 13
+USE_LIBTOOL_VER=15
GNU_CONFIGURE= yes
.include <bsd.port.mk>
diff --git a/comms/gsmlib/Makefile b/comms/gsmlib/Makefile
index e1a3a055960e..258f90e73704 100644
--- a/comms/gsmlib/Makefile
+++ b/comms/gsmlib/Makefile
@@ -19,7 +19,7 @@ USE_GNOME= gnometarget lthack
USE_GETOPT_LONG= yes
USE_REINPLACE= yes
USE_GMAKE= yes
-USE_INC_LIBTOOL_VER= 13
+USE_LIBTOOL_VER=15
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
INSTALLS_SHLIB= yes