aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-05-06 10:22:41 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-05-06 10:22:41 +0000
commit062ed8d36fcff34f0d3051dd7687377d27558a32 (patch)
tree35173dab2afafdac2c12b688bfc1f1397a7b8cfb
parent00787ee8ab577b8449043d2c735d6136daf31f74 (diff)
downloadports-062ed8d36fcff34f0d3051dd7687377d27558a32.tar.gz
ports-062ed8d36fcff34f0d3051dd7687377d27558a32.zip
Notes
-rw-r--r--devel/rsvndump/Makefile18
-rw-r--r--multimedia/banshee/Makefile3
-rw-r--r--multimedia/bino/Makefile4
-rw-r--r--multimedia/freevo/Makefile16
-rw-r--r--multimedia/gaupol/Makefile10
-rw-r--r--multimedia/gmencoder/Makefile2
-rw-r--r--multimedia/gnome-subtitles/Makefile10
-rw-r--r--multimedia/gopchop/Makefile17
-rw-r--r--multimedia/linux-realplayer/Makefile10
-rw-r--r--multimedia/sabbu/Makefile12
-rw-r--r--net-im/freetalk/Makefile17
-rw-r--r--net-im/licq/Makefile4
-rw-r--r--net-im/pidgin-libnotify/Makefile19
-rw-r--r--net-mgmt/ap-utils/Makefile14
-rw-r--r--net-mgmt/etherape/Makefile10
-rw-r--r--net-mgmt/wifimgr/Makefile13
-rw-r--r--net-p2p/microdc2/Makefile10
-rw-r--r--net/gnu-dico/Makefile29
-rw-r--r--net/jwhois/Makefile15
-rw-r--r--net/miredo/Makefile16
-rw-r--r--net/nc6/Makefile10
-rw-r--r--net/net6/Makefile10
-rw-r--r--net/remmina-plugins/Makefile24
-rw-r--r--net/remmina-plugins/bsd.plugin.mk6
-rw-r--r--net/remmina/Makefile29
-rw-r--r--net/smb4k-kde4/Makefile18
-rw-r--r--net/tcpreen/Makefile6
-rw-r--r--net/wol/Makefile21
-rw-r--r--palm/jpilot/Makefile16
-rw-r--r--print/gtklp/Makefile12
30 files changed, 185 insertions, 216 deletions
diff --git a/devel/rsvndump/Makefile b/devel/rsvndump/Makefile
index 719acedf578f..0a0c4ece736e 100644
--- a/devel/rsvndump/Makefile
+++ b/devel/rsvndump/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: rsvndump
-# Date created: 2008-10-12
-# Whom: glarkin
-#
+# Created by: glarkin
# $FreeBSD$
-#
PORTNAME= rsvndump
PORTVERSION= 0.5.8
@@ -15,7 +11,9 @@ COMMENT= Remote Subversion repository dumpfile generator
GNU_CONFIGURE= yes
-.if !defined(WITHOUT_NLS)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
USES+= gettext
PLIST_FILES+= share/locale/de/LC_MESSAGES/rsvndump.mo
.else
@@ -24,14 +22,12 @@ CONFIGURE_ARGS+= --disable-nls
CONFIGURE_ARGS+= --enable-man \
--with-svn=${LOCALBASE}
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
MAN1= rsvndump.1
.endif
PLIST_FILES+= bin/rsvndump
-.include <bsd.port.pre.mk>
-
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
BUILD_DEPENDS+= asciidoc:${PORTSDIR}/textproc/asciidoc \
xmlto:${PORTSDIR}/textproc/xmlto
CONFIGURE_ARGS+=--enable-man
@@ -40,4 +36,4 @@ CONFIGURE_ARGS+=--disable-man
.endif
BUILD_DEPENDS+= svn:${PORTSDIR}/devel/subversion
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/multimedia/banshee/Makefile b/multimedia/banshee/Makefile
index 48300951105f..10d21f041f31 100644
--- a/multimedia/banshee/Makefile
+++ b/multimedia/banshee/Makefile
@@ -1,4 +1,3 @@
-# Created by: Florent Thoumie <flz@FreeBSD.org>
# $FreeBSD$
PORTNAME= banshee
@@ -52,7 +51,7 @@ CONFIGURE_ARGS= --with-vendor-build-id=FreeBSD\ BSD\#\ Project --disable-gio-har
.include "${.CURDIR}/../../lang/mono/bsd.mono.mk"
-.if !defined(WITHOUT_NLS)
+.if ${PORT_OPTIONS:MNLS}
USES+= gettext
PLIST_SUB+= NLS=""
.else
diff --git a/multimedia/bino/Makefile b/multimedia/bino/Makefile
index 6a0c2057d564..1dac904f6e6a 100644
--- a/multimedia/bino/Makefile
+++ b/multimedia/bino/Makefile
@@ -31,7 +31,9 @@ LIB_DEPENDS+= ass.5:${PORTSDIR}/multimedia/libass \
MAN1= bino.1
INFO= bino
-.if !defined(WITHOUT_NLS)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
USES+= gettext
PLIST_SUB+= NLS=""
.else
diff --git a/multimedia/freevo/Makefile b/multimedia/freevo/Makefile
index 8892a14c1816..61dfd6c93789 100644
--- a/multimedia/freevo/Makefile
+++ b/multimedia/freevo/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: freevo
-# Date created: April 10 2004
-# Whom: Lewis Thompson (purple@lewiz.net)
-#
+# Created by: Lewis Thompson (purple@lewiz.net)
# $FreeBSD$
-#
PORTNAME= freevo
PORTVERSION= 1.9.0
@@ -54,15 +50,17 @@ CONFDIR= ${PREFIX}/etc/${PORTNAME}
DATADIR= ${PREFIX}/share/${PORTNAME}
DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}-${PORTVERSION}
-.if defined(WITHOUT_NLS)
-PLIST_SUB+= NLS="@comment "
-.else
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
USES+= gettext
PLIST_SUB+= NLS=""
+.else
+PLIST_SUB+= NLS="@comment "
.endif
post-patch:
-.if defined(WITHOUT_NLS)
+.if ! ${PORT_OPTIONS:MNLS}
@${REINPLACE_CMD} -e 's| freevo_locale| # freevo_locale|' ${WRKSRC}/${PORTNAME}
@${MV} ${WRKSRC}/i18n ${WRKSRC}/i18n-nls-disabled
.endif
diff --git a/multimedia/gaupol/Makefile b/multimedia/gaupol/Makefile
index 986ecb69aea3..fdf8e83aa52a 100644
--- a/multimedia/gaupol/Makefile
+++ b/multimedia/gaupol/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: gaupol
-# Date created: 08 January 2007
-# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
-#
+# Created by: Andrew Pantyukhin <infofarmer@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= gaupol
PORTVERSION= 0.19.2
@@ -28,7 +24,9 @@ INSTALLS_ICONS= yes
MAN1= ${PORTNAME}.1
-.if !defined(WITHOUT_NLS)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
USES+= gettext
PLIST_SUB+= NLS=""
.else
diff --git a/multimedia/gmencoder/Makefile b/multimedia/gmencoder/Makefile
index 4b58ea6695b0..3c8cf8930968 100644
--- a/multimedia/gmencoder/Makefile
+++ b/multimedia/gmencoder/Makefile
@@ -55,7 +55,7 @@ post-patch:
${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|/dev/dvd|${DEFAULT_DVD_DEVICE}|' \
${WRKSRC}/src/main.c ${WRKSRC}/src/interface.c
-.if defined(WITHOUT_NLS)
+.if ! ${PORT_OPTIONS:MNLS}
@${REINPLACE_CMD} -e '/^ALL_LINGUAS/d' ${WRKSRC}/configure
.endif
diff --git a/multimedia/gnome-subtitles/Makefile b/multimedia/gnome-subtitles/Makefile
index 8c34efcf9521..d0157408ae4f 100644
--- a/multimedia/gnome-subtitles/Makefile
+++ b/multimedia/gnome-subtitles/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: gnome-subtitles
-# Date created: 23 March 2007
-# Whom: Marcin Simonides <marcin@studio4plus.com>
-#
+# Created by: Marcin Simonides <marcin@studio4plus.com>
# $FreeBSD$
-#
PORTNAME= gnome-subtitles
PORTVERSION= 1.2
@@ -35,7 +31,9 @@ USE_LDCONFIG= ${PREFIX}/lib/gnome-subtitles
MAN1= gnome-subtitles.1
-.if !defined(WITHOUT_NLS)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
USES+= gettext
PLIST_SUB+= NLS=""
.else
diff --git a/multimedia/gopchop/Makefile b/multimedia/gopchop/Makefile
index ac9c24391ad5..fa209173d480 100644
--- a/multimedia/gopchop/Makefile
+++ b/multimedia/gopchop/Makefile
@@ -1,10 +1,5 @@
-# ex:ts=8
-# Ports collection makefile for: GOPchop
-# Date created: Apr 24, 2002
-# Whom: ijliao
-#
+# Created by: ijliao
# $FreeBSD$
-#
PORTNAME= gopchop
PORTVERSION= 1.0.0
@@ -28,12 +23,14 @@ PORTSCOUT= skipv:1.1.0,1.1.1,1.1.2,1.1.3,1.1.4,1.1.5,1.1.6,1.1.7,1.1.8
CPPFLAGS+= -I${LOCALBASE}/include -DHAVE_DECL_GETOPT
LDFLAGS+= -L${LOCALBASE}/lib
-.if defined(WITHOUT_NLS)
-CONFIGURE_ARGS+= --disable-nls
-PLIST_SUB+= NLS="@comment "
-.else
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
USES+= gettext
PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= NLS="@comment "
.endif
post-patch:
diff --git a/multimedia/linux-realplayer/Makefile b/multimedia/linux-realplayer/Makefile
index 5eef0b29dc51..90e6c3934e0e 100644
--- a/multimedia/linux-realplayer/Makefile
+++ b/multimedia/linux-realplayer/Makefile
@@ -28,10 +28,12 @@ RADIR= ${PREFIX}/lib/RealPlayer
PLUGINSDIR= ${PREFIX}/lib/linux-mozilla/plugins
RABINDIR= ${PREFIX}/bin
-.if defined(WITHOUT_NLS)
-PLIST_SUB+= NLS="@comment "
-.else
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
PLIST_SUB+= NLS="" LINUXBASE="${LINUXBASE}"
+.else
+PLIST_SUB+= NLS="@comment "
.endif
.include <bsd.port.pre.mk>
@@ -84,7 +86,7 @@ do-install:
${LN} -sf $c.so.6.0 ${RADIR}/codecs/$c.so
.endfor
-.if !defined(WITHOUT_NLS)
+.if ${PORT_OPTIONS:MNLS}
@${MKDIR} ${RADIR}/share/locale
${CP} -Rp ${WRKSRC}/share/locale/* ${RADIR}/share/locale
${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${RADIR}/share/locale
diff --git a/multimedia/sabbu/Makefile b/multimedia/sabbu/Makefile
index 58f388db472e..e2b8b7d84769 100644
--- a/multimedia/sabbu/Makefile
+++ b/multimedia/sabbu/Makefile
@@ -21,16 +21,18 @@ USE_GNOME= gtk20
CFLAGS+= ${PTHREAD_CFLAGS} -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS} -lswscale
-.if defined(WITHOUT_NLS)
-CONFIGURE_ARGS+= --disable-nls
-PLIST_SUB+= WITH_NLS="@comment "
-.else
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
USES+= gettext
PLIST_SUB+= WITH_NLS=""
+.else
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= WITH_NLS="@comment "
.endif
ASPELL_PORT?= textproc/aspell
-.if !defined(WITHOUT_GTKSPELL)
+.if ${PORT_OPTIONS:MGTKSPELL}
LIB_DEPENDS+= gtkspell:${PORTSDIR}/textproc/gtkspell
PLIST_SUB+= WITH_ASPELL=""
.else
diff --git a/net-im/freetalk/Makefile b/net-im/freetalk/Makefile
index 740c537a9410..a6d9902fc07a 100644
--- a/net-im/freetalk/Makefile
+++ b/net-im/freetalk/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: freetalk
-# Date created: 19 June 2009
-# Whom: Oleg Ginzburg (olevole@olevole.ru)
-#
+# Created by: Oleg Ginzburg (olevole@olevole.ru)
# $FreeBSD$
-#
PORTNAME= freetalk
PORTVERSION= 3.2
@@ -15,14 +11,15 @@ MASTER_SITES= SAVANNAH/freetalk \
MAINTAINER= olevole@olevole.ru
COMMENT= GNU console based Jabber client
-OPTIONS_DEFINE= BEEP
+OPTIONS_DEFINE= BEEP NLS
BEEP_DESC= Use beep program
LIB_DEPENDS= loudmouth-1.0:${PORTSDIR}/net-im/loudmouth
BUILD_DEPENDS= guile>=1.8.6:${PORTSDIR}/lang/guile
RUN_DEPENDS= guile>=1.8.6:${PORTSDIR}/lang/guile
-USE_GNOME= pkgconfig glib20
+USES= pkgconfig
+USE_GNOME= glib20
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
@@ -30,9 +27,9 @@ LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
MAN1= freetalk.1
INFO= freetalk
-OPTIONS= BEEP "Use beep program" off
+.include <bsd.port.options.mk>
-.if !defined(WITHOUT_NLS)
+.if ${PORT_OPTIONS:MNLS}
PLIST_SUB+= NLS=""
USES+= gettext
CONFIGURE_ARGS= --with-libintl-prefix=${LOCALBASE}
@@ -41,8 +38,6 @@ CONFIGURE_ARGS+=--disable-nls
PLIST_SUB+= NLS="@comment "
.endif
-.include <bsd.port.options.mk>
-
.if ${PORT_OPTIONS:MBEEP}
RUN_DEPENDS+= ${LOCALBASE}/bin/beep:${PORTSDIR}/audio/beep
.endif
diff --git a/net-im/licq/Makefile b/net-im/licq/Makefile
index 97275dfe7d86..91463b191f0b 100644
--- a/net-im/licq/Makefile
+++ b/net-im/licq/Makefile
@@ -30,7 +30,9 @@ CONFIGURE_ARGS+=--with-openssl-inc=${OPENSSLINC}
CONFIGURE_ARGS+=--with-openssl-lib=${OPENSSLLIB}
.endif
-.if defined(WITHOUT_NLS)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
CMAKE_ARGS+= -DENABLE_NLS:BOOL=OFF
PLIST_SUB+= NLS="@comment "
.else
diff --git a/net-im/pidgin-libnotify/Makefile b/net-im/pidgin-libnotify/Makefile
index bb72fc2497a5..94216ad3a9f8 100644
--- a/net-im/pidgin-libnotify/Makefile
+++ b/net-im/pidgin-libnotify/Makefile
@@ -1,9 +1,5 @@
-# Ports collection Makefile for: pidgin-libnotify
-# Date created: 2007-07-10
-# Whom: Meethune Bhowmick <meethune@gmail.com>
-#
+# Created by: Meethune Bhowmick <meethune@gmail.com>
# $FreeBSD$
-#
PORTNAME= libnotify
PORTVERSION= 0.14
@@ -24,14 +20,17 @@ LIB_DEPENDS= notify.4:${PORTSDIR}/devel/libnotify \
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
USE_GMAKE= yes
-USE_GNOME= pkgconfig gtk20
+USE_GNOME= gtk20
+USES= pkgconfig
-.if defined(WITHOUT_NLS)
-CONFIGURE_ARGS+= --disable-nls
-PLIST_SUB+= NLS="@comment "
-.else
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
USES+= gettext
PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= NLS="@comment "
.endif
CPPFLAGS+= ${PTHREAD_CFLAGS} -I${LOCALBASE}/include
diff --git a/net-mgmt/ap-utils/Makefile b/net-mgmt/ap-utils/Makefile
index ca96fec38dc6..335c1ccb6b8b 100644
--- a/net-mgmt/ap-utils/Makefile
+++ b/net-mgmt/ap-utils/Makefile
@@ -1,15 +1,11 @@
-# New ports collection makefile for: ap-utils
-# Date created: 2002/07/10
-# Whom: Jerry A! <jerry@thehutt.org>
-#
+# Created by: Jerry A! <jerry@thehutt.org>
# $FreeBSD$
-#
PORTNAME= ap-utils
PORTVERSION= 1.4.1
PORTREVISION= 4
CATEGORIES= net-mgmt
-MASTER_SITES=` SF
+MASTER_SITES= SF
MAINTAINER= david@catwhisker.org
COMMENT= A set of utilities to configure and monitor wireless access points
@@ -22,7 +18,9 @@ CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -lintl -L${LOCALBASE}/lib
MAN8= ap-trapd.8 ap-mrtg.8 ap-config.8
-.if !defined(WITHOUT_NLS)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
USES+= gettext
PLIST_SUB+= NLS=""
.else
@@ -34,7 +32,7 @@ PLIST_SUB+= NLS="@comment "
post-patch:
@${REINPLACE_CMD} -e 's|_nl_domain_bindings|libintl_nl_domain_bindings|' ${WRKSRC}/configure
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
post-install:
${MKDIR} ${DOCSDIR}
cd ${WRKSRC}/Documentation && \
diff --git a/net-mgmt/etherape/Makefile b/net-mgmt/etherape/Makefile
index bf7fbb90aa69..dd3400aad376 100644
--- a/net-mgmt/etherape/Makefile
+++ b/net-mgmt/etherape/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: etherape
-# Date created: 4 April 2001
-# Whom: Holger Lamm <holger@eit.uni-kl.de>
-#
+# Created by: Holger Lamm <holger@eit.uni-kl.de>
# $FreeBSD$
-#
PORTNAME= etherape
PORTVERSION= 0.9.9
@@ -23,7 +19,9 @@ LDFLAGS+= -L${LOCALBASE}/lib
MAN1= etherape.1
-.if !defined(WITHOUT_NLS)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
USES+= gettext
PLIST_SUB+= NLS=""
.else
diff --git a/net-mgmt/wifimgr/Makefile b/net-mgmt/wifimgr/Makefile
index e23c4e95b220..3d877e19c9f2 100644
--- a/net-mgmt/wifimgr/Makefile
+++ b/net-mgmt/wifimgr/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: wifimgr
-# Date created: 2009 November 10
-# Whom: J.R. Oldroyd <fbsd@opal.com>
-#
+# Created by: J.R. Oldroyd <fbsd@opal.com>
# $FreeBSD$
-#
PORTNAME= wifimgr
PORTVERSION= 1.10
@@ -15,12 +11,15 @@ MASTER_SITES= http://opal.com/freebsd/ports/net-mgmt/wifimgr/ \
MAINTAINER= fbsd@opal.com
COMMENT= WiFi Networks Manager
+USES= pkgconfig
USE_BZIP2= yes
USE_XORG= x11
-USE_GNOME= gtk20 pkgconfig
+USE_GNOME= gtk20
INSTALLS_ICONS= yes
-.if !defined(WITHOUT_NLS)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
USES+= gettext
PLIST_SUB+= NLS=""
.else
diff --git a/net-p2p/microdc2/Makefile b/net-p2p/microdc2/Makefile
index 76b135010778..4a23f66ef971 100644
--- a/net-p2p/microdc2/Makefile
+++ b/net-p2p/microdc2/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: microdc
-# Date created: 2006-12-02
-# Whom: Pankov Pavel <pankov_p@mail.ru>
-#
+# Created by: Pankov Pavel <pankov_p@mail.ru>
# $FreeBSD$
-#
PORTNAME= microdc2
PORTVERSION= 0.15.6
@@ -21,7 +17,9 @@ GNU_CONFIGURE= yes
USES= iconv
USE_GNOME= libxml2
-.if !defined(WITHOUT_NLS)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
USES+= gettext
PLIST_SUB+= NLS=""
.else
diff --git a/net/gnu-dico/Makefile b/net/gnu-dico/Makefile
index 04c193f84a40..7b345c859c21 100644
--- a/net/gnu-dico/Makefile
+++ b/net/gnu-dico/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: gnu dico
-# Date created: 27-12-2009
-# Whom: Goran Tal
-#
+# Created by: Goran Tal
# $FreeBSD$
-#
PORTNAME= dico
PORTVERSION= 2.2
@@ -26,16 +22,13 @@ CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS= --localstatedir=/var
-OPTIONS= PYTHON "With PYTHON support" on \
- GUILE "With GUILE support" on \
- PCRE "With PCRE support" on \
- GSASL "With GSASL support" off \
- PAM "With PAM support" off \
- LDAP "With LDAP support" off
+OPTIONS_DEFINE= PYTHON GUILE PCRE GSASL PAM LDAP
+OPTIONS_DEFAULT= PYTHON GUILE PCRE
+GSASL_DESC= GSASL support
.include <bsd.port.options.mk>
-.if defined(WITH_PYTHON)
+.if ${PORT_OPTIONS:MPYTHON}
USE_PYTHON= yes
PLIST_SUB+= PYTHON=""
.else
@@ -43,7 +36,7 @@ CONFIGURE_ARGS+=--without-python
PLIST_SUB+= PYTHON="@comment "
.endif
-.if defined(WITH_GUILE)
+.if ${PORT_OPTIONS:MGUILE}
LIB_DEPENDS+= guile.21:${PORTSDIR}/lang/guile
PLIST_SUB+= GUILE=""
.else
@@ -51,7 +44,7 @@ CONFIGURE_ARGS+=--without-guile
PLIST_SUB+= GUILE="@comment "
.endif
-.if defined(WITH_PCRE)
+.if ${PORT_OPTIONS:MPCRE}
LIB_DEPENDS+= pcre.3:${PORTSDIR}/devel/pcre
PLIST_SUB+= PCRE=""
.else
@@ -59,14 +52,14 @@ CONFIGURE_ARGS+=--without-pcre
PLIST_SUB+= PCRE="@comment "
.endif
-.if defined(WITH_GSASL)
+.if ${PORT_OPTIONS:MGSASL}
LIB_DEPENDS+= gsasl.16:${PORTSDIR}/security/gsasl
CONFIGURE_ARGS+=--with-gsasl
.else
CONFIGURE_ARGS+=--without-gsasl
.endif
-.if defined(WITH_PAM)
+.if ${PORT_OPTIONS:MPAM}
PLIST_SUB+= PAM=""
CONFIGURE_ARGS+=--enable-pam
.else
@@ -74,7 +67,7 @@ PLIST_SUB+= PAM="@comment "
CONFIGURE_ARGS+=--disable-pam
.endif
-.if defined(WITH_LDAP)
+.if ${PORT_OPTIONS:MLDAP}
USE_OPENLDAP= yes
PLIST_SUB+= LDAP=""
.else
@@ -82,7 +75,7 @@ CONFIGURE_ARGS+=--without-ldap
PLIST_SUB+= LDAP="@comment "
.endif
-.if !defined(WITHOUT_NLS)
+.if ${PORT_OPTIONS:MNLS}
USES+= gettext
PLIST_SUB+= NLS=""
.else
diff --git a/net/jwhois/Makefile b/net/jwhois/Makefile
index c356e53a849e..4bff3acb95f1 100644
--- a/net/jwhois/Makefile
+++ b/net/jwhois/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: jwhois
-# Date created: 15 Jul 2000
-# Whom: matusita@jp.FreeBSD.org
-#
+# Created by: matusita@jp.FreeBSD.org
# $FreeBSD$
-#
PORTNAME= jwhois
PORTVERSION= 4.0
@@ -22,11 +18,14 @@ USE_GMAKE= yes
CPPFLAGS+= -I${PREFIX}/include
LDFLAGS+= -L${PREFIX}/lib
CONFIGURE_ARGS= --localstatedir=${PREFIX}/var/jwhois
-.if defined(WITHOUT_NLS)
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
+PLIST_SUB= NLS=""
+.else
CONFIGURE_ARGS+= --disable-nls
PLIST_SUB= NLS="@comment "
-.else
-PLIST_SUB= NLS=""
.endif
INSTALL_TARGET= install-strip
diff --git a/net/miredo/Makefile b/net/miredo/Makefile
index ec73e3b72578..d14fe82556a3 100644
--- a/net/miredo/Makefile
+++ b/net/miredo/Makefile
@@ -1,9 +1,5 @@
-# Ports collection makefile for: miredo
-# Date created: 2006-08-12
-# Whom: Andreas Kohn <andreas@syndrom23.de>
-#
+# Created by: Andreas Kohn <andreas@syndrom23.de>
# $FreeBSD$
-#
PORTNAME= miredo
PORTVERSION= 1.2.5
@@ -21,7 +17,8 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --localstatedir=/var --enable-examplesdir=$(EXAMPLESDIR)
USE_LDCONFIG= yes
-OPTIONS= POLICYTABLE "Install policy table to support teredo" off
+OPTIONS_DEFINE= POLICYTABLE NLS
+POLICYTABLE_DESC= Install policy table to support teredo
MAN1= teredo-mire.1
MAN5= miredo-server.conf.5 miredo.conf.5
@@ -30,7 +27,9 @@ USE_RC_SUBR= miredo_server miredo
LDFLAGS+= -L${LOCALBASE}/lib
-.if !defined(WITHOUT_NLS)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
USES+= gettext iconv
CONFIGURE_ARGS+= --enable-nls
PLIST_SUB= NLS=""
@@ -39,10 +38,9 @@ CONFIGURE_ARGS+= --disable-nls
PLIST_SUB= NLS="@comment "
.endif
-.include <bsd.port.options.mk>
post-install:
-.if defined(WITH_POLICYTABLE)
+.if ${PORT_OPTIONS:MPOLICYTABLE}
$(INSTALL_DATA) $(FILESDIR)/ip6addrctl.conf /etc
PLIST_SUB+= POLICYTABLE=""
.else
diff --git a/net/nc6/Makefile b/net/nc6/Makefile
index 427375c7750c..32a19c8e1b33 100644
--- a/net/nc6/Makefile
+++ b/net/nc6/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: nc6
-# Date created: 30 May 2002
-# Whom: Filippo Natali <filippo@widestore.net>
-#
+# Created by: Filippo Natali <filippo@widestore.net>
# $FreeBSD$
-#
PORTNAME= nc6
PORTVERSION= 1.0
@@ -21,7 +17,9 @@ GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-.if !defined(WITHOUT_NLS)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
USES+= gettext
PLIST_SUB+= NLS=""
.else
diff --git a/net/net6/Makefile b/net/net6/Makefile
index f4010d49aee6..ed8141b54b65 100644
--- a/net/net6/Makefile
+++ b/net/net6/Makefile
@@ -20,14 +20,16 @@ USE_AUTOTOOLS= libtool
MAKE_JOBS_SAFE= yes
USE_LDCONFIG= yes
-.if defined(WITHOUT_NLS)
-CONFIGURE_ARGS+=--disable-nls
-PLIST_SUB+= NLS="@comment "
-.else
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
USES+= gettext
PLIST_SUB+= NLS=""
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
+.else
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB+= NLS="@comment "
.endif
.include <bsd.port.mk>
diff --git a/net/remmina-plugins/Makefile b/net/remmina-plugins/Makefile
index 61da5d548506..046c97797cb0 100644
--- a/net/remmina-plugins/Makefile
+++ b/net/remmina-plugins/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: remmina-plugins
-# Date created: 24 June 2010
-# Whom: Alexander Logvinov <avl@FreeBSD.org>
-#
+# Created by: Alexander Logvinov <avl@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME?= remmina-plugins
PORTVERSION= 0.9.2
@@ -19,29 +15,31 @@ COMMENT?= Remmina plugin system
.include "${.CURDIR}/../remmina-plugins/bsd.plugin.mk"
.else
-OPTIONS= RDP "Install RDP protocol plugin" on \
- VNC "Install VNC protocol plugin" on \
- XDMCP "Install XDMCP protocol plugin" on \
- TELEP "Install Telepathy protocol plugin" on
+OPTIONS_DEFINE= RDP VNC XDMCP TELEP
+OPTIONS_DEFAULT= RDP VNC XDMCP TELEP
+RDP_DESC= RDP protocol plugin
+VNC_DESC= VNC protocol plugin
+XDMCP_DESC= XDMCP protocol plugin
+TELEP_DESC= Telepathy protocol plugin
NO_BUILD= yes
PATCHDIR= # none
.include <bsd.port.options.mk>
-.if !defined(WITHOUT_RDP)
+.if ${PORT_OPTIONS:MRDP}
RUN_DEPENDS+= ${LOCALBASE}/lib/remmina/plugins/remmina-plugin-rdp.so:${PORTSDIR}/net/remmina-plugin-rdp
.endif
-.if !defined(WITHOUT_VNC)
+.if ${PORT_OPTIONS:MVNC}
RUN_DEPENDS+= ${LOCALBASE}/lib/remmina/plugins/remmina-plugin-vnc.so:${PORTSDIR}/net/remmina-plugin-vnc
.endif
-.if !defined(WITHOUT_XDMCP)
+.if ${PORT_OPTIONS:MXDMCP}
RUN_DEPENDS+= ${LOCALBASE}/lib/remmina/plugins/remmina-plugin-xdmcp.so:${PORTSDIR}/net/remmina-plugin-xdmcp
.endif
-.if !defined(WITHOUT_TELEP)
+.if ${PORT_OPTIONS:MTELEP}
RUN_DEPENDS+= ${LOCALBASE}/lib/remmina/plugins/remmina-plugin-telepathy.so:${PORTSDIR}/net/remmina-plugin-telepathy
.endif
diff --git a/net/remmina-plugins/bsd.plugin.mk b/net/remmina-plugins/bsd.plugin.mk
index 6aa1b7e77816..88cddb9915c9 100644
--- a/net/remmina-plugins/bsd.plugin.mk
+++ b/net/remmina-plugins/bsd.plugin.mk
@@ -31,12 +31,12 @@ CONFIGURE_ARGS+=--enable${PKGNAMESUFFIX}
PLIST_SUB+= PLUGIN="${PKGNAMESUFFIX:S,-,,}"
PLIST= ${PKGDIR}/pkg-plist.plugin
-.if defined(WITH_TELEP)
+.if ${PORT_OPTIONS:MTELEP}
PLIST_SUB+= TELEP="" ICONS="@comment "
.else
PLIST_SUB+= TELEP="@comment " ICONS=""
.endif
-.if defined(WITH_SSH)
+.if ${PORT_OPTIONS:MTELEP}
LIB_DEPENDS+= ssh.4:${PORTSDIR}/security/libssh
CONFIGURE_ARGS+=--enable-ssh
PLIST_SUB+= SSH="@comment "
@@ -47,7 +47,7 @@ LDFLAGS+= -fstack-protector
PLIST_SUB+= SSH=""
.endif
-.if !defined(WITHOUT_NLS)
+.if ${PORT_OPTONS:MNLS}
RUN_DEPENDS+= ${LOCALBASE}/share/locale/bg/LC_MESSAGES/remmina-plugins.mo:${PORTSDIR}/net/remmina-plugin-i18n
.endif
diff --git a/net/remmina/Makefile b/net/remmina/Makefile
index 8e0a29654521..3ad1277b9ea0 100644
--- a/net/remmina/Makefile
+++ b/net/remmina/Makefile
@@ -10,11 +10,12 @@ MASTER_SITES= SF/${PORTNAME}/0.9
MAINTAINER= fluffy@FreeBSD.org
COMMENT= The GTK+ Remote Desktop Client
-OPTIONS= SSH "Build with SSH tunneling support" on \
- GCRYPT "Build with libgcrypt support for password encryption" on \
- TERM "Build with terminal support" on \
- AVAHI "Build with Avahi support" on \
- UNIQUE "Build with Unique-App support" on
+OPTIONS_DEFINE= SSH GCRYPT TERM AVAHI UNIQUE NLS
+OPTIONS_DEFAULT= SSH GCRYPT TERM AVAHI UNIQUE
+SSH_DESC= SSH tunneling support
+GCRYPT_DESC= libgcrypt support for password encryption
+TERM_DESC= terminal support
+UNIQUE_DESC= Unique-App support
GNU_CONFIGURE= yes
USE_GMAKE= yes
@@ -29,15 +30,15 @@ LICENSE_FILE= ${WRKSRC}/COPYING
.include <bsd.port.options.mk>
-.if defined(WITHOUT_NLS)
-CONFIGURE_ARGS+=--disable-nls
-PLIST_SUB+= NLS="@comment "
-.else
+.if ${PORT_OPTIONS:MNLS}
USES+= gettext
PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB+= NLS="@comment "
.endif
-.if !defined(WITHOUT_SSH)
+.if ${PORT_OPTIONS:MSSH}
BUILD_DEPENDS+= ${LOCALBASE}/include/libssh/libssh.h:${PORTSDIR}/security/libssh
RUN_DEPENDS+= ${LOCALBASE}/lib/libssh.so.4:${PORTSDIR}/security/libssh
.if ${OSVERSION} >= 800040
@@ -47,25 +48,25 @@ LDFLAGS+= -fstack-protector
CONFIGURE_ARGS+=--disable-ssh
.endif
-.if !defined(WITHOUT_GCRYPT)
+.if ${PORT_OPTIONS:MGCRYPT}
LIB_DEPENDS+= gcrypt:${PORTSDIR}/security/libgcrypt
.else
CONFIGURE_ARGS+=--disable-gcrypt
.endif
-.if !defined(WITHOUT_TERM)
+.if ${PORT_OPTIONS:MTERM}
USE_GNOME+= vte
.else
CONFIGURE_ARGS+=--disable-vte
.endif
-.if !defined(WITHOUT_AVAHI)
+.if ${PORT_OPTIONS:MAVAHI}
LIB_DEPENDS+= avahi-ui.0:${PORTSDIR}/net/avahi-gtk
.else
CONFIGURE_ARGS+=--disable-avahi
.endif
-.if !defined(WITHOUT_UNIQUE)
+.if ${PORT_OPTIONS:MUNIQUE}
LIB_DEPENDS+= unique-1.0.2:${PORTSDIR}/x11-toolkits/unique
.else
CONFIGURE_ARGS+=--disable-unique
diff --git a/net/smb4k-kde4/Makefile b/net/smb4k-kde4/Makefile
index 61722f1f8809..ce1b9ac8611e 100644
--- a/net/smb4k-kde4/Makefile
+++ b/net/smb4k-kde4/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: smb4k-kde4
-# Date created: 02 Jan 2011
-# Whom: Josh Paetzel <jpaetzel@FreeBSD.org>
-#
+# Created by: Josh Paetzel <jpaetzel@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= smb4k-kde4
PORTVERSION= 0.10.9
@@ -30,19 +26,21 @@ USE_QT4= corelib gui network opengl script svg webkit \
DOCSDIR= ${PREFIX}/share/doc/HTML/en/smb4k
SUB_FILES= pkg-message
-.if defined(WITHOUT_NLS)
-NLS= "@comment "
-.else
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
NLS= ""
+.else
+NLS= "@comment "
.endif
PLIST_SUB+= NLS=${NLS}
pre-configure:
-.if defined(WITHOUT_NLS)
+.if ! ${PORT_OPTIONS:MNLS}
${REINPLACE_CMD} -e 's|add_subdirectory( po )|#add_subdirectory( po )|' \
${WRKSRC}/CMakeLists.txt
.endif
-.if defined(NOPORTDOCS)
+.if ! ${PORT_OPTIONS:MDOCS}
${REINPLACE_CMD} -e 's|add_subdirectory( doc )|#add_subdirectory( doc )|' \
${WRKSRC}/CMakeLists.txt
.endif
diff --git a/net/tcpreen/Makefile b/net/tcpreen/Makefile
index 605be9513d8d..502cb0f4aa79 100644
--- a/net/tcpreen/Makefile
+++ b/net/tcpreen/Makefile
@@ -16,7 +16,9 @@ MAN1= tcpreen.1
DOC_FILES= AUTHORS NEWS README THANKS TODO
-.if !defined(WITHOUT_NLS)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
USES+= gettext
PLIST_SUB+= NLS=""
.else
@@ -25,7 +27,7 @@ PLIST_SUB+= NLS="@comment "
.endif
post-install:
-.ifndef(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
.for file in ${DOC_FILES}
@${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
diff --git a/net/wol/Makefile b/net/wol/Makefile
index 1d4de7c79266..a0b7981d9ee4 100644
--- a/net/wol/Makefile
+++ b/net/wol/Makefile
@@ -1,5 +1,3 @@
-# ex:ts=8
-# Ports collection makefile for: wol
# Created by: ijliao
# $FreeBSD$
@@ -17,19 +15,20 @@ USE_PERL5_BUILD= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-.if defined(WITHOUT_NLS)
-CONFIGURE_ARGS= --disable-nls
-PLIST_SUB= NLS="@comment "
-.else
-USES+= gettext iconv
-PLIST_SUB= NLS=""
-.endif
-
MAN1= wol.1
INFO= wol
DOCS= AUTHORS NEWS README TODO
-.if !defined(NOPORTDOCS)
+.include <bsd.port.options.mk>
+.if ${PORT_OPTIONS:MNLS}
+USES+= gettext iconv
+PLIST_SUB= NLS=""
+.else
+CONFIGURE_ARGS= --disable-nls
+PLIST_SUB= NLS="@comment "
+.endif
+
+.if ${PORT_OPTIONS:MDOCS}
post-install:
@${MKDIR} ${DOCSDIR}
cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
diff --git a/palm/jpilot/Makefile b/palm/jpilot/Makefile
index c800b463a463..c637c5d62924 100644
--- a/palm/jpilot/Makefile
+++ b/palm/jpilot/Makefile
@@ -26,7 +26,13 @@ CONFIGURE_ARGS+= --with-pilot-prefix=${LOCALBASE}
LICENSE= GPLv2
-.if !defined(WITHOUT_NLS)
+USE_GNOME+= gtk20
+
+MAN1= jpilot-dial.1 jpilot-dump.1 jpilot-sync.1 jpilot.1
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
USES+= gettext
CONFIGURE_ARGS+= --enable-nls
PLIST_SUB= NLS=""
@@ -35,11 +41,7 @@ CONFIGURE_ARGS+= --disable-nls
PLIST_SUB= NLS="@comment "
.endif
-USE_GNOME+= gtk20
-
-MAN1= jpilot-dial.1 jpilot-dump.1 jpilot-sync.1 jpilot.1
-
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
PORTDOCS= *
.endif
@@ -62,7 +64,7 @@ post-install:
${SED} 's,^${PREFIX}/,,' >> ${TMPPLIST}
@${FIND} ${DATADIR} -type d | ${SORT} -r | \
${SED} 's,^${PREFIX}/,@dirrm ,' >> ${TMPPLIST}
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
.for ext in html png jpg
${INSTALL_DATA} ${WRKSRC}/docs/*.${ext} ${DOCSDIR}
diff --git a/print/gtklp/Makefile b/print/gtklp/Makefile
index 51962010d463..26eda1d756c0 100644
--- a/print/gtklp/Makefile
+++ b/print/gtklp/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: gtklp
-# Date created: 22 Oct 2002
-# Whom: Martin Klaffenboeck <martin.klaffenboeck@gmx.at>
-#
+# Created by: Martin Klaffenboeck <martin.klaffenboeck@gmx.at>
# $FreeBSD$
-#
PORTNAME= gtklp
PORTVERSION= 1.2.9
@@ -13,7 +9,7 @@ CATEGORIES= print
MASTER_SITES= SF
MAINTAINER= sylvio@FreeBSD.org
-COMMENT= A gtk interface to cups
+COMMENT= GTK interface to cups
LIB_DEPENDS= cups.2:${PORTSDIR}/print/cups-client
@@ -28,7 +24,9 @@ LDFLAGS+= -L${LOCALBASE}/lib
MAN1= gtklp.1 gtklpq.1
-.if !defined(WITHOUT_NLS)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
USES+= gettext
PLIST_SUB+= NLS=""
.endif