aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-02-21 18:55:42 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-02-21 18:55:42 +0000
commit1b5362f4a7b350f031e2c7fa7dc98699a6baad83 (patch)
tree663c0ac7e466eec0553975aa45a99303ac66abb3
parent29ac4503d4cba3a2ad48832c897a0c4819568ee6 (diff)
downloadports-1b5362f4a7b350f031e2c7fa7dc98699a6baad83.tar.gz
ports-1b5362f4a7b350f031e2c7fa7dc98699a6baad83.zip
Notes
-rw-r--r--net/gupnp-igd/Makefile6
-rw-r--r--net/gupnp-igd/files/patch-configure61
-rw-r--r--net/gupnp-igd/files/patch-gupnp-igd-1.0.pc.in11
-rw-r--r--net/gupnp-igd/files/patch-libgupnp-igd-GUPnPIgd-1.0.gir11
-rw-r--r--net/gupnp-igd/files/patch-libgupnp-igd-Makefile.in11
5 files changed, 95 insertions, 5 deletions
diff --git a/net/gupnp-igd/Makefile b/net/gupnp-igd/Makefile
index 1b7176c22293..054ccab16ce3 100644
--- a/net/gupnp-igd/Makefile
+++ b/net/gupnp-igd/Makefile
@@ -22,13 +22,9 @@ RUN_DEPENDS= gupnp>=0.18:net/gupnp
USES= compiler:c11 gmake gnome libtool pathfix pkgconfig tar:xz
USE_GNOME= glib20 introspection:build
-CONFIGURE_ARGS= --enable-introspection=yes --disable-python
+CONFIGURE_ARGS= --disable-python --enable-introspection=yes
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
USE_LDCONFIG= yes
-post-patch:
- @${REINPLACE_CMD} -e 's|gssdp-1.0|gssdp-1.2|; s|gupnp-1.0|gupnp-1.2|' ${WRKSRC}/configure ${WRKSRC}/gupnp-igd-1.0.pc.in ${WRKSRC}/libgupnp-igd/Makefile.in ${WRKSRC}/libgupnp-igd/GUPnPIgd-1.0.gir
- @${REINPLACE_CMD} -e '/ --define-variable=/d' ${WRKSRC}/configure
-
.include <bsd.port.mk>
diff --git a/net/gupnp-igd/files/patch-configure b/net/gupnp-igd/files/patch-configure
new file mode 100644
index 000000000000..709b1412eca7
--- /dev/null
+++ b/net/gupnp-igd/files/patch-configure
@@ -0,0 +1,61 @@
+--- configure.orig 2017-11-20 16:27:28 UTC
++++ configure
+@@ -13055,12 +13055,12 @@ if test -n "$LIBGUPNP_CFLAGS"; then
+ pkg_cv_LIBGUPNP_CFLAGS="$LIBGUPNP_CFLAGS"
+ elif test -n "$PKG_CONFIG"; then
+ if test -n "$PKG_CONFIG" && \
+- { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"glib-2.0 >= 2.26 gobject-2.0 >= 2.26 gssdp-1.0 gupnp-1.0 >= 0.18 gthread-2.0\""; } >&5
+- ($PKG_CONFIG --exists --print-errors "glib-2.0 >= 2.26 gobject-2.0 >= 2.26 gssdp-1.0 gupnp-1.0 >= 0.18 gthread-2.0") 2>&5
++ { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"glib-2.0 >= 2.26 gobject-2.0 >= 2.26 gssdp-1.2 gupnp-1.2 >= 0.18 gthread-2.0\""; } >&5
++ ($PKG_CONFIG --exists --print-errors "glib-2.0 >= 2.26 gobject-2.0 >= 2.26 gssdp-1.2 gupnp-1.2 >= 0.18 gthread-2.0") 2>&5
+ ac_status=$?
+ $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
+ test $ac_status = 0; }; then
+- pkg_cv_LIBGUPNP_CFLAGS=`$PKG_CONFIG --cflags "glib-2.0 >= 2.26 gobject-2.0 >= 2.26 gssdp-1.0 gupnp-1.0 >= 0.18 gthread-2.0" 2>/dev/null`
++ pkg_cv_LIBGUPNP_CFLAGS=`$PKG_CONFIG --cflags "glib-2.0 >= 2.26 gobject-2.0 >= 2.26 gssdp-1.2 gupnp-1.2 >= 0.18 gthread-2.0" 2>/dev/null`
+ test "x$?" != "x0" && pkg_failed=yes
+ else
+ pkg_failed=yes
+@@ -13072,12 +13072,12 @@ if test -n "$LIBGUPNP_LIBS"; then
+ pkg_cv_LIBGUPNP_LIBS="$LIBGUPNP_LIBS"
+ elif test -n "$PKG_CONFIG"; then
+ if test -n "$PKG_CONFIG" && \
+- { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"glib-2.0 >= 2.26 gobject-2.0 >= 2.26 gssdp-1.0 gupnp-1.0 >= 0.18 gthread-2.0\""; } >&5
+- ($PKG_CONFIG --exists --print-errors "glib-2.0 >= 2.26 gobject-2.0 >= 2.26 gssdp-1.0 gupnp-1.0 >= 0.18 gthread-2.0") 2>&5
++ { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"glib-2.0 >= 2.26 gobject-2.0 >= 2.26 gssdp-1.2 gupnp-1.2 >= 0.18 gthread-2.0\""; } >&5
++ ($PKG_CONFIG --exists --print-errors "glib-2.0 >= 2.26 gobject-2.0 >= 2.26 gssdp-1.2 gupnp-1.2 >= 0.18 gthread-2.0") 2>&5
+ ac_status=$?
+ $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
+ test $ac_status = 0; }; then
+- pkg_cv_LIBGUPNP_LIBS=`$PKG_CONFIG --libs "glib-2.0 >= 2.26 gobject-2.0 >= 2.26 gssdp-1.0 gupnp-1.0 >= 0.18 gthread-2.0" 2>/dev/null`
++ pkg_cv_LIBGUPNP_LIBS=`$PKG_CONFIG --libs "glib-2.0 >= 2.26 gobject-2.0 >= 2.26 gssdp-1.2 gupnp-1.2 >= 0.18 gthread-2.0" 2>/dev/null`
+ test "x$?" != "x0" && pkg_failed=yes
+ else
+ pkg_failed=yes
+@@ -13098,14 +13098,14 @@ else
+ _pkg_short_errors_supported=no
+ fi
+ if test $_pkg_short_errors_supported = yes; then
+- LIBGUPNP_PKG_ERRORS=`$PKG_CONFIG --short-errors --print-errors --cflags --libs "glib-2.0 >= 2.26 gobject-2.0 >= 2.26 gssdp-1.0 gupnp-1.0 >= 0.18 gthread-2.0" 2>&1`
++ LIBGUPNP_PKG_ERRORS=`$PKG_CONFIG --short-errors --print-errors --cflags --libs "glib-2.0 >= 2.26 gobject-2.0 >= 2.26 gssdp-1.2 gupnp-1.2 >= 0.18 gthread-2.0" 2>&1`
+ else
+- LIBGUPNP_PKG_ERRORS=`$PKG_CONFIG --print-errors --cflags --libs "glib-2.0 >= 2.26 gobject-2.0 >= 2.26 gssdp-1.0 gupnp-1.0 >= 0.18 gthread-2.0" 2>&1`
++ LIBGUPNP_PKG_ERRORS=`$PKG_CONFIG --print-errors --cflags --libs "glib-2.0 >= 2.26 gobject-2.0 >= 2.26 gssdp-1.2 gupnp-1.2 >= 0.18 gthread-2.0" 2>&1`
+ fi
+ # Put the nasty error message in config.log where it belongs
+ echo "$LIBGUPNP_PKG_ERRORS" >&5
+
+- as_fn_error $? "Package requirements (glib-2.0 >= 2.26 gobject-2.0 >= 2.26 gssdp-1.0 gupnp-1.0 >= 0.18 gthread-2.0) were not met:
++ as_fn_error $? "Package requirements (glib-2.0 >= 2.26 gobject-2.0 >= 2.26 gssdp-1.2 gupnp-1.2 >= 0.18 gthread-2.0) were not met:
+
+ $LIBGUPNP_PKG_ERRORS
+
+@@ -13655,8 +13655,6 @@ fi
+
+
+ if test "x$found_introspection" = "xyes"; then
+- INTROSPECTION_TYPELIBDIR=`$PKG_CONFIG --variable=typelibdir --define-variable="libdir=${libdir}" gobject-introspection-1.0`
+- INTROSPECTION_GIRDIR=`$PKG_CONFIG --variable=girdir --define-variable="datadir=${datadir}" gobject-introspection-1.0`
+
+
+ fi
diff --git a/net/gupnp-igd/files/patch-gupnp-igd-1.0.pc.in b/net/gupnp-igd/files/patch-gupnp-igd-1.0.pc.in
new file mode 100644
index 000000000000..8bff8053894b
--- /dev/null
+++ b/net/gupnp-igd/files/patch-gupnp-igd-1.0.pc.in
@@ -0,0 +1,11 @@
+--- gupnp-igd-1.0.pc.in.orig 2009-05-04 22:40:53 UTC
++++ gupnp-igd-1.0.pc.in
+@@ -5,7 +5,7 @@ includedir=@includedir@
+
+ Name: gupnp-igd-1.0
+ Description: GUPnP Simple IGD library
+-Requires: gupnp-1.0
++Requires: gupnp-1.2
+ Version: @VERSION@
+ Libs: -L${libdir} -lgupnp-igd-1.0
+ Cflags: -I${includedir}/gupnp-igd-1.0
diff --git a/net/gupnp-igd/files/patch-libgupnp-igd-GUPnPIgd-1.0.gir b/net/gupnp-igd/files/patch-libgupnp-igd-GUPnPIgd-1.0.gir
new file mode 100644
index 000000000000..0066daf7259c
--- /dev/null
+++ b/net/gupnp-igd/files/patch-libgupnp-igd-GUPnPIgd-1.0.gir
@@ -0,0 +1,11 @@
+--- libgupnp-igd/GUPnPIgd-1.0.gir.orig 2017-11-20 16:27:47 UTC
++++ libgupnp-igd/GUPnPIgd-1.0.gir
+@@ -7,7 +7,7 @@ and/or use gtk-doc annotations. -->
+ xmlns:c="http://www.gtk.org/introspection/c/1.0"
+ xmlns:glib="http://www.gtk.org/introspection/glib/1.0">
+ <include name="GObject" version="2.0"/>
+- <package name="gupnp-1.0"/>
++ <package name="gupnp-1.2"/>
+ <namespace name="GUPnPIgd"
+ version="1.0"
+ shared-library="libgupnp-igd-1.0.so.4"
diff --git a/net/gupnp-igd/files/patch-libgupnp-igd-Makefile.in b/net/gupnp-igd/files/patch-libgupnp-igd-Makefile.in
new file mode 100644
index 000000000000..ff6bd66f831d
--- /dev/null
+++ b/net/gupnp-igd/files/patch-libgupnp-igd-Makefile.in
@@ -0,0 +1,11 @@
+--- libgupnp-igd/Makefile.in.orig 2017-11-20 16:27:29 UTC
++++ libgupnp-igd/Makefile.in
+@@ -411,7 +411,7 @@ GUPnPIgd_1_0_gir_VERSION = 1.0
+ GUPnPIgd_1_0_gir_LIBS = $(lib_LTLIBRARIES)
+ GUPnPIgd_1_0_gir_FILES = $(libgupnp_igd_1_0_la_SOURCES) $(libgupnp_igd_inc_HEADERS)
+ GUPnPIgd_1_0_gir_INCLUDES = GObject-2.0
+-GUPnPIgd_1_0_gir_PACKAGES = gupnp-1.0
++GUPnPIgd_1_0_gir_PACKAGES = gupnp-1.2
+ GUPnPIgd_1_0_gir_CFLAGS = -I$(srcdir) -I$(top_srcdir)
+ @HAVE_INTROSPECTION_TRUE@girdir = $(INTROSPECTION_GIRDIR)
+ @HAVE_INTROSPECTION_TRUE@dist_gir_DATA = $(INTROSPECTION_GIRS)