aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-03-01 23:35:17 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-03-01 23:35:17 +0000
commit28eaef1ec7bae7a75a36f01293c649e3e3d1a135 (patch)
treecfe5a1a0fd67b1ea1740aa9111bd2e1ba76686b0
parentf018d5629aa7e9d8d87e3a38f34661dd6a670da5 (diff)
downloadports-28eaef1ec7bae7a75a36f01293c649e3e3d1a135.tar.gz
ports-28eaef1ec7bae7a75a36f01293c649e3e3d1a135.zip
Notes
-rw-r--r--misc/gkrellweather2/Makefile16
-rw-r--r--misc/gkrellweather2/distinfo4
-rw-r--r--misc/gkrellweather2/files/extra-patch-lrintf11
-rw-r--r--misc/gkrellweather2/files/patch-Makefile17
-rw-r--r--misc/gkrellweather2/pkg-plist1
5 files changed, 37 insertions, 12 deletions
diff --git a/misc/gkrellweather2/Makefile b/misc/gkrellweather2/Makefile
index a1fec3731d6e..ebc60fd1b22a 100644
--- a/misc/gkrellweather2/Makefile
+++ b/misc/gkrellweather2/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= gkrellweather
-PORTVERSION= 2.0.6
-PORTREVISION= 3
+PORTVERSION= 2.0.7
CATEGORIES= misc
MASTER_SITES= http://kmlinux.fjfi.cvut.cz/~makovick/gkrellm/
EXTRACT_SUFX= .tgz
@@ -16,8 +15,7 @@ MAINTAINER= pav@FreeBSD.org
COMMENT= GKrellWeather is a weather plugin for GKrellM
BUILD_DEPENDS= ${X11BASE}/include/gkrellm2/gkrellm.h:${PORTSDIR}/sysutils/gkrellm2
-RUN_DEPENDS= gkrellm:${PORTSDIR}/sysutils/gkrellm2 \
- ${X11BASE}/bin/GrabWeather:${PORTSDIR}/misc/wmweather
+RUN_DEPENDS= gkrellm:${PORTSDIR}/sysutils/gkrellm2
USE_GMAKE= yes
USE_X_PREFIX= yes
@@ -25,10 +23,18 @@ ALL_TARGET= gkrellweather.so
MAKE_ENV= enable_nls=1 PTHREAD_LIBS=${PTHREAD_LIBS}
+.include <bsd.port.pre.mk>
+
+# uses C99 builtin lrintf
+.if ${OSVERSION} < 500000
+EXTRA_PATCHES= ${FILESDIR}/extra-patch-lrintf
+.endif
+
do-install:
${MKDIR} ${PREFIX}/libexec/gkrellm2/plugins
${INSTALL_DATA} ${WRKSRC}/gkrellweather.so ${PREFIX}/libexec/gkrellm2/plugins
${MKDIR} ${PREFIX}/share/locale/ru/
${INSTALL_DATA} ${WRKSRC}/po/ru.mo ${PREFIX}/share/locale/ru/LC_MESSAGES/gkrellweather.mo
+ ${INSTALL_SCRIPT} ${WRKSRC}/GrabWeather ${PREFIX}/bin
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/misc/gkrellweather2/distinfo b/misc/gkrellweather2/distinfo
index 6fa5e0c782b2..90e66df68258 100644
--- a/misc/gkrellweather2/distinfo
+++ b/misc/gkrellweather2/distinfo
@@ -1,2 +1,2 @@
-MD5 (gkrellweather-2.0.6.tgz) = 458125fe9276db3733a6c4b0e27eca86
-SIZE (gkrellweather-2.0.6.tgz) = 20399
+MD5 (gkrellweather-2.0.7.tgz) = 73f5ec4e950f933a5904317037d6add2
+SIZE (gkrellweather-2.0.7.tgz) = 19968
diff --git a/misc/gkrellweather2/files/extra-patch-lrintf b/misc/gkrellweather2/files/extra-patch-lrintf
new file mode 100644
index 000000000000..aacc5a32a00d
--- /dev/null
+++ b/misc/gkrellweather2/files/extra-patch-lrintf
@@ -0,0 +1,11 @@
+--- gkrellweather.c.orig Wed Mar 2 00:23:34 2005
++++ gkrellweather.c Wed Mar 2 00:28:58 2005
+@@ -7,6 +7,8 @@
+ #include <gkrellm2/gkrellm.h>
+ #include <math.h>
+
++#define lrintf(x) (int)rintf(x)
++
+ #define DEFAULT_STATION_ID "YSSY"
+
+ #define STYLE_NAME "weather"
diff --git a/misc/gkrellweather2/files/patch-Makefile b/misc/gkrellweather2/files/patch-Makefile
index d4212135385b..63618847d54f 100644
--- a/misc/gkrellweather2/files/patch-Makefile
+++ b/misc/gkrellweather2/files/patch-Makefile
@@ -1,9 +1,9 @@
---- Makefile.orig Mon Mar 31 13:12:57 2003
-+++ Makefile Sun Jul 13 13:58:11 2003
+--- Makefile.orig Sun Feb 27 14:54:47 2005
++++ Makefile Wed Mar 2 00:22:17 2005
@@ -1,9 +1,9 @@
PKGNAME = gkrellweather
- VERSION = 2.0.6
--CFLAGS = -O2 -Wall -fPIC `pkg-config gtk+-2.0 --cflags`
+ VERSION = 2.0.7
+-CFLAGS = -O2 -std=gnu99 -Wall -fPIC `pkg-config gtk+-2.0 --cflags`
+CFLAGS += -Wall -fPIC `pkg-config gtk+-2.0 --cflags`
LIBS = `pkg-config gtk+-2.0 --libs`
LFLAGS = -shared
@@ -12,7 +12,14 @@
LOCALEDIR := $(PREFIX)/share/locale
-@@ -20,7 +20,7 @@
+@@ -14,13 +14,13 @@
+ CFLAGS += -DPACKAGE="\"$(PKGNAME)\""
+ export PKGNAME LOCALEDIR
+
+-CC = gcc
++CC ?= gcc
+
+ OBJS = gkrellweather.o
gkrellweather.so: $(OBJS)
(cd po && ${MAKE} all )
diff --git a/misc/gkrellweather2/pkg-plist b/misc/gkrellweather2/pkg-plist
index e016ff2ed65a..d6dbbf46b638 100644
--- a/misc/gkrellweather2/pkg-plist
+++ b/misc/gkrellweather2/pkg-plist
@@ -1,2 +1,3 @@
+bin/GrabWeather
libexec/gkrellm2/plugins/gkrellweather.so
share/locale/ru/LC_MESSAGES/gkrellweather.mo