aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2005-12-28 21:46:23 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2005-12-28 21:46:23 +0000
commit2d2fd3c93832399f86d6e9c56649408354854daa (patch)
treed0d0aa783b0d651381163fbef1908fc4a66e2e65
parentc1a4c8cc30e10b9decabb4bc365a15b264508189 (diff)
downloadports-2d2fd3c93832399f86d6e9c56649408354854daa.tar.gz
ports-2d2fd3c93832399f86d6e9c56649408354854daa.zip
Notes
-rw-r--r--net/ipa_ipfw/Makefile60
-rw-r--r--net/ipa_ipfw/distinfo3
-rw-r--r--net/ipa_ipfw/pkg-descr18
3 files changed, 81 insertions, 0 deletions
diff --git a/net/ipa_ipfw/Makefile b/net/ipa_ipfw/Makefile
new file mode 100644
index 000000000000..2a03770196a9
--- /dev/null
+++ b/net/ipa_ipfw/Makefile
@@ -0,0 +1,60 @@
+# New ports collection makefile for: ipa_ipfw
+# Date created: 27 December 2005
+# Whom: Andrey Simonenko
+#
+# $FreeBSD$
+#
+
+PORTNAME= ipa_ipfw
+PORTVERSION= 1.0
+CATEGORIES= net
+MASTER_SITES= http://ipa-system.sourceforge.net/modules/ipa_ipfw/
+
+MAINTAINER= simon@comsys.ntu-kpi.kiev.ua
+COMMENT= IPA accounting module for FreeBSD IP Firewall
+
+NO_PACKAGE= "Needs to be built uniquely for each host"
+
+USE_BZIP2= yes
+
+OPTIONS= PTHREAD "Build pthread safe module" off \
+ DEBUG_INFO "Produce debugging info" off \
+ IPFW2 "Enable IPFW2 support (on FreeBSD < 5.x)" off \
+ MAN_KOI8_R "Install Russian manual pages" off
+
+.include <bsd.port.pre.mk>
+
+.ifdef WITH_PTHREAD
+MAKE_ENV+= WITH_PTHREAD=yes
+CFLAGS+= ${PTHREAD_CFLAGS}
+.endif
+
+.if ${OSVERSION} >= 460100 && ${OSVERSION} < 500038
+. if (defined(IPFW2) && !defined(WITH_IPFW2)) || defined(WITH_IPFW2)
+MAKE_ENV+= IPFW2=yes
+. endif
+.endif
+
+.ifdef WITHOUT_DEBUG_INFO
+MAKE_ENV+= DEBUG_FLAGS=""
+.endif
+
+BUILD_DEPENDS= ${PREFIX}/include/ipa_mod.h:${PORTSDIR}/sysutils/ipa
+
+PLIST_FILES= lib/ipa_ipfw.so
+
+MANCOMPRESSED= yes
+MAN8= ipa_ipfw.8
+MANLANG= ""
+.ifdef WITH_MAN_KOI8_R
+MANLANG+= ru.KOI8-R
+.endif
+
+do-install:
+ cd ${WRKSRC} && make install
+ echo ${MANLANG}
+.ifdef WITH_MAN_KOI8_R
+ cd ${WRKSRC}/man && make LANG_DIR_SRC=ru.KOI8-R clean all install
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net/ipa_ipfw/distinfo b/net/ipa_ipfw/distinfo
new file mode 100644
index 000000000000..e94a7e7fc011
--- /dev/null
+++ b/net/ipa_ipfw/distinfo
@@ -0,0 +1,3 @@
+MD5 (ipa_ipfw-1.0.tar.bz2) = 35dc5a261215d361131b2351f68ad2a0
+SHA256 (ipa_ipfw-1.0.tar.bz2) = 1d4e3ff9d4ff2c51d1c651172edb164b9276ae4f1c51939ced55f99acc1cda06
+SIZE (ipa_ipfw-1.0.tar.bz2) = 16290
diff --git a/net/ipa_ipfw/pkg-descr b/net/ipa_ipfw/pkg-descr
new file mode 100644
index 000000000000..d00bc5fc7a64
--- /dev/null
+++ b/net/ipa_ipfw/pkg-descr
@@ -0,0 +1,18 @@
+IPA_IPFW -- IPA accounting module for FreeBSD IP Firewall
+
+Main features:
+
+- The module is designed for traffic accounting from FreeBSD IP
+ Firewall (including IPFW2) rules byte counters;
+- The module understands IP Firewall rules byte counters overflow;
+- It is possible to summarize and subtract statistics from IP Firewall
+ rules byte counters;
+- It is possible to distinguish IP Firewall rules with the same
+ numbers;
+- IP Firewall rules can be dynamically added to and removed from
+ the system, the module correctly works in such situations.
+
+WWW: http://ipa-system.sourceforge.net/modules/ipa_ipfw/
+
+- Andrey Simonenko
+simon@comsys.ntu-kpi.kiev.ua