aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>1999-08-22 03:59:22 +0000
committerSteve Price <steve@FreeBSD.org>1999-08-22 03:59:22 +0000
commit37085ff8a562119875457cf5ae3471c3c73dee53 (patch)
tree04bb761a6c0e4ba1253c104c9d9a92136e894e10
parent2aeb60bd01604efaee34f25e11cc3f94130ea204 (diff)
downloadports-37085ff8a562119875457cf5ae3471c3c73dee53.tar.gz
ports-37085ff8a562119875457cf5ae3471c3c73dee53.zip
Notes
-rw-r--r--math/gnumeric/Makefile8
-rw-r--r--math/gnumeric/distinfo2
-rw-r--r--math/gnumeric/files/patch-aa48
-rw-r--r--math/gnumeric/files/patch-ba14
-rw-r--r--math/gnumeric/pkg-plist29
-rw-r--r--math/gnumeric2/Makefile8
-rw-r--r--math/gnumeric2/distinfo2
-rw-r--r--math/gnumeric2/files/patch-aa48
-rw-r--r--math/gnumeric2/files/patch-ba14
-rw-r--r--math/gnumeric2/pkg-plist29
10 files changed, 104 insertions, 98 deletions
diff --git a/math/gnumeric/Makefile b/math/gnumeric/Makefile
index 9c3671c224f0..57d91de7ff6d 100644
--- a/math/gnumeric/Makefile
+++ b/math/gnumeric/Makefile
@@ -1,12 +1,12 @@
# New ports collection makefile for: gnumeric
-# Version required: 0.26
+# Version required: 0.31
# Date created: 08 October 1998
# Whom: Yukihiro Nakai <Nakai@technologist.com>
#
-# $Id: Makefile,v 1.11 1999/05/09 17:22:27 steve Exp $
+# $Id: Makefile,v 1.12 1999/05/30 03:50:25 steve Exp $
#
-DISTNAME= gnumeric-0.26
+DISTNAME= gnumeric-0.31
CATEGORIES= math gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/gnumeric
@@ -17,7 +17,7 @@ BUILD_DEPENDS= panel:${PORTSDIR}/x11/gnomecore \
python:${PORTSDIR}/lang/python
RUN_DEPENDS= panel:${PORTSDIR}/x11/gnomecore \
python:${PORTSDIR}/lang/python
-LIB_DEPENDS= xml.0:${PORTSDIR}/textproc/libxml
+LIB_DEPENDS= glade.1:${PORTSDIR}/devel/libglade
GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
diff --git a/math/gnumeric/distinfo b/math/gnumeric/distinfo
index bb56a8e290ae..e11972da3623 100644
--- a/math/gnumeric/distinfo
+++ b/math/gnumeric/distinfo
@@ -1 +1 @@
-MD5 (gnumeric-0.26.tar.gz) = 67cf0ef52a3fb6081c1c70613cea1648
+MD5 (gnumeric-0.31.tar.gz) = 66940913e2d318028a406f577402e028
diff --git a/math/gnumeric/files/patch-aa b/math/gnumeric/files/patch-aa
index c24f8ceae6d7..c454c52d5284 100644
--- a/math/gnumeric/files/patch-aa
+++ b/math/gnumeric/files/patch-aa
@@ -1,6 +1,6 @@
---- configure.orig Tue May 18 18:00:05 1999
-+++ configure Sat May 22 15:59:03 1999
-@@ -2860,7 +2860,7 @@
+--- configure.orig Fri Jul 9 22:12:23 1999
++++ configure Mon Jul 12 16:48:09 1999
+@@ -2786,7 +2786,7 @@
fi
if eval "test \"`echo '$ac_cv_lib_'$ac_lib_var`\" = yes"; then
echo "$ac_t""yes" 1>&6
@@ -9,16 +9,16 @@
else
echo "$ac_t""no" 1>&6
echo $ac_n "checking for pthread_create""... $ac_c" 1>&6
-@@ -3405,7 +3405,7 @@
+@@ -3356,7 +3356,7 @@
echo $ac_n "(cached) $ac_c" 1>&6
else
ac_save_LIBS="$LIBS"
-LIBS="-lxml `gnome-config --libs xml` $LIBS"
+LIBS="`xml-config --libs` $LIBS"
cat > conftest.$ac_ext <<EOF
- #line 3411 "configure"
+ #line 3362 "configure"
#include "confdefs.h"
-@@ -3436,7 +3436,7 @@
+@@ -3387,7 +3387,7 @@
@@ -27,7 +27,7 @@
else
echo "$ac_t""no" 1>&6
-@@ -5657,15 +5657,15 @@
+@@ -5616,15 +5616,15 @@
fi
@@ -42,28 +42,26 @@
LIBS=`echo $LIBS | sed -e 's/-lintl//'`
- nls_cv_header_intl=intl/libintl.h
- nls_cv_header_libgt=intl/libgettext.h
-+# nls_cv_header_intl=intl/libintl.h
-+# nls_cv_header_libgt=intl/libgettext.h
++# nls_cv_header_intl=intl/libintl.h
++# nls_cv_header_libgt=intl/libgettext.h
fi
if test "$XGETTEXT" != ":"; then
-@@ -6249,7 +6249,7 @@
- test -n "$AWK" && break
- done
+@@ -6053,14 +6053,14 @@
--GDK_KEYSYMS="`$GTK_CONFIG --prefix`/include/gdk/gdkkeysyms.h"
-+GDK_KEYSYMS="`$GTK_CONFIG --prefix`/include/gtk12/gdk/gdkkeysyms.h"
-
- cat >> confdefs.h <<\EOF
- #define ENABLE_GNOME 1
-@@ -6273,8 +6273,8 @@
- LIBGLADE_FULLDIST_TRUE='#'
- LIBGLADE_FULLDIST_FALSE=
+ echo $ac_n "checking For Glade libraries""... $ac_c" 1>&6
+ echo "configure:6056: checking For Glade libraries" >&5
+-if gnome-config --libs libglade > /dev/null 2>&1; then
++if libglade-config --libs > /dev/null 2>&1; then
+ echo "$ac_t""found" 1>&6
+ else
+ { echo "configure: error: Did not find libGlade installed" 1>&2; exit 1; }
fi
--XML_LIBS=`gnome-config --libs xml`
--XML_CFLAGS=`gnome-config --cflags xml`/gnome-xml
-+XML_LIBS=`xml-config --libs`
-+XML_CFLAGS=`xml-config --cflags`
+
+-EXTRA_GNOME_LIBS=`gnome-config --libs gnomeui print libglade $bonobo`
+-EXTRA_GNOME_CFLAGS=`gnome-config --cflags gnomeui print libglade $bonobo`
++EXTRA_GNOME_LIBS="`gnome-config --libs gnomeui print` `libglade-config --libs gnome` $bonobo"
++EXTRA_GNOME_CFLAGS="`gnome-config --cflags gnomeui print` `libglade-config --cflags gnome` $bonobo"
+
- if false; then
diff --git a/math/gnumeric/files/patch-ba b/math/gnumeric/files/patch-ba
index 6a7b72a8443b..1cfa4d498f84 100644
--- a/math/gnumeric/files/patch-ba
+++ b/math/gnumeric/files/patch-ba
@@ -1,15 +1,15 @@
---- Makefile.in.orig Wed Feb 24 03:49:45 1999
-+++ Makefile.in Wed Feb 24 19:06:37 1999
-@@ -137,7 +137,7 @@
+--- Makefile.in.orig Fri Jul 9 22:17:31 1999
++++ Makefile.in Mon Jul 12 16:51:07 1999
+@@ -140,7 +140,7 @@
perl_val = @perl_val@
python_val = @python_val@
--SUBDIRS = intl po macros libglade plugins src doc
-+SUBDIRS = intl po macros libglade plugins src
+-SUBDIRS = intl po macros plugins src doc icons
++SUBDIRS = intl po macros plugins src icons
- EXTRA_DIST = gnumeric.desktop README HACKING gnumeric.spec.in gnumeric.keys.in gnumeric.mime $(appicon_DATA)
+ EXTRA_DIST = gnumeric.desktop README HACKING gnumeric.spec.in gnumeric.keys.in gnumeric.mime $(appicon_DATA) gnumeric.gnorba
-@@ -145,7 +145,7 @@
+@@ -148,7 +148,7 @@
appicondir = $(datadir)/pixmaps
appicon_DATA = gnome-gnumeric.png gnome-gnumeric-xl.png
diff --git a/math/gnumeric/pkg-plist b/math/gnumeric/pkg-plist
index 3946d7b89ed7..6e1c727c4616 100644
--- a/math/gnumeric/pkg-plist
+++ b/math/gnumeric/pkg-plist
@@ -1,29 +1,29 @@
bin/gnumeric
etc/CORBA/servers/gnumeric.gnorba
share/gnome/apps/Applications/gnumeric.desktop
+share/gnome/gnumeric/glade/font-sel.glade
+share/gnome/gnumeric/glade/hf-config.glade
+share/gnome/gnumeric/glade/import.glade
+share/gnome/gnumeric/glade/print.glade
share/gnome/gnumeric/guile/gnumeric_startup.scm
-share/gnome/gnumeric/perl/startup.pl
-share/gnome/gnumeric/plugins/libcsv.a
share/gnome/gnumeric/plugins/libcsv.so
-share/gnome/gnumeric/plugins/libcsv.so.0
-share/gnome/gnumeric/plugins/libgnumguile.a
share/gnome/gnumeric/plugins/libgnumguile.so
-share/gnome/gnumeric/plugins/libgnumguile.so.0
-share/gnome/gnumeric/plugins/libpython.a
+share/gnome/gnumeric/plugins/libhtml.so
share/gnome/gnumeric/plugins/libpython.so
-share/gnome/gnumeric/plugins/libpython.so.0
-share/gnome/gnumeric/plugins/libstat.a
share/gnome/gnumeric/plugins/libstat.so
-share/gnome/gnumeric/plugins/libstat.so.0
-share/gnome/gnumeric/plugins/libtext.a
share/gnome/gnumeric/plugins/libtext.so
-share/gnome/gnumeric/plugins/libtext.so.0
+share/gnome/gnumeric/plugins/libxbase.so
share/gnome/gnumeric/python/gnumeric_startup.py
+share/gnome/idl/Gnumeric.idl
share/gnome/mc/templates/gnumeric.desktop
share/gnome/mime-info/gnumeric.keys
share/gnome/mime-info/gnumeric.mime
share/gnome/pixmaps/gnome-gnumeric-xl.png
share/gnome/pixmaps/gnome-gnumeric.png
+share/gnome/pixmaps/gnumeric/down-right.png
+share/gnome/pixmaps/gnumeric/orient-horizontal.png
+share/gnome/pixmaps/gnumeric/orient-vertical.png
+share/gnome/pixmaps/gnumeric/right-down.png
share/locale/cs/LC_MESSAGES/gnumeric.mo
share/locale/de/LC_MESSAGES/gnumeric.mo
share/locale/en_GB/LC_MESSAGES/gnumeric.mo
@@ -35,7 +35,9 @@ share/locale/es_MX/LC_MESSAGES/gnumeric.mo
share/locale/es_PA/LC_MESSAGES/gnumeric.mo
share/locale/es_PE/LC_MESSAGES/gnumeric.mo
share/locale/es_SV/LC_MESSAGES/gnumeric.mo
+share/locale/fi/LC_MESSAGES/gnumeric.mo
share/locale/fr/LC_MESSAGES/gnumeric.mo
+share/locale/hr/LC_MESSAGES/gnumeric.mo
share/locale/hu/LC_MESSAGES/gnumeric.mo
share/locale/it/LC_MESSAGES/gnumeric.mo
share/locale/ja/LC_MESSAGES/gnumeric.mo
@@ -45,8 +47,11 @@ share/locale/pl/LC_MESSAGES/gnumeric.mo
share/locale/pt/LC_MESSAGES/gnumeric.mo
share/locale/ru/LC_MESSAGES/gnumeric.mo
share/locale/sk/LC_MESSAGES/gnumeric.mo
+share/locale/sv/LC_MESSAGES/gnumeric.mo
+share/locale/zh_TW.Big5/LC_MESSAGES/gnumeric.mo
+@dirrm share/gnome/pixmaps/gnumeric
@dirrm share/gnome/gnumeric/python
@dirrm share/gnome/gnumeric/plugins
-@dirrm share/gnome/gnumeric/perl
@dirrm share/gnome/gnumeric/guile
+@dirrm share/gnome/gnumeric/glade
@dirrm share/gnome/gnumeric
diff --git a/math/gnumeric2/Makefile b/math/gnumeric2/Makefile
index 9c3671c224f0..57d91de7ff6d 100644
--- a/math/gnumeric2/Makefile
+++ b/math/gnumeric2/Makefile
@@ -1,12 +1,12 @@
# New ports collection makefile for: gnumeric
-# Version required: 0.26
+# Version required: 0.31
# Date created: 08 October 1998
# Whom: Yukihiro Nakai <Nakai@technologist.com>
#
-# $Id: Makefile,v 1.11 1999/05/09 17:22:27 steve Exp $
+# $Id: Makefile,v 1.12 1999/05/30 03:50:25 steve Exp $
#
-DISTNAME= gnumeric-0.26
+DISTNAME= gnumeric-0.31
CATEGORIES= math gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/gnumeric
@@ -17,7 +17,7 @@ BUILD_DEPENDS= panel:${PORTSDIR}/x11/gnomecore \
python:${PORTSDIR}/lang/python
RUN_DEPENDS= panel:${PORTSDIR}/x11/gnomecore \
python:${PORTSDIR}/lang/python
-LIB_DEPENDS= xml.0:${PORTSDIR}/textproc/libxml
+LIB_DEPENDS= glade.1:${PORTSDIR}/devel/libglade
GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
diff --git a/math/gnumeric2/distinfo b/math/gnumeric2/distinfo
index bb56a8e290ae..e11972da3623 100644
--- a/math/gnumeric2/distinfo
+++ b/math/gnumeric2/distinfo
@@ -1 +1 @@
-MD5 (gnumeric-0.26.tar.gz) = 67cf0ef52a3fb6081c1c70613cea1648
+MD5 (gnumeric-0.31.tar.gz) = 66940913e2d318028a406f577402e028
diff --git a/math/gnumeric2/files/patch-aa b/math/gnumeric2/files/patch-aa
index c24f8ceae6d7..c454c52d5284 100644
--- a/math/gnumeric2/files/patch-aa
+++ b/math/gnumeric2/files/patch-aa
@@ -1,6 +1,6 @@
---- configure.orig Tue May 18 18:00:05 1999
-+++ configure Sat May 22 15:59:03 1999
-@@ -2860,7 +2860,7 @@
+--- configure.orig Fri Jul 9 22:12:23 1999
++++ configure Mon Jul 12 16:48:09 1999
+@@ -2786,7 +2786,7 @@
fi
if eval "test \"`echo '$ac_cv_lib_'$ac_lib_var`\" = yes"; then
echo "$ac_t""yes" 1>&6
@@ -9,16 +9,16 @@
else
echo "$ac_t""no" 1>&6
echo $ac_n "checking for pthread_create""... $ac_c" 1>&6
-@@ -3405,7 +3405,7 @@
+@@ -3356,7 +3356,7 @@
echo $ac_n "(cached) $ac_c" 1>&6
else
ac_save_LIBS="$LIBS"
-LIBS="-lxml `gnome-config --libs xml` $LIBS"
+LIBS="`xml-config --libs` $LIBS"
cat > conftest.$ac_ext <<EOF
- #line 3411 "configure"
+ #line 3362 "configure"
#include "confdefs.h"
-@@ -3436,7 +3436,7 @@
+@@ -3387,7 +3387,7 @@
@@ -27,7 +27,7 @@
else
echo "$ac_t""no" 1>&6
-@@ -5657,15 +5657,15 @@
+@@ -5616,15 +5616,15 @@
fi
@@ -42,28 +42,26 @@
LIBS=`echo $LIBS | sed -e 's/-lintl//'`
- nls_cv_header_intl=intl/libintl.h
- nls_cv_header_libgt=intl/libgettext.h
-+# nls_cv_header_intl=intl/libintl.h
-+# nls_cv_header_libgt=intl/libgettext.h
++# nls_cv_header_intl=intl/libintl.h
++# nls_cv_header_libgt=intl/libgettext.h
fi
if test "$XGETTEXT" != ":"; then
-@@ -6249,7 +6249,7 @@
- test -n "$AWK" && break
- done
+@@ -6053,14 +6053,14 @@
--GDK_KEYSYMS="`$GTK_CONFIG --prefix`/include/gdk/gdkkeysyms.h"
-+GDK_KEYSYMS="`$GTK_CONFIG --prefix`/include/gtk12/gdk/gdkkeysyms.h"
-
- cat >> confdefs.h <<\EOF
- #define ENABLE_GNOME 1
-@@ -6273,8 +6273,8 @@
- LIBGLADE_FULLDIST_TRUE='#'
- LIBGLADE_FULLDIST_FALSE=
+ echo $ac_n "checking For Glade libraries""... $ac_c" 1>&6
+ echo "configure:6056: checking For Glade libraries" >&5
+-if gnome-config --libs libglade > /dev/null 2>&1; then
++if libglade-config --libs > /dev/null 2>&1; then
+ echo "$ac_t""found" 1>&6
+ else
+ { echo "configure: error: Did not find libGlade installed" 1>&2; exit 1; }
fi
--XML_LIBS=`gnome-config --libs xml`
--XML_CFLAGS=`gnome-config --cflags xml`/gnome-xml
-+XML_LIBS=`xml-config --libs`
-+XML_CFLAGS=`xml-config --cflags`
+
+-EXTRA_GNOME_LIBS=`gnome-config --libs gnomeui print libglade $bonobo`
+-EXTRA_GNOME_CFLAGS=`gnome-config --cflags gnomeui print libglade $bonobo`
++EXTRA_GNOME_LIBS="`gnome-config --libs gnomeui print` `libglade-config --libs gnome` $bonobo"
++EXTRA_GNOME_CFLAGS="`gnome-config --cflags gnomeui print` `libglade-config --cflags gnome` $bonobo"
+
- if false; then
diff --git a/math/gnumeric2/files/patch-ba b/math/gnumeric2/files/patch-ba
index 6a7b72a8443b..1cfa4d498f84 100644
--- a/math/gnumeric2/files/patch-ba
+++ b/math/gnumeric2/files/patch-ba
@@ -1,15 +1,15 @@
---- Makefile.in.orig Wed Feb 24 03:49:45 1999
-+++ Makefile.in Wed Feb 24 19:06:37 1999
-@@ -137,7 +137,7 @@
+--- Makefile.in.orig Fri Jul 9 22:17:31 1999
++++ Makefile.in Mon Jul 12 16:51:07 1999
+@@ -140,7 +140,7 @@
perl_val = @perl_val@
python_val = @python_val@
--SUBDIRS = intl po macros libglade plugins src doc
-+SUBDIRS = intl po macros libglade plugins src
+-SUBDIRS = intl po macros plugins src doc icons
++SUBDIRS = intl po macros plugins src icons
- EXTRA_DIST = gnumeric.desktop README HACKING gnumeric.spec.in gnumeric.keys.in gnumeric.mime $(appicon_DATA)
+ EXTRA_DIST = gnumeric.desktop README HACKING gnumeric.spec.in gnumeric.keys.in gnumeric.mime $(appicon_DATA) gnumeric.gnorba
-@@ -145,7 +145,7 @@
+@@ -148,7 +148,7 @@
appicondir = $(datadir)/pixmaps
appicon_DATA = gnome-gnumeric.png gnome-gnumeric-xl.png
diff --git a/math/gnumeric2/pkg-plist b/math/gnumeric2/pkg-plist
index 3946d7b89ed7..6e1c727c4616 100644
--- a/math/gnumeric2/pkg-plist
+++ b/math/gnumeric2/pkg-plist
@@ -1,29 +1,29 @@
bin/gnumeric
etc/CORBA/servers/gnumeric.gnorba
share/gnome/apps/Applications/gnumeric.desktop
+share/gnome/gnumeric/glade/font-sel.glade
+share/gnome/gnumeric/glade/hf-config.glade
+share/gnome/gnumeric/glade/import.glade
+share/gnome/gnumeric/glade/print.glade
share/gnome/gnumeric/guile/gnumeric_startup.scm
-share/gnome/gnumeric/perl/startup.pl
-share/gnome/gnumeric/plugins/libcsv.a
share/gnome/gnumeric/plugins/libcsv.so
-share/gnome/gnumeric/plugins/libcsv.so.0
-share/gnome/gnumeric/plugins/libgnumguile.a
share/gnome/gnumeric/plugins/libgnumguile.so
-share/gnome/gnumeric/plugins/libgnumguile.so.0
-share/gnome/gnumeric/plugins/libpython.a
+share/gnome/gnumeric/plugins/libhtml.so
share/gnome/gnumeric/plugins/libpython.so
-share/gnome/gnumeric/plugins/libpython.so.0
-share/gnome/gnumeric/plugins/libstat.a
share/gnome/gnumeric/plugins/libstat.so
-share/gnome/gnumeric/plugins/libstat.so.0
-share/gnome/gnumeric/plugins/libtext.a
share/gnome/gnumeric/plugins/libtext.so
-share/gnome/gnumeric/plugins/libtext.so.0
+share/gnome/gnumeric/plugins/libxbase.so
share/gnome/gnumeric/python/gnumeric_startup.py
+share/gnome/idl/Gnumeric.idl
share/gnome/mc/templates/gnumeric.desktop
share/gnome/mime-info/gnumeric.keys
share/gnome/mime-info/gnumeric.mime
share/gnome/pixmaps/gnome-gnumeric-xl.png
share/gnome/pixmaps/gnome-gnumeric.png
+share/gnome/pixmaps/gnumeric/down-right.png
+share/gnome/pixmaps/gnumeric/orient-horizontal.png
+share/gnome/pixmaps/gnumeric/orient-vertical.png
+share/gnome/pixmaps/gnumeric/right-down.png
share/locale/cs/LC_MESSAGES/gnumeric.mo
share/locale/de/LC_MESSAGES/gnumeric.mo
share/locale/en_GB/LC_MESSAGES/gnumeric.mo
@@ -35,7 +35,9 @@ share/locale/es_MX/LC_MESSAGES/gnumeric.mo
share/locale/es_PA/LC_MESSAGES/gnumeric.mo
share/locale/es_PE/LC_MESSAGES/gnumeric.mo
share/locale/es_SV/LC_MESSAGES/gnumeric.mo
+share/locale/fi/LC_MESSAGES/gnumeric.mo
share/locale/fr/LC_MESSAGES/gnumeric.mo
+share/locale/hr/LC_MESSAGES/gnumeric.mo
share/locale/hu/LC_MESSAGES/gnumeric.mo
share/locale/it/LC_MESSAGES/gnumeric.mo
share/locale/ja/LC_MESSAGES/gnumeric.mo
@@ -45,8 +47,11 @@ share/locale/pl/LC_MESSAGES/gnumeric.mo
share/locale/pt/LC_MESSAGES/gnumeric.mo
share/locale/ru/LC_MESSAGES/gnumeric.mo
share/locale/sk/LC_MESSAGES/gnumeric.mo
+share/locale/sv/LC_MESSAGES/gnumeric.mo
+share/locale/zh_TW.Big5/LC_MESSAGES/gnumeric.mo
+@dirrm share/gnome/pixmaps/gnumeric
@dirrm share/gnome/gnumeric/python
@dirrm share/gnome/gnumeric/plugins
-@dirrm share/gnome/gnumeric/perl
@dirrm share/gnome/gnumeric/guile
+@dirrm share/gnome/gnumeric/glade
@dirrm share/gnome/gnumeric