aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason E. Hale <jhale@FreeBSD.org>2012-12-11 14:14:42 +0000
committerJason E. Hale <jhale@FreeBSD.org>2012-12-11 14:14:42 +0000
commit376325e6360d2e5d56aa3d38f712a497ca43eba2 (patch)
treecb2ad2c3f46724023d71204b290b4414fecaad87
parent64fcb45384fa6a14fe2717cd086063f935e8cfc7 (diff)
downloadports-376325e6360d2e5d56aa3d38f712a497ca43eba2.tar.gz
ports-376325e6360d2e5d56aa3d38f712a497ca43eba2.zip
Notes
-rw-r--r--devel/libvanessa_logger/Makefile21
-rw-r--r--devel/libvanessa_logger/distinfo4
-rw-r--r--devel/libvanessa_logger/files/patch-Makefile.in11
-rw-r--r--devel/libvanessa_logger/pkg-descr2
-rw-r--r--devel/libvanessa_logger/pkg-plist7
5 files changed, 16 insertions, 29 deletions
diff --git a/devel/libvanessa_logger/Makefile b/devel/libvanessa_logger/Makefile
index c527de913fe5..fa9695e144af 100644
--- a/devel/libvanessa_logger/Makefile
+++ b/devel/libvanessa_logger/Makefile
@@ -1,25 +1,22 @@
-# New ports collection makefile for: libvanessa_logger
-# Date created: 28 April 2001
-# Whom: Konstantinos Konstantinidis <kkonstan@daemon.gr>
-#
+# Created by: Konstantinos Konstantinidis <kkonstan@daemon.gr>
# $FreeBSD$
-#
PORTNAME= libvanessa_logger
-PORTVERSION= 0.0.7
+PORTVERSION= 0.0.10
CATEGORIES= devel
-MASTER_SITES= http://www.vergenet.net/linux/vanessa/download/%SUBDIR%/
-MASTER_SITE_SUBDIR= vanessa_logger/${PORTVERSION}
+MASTER_SITES= http://horms.net/projects/vanessa/download/vanessa_logger/${PORTVERSION}/
DISTNAME= vanessa_logger-${PORTVERSION}
MAINTAINER= thomas@bsdunix.ch
COMMENT= Library that provides a generic logging layer
+USE_BZIP2= yes
USE_AUTOTOOLS= libtool
-USE_LDCONFIG= YES
-GNU_CONFIGURE= YES
+USE_GNOME= gnomehack
+USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
post-patch:
- @${REINPLACE_CMD} -e 's,^loop:,loop: ;,' \
- ${WRKSRC}/${PORTNAME}/vanessa_logger.c
+ @${REINPLACE_CMD} -e '/^SUBDIRS/s|sample debian||' ${WRKSRC}/Makefile.in
+
.include <bsd.port.mk>
diff --git a/devel/libvanessa_logger/distinfo b/devel/libvanessa_logger/distinfo
index b0df0dcf0afe..8d75b38bfd35 100644
--- a/devel/libvanessa_logger/distinfo
+++ b/devel/libvanessa_logger/distinfo
@@ -1,2 +1,2 @@
-SHA256 (vanessa_logger-0.0.7.tar.gz) = 65323bf673cbe94c7077f7bc475f95ef25a18d51f96a59cfa463a18b0e6881d0
-SIZE (vanessa_logger-0.0.7.tar.gz) = 303977
+SHA256 (vanessa_logger-0.0.10.tar.bz2) = f5517dcd31d1af11ca2dce6a281fa3a3bedea98e0441e4b3895583c23be5353f
+SIZE (vanessa_logger-0.0.10.tar.bz2) = 265809
diff --git a/devel/libvanessa_logger/files/patch-Makefile.in b/devel/libvanessa_logger/files/patch-Makefile.in
deleted file mode 100644
index 9d1bf9f69ddd..000000000000
--- a/devel/libvanessa_logger/files/patch-Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- Makefile.in.orig Tue Mar 23 15:35:30 2004
-+++ Makefile.in Tue Mar 23 15:36:13 2004
-@@ -110,7 +110,7 @@
- STRIP = @STRIP@
- VERSION = @VERSION@
-
--SUBDIRS = libvanessa_logger sample debian
-+SUBDIRS = libvanessa_logger
-
- EXTRA_DIST = configure configure.in README TODO INSTALL.in INSTALL vanessa_logger.spec.in vanessa_logger.spec autogen.sh
-
diff --git a/devel/libvanessa_logger/pkg-descr b/devel/libvanessa_logger/pkg-descr
index 2a659a9bb43c..d62192294d83 100644
--- a/devel/libvanessa_logger/pkg-descr
+++ b/devel/libvanessa_logger/pkg-descr
@@ -4,4 +4,4 @@ limitations in the implementation of syslog opening multiple syslog loggers
doesn't makes sense. Includes the ability to limit which messages will be
logged based on priorities.
-WWW: http://www.vergenet.net/linux/vanessa/
+WWW: http://horms.net/projects/vanessa/
diff --git a/devel/libvanessa_logger/pkg-plist b/devel/libvanessa_logger/pkg-plist
index aab5926c683b..0d9634130e49 100644
--- a/devel/libvanessa_logger/pkg-plist
+++ b/devel/libvanessa_logger/pkg-plist
@@ -1,5 +1,6 @@
include/vanessa_logger.h
-lib/libvanessa_logger.so.0
-lib/libvanessa_logger.so
-lib/libvanessa_logger.la
lib/libvanessa_logger.a
+lib/libvanessa_logger.la
+lib/libvanessa_logger.so
+lib/libvanessa_logger.so.0
+libdata/pkgconfig/vanessa-logger.pc