aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHiroki Sato <hrs@FreeBSD.org>2017-04-01 08:55:16 +0000
committerHiroki Sato <hrs@FreeBSD.org>2017-04-01 08:55:16 +0000
commit3e6d065642c2f9770eeabe4475b21774489c14b8 (patch)
tree49c64eb331d457a4e7a08564c5f5109b67d06572
parent2a336dca48c092a5436faff69cbf6c4bc321e7ff (diff)
downloadports-3e6d065642c2f9770eeabe4475b21774489c14b8.tar.gz
ports-3e6d065642c2f9770eeabe4475b21774489c14b8.zip
Notes
-rw-r--r--textproc/cdif/Makefile36
-rw-r--r--textproc/cdif/distinfo5
-rw-r--r--textproc/cdif/pkg-descr37
3 files changed, 36 insertions, 42 deletions
diff --git a/textproc/cdif/Makefile b/textproc/cdif/Makefile
index bf30289bdc6d..b0c3c36d1a51 100644
--- a/textproc/cdif/Makefile
+++ b/textproc/cdif/Makefile
@@ -1,27 +1,35 @@
# Created by: Yoshiro MIHIRA <sanpei@sanpei.org>
# $FreeBSD$
-PORTNAME= cdif
-PORTVERSION= 1.19
-CATEGORIES= textproc
-MASTER_SITES= LOCAL/sanpei
-EXTRACT_SUFX= # empty
+PORTNAME= cdif
+PORTVERSION= 2.14.20170401
+DISTVERSIONPREFIX= v
+CATEGORIES= textproc
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Word context diff
+MAINTAINER= hrs@FreeBSD.org
+COMMENT= Word context visualizer of DIFF output
-USES= perl5 shebangfix
-SHEBANG_FILES= ${DISTNAME}
+LICENSE= GREPLE
+LICENSE_NAME= GREPLE License
+LICENSE_FILE= ${WRKSRC}/LICENSE
+LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
-NO_WRKSUBDIR= yes
-NO_BUILD= yes
+RUN_DEPENDS= ${SITE_PERL}/Getopt/EX.pm:devel/p5-Getopt-EX
+USES= perl5 shebangfix
+SHEBANG_FILES= ${PORTNAME}
+USE_GITHUB= yes
+GH_ACCOUNT= kaz-utashiro
+GH_TAGNAME= 2f4de90
+NO_BUILD= yes
+NO_ARCH= yes
PLIST_FILES= bin/cdif
-do-extract:
- ${CP} ${DISTDIR}/${DISTNAME} ${WRKSRC}/${DISTNAME}
+post-extract:
+ cd ${WRKSRC} && \
+ ${SED} -n "/^# COPYRIGHT/,//p" README.md > LICENSE
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/${DISTNAME} ${STAGEDIR}${PREFIX}/bin/cdif
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/cdif
.include <bsd.port.mk>
diff --git a/textproc/cdif/distinfo b/textproc/cdif/distinfo
index 97500470c726..d91e7c8b80ba 100644
--- a/textproc/cdif/distinfo
+++ b/textproc/cdif/distinfo
@@ -1,2 +1,3 @@
-SHA256 (cdif-1.19) = 1b11fd4fd06680f9563dbd58c9bcecf8317d4f4633028598769d930e3a487b3c
-SIZE (cdif-1.19) = 19894
+TIMESTAMP = 1491036190
+SHA256 (kaz-utashiro-cdif-v2.14.20170401-2f4de90_GH0.tar.gz) = 0396528034f54ddb22ffcdfcf925355c8f2a9426a7de6ca1c149e9e5b4ec8377
+SIZE (kaz-utashiro-cdif-v2.14.20170401-2f4de90_GH0.tar.gz) = 19118
diff --git a/textproc/cdif/pkg-descr b/textproc/cdif/pkg-descr
index 23ddba16dc25..708e63d9e923 100644
--- a/textproc/cdif/pkg-descr
+++ b/textproc/cdif/pkg-descr
@@ -1,26 +1,11 @@
-Usage: cdif [-Bvns] [-A #] [-C #] [-D #] [-I #] [-e #] [-[bwcu]] file1 file2
- cdif [-rcs] [-q] [-rrev1 [-rrev2]] [$myname options] file
- cdif [$myname options] [diff-output-file]
-Options:
- -B byte compare
- -v use video standout (default for tty)
- -n use nroff style overstrike (default for non-tty)
- -b ignore trailing blank
- -w ignore whitespace
- -c[#] context diff
- -u[#] unified diff (if diff has -u option)
- -e # expression of `word' (default is '\w+')
- -s show statistical information at the end
- -A, -C, -D (Append, Change, Delete) takes one of
- vso: video standout
- vul: video underline
- vbd: video bold
- bd: nroff style overstrike
- ul: nroff style underline
- or any sequence or sequences separated by comma
- -I specify string to be shown on insertion point
- Following strings have special meanings.
- vbar: print vertical bar at the point
- caret: print caret under the point
- -diff=command
- specify any diff command
+cdif is a post-processor of the Unix diff command. It highlights
+deleted, changed and added words based on word context. You may want
+to compare character-by-character rather than word-by-word. Option -B
+option can be used for that purpose. If only one file is specified,
+cdif reads that file (stdin if no file) as a output from diff command.
+Lines those don't look like diff output are simply ignored and
+printed.
+
+Note that this requires fdescfs(5) mounted.
+
+WWW: https://github.com/kaz-utashiro/cdif