aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2006-04-28 01:26:18 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2006-04-28 01:26:18 +0000
commit41d58c5272edf8681536c182691f8a73f9d7c043 (patch)
treefacd3c376cdbde367a286d4715d9b734f98c7512
parent2632e04e8a236f462625aaa292d8fb185ae15af8 (diff)
downloadports-41d58c5272edf8681536c182691f8a73f9d7c043.tar.gz
ports-41d58c5272edf8681536c182691f8a73f9d7c043.zip
Notes
-rw-r--r--finance/Makefile1
-rw-r--r--finance/p5-Finance-TW-TSEQuote/Makefile28
-rw-r--r--finance/p5-Finance-TW-TSEQuote/distinfo3
-rw-r--r--finance/p5-Finance-TW-TSEQuote/pkg-descr5
-rw-r--r--finance/p5-Finance-TW-TSEQuote/pkg-plist7
5 files changed, 44 insertions, 0 deletions
diff --git a/finance/Makefile b/finance/Makefile
index 32796bb3c130..fb5f50732ad7 100644
--- a/finance/Makefile
+++ b/finance/Makefile
@@ -48,6 +48,7 @@
SUBDIR += p5-Finance-Currency-Convert-XE
SUBDIR += p5-Finance-Quote
SUBDIR += p5-Finance-QuoteHist
+ SUBDIR += p5-Finance-TW-TSEQuote
SUBDIR += p5-Locale-Currency-Format
SUBDIR += p5-Math-Financial
SUBDIR += pfpro
diff --git a/finance/p5-Finance-TW-TSEQuote/Makefile b/finance/p5-Finance-TW-TSEQuote/Makefile
new file mode 100644
index 000000000000..022fa958d314
--- /dev/null
+++ b/finance/p5-Finance-TW-TSEQuote/Makefile
@@ -0,0 +1,28 @@
+# ex:ts=8
+# Ports collection makefile for: Finance::TW::TSEQuote
+# Date created: Apr 28, 2006
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= Finance-TW-TSEQuote
+PORTVERSION= 0.2
+CATEGORIES= finance perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Finance
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ijliao@FreeBSD.org
+COMMENT= Check stock quotes from Taiwan Security Exchange
+
+BUILD_DEPENDS= p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
+ p5-Encode>=0:${PORTSDIR}/devel/p5-Encode \
+ p5-URI>=0:${PORTSDIR}/net/p5-URI
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Finance::TW::TSEQuote.3
+
+.include <bsd.port.mk>
diff --git a/finance/p5-Finance-TW-TSEQuote/distinfo b/finance/p5-Finance-TW-TSEQuote/distinfo
new file mode 100644
index 000000000000..60f9c5ff2168
--- /dev/null
+++ b/finance/p5-Finance-TW-TSEQuote/distinfo
@@ -0,0 +1,3 @@
+MD5 (Finance-TW-TSEQuote-0.2.tar.gz) = 33be2844b9d3e869251a4ed6ffcd5965
+SHA256 (Finance-TW-TSEQuote-0.2.tar.gz) = af9ff4bb314de72b783e386c580f60db1e03a744e8d253ec5fae26a9724cf0c0
+SIZE (Finance-TW-TSEQuote-0.2.tar.gz) = 2146
diff --git a/finance/p5-Finance-TW-TSEQuote/pkg-descr b/finance/p5-Finance-TW-TSEQuote/pkg-descr
new file mode 100644
index 000000000000..7f74d8732bae
--- /dev/null
+++ b/finance/p5-Finance-TW-TSEQuote/pkg-descr
@@ -0,0 +1,5 @@
+This module provides interface to stock information available from Taiwan
+Security Exchange. You could resolve company name to stock symbol, as well
+as getting the real time quote.
+
+WWW: http://search.cpan.org/dist/Finance-TW-TSEQuote/
diff --git a/finance/p5-Finance-TW-TSEQuote/pkg-plist b/finance/p5-Finance-TW-TSEQuote/pkg-plist
new file mode 100644
index 000000000000..25c6265b8e89
--- /dev/null
+++ b/finance/p5-Finance-TW-TSEQuote/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Finance/TW/TSEQuote/.packlist
+%%SITE_PERL%%/Finance/TW/TSEQuote.pm
+@dirrm %%SITE_PERL%%/Finance/TW
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Finance/TW/TSEQuote
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Finance/TW
+@dirrmtry %%SITE_PERL%%/Finance
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Finance