aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Grzybowski <wg@FreeBSD.org>2013-07-10 17:06:01 +0000
committerWilliam Grzybowski <wg@FreeBSD.org>2013-07-10 17:06:01 +0000
commit5258a1936ec373454742cb39bbe973aa1480de8e (patch)
tree7b387f551085672d0d3b9519f94a222220b910b6
parent0bdf3055bd8f7a9d9b21421a226a4c3690c6bc8d (diff)
downloadports-5258a1936ec373454742cb39bbe973aa1480de8e.tar.gz
ports-5258a1936ec373454742cb39bbe973aa1480de8e.zip
Notes
-rw-r--r--net-p2p/libtorrent-rasterbar-16/Makefile44
-rw-r--r--net-p2p/libtorrent-rasterbar-16/distinfo4
-rw-r--r--net-p2p/libtorrent-rasterbar-16/pkg-descr12
3 files changed, 35 insertions, 25 deletions
diff --git a/net-p2p/libtorrent-rasterbar-16/Makefile b/net-p2p/libtorrent-rasterbar-16/Makefile
index c468cbf5dd7c..18bcacbd2431 100644
--- a/net-p2p/libtorrent-rasterbar-16/Makefile
+++ b/net-p2p/libtorrent-rasterbar-16/Makefile
@@ -1,28 +1,28 @@
+# Created by: Doug Barton <dougb@FreeBSD.org>
# $FreeBSD$
PORTNAME= libtorrent-rasterbar
-PORTVERSION= 0.16.7
-PORTREVISION?= 2
+PORTVERSION= 0.16.10
CATEGORIES?= net-p2p ipv6
MASTER_SITES= GOOGLE_CODE
PROJECTHOST= libtorrent
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= nemysis@gmx.ch
COMMENT?= C++ library implementing a BitTorrent client
-MAKE_JOBS_SAFE= yes
-
-CONFLICTS+= libtorrent-rasterbar-0.1[45789].*
-
-NO_LATEST_LINK= yes
+LICENSE= BSD
LIB_DEPENDS+= boost_date_time:${PORTSDIR}/devel/boost-libs \
GeoIP:${PORTSDIR}/net/GeoIP
-GNU_CONFIGURE= yes
USES= pathfix pkgconfig iconv
-USE_LDCONFIG= yes
USE_OPENSSL= yes
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+MAKE_JOBS_SAFE= yes
+
+CONFLICTS+= libtorrent-rasterbar-0.1[45789].*
+NO_LATEST_LINK= yes
CONFIGURE_ARGS+= --disable-debug \
--disable-static \
@@ -39,7 +39,16 @@ CONFIGURE_ARGS+= --disable-debug \
PORTDOCS= *
-OPTIONS_DEFINE= DOCS
+DOCSRCDIR1= ${WRKSRC}
+DOC_FILES1= AUTHORS README
+
+DOCSRCDIR2= ${WRKSRC}/docs
+DOCSDIR2= ${DOCSDIR}/docs
+DOC_FILES2= *.png *.jpg *.gif *.html *.rst *.css
+
+PORTEXAMPLES= *.cpp
+
+OPTIONS_DEFINE= DOCS EXAMPLES
.include <bsd.port.pre.mk>
@@ -53,6 +62,7 @@ CONFIGURE_ARGS+= --disable-python-binding
.if defined(SLAVE_PORT) && ${SLAVE_PORT:L} == "yes"
post-patch: slave-post-patch
.else
+
post-patch:
@${REINPLACE_CMD} -e 's|<include>/usr/local/include|<include>${PREFIX}/include|' \
${WRKSRC}/Jamfile
@@ -65,11 +75,13 @@ post-install:
.endif
.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/docs/*.html ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/docs/*.css ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/docs/*.gif ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/docs/*.jpg ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/docs/*.png ${DOCSDIR}
+ ${INSTALL_DATA} ${DOC_FILES1:S|^|${DOCSRCDIR1}/|} ${DOCSDIR}
+ @${MKDIR} ${DOCSDIR2}
+ ${INSTALL_DATA} ${DOC_FILES2:S|^|${DOCSRCDIR2}/|} ${DOCSDIR2}
+.endif
+.if ${PORT_OPTIONS:MEXAMPLES}
+ @${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${PORTEXAMPLES:S|^|${WRKSRC}/examples/|} ${EXAMPLESDIR}
.endif
.include <bsd.port.post.mk>
diff --git a/net-p2p/libtorrent-rasterbar-16/distinfo b/net-p2p/libtorrent-rasterbar-16/distinfo
index 91fa369b3e4c..c7523c5d4bf6 100644
--- a/net-p2p/libtorrent-rasterbar-16/distinfo
+++ b/net-p2p/libtorrent-rasterbar-16/distinfo
@@ -1,2 +1,2 @@
-SHA256 (libtorrent-rasterbar-0.16.7.tar.gz) = 6d3ec18ffb14e6637020f020b3a7ea1831ab02941f4698f30beedbfa63f30048
-SIZE (libtorrent-rasterbar-0.16.7.tar.gz) = 2931824
+SHA256 (libtorrent-rasterbar-0.16.10.tar.gz) = 4c0d78b28af8051ff8a19a3a3e10a5edfec50945b8f3c9a76612111c47d671bc
+SIZE (libtorrent-rasterbar-0.16.10.tar.gz) = 2985640
diff --git a/net-p2p/libtorrent-rasterbar-16/pkg-descr b/net-p2p/libtorrent-rasterbar-16/pkg-descr
index 1056baf8fd27..7d77d3d54b63 100644
--- a/net-p2p/libtorrent-rasterbar-16/pkg-descr
+++ b/net-p2p/libtorrent-rasterbar-16/pkg-descr
@@ -1,14 +1,12 @@
libtorrent is a C++ library that aims to be a good alternative to all the
-other bittorrent implementations around. It is a library and not a full
-featured client.
+other bittorrent implementations around. It is a library and not a full
+featured client, although it comes with a working example client.
-The main goals of libtorrent are:
- * to be cpu efficient
- * to be memory efficient
- * to be very easy to use
+The main goals of libtorrent are to be cpu efficient, memory efficient and
+very easy to use.
The 0.16 branch adds uTP support.
Note that this is NOT the same library as the libtorrent port!
-WWW: http://www.rasterbar.com/products/libtorrent/index.html
+WWW: http://www.rasterbar.com/products/libtorrent/