aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBoris Samorodov <bsam@FreeBSD.org>2011-09-23 17:38:32 +0000
committerBoris Samorodov <bsam@FreeBSD.org>2011-09-23 17:38:32 +0000
commit5a3460cbae46ec9811bc81ae3461460b470dbac4 (patch)
tree9d0728938272eab1ff827e60bb2fa6dcf55e9123
parent218d121ee8aff7323f0f78ddd95c93ed5be171aa (diff)
downloadports-5a3460cbae46ec9811bc81ae3461460b470dbac4.tar.gz
ports-5a3460cbae46ec9811bc81ae3461460b470dbac4.zip
Notes
-rw-r--r--security/Makefile1
-rw-r--r--security/linux-f10-libgpg-error/Makefile25
-rw-r--r--security/linux-f10-libgpg-error/distinfo.i3864
-rw-r--r--security/linux-f10-libgpg-error/pkg-plist26
4 files changed, 56 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 79f925f5847e..f712a3a2fe31 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -262,6 +262,7 @@
SUBDIR += libwhisker
SUBDIR += linux-f10-cyrus-sasl2
SUBDIR += linux-f10-libgcrypt
+ SUBDIR += linux-f10-libgpg-error
SUBDIR += linux-f10-libssh2
SUBDIR += linux-f10-libtasn1
SUBDIR += linux-f10-nss
diff --git a/security/linux-f10-libgpg-error/Makefile b/security/linux-f10-libgpg-error/Makefile
new file mode 100644
index 000000000000..392f36f97de8
--- /dev/null
+++ b/security/linux-f10-libgpg-error/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: security/linux-f10-libgpg-error
+# Date created: 10 Nov 2010
+# Whom: Stas Timoklhin <devel@stasyan.com>
+# $FreeBSD$
+#
+
+PORTNAME= libgpg-error
+PORTVERSION= 1.6
+CATEGORIES= security linux
+PKGNAMEPREFIX= linux-f10-
+DISTNAME= ${PORTNAME}-${PORTVERSION}-${RPMVERSION}
+
+MAINTAINER= emulation@FreeBSD.org
+COMMENT= Common error values for all GnuPG components
+
+USE_LINUX_RPM= yes
+LINUX_DIST_VER= 10
+RPMVERSION= 2
+USE_LDCONFIG= yes
+BRANDELF_FILES= usr/bin/gpg-error
+
+PLIST_SUB= PORTVERSION="${PORTVERSION}"
+DESCR= ${.CURDIR}/../libgpg-error/pkg-descr
+
+.include <bsd.port.mk>
diff --git a/security/linux-f10-libgpg-error/distinfo.i386 b/security/linux-f10-libgpg-error/distinfo.i386
new file mode 100644
index 000000000000..16a5ef6f11fb
--- /dev/null
+++ b/security/linux-f10-libgpg-error/distinfo.i386
@@ -0,0 +1,4 @@
+SHA256 (rpm/i386/fedora/10/libgpg-error-1.6-2.i386.rpm) = 916463d3039ca04ec5ee171706b9b7168fa5b996099a0002ccef4a55b3e42453
+SIZE (rpm/i386/fedora/10/libgpg-error-1.6-2.i386.rpm) = 66471
+SHA256 (rpm/i386/fedora/10/libgpg-error-1.6-2.src.rpm) = 9f5d7d88ad279b78bedeae96ee0bc87b01ed26b890b86dbc66fc4edf1a7de490
+SIZE (rpm/i386/fedora/10/libgpg-error-1.6-2.src.rpm) = 463059
diff --git a/security/linux-f10-libgpg-error/pkg-plist b/security/linux-f10-libgpg-error/pkg-plist
new file mode 100644
index 000000000000..bfa869efc27d
--- /dev/null
+++ b/security/linux-f10-libgpg-error/pkg-plist
@@ -0,0 +1,26 @@
+lib/libgpg-error.so.0
+lib/libgpg-error.so.0.4.0
+usr/bin/gpg-error
+usr/share/locale/ro/LC_MESSAGES/libgpg-error.mo
+usr/share/locale/de/LC_MESSAGES/libgpg-error.mo
+usr/share/locale/vi/LC_MESSAGES/libgpg-error.mo
+usr/share/locale/sv/LC_MESSAGES/libgpg-error.mo
+usr/share/locale/fr/LC_MESSAGES/libgpg-error.mo
+usr/share/locale/pl/LC_MESSAGES/libgpg-error.mo
+%%PORTDOCS%%usr/%%DOCSDIR%%-%%PORTVERSION%%/AUTHORS
+%%PORTDOCS%%usr/%%DOCSDIR%%-%%PORTVERSION%%/COPYING
+%%PORTDOCS%%usr/%%DOCSDIR%%-%%PORTVERSION%%/COPYING.LIB
+%%PORTDOCS%%usr/%%DOCSDIR%%-%%PORTVERSION%%/ChangeLog
+%%PORTDOCS%%usr/%%DOCSDIR%%-%%PORTVERSION%%/NEWS
+%%PORTDOCS%%usr/%%DOCSDIR%%-%%PORTVERSION%%/README
+%%PORTDOCS%%@dirrm usr/%%DOCSDIR%%-%%PORTVERSION%%
+@dirrmtry usr/share/locale/vi/LC_MESSAGES
+@dirrmtry usr/share/locale/sv/LC_MESSAGES
+@dirrmtry usr/share/locale/pl/LC_MESSAGES
+@dirrmtry usr/share/locale/fr/LC_MESSAGES
+@dirrmtry usr/share/locale/de/LC_MESSAGES
+@dirrmtry usr/share/locale/vi
+@dirrmtry usr/share/locale/sv
+@dirrmtry usr/share/locale/pl
+@dirrmtry usr/share/locale/fr
+@dirrmtry usr/share/locale/de