aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2013-12-03 22:04:38 +0000
committerKoop Mast <kwm@FreeBSD.org>2013-12-03 22:04:38 +0000
commit5dbda1a7f42673d8910bc41ba945a668cdafa512 (patch)
tree4e7a4cd8df80a16e6dccf15de74b3095303e3437
parentf533a481b2a36be22465084e538c383e27820f33 (diff)
downloadports-5dbda1a7f42673d8910bc41ba945a668cdafa512.tar.gz
ports-5dbda1a7f42673d8910bc41ba945a668cdafa512.zip
Notes
-rw-r--r--graphics/goocanvas/Makefile8
-rw-r--r--graphics/goocanvasmm/Makefile18
-rw-r--r--graphics/goocanvasmm/pkg-plist1
3 files changed, 16 insertions, 11 deletions
diff --git a/graphics/goocanvas/Makefile b/graphics/goocanvas/Makefile
index ded9678b72b9..c7f4853b5930 100644
--- a/graphics/goocanvas/Makefile
+++ b/graphics/goocanvas/Makefile
@@ -10,9 +10,11 @@ MASTER_SITES= GNOME
MAINTAINER= kwm@FreeBSD.org
COMMENT= Canvas widget for GTK+
+PORTSCOUT= ignore:1
+
USES= pathfix pkgconfig
USE_GNOME= gtk20 ltverhack
-USE_AUTOTOOLS= libtool
+GNU_CONFIGURE= yes
USE_LDCONFIG= yes
USE_BZIP2= yes
@@ -21,7 +23,6 @@ LDFLAGS+= -L${LOCALBASE}/lib
PORTDOCS= *
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNLS}
@@ -41,4 +42,7 @@ post-patch:
@${REINPLACE_CMD} -e '/^SUBDIRS/s|po||g' ${WRKSRC}/Makefile.in
.endif
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libgoocanvas.so.3
+
.include <bsd.port.mk>
diff --git a/graphics/goocanvasmm/Makefile b/graphics/goocanvasmm/Makefile
index 7aefcda9e258..b5b608ad4aaf 100644
--- a/graphics/goocanvasmm/Makefile
+++ b/graphics/goocanvasmm/Makefile
@@ -4,23 +4,25 @@
PORTNAME= goocanvasmm
PORTVERSION= 0.15.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics
MASTER_SITES= GNOME
MAINTAINER= kwm@FreeBSD.org
COMMENT= C++ bindings for the goocanvas widget for GTK
-LIB_DEPENDS= gtkmm-2.4.1:${PORTSDIR}/x11-toolkits/gtkmm24 \
- goocanvas.3:${PORTSDIR}/graphics/goocanvas
+LIB_DEPENDS= libgoocanvas.so:${PORTSDIR}/graphics/goocanvas
-USES= pkgconfig
-USE_GNOME= gnomehack ltverhack
-USE_AUTOTOOLS= libtool
+PORTSCOUT= ignore:1
+
+USES= gmake pathfix pkgconfig
+USE_GNOME= gtkmm24 ltverhack
+GNU_CONFIGURE= yes
USE_LDCONFIG= yes
CONFIGURE_ARGS= --disable-documentation
USE_BZIP2= yes
-USE_GMAKE= yes
-NO_STAGE= yes
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libgoocanvasmm-1.0.so.5
+
.include <bsd.port.mk>
diff --git a/graphics/goocanvasmm/pkg-plist b/graphics/goocanvasmm/pkg-plist
index 5e45c93de313..fb483d1ac84e 100644
--- a/graphics/goocanvasmm/pkg-plist
+++ b/graphics/goocanvasmm/pkg-plist
@@ -61,7 +61,6 @@ include/goocanvasmm-1.0/goocanvasmm/types.h
include/goocanvasmm-1.0/goocanvasmm/widget.h
include/goocanvasmm-1.0/goocanvasmm/wrap_init.h
lib/goocanvasmm-1.0/include/goocanvasmmconfig.h
-lib/libgoocanvasmm-1.0.a
lib/libgoocanvasmm-1.0.la
lib/libgoocanvasmm-1.0.so
lib/libgoocanvasmm-1.0.so.5