aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJuergen Lock <nox@FreeBSD.org>2009-07-03 20:58:54 +0000
committerJuergen Lock <nox@FreeBSD.org>2009-07-03 20:58:54 +0000
commit67afa6153571c67e9fcdbe6edce4fbfc9e71ab27 (patch)
tree38923a8d667a362f6a10c8ff1b13f477a50f750a
parentb79f1aea403565ac069b136473718d87aaade7f0 (diff)
downloadports-67afa6153571c67e9fcdbe6edce4fbfc9e71ab27.tar.gz
ports-67afa6153571c67e9fcdbe6edce4fbfc9e71ab27.zip
Notes
-rw-r--r--Mk/bsd.linux-apps.mk16
-rw-r--r--ftp/linux-f10-curl/Makefile3
2 files changed, 17 insertions, 2 deletions
diff --git a/Mk/bsd.linux-apps.mk b/Mk/bsd.linux-apps.mk
index 0df4d60332e0..7245e9ab7b8d 100644
--- a/Mk/bsd.linux-apps.mk
+++ b/Mk/bsd.linux-apps.mk
@@ -70,7 +70,8 @@ _LINUX_APPS_ALL= allegro alsalib arts aspell atk cairo curl dri esound expat fon
_LINUX_APPS_ALL+=
# 2.6.16 components
-_LINUX_26_APPS= libidn libssh2 nspr nss sqlite3 tcl84 tk84
+_LINUX_26_APPS= cyrus-sasl2 libidn libssh2 nspr nss openldap \
+ sqlite3 tcl84 tk84
_LINUX_APPS_ALL+= ${_LINUX_26_APPS}
@@ -136,6 +137,14 @@ curl_f8_FILE= ${LINUXBASE}/usr/lib/libcurl.so.4.1.0
curl_f10_FILE= ${LINUXBASE}/usr/lib/libcurl.so.4.1.1
curl_DETECT= ${curl${LINUX_DIST_SUFFIX:S/-/_/}_FILE}
curl_PORT= ${PORTSDIR}/ftp/linux${LINUX_DIST_SUFFIX}-curl
+. if ${LINUX_DIST_SUFFIX} == "-f10"
+curl_DEPENDS= cyrus-sasl2 openldap
+. endif
+
+# no cyrus-sasl2_FILE, cyrus-sasl2_f8_FILE
+cyrus-sasl2_f10_FILE= ${LINUXBASE}/usr/lib/libsasl2.so.2.0.22
+cyrus-sasl2_DETECT= ${cyrus-sasl2${LINUX_DIST_SUFFIX:S/-/_/}_FILE}
+cyrus-sasl2_PORT= ${PORTSDIR}/security/linux${LINUX_DIST_SUFFIX}-cyrus-sasl2
dri_FILE= ${LINUXBASE}/usr/X11R6/lib/libGL.so.1
dri_f8_FILE= ${LINUXBASE}/usr/lib/libGL.so.1
@@ -307,6 +316,11 @@ mikmod_f10_FILE= ${LINUXBASE}/usr/lib/libmikmod.so.3.0.0
mikmod_DETECT= ${mikmod${LINUX_DIST_SUFFIX:S/-/_/}_FILE}
mikmod_PORT= ${PORTSDIR}/audio/linux${LINUX_DIST_SUFFIX}-mikmod
+# no openldap_FILE, openldap_f8_FILE
+openldap_f10_FILE= ${LINUXBASE}/usr/lib/libldap-2.4.so.2.2.0
+openldap_DETECT= ${openldap${LINUX_DIST_SUFFIX:S/-/_/}_FILE}
+openldap_PORT= ${PORTSDIR}/net/linux${LINUX_DIST_SUFFIX}-openldap
+
openmotif_FILE= ${LINUXBASE}/usr/X11R6/lib/libXm.so.3.0.3
openmotif_f8_FILE= ${LINUXBASE}/usr/lib/libXm.so.4.0.2
openmotif_f10_FILE= ${LINUXBASE}/usr/X11R6/lib/libXm.so.3.0.3
diff --git a/ftp/linux-f10-curl/Makefile b/ftp/linux-f10-curl/Makefile
index 70e37df5ce71..b8294cb19b03 100644
--- a/ftp/linux-f10-curl/Makefile
+++ b/ftp/linux-f10-curl/Makefile
@@ -7,7 +7,7 @@
PORTNAME= curl
PORTVERSION= 7.19.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= ftp linux
PKGNAMEPREFIX= linux-f10-
DISTFILES= curl-${PORTVERSION}-${RPMVERSION}.i386.rpm \
@@ -24,6 +24,7 @@ COMMENT= The command line tool for transferring files with URL syntax (Linux Fed
CONFLICTS= linux-curl-[0-9]* linux-f8-curl-[0-9]*
USE_LINUX_RPM= yes
+USE_LINUX_APPS= cyrus-sasl2 openldap
LINUX_DIST_VER= 10
RPMVERSION= 5.fc10
USE_LDCONFIG= yes