aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-04-11 21:10:03 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-04-11 21:10:03 +0000
commit6b2eaec4b98273c12a8bc82fef1a1aa394eb53d3 (patch)
tree20f2b5d2a1d36a0f22ab946d74da992e797111b7
parent6badf436b01fbb7036c1db4f8dff09403002cb10 (diff)
downloadports-6b2eaec4b98273c12a8bc82fef1a1aa394eb53d3.tar.gz
ports-6b2eaec4b98273c12a8bc82fef1a1aa394eb53d3.zip
Notes
-rw-r--r--misc/Makefile1
-rw-r--r--misc/esniper/Makefile29
-rw-r--r--misc/esniper/distinfo2
-rw-r--r--misc/esniper/pkg-descr3
-rw-r--r--misc/esniper/pkg-plist4
5 files changed, 39 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index d6c37b30d955..df55bc1055f5 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -70,6 +70,7 @@
SUBDIR += edonkey-tool-hash
SUBDIR += edonkey-tool-slist
SUBDIR += elscreen
+ SUBDIR += esniper
SUBDIR += estic
SUBDIR += ewipe
SUBDIR += explosions
diff --git a/misc/esniper/Makefile b/misc/esniper/Makefile
new file mode 100644
index 000000000000..032195e96f8a
--- /dev/null
+++ b/misc/esniper/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: esniper
+# Date created: 10 April 2005
+# Whom: Lewis Thompson <lewiz@compsoc.man.ac.uk>
+#
+# $FreeBSD$
+
+PORTNAME= esniper
+DISTVERSION= 2-10-0
+CATEGORIES= misc net
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= lewiz@compsoc.man.ac.uk
+COMMENT= Lightweight tool for sniping ebay auctions
+
+LIB_DEPENDS= curl.3:${PORTSDIR}/ftp/curl
+
+GNU_CONFIGURE= yes
+USE_OPENSSL= yes
+
+MAN1= esniper.1
+
+post-install:
+ ${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/sample_auction.txt ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/sample_config.txt ${EXAMPLESDIR}
+
+.include <bsd.port.mk>
diff --git a/misc/esniper/distinfo b/misc/esniper/distinfo
new file mode 100644
index 000000000000..79624074cacd
--- /dev/null
+++ b/misc/esniper/distinfo
@@ -0,0 +1,2 @@
+MD5 (esniper-2-10-0.tgz) = 48bfbd3527e8e95cbf2b61da9492c60f
+SIZE (esniper-2-10-0.tgz) = 113317
diff --git a/misc/esniper/pkg-descr b/misc/esniper/pkg-descr
new file mode 100644
index 000000000000..2ffd23f22e9f
--- /dev/null
+++ b/misc/esniper/pkg-descr
@@ -0,0 +1,3 @@
+esniper is a simple, lightweight tool for sniping ebay auctions.
+
+WWW: http://esniper.sourceforge.net/
diff --git a/misc/esniper/pkg-plist b/misc/esniper/pkg-plist
new file mode 100644
index 000000000000..556f10454022
--- /dev/null
+++ b/misc/esniper/pkg-plist
@@ -0,0 +1,4 @@
+bin/esniper
+%%EXAMPLESDIR%%/sample_auction.txt
+%%EXAMPLESDIR%%/sample_config.txt
+@dirrm %%EXAMPLESDIR%%