aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-10-07 23:43:13 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-10-07 23:43:13 +0000
commit6e34d8a2b884311aed6de9a3a18b77bc37e19dbe (patch)
treed425e1178b83d62cd88fb4f0615ba3efba006a73
parent867f451ee77856eef9e1595ba08a990dc0c25c12 (diff)
downloadports-6e34d8a2b884311aed6de9a3a18b77bc37e19dbe.tar.gz
ports-6e34d8a2b884311aed6de9a3a18b77bc37e19dbe.zip
Notes
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-HTML-Template-Associate/Makefile28
-rw-r--r--www/p5-HTML-Template-Associate/distinfo1
-rw-r--r--www/p5-HTML-Template-Associate/pkg-descr12
-rw-r--r--www/p5-HTML-Template-Associate/pkg-plist6
5 files changed, 48 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 3dab014e0aac..2a0d8a99192e 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -366,6 +366,7 @@
SUBDIR += p5-HTML-TableLayout
SUBDIR += p5-HTML-Tagset
SUBDIR += p5-HTML-Template
+ SUBDIR += p5-HTML-Template-Associate
SUBDIR += p5-HTML-Template-Expr
SUBDIR += p5-HTML-Tree
SUBDIR += p5-HTML-Webmake
diff --git a/www/p5-HTML-Template-Associate/Makefile b/www/p5-HTML-Template-Associate/Makefile
new file mode 100644
index 000000000000..95f55b8a5960
--- /dev/null
+++ b/www/p5-HTML-Template-Associate/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: HTML-Template-Associate
+# Date created: 2 Sep 2003
+# Whom: Manuel Rábade <mig@mig-29.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= HTML-Template-Associate
+PORTVERSION= 1.10
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../../../authors/id/A/AL/ALEXP
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= mig@mig-29.net
+COMMENT= Bridges gap between HTML::Template and other modules
+
+RUN_DEPENDS= ${SITE_PERL}/HTML/Template.pm:${PORTSDIR}/www/p5-HTML-Template \
+ ${SITE_PERL}/CGI/Base.pm:${PORTSDIR}/www/p5-CGI-modules \
+ ${SITE_PERL}/Data/FormValidator.pm:${PORTSDIR}/textproc/p5-Data-FormValidator
+
+PERL_CONFIGURE= yes
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= HTML::Template::Associate.3 \
+ HTML::Template::Associate::FormValidator.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-HTML-Template-Associate/distinfo b/www/p5-HTML-Template-Associate/distinfo
new file mode 100644
index 000000000000..97587878fa5a
--- /dev/null
+++ b/www/p5-HTML-Template-Associate/distinfo
@@ -0,0 +1 @@
+MD5 (HTML-Template-Associate-1.10.tar.gz) = 2331821473533b510c3307f495887c8e
diff --git a/www/p5-HTML-Template-Associate/pkg-descr b/www/p5-HTML-Template-Associate/pkg-descr
new file mode 100644
index 000000000000..20b5bb3ab9c7
--- /dev/null
+++ b/www/p5-HTML-Template-Associate/pkg-descr
@@ -0,0 +1,12 @@
+HTML::Template::Associate bridges gap between HTML::Template and
+other modules that can be used in conjunction with it to do something
+useful together, like for example Data::FormValidator that can verify form
+inputs.
+
+The primary reason I wrote this is that I needed something to bridge those
+two and the thought of creating something more expandable came to mind.
+
+WWW: http://search.cpan.org/author/ALEXP/HTML-Template-Associate-1.10/
+
+- Manuel Rodrigo Rabade Garcia
+mig@mig-29.net
diff --git a/www/p5-HTML-Template-Associate/pkg-plist b/www/p5-HTML-Template-Associate/pkg-plist
new file mode 100644
index 000000000000..78bc19a697f8
--- /dev/null
+++ b/www/p5-HTML-Template-Associate/pkg-plist
@@ -0,0 +1,6 @@
+%%SITE_PERL%%/HTML/Template/Associate.pm
+%%SITE_PERL%%/HTML/Template/Associate/FormValidator.pm
+@dirrm %%SITE_PERL%%/HTML/Template/Associate
+%%SITE_PERL%%/mach/auto/HTML/Template/Associate/.packlist
+@dirrm %%SITE_PERL%%/mach/auto/HTML/Template/Associate
+@unexec rmdir %D/%%SITE_PERL%%/HTML/Template 2>/dev/null || true