aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2007-08-25 15:45:53 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2007-08-25 15:45:53 +0000
commit70b5ee8d4af9159b0abce4ff8bb1f4b961974dc6 (patch)
treeac043f13e8e6f831840c518a55a95f3453880a83
parenta154cc41c0eacd3a116423be46c2bcbea0b20a5c (diff)
downloadports-70b5ee8d4af9159b0abce4ff8bb1f4b961974dc6.tar.gz
ports-70b5ee8d4af9159b0abce4ff8bb1f4b961974dc6.zip
Notes
-rw-r--r--x11-toolkits/otk/Makefile25
-rw-r--r--x11-toolkits/otk/distinfo6
-rw-r--r--x11-toolkits/otk/pkg-descr30
3 files changed, 30 insertions, 31 deletions
diff --git a/x11-toolkits/otk/Makefile b/x11-toolkits/otk/Makefile
index d486c350aa1d..1ca55809d314 100644
--- a/x11-toolkits/otk/Makefile
+++ b/x11-toolkits/otk/Makefile
@@ -6,11 +6,10 @@
#
PORTNAME= otk
-PORTVERSION= 0.53
-PORTREVISION= 1
+PORTVERSION= 0.61
CATEGORIES= x11-toolkits graphics
MASTER_SITES= SF
-DISTNAME= ${PORTNAME}_lib_${PORTVERSION}
+DISTNAME= ${PORTNAME}_lib_${DISTVERSION}
EXTRACT_SUFX= .tgz
MAINTAINER= infofarmer@FreeBSD.org
@@ -18,19 +17,21 @@ COMMENT= Widget library based on OpenGL
LIB_DEPENDS= glut.4:${PORTSDIR}/graphics/libglut
-USE_GL= yes
-USE_X_PREFIX= yes
+USE_GL= glu gl
+USE_LDCONFIG= yes
+USE_XORG= xmu xext x11
WRKSRC= ${WRKDIR}/${PORTNAME}_lib
-
-PLIST_FILES= lib/libotk.a include/gadget_lib.h include/otk_lib.h
+CFLAGS+= -I${LOCALBASE}/include -fPIC
+LDFLAGS= -lGLU -lGL -lXmu -lXext -lX11 -L${LOCALBASE}/lib
+PLIST_FILES= lib/libotk.so lib/libotk.so.0 include/gadget_lib.h include/otk_lib.h
do-build:
- cd ${WRKSRC} && \
- ${CC} ${CFLAGS} -I${X11BASE}/include -c ./otk_lib.c && \
- ar q ./libotk.a ./otk_lib.o && ranlib ./libotk.a
+ @cd ${WRKSRC}/&&\
+ ${CC} ${CFLAGS} ${LDFLAGS} -shared ./otk_lib.c -o libotk.so.0
do-install:
- ${INSTALL_DATA} ${WRKSRC}/libotk.a ${PREFIX}/lib
- ${INSTALL_DATA} ${WRKSRC}/*.h ${PREFIX}/include
+ @${INSTALL_PROGRAM} ${WRKSRC}/libotk.so.0 ${PREFIX}/lib/
+ @${LN} -sf libotk.so.0 ${PREFIX}/lib/libotk.so
+ @${INSTALL_DATA} ${WRKSRC}/*.h ${PREFIX}/include/
.include <bsd.port.mk>
diff --git a/x11-toolkits/otk/distinfo b/x11-toolkits/otk/distinfo
index ce15f86f996d..dfe694b52ae9 100644
--- a/x11-toolkits/otk/distinfo
+++ b/x11-toolkits/otk/distinfo
@@ -1,3 +1,3 @@
-MD5 (otk_lib_0.53.tgz) = b63e12cfd908f0662ef3ff233444a35a
-SHA256 (otk_lib_0.53.tgz) = 1e56674eaca26657b8ad12ded6c133f6da9642a7be2880b13bbf8108514f9fda
-SIZE (otk_lib_0.53.tgz) = 65615
+MD5 (otk_lib_0.61.tgz) = 037b1e76cb6c15023413200b812d5e9f
+SHA256 (otk_lib_0.61.tgz) = 83ac21f002d2546a24997f19b44f0946f02e6a3af38e2a28ac7b2e663a4f84ef
+SIZE (otk_lib_0.61.tgz) = 70949
diff --git a/x11-toolkits/otk/pkg-descr b/x11-toolkits/otk/pkg-descr
index 0741c8b949b0..534c9fbb17b7 100644
--- a/x11-toolkits/otk/pkg-descr
+++ b/x11-toolkits/otk/pkg-descr
@@ -1,19 +1,17 @@
Otk is a portable widget library for making graphical user interfaces for
application programs. It emphasizes simplicity without eliminating capability.
-It is based on OpenGL, and C. Otk provides the following basic widgets:
+It is based on OpenGL and C. Otk provides the following basic widgets:
+* Panel - The "container" widget,
+* Text Label - Text labels,
+* Button - Buttons with labels and call-backs
+ to user functions,
+* Text Form Box - Accept text with function call-back,
+ also scrollable editor window,
+* Pull-down Menu - Display hierarchical menu-lists with user
+ function call-backs on mouse release,
+* Slider Control - Slider control with call-back,
+* Sub-windows - Detachable self-managed windows,
+* Gadgets - High level widgets
- * Panel - The "container" widget,
- * Text Label - Text labels,
- * Button - Buttons with labels and call-backs
- to user functions,
- * Text Form Box - Accept text with function call-back,
- also scrollable editor window,
- * Pull-down Menu - Display hierarchical menu-lists with user
- function call-backs on mouse release,
- * Slider Control - Slider control with call-back,
- * Sub-windows - Detachable self-managed windows,
- * Gadgets - High level widgets
-
-and many others.
-
-WWW: http://otk.sourceforge.net/
+WWW: http://otk.sourceforge.net/
+Author: Carl Kindman <carlkindman@yahoo.com>